
 

 
 

©2022 Unanet. All rights reserved. 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 

UNANET AE: 
ADMINISTERING THE SYSTEM 
 
 

PARTICIPANT GUIDE 
 
 
 
 
 
 
 
 
 
 
 
 
Last Revised September 15, 2023 
 
 
  



 
Table of Contents ©2022 Unanet. All rights reserved. 

 
2 

TABLE OF CONTENTS 
ABOUT THIS PARTICIPANT GUIDE ......................................................... 7 

Symbols used in this guide ...................................................................................... 7 

Unanet Contact Information ..................................................................................... 7 

Support Portal ............................................................................................................ 7 

Student Training Site ................................................................................................. 8 

COURSE INTRODUCTION ........................................................................ 9 

Learning Objectives .................................................................................................. 9 

Lesson 1: Managing System-wide Permissions ................................... 10 

Learning Objectives ................................................................................................ 10 

User and Group Permissions ................................................................................. 10 

Activity 1.1 – Set Up User and Group Permissions ................................................ 11 

Password Management ........................................................................................... 13 

Activity 1.2 – Manage Passwords .......................................................................... 14 

Document Manager Permissions ........................................................................... 15 

Activity 1.3 – Assign Document Manager Applet Permissions ............................... 15 

Activity 1.4 – Assign Document Type Permissions ................................................ 16 

Navigator Query Permissions ................................................................................ 17 

Activity 1.5 – Assign Navigator Queries Applet Permissions .................................. 17 

Activity 1.6 – Assign Permissions to Specific Navigator Queries ........................... 18 

Check Your Understanding .................................................................................... 19 

Lesson 2: Setting Up Time and Expense .............................................. 20 

Learning Objectives ................................................................................................ 20 

Projects .................................................................................................................... 20 

Activity 2.1 – Create Projects ................................................................................. 20 

Timesheet Groups ................................................................................................... 21 

Activity 2.2 – Create and Apply Timesheet Groups ................................................ 21 

Holiday Calendars ................................................................................................... 22 

Activity 2.3 – Set Up Holiday Calendars ................................................................. 22 

Time and Expense Templates ................................................................................ 24 

Activity 2.4 – Create and Apply Time and Expense Templates .............................. 24 

Expense Codes ........................................................................................................ 25 



 
Table of Contents ©2022 Unanet. All rights reserved. 

 
3 

Activity 2.5 – Create Expense Codes/Groups ........................................................ 25 

Unit Billing ................................................................................................................ 27 

Activity 2.6 – System Configuration to Support Expense Units .............................. 27 

Activity 2.7 – Add Unit to Expense Group .............................................................. 28 

Labor Codes/Groups ............................................................................................... 28 

Activity 2.8 – Create Labor Codes/Groups ............................................................. 28 

Job Titles .................................................................................................................. 30 

Activity 2.9 – Create Job Titles ............................................................................... 30 

Check Your Understanding .................................................................................... 31 

Lesson 3: Managing Benefits ................................................................ 32 

Learning Objectives ................................................................................................ 32 

Benefit Accrual Setup ............................................................................................. 32 

Activity 3.1 – Set Up Benefits ................................................................................. 32 

Accrual Schedules ................................................................................................... 34 

Activity 3.2 – Create Accrual Schedules ................................................................ 34 

Check Your Understanding .................................................................................... 37 

Lesson 4: Project Administration .......................................................... 38 

Learning Objectives ................................................................................................ 38 

Rate Schedules ........................................................................................................ 38 

Activity 4.1 – Create Rate Schedules ..................................................................... 38 

WBS Templates........................................................................................................ 40 

Activity 4.2 – Create WBS Templates .................................................................... 41 

Check Your Understanding .................................................................................... 42 

Lesson 5: Managing PM Permissions and Access .............................. 43 

Learning Objectives ................................................................................................ 43 

Permissions and Special Rights for PM Applets .................................................. 43 

Activity 5.1 – Set Up Permissions and Special Rights for PM Applets ................... 43 

PM Security and Access ......................................................................................... 44 

Activity 5.2 – Grant Access to Projects and Cost ................................................... 45 

Project Roles ............................................................................................................ 47 

Activity 5.3 – Create and Manage Project Roles .................................................... 47 

Resource Groups ..................................................................................................... 48 



 
Table of Contents ©2022 Unanet. All rights reserved. 

 
4 

Activity 5.4 – Create Resource Groups .................................................................. 48 

Check Your Understanding .................................................................................... 50 

Lesson 6: Managing Reports ................................................................. 51 

Learning Objectives ................................................................................................ 51 

Reporting Overview ................................................................................................. 51 

Reporting Permissions ........................................................................................... 52 

Activity 6.1 – Manage Reporting Management Applets Permissions ..................... 52 

Managing Report Management Reports ................................................................ 53 

Demo 6.2 – Explore Report Management .............................................................. 53 

Managing PM Report Designer Reports ................................................................ 54 

Activity 6.3 – Manage PM Reports Permissions and Defaults ............................... 54 

Managing Custom Reports/Actions ....................................................................... 55 

Activity 6.4 – Manage Custom Reports/Actions ..................................................... 55 

Check Your Understanding .................................................................................... 57 

Lesson 7: Creating Reports ................................................................... 58 

Learning Objectives ................................................................................................ 58 

ReportBuilder ........................................................................................................... 58 

Activity 7.1 – Create and Edit ReportBuilder Reports ............................................. 59 

Masterfile Queries .................................................................................................... 62 

Activity 7.2 – Create Queries.................................................................................. 62 

Query Builder ........................................................................................................... 65 

Activity 7.3 – Create SQL Queries Using Query Builder ........................................ 65 

Financial Statement Designer ................................................................................ 66 

Activity 7.4 – Create Financial Reports .................................................................. 66 

Invoice Designs ....................................................................................................... 69 

Activity 7.5 – Edit Invoice Design ........................................................................... 69 

Check Your Understanding .................................................................................... 70 

Lesson 8: Creating and Managing Dashboards ................................... 71 

Learning Objectives ................................................................................................ 71 

Dashboard Groups .................................................................................................. 71 

Activity 8.1 – Create Dashboard Groups ................................................................ 71 

Deploying Dashboard .............................................................................................. 73 



 
Table of Contents ©2022 Unanet. All rights reserved. 

 
5 

Activity 8.2 – Apply Dashboards............................................................................. 73 

Configuring Dashboards ......................................................................................... 73 

Activity 8.3 – Manage Dashboard Layouts ............................................................. 73 

Check Your Understanding .................................................................................... 77 

Lesson 9: Creating and Managing Analytic Dashboards ..................... 78 

Learning Objectives ................................................................................................ 78 

Analytic Dashboard – Moving Parts Overview ...................................................... 78 

Analytic Dashboards Permissions ......................................................................... 79 

Activity 9.1 – Work with Analytic Dashboard Applets ............................................. 79 

Analytic Models ....................................................................................................... 80 

Demo 9.2 – Download Analytic Models (Marketplace) ........................................... 80 

Activity 9.3 – Install the Analytic Model and Assign Permissions ........................... 81 

Analytic Dashboard Designer ................................................................................. 81 

Activity 9.4 – Use the Analytic Dashboard Designer Tool ...................................... 82 

Analytic Dashboards ............................................................................................... 86 

Activity 9.5 – Manage Analytic Dashboards ........................................................... 86 

Activity 9.6 – Deploy Analytic Dashboards ............................................................. 87 

Check Your Understanding .................................................................................... 88 

Lesson 10: Customizing the User Interface .......................................... 89 

Learning Objectives ................................................................................................ 89 

Column Chooser ...................................................................................................... 89 

Activity 10.1 – Work with the Column Chooser ...................................................... 89 

UDF Designer ........................................................................................................... 90 

Activity 10.2 – Create a User Defined Field (UDF) ................................................. 90 

Activity 10.3 – Create a UDF Table ........................................................................ 91 

Layout Manager ....................................................................................................... 92 

Activity 10.4 – Use the Layout Manager ................................................................. 92 

Check Your Understanding .................................................................................... 94 

APPENDIX A: Check Your Understanding Answer Key ....................... 95 

Lesson 1: Managing System-wide Permissions ................................................... 95 

Lesson 2: Setting Up Time and Expense ............................................................... 96 

Lesson 3: Managing Benefits ................................................................................. 97 



 
Table of Contents ©2022 Unanet. All rights reserved. 

 
6 

Lesson 4: Project Administration ........................................................................... 98 

Lesson 5: Managing PM Permissions and Access ............................................... 99 

Lesson 6: Managing Reports ................................................................................ 100 

Lesson 7: Creating Reports .................................................................................. 101 

Lesson 8: Creating and Managing Dashboards .................................................. 102 

Lesson 9: Creating and Managing Analytic Dashboards ................................... 103 

Lesson 10: Customizing the User Interface ........................................................ 104 

COMPLETION CERTIFICATE AND EVALUATION ............................... 105 

 



 

 
 
ABOUT THIS PARTICIPANT GUIDE ©2022 Unanet. All rights reserved. 

 
7 

ABOUT THIS PARTICIPANT GUIDE 
 
This document serves as a supplement to the training courses offered through Unanet 
University. Participants should use this workbook to complete exercises in the student 
Unanet system while attending the course. Additionally, participants should record notes 
and actions for reference when working within their own Unanet AE system.  

Symbols used in this guide 
 

   
 

   
 

 

Unanet Contact Information 
• VirtualUU@unanet.com  

 
Send questions here for information about courses, course schedule, 
unanetuniversity.com, certifications, and enrollments. This is a mailbox that is monitored 
daily. 

Support Portal  
To improve your experience in accessing our support resources, all Knowledge Center 
articles, and FAQs have been relocated to the Unanet Support Portal, located 
at support.unanet.com. You will need a Support ID to access the portal, which you can 
acquire using the steps below: 

To obtain a login to the Unanet support portal or to create a new ticket, send an 
email to support@unanet.com with "Support Portal ID request" in the Subject line. 

The following conditions must be met to be granted a support account: 
• The "from" address must match the domain of your company. 
• It must NOT be a generic email account (e.g., it cannot be from 

gmail.com, aol.com, or msn.com). 
 
The company must have an active support agreement with Unanet. 

Activity 

Demo 

Tour 

Important Note 

Question 

mailto:VirtualUU@unanet.com
https://support.unanet.com/support/home
mailto:support@unanet.com?subject=Support%20Portal%20ID%20request&body=Please%20activate%20a%20support%20ID%20for%20my%20email.
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Student Training Site  
 
A Unanet AE training system has been specifically created to support this course. The 
system is configured around a fictional Unanet AE company named Casco & Wilson, 
Inc. The activities, and accompanying simulations, reference Casco & Wilson, Inc, its 
related internal and external organizations, and business processes. 
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COURSE INTRODUCTION 
 
In this course, you will review tasks specific to general administration of the system 
such as creating and modifying permissions, time, expenses, benefits, projects, reports, 
and dashboards.  

Learning Objectives  
 
After this session of Unanet AE: Administering the System, participants will be able 
to: 
 

• Explain how to set up system-wide permissions. 
• Explain how to set up various components of Time and Expense. 
• Recall how to manage benefits. 
• Explain how to set up various components of Project Administration. 
• Summarize how to assign Project Management permissions and access. 
• Explain how to set up reporting.  
• Recall the steps to create various reports. 
• Summarize how to create and manage Dashboards. 
• Summarize how to create and manage Analytic Dashboards. 
• Recall methods to customize the user interface.  
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LESSON 1: MANAGING SYSTEM-WIDE PERMISSIONS 

Learning Objectives 
 
Explain how to set up system-wide permissions. 

• Summarize how to set up User and Group permissions. 
• Recall how to manage passwords. 
• Explain how to assign Document Manager permissions. 
• Explain how to assign Navigator Query permissions. 

 

User and Group Permissions 
Permissions can be assigned to users and/or groups. Groups usually are established 
based on common departmental requirements. For example, the user may establish an 
Accounts Receivable group and assign all personnel who perform client billing to that 
group. When doing so, assign least common denominator rights to that group, since 
one member of the group is likely a manager and will receive more rights. A user can 
belong to multiple groups and has all the combined rights. If someone in the Accounts 
Receivable group requires additional access, assign the user to another group.  

User permissions are assigned per applet. Applets are the subcategories within a 
module. Each applet has four basic rights. 

• View: Gives users permission to view records. 
• Edit: Gives users permission to modify records. 
• Add: Gives users permission to add records. 
• Delete: Gives users permission to delete records. 

If no right is selected, the applet does not appear on the Main Menu for that user. 
Likewise, if no applets are viewable within a given module, that module will not appear 
in the Main Menu for that user. Some applets have special rights in addition to the four 
basic rights. The permission name is indicative of what it controls. 
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Permissions in Unanet AE define both access and reporting permissions for users. 

Permission Description 
User  Defines the applets a user has access to and any related 

special rights. 
Reporting Specifies the reports a user can run and the project, cost, and 

sensitive data those reports can include. 
Feature Defines access to other areas, such as Documents and 

Navigator Queries. 
 
Permission Groups are created and managed in Administration > Permissions. Best 
practice is to set permissions at a group level first. Then, add additional user 
permissions, as necessary.  
 

Activity 1.1 – Set Up User and Group Permissions 
In this activity, you will create a new user and set user permissions. In 
addition, you will create a new group, assign permissions to the group, and 
assign a member to the group.  

 
Activity Steps 
 
Part 1: Create a New User 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Type CBA01 in the Code field.  
3. Type Corey in the First field.  
4. Type B in the Middle field.  
5. Type Adams in the Last field.  
6. Select Weekly from the Timesheet Group drop-down list.  
7. Select the wand icon in the InFocus Username field to generate a username for 

the employee. Note: By default, the username format is first initial, last name.  
8. Type [Today’s date] in the Hire Date field.  
9. Select the Save button.  

 
Part 2: Assign Permissions 

1. Select Project Accountant for the Job Type drop-down list. Note: By default, a 
Project Accountant has access to all projects when reporting, planning, and 
billing.  

2. Select Accounting from the Dashboard Group drop-down list.  
3. Select the Accounting/Rates tab.  
4. Select Lookup in the Default Approver field. The Employee Lookup window 

opens.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.1/story.html
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5. Double-click Casco, Lewis J.  
6. Select the following check boxes in the Rate Options section:  

• Can View Pay Rate 
• Can View Pay Rate In Summary 
• Can View Job Cost Rate 
• Can View Job Cost In Summary 

7. Select the Save button.  
8. Close the Employees applet.  

 
Part 3: Assign Group Permissions to Employee 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the lock icon for the cadams under the Users tab to assign Permissions. 

The InFocus Permissions for cadams window opens.  
3. Select the Member Of tab. 
4. Select the General Employee check box. 
5. Select the Project Accountant check box. 
6. Select the Save button.  

 
Part 4: Create a New Group  

1. Select the Groups tab.  
2. Type Accounts Receivable in the Enter New Line field.  
3. Select the Save button.  

 
Part 5: Assign Permissions  

1. Select the lock icon for the newly created Accounts Receivable group to add 
permissions. The Permissions for Accounts Receivable window opens.  

2. Select the Group Permissions tab.  
3. Select the +/- icon to collapse the tree. The permissions are based on the 

modules and corresponding applets in Unanet AE.  
4. Select All from the Set drop-down list.  
5. Select Accounts Receivable from the For drop-down list.  
6. Select the To check box.  
7. Select the Go button. All the permissions for Accounts Receivable are assigned 

to the group. Note: The only permissions that are not updated are Special 
Permissions for that module.  

 
Part 6: Assign Members to a Group  

1. Select the Members tab. Here you can add individual users to the group 
permission.  

2. Select the Is Member check box for cadams. Note: An individual can be a 
member of more than one group. 

3. Select the Save button.  
4. Close the Permissions applet.  
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Password Management 
From an administrative perspective, passwords are managed via the Administration 
module.  
 
Password Settings 
It is important for a company to establish a global company policy for passwords. This 
includes requirements regarding strength and expiration. Password Settings are set via 
Permissions > Global Settings.  
 

 
 

The following table provides a description of the password options. 

Option Description 
Min Password 
Length  

Minimum number of characters required for a valid password. 

Password Expire 
Days 

If a number is entered, all passwords will expire if the specified 
number of days have passed since the last time the password 
was changed by the user. 

Require Number Requires the use of a number in a password when it is created. 
Require Special 
Character 

Requires the use of a special character (@,*,^ etc.) in a 
password when it is created. 

Require Lower 
Case Letter 

Requires the use of a lower case letter in a password when it is 
created. 

Require Upper Case 
Letter 

Requires the use of an upper case letter in a password when it 
is created. 
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Password Updates and Resets 
Once you have a password policy in place, you can manage passwords via 
Administration > Permissions. Administrators can update passwords and require a 
password reset when a user next logs in. 
 

Activity 1.2 – Manage Passwords 
In this activity, you will change a password for a user and require the user to 
reset their password with their next login.  

 
Activity Steps 
 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the lock icon for cadams to create a password under the Users tab. The 

InFocus Permissions for cadams window opens.  
3. Type Welcome1 in the New Password field.  
4. Type Welcome1 in the Confirm Password field.  
5. Select the Change Password button. The Save Successful window opens.  
6. Select the OK button.  
7. Select the Save button.  
8. Select the Require Reset check box for cadams. The user will be required to 

reset their password the next time they login.  
9. Select the Save button.  
10. Close the Permissions applet.  

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.2/story.html
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Document Manager Permissions 
Access Permissions for working with Document Manager is assigned in Administration 
> Permissions. Use the special rights options to provide access to view the specified 
reports. 
 

Activity 1.3 – Assign Document Manager Applet Permissions 
In this activity, you will set permissions for working with Document Manager.  

 
 
Activity Steps 
 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Accounts Receivable group to add permissions. 

The Permissions for Accounts Receivable window opens.  
4. Select the Group Permissions tab.  
5. Select the +/- icon to collapse the tree. 
6. Select the + icon for the Utilities module.  
7. Select the following check boxes for Document Manager:  

• View 
• Edit 
• Add 
• Delete 

8. Select the Save button.  
9. Close the Permissions applet.  

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.3/story.html
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Activity 1.4 – Assign Document Type Permissions 
In this activity, you will create and set permissions for Document Types. 

 
 
Activity Steps 
 
Part 1: Create and Set Permissions for a Document Type 

1. Navigate to Utilities > Document Manager. The Document Manager applet 
opens.  

2. Type Proposal in the Enter New Line field in the Custom Types grid.  
3. Select the Save button.  
4. Select the lock icon for the Proposal Document Type in the Permissions 

column. The Document Type Permissions window opens.  
5. Select the View check box for the demo user.  
6. Select the Modify check box for the demo user. 
7. Select the View check box for the Accounts Receivable group.  
8. Select the Modify check box for the Accounts Receivable group. 
9. Select the Save button. The Are You Sure? window opens.  
10. Select the Yes button to reset permissions.  
11. Select the paper icon for the Proposal Document Type in the Applets column. 

The Applet Association window opens.  
12. Select the Allowed check box for the Projects applet. 
13. Select the Save button.  
14. Close the Document Manager applet.  

 

Part 2: Review Document Types on a Project 
1. Navigate to Project Administration > Projects. The Projects applet opens.  
2. Type 20130000 in the Project Lookup field.  
3. Press Enter. The Million Dollar Bridge project information displays.  
4. Select the Documents tab.  
5. Select the Add Document + icon. The Document Upload window opens. Here 

you can upload documents.  
6. Select the Doc Type drop-down arrow. The Proposal Document Type is 

available to select.  
7. Select the Cancel button.  
8. Close the Projects applet.  

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.4/story.html
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Navigator Query Permissions 
Navigator Queries are a powerful search function. They affect most user screens and 
make finding transactions and/or records easier. The selections available in the 
Navigator are driven by data queries. Each of these system queries can be edited as 
needed. Additionally, custom queries can be written to be utilized by the Navigator. 
Permissions to specific Navigator Queries are granted to user or group.  
 

Activity 1.5 – Assign Navigator Queries Applet Permissions 
In this activity, you will assign permissions to access the Navigator Queries 
applet.  

 
Activity Steps 
 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Accounts Receivable group to add permissions. 

The Permissions for Accounts Receivable window opens.  
4. Select the Group Permissions tab.  
5. Select the +/- icon to collapse the tree. 
6. Select the + icon for the Utilities module.  
7. Select the following check boxes for Navigator Queries:  

• View 
• Edit 
• Add 
• Delete 

8. Select the Save button.  
9. Close the Permission applet.  

  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.5/story.html
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Activity 1.6 – Assign Permissions to Specific Navigator 
Queries 
In this activity, you will assign Navigator Query permissions for the user you 
created.  

 
Activity Steps 
 

1. Navigate to Utilities > Navigator Queries. The Navigator Queries applet 
opens.  

2. Select the Active By Name query in the Clients section.  
3. Select the Permissions tab.  
4. Select the Accounts Receivable check box in the Groups table.  
5. Select the Save button.  
6. Close the Navigator Queries applet.  

  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_1.6/story.html
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Check Your Understanding 
 

 
Where are groups created and permissions assigned to groups?  
 

a) Administration > Permissions 
b) Human Resources > Employees 
c) Utilities > Navigator Queries 
d) Accounts Receivable > Clients 

 
 
Which module is used for creating a new document type?  
 

a) Administration  
b) Human Resources  
c) Utilities  
d) Accounts Receivable  
 

 
 

 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 2: SETTING UP TIME AND EXPENSE 

Learning Objectives 
 
Explain how to set up various components of Time and Expense. 

• List the steps to create Timesheet Groups. 
• Explain how to create Time and Expense Templates. 
• Summarize how to set up Holiday Calendars. 
• List the steps to create Expense Codes. 
• Explain how to create Expense Units. 
• List the steps to create Labor Codes/Groups. 
• Explain how to create Job Titles. 

 

Projects 
Projects are used to manage jobs in Unanet AE. These projects integrate with many 
areas including time and expenses, billing, and administration. As part of this course, 
you will create simple projects to use with the other activities in this course.  
 

Activity 2.1 – Create Projects 
In this activity, you will create a billable project and an indirect project.  

 
 
Activity Steps 
 
Part 1: Create a Billable Project 

1. Navigate to Project Administration > Projects. The Projects applet opens.  
2. Select Project from the New menu in the header.  
3. Type 20210000 in the Code field.  
4. Type Hypoch Park Pedestrian Bridge in the Name field.  
5. Select Billable from the Charge Type drop-down list.  
6. Select City of Portland in the Client field.  
7. Select Time and Materials from the Contract Type drop-down list.  
8. Select the Save button.  

 
Part 2: Create an Indirect Project 

1. Select Project from the New menu in the header.  
2. Type PRDEV in the Code field.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_2.1/story.html
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3. Type Professional Development in the Name field.  
4. Select Indirect from the Charge Type drop-down list.  
5. Select the Save button.  
6. Close the Projects applet.  

 

Timesheet Groups 
Timesheet Groups provide a mechanism for the preparation of timesheet coverage 
periods. Timesheet coverage periods govern the starting and ending dates for a 
timesheet, which affects how frequently timesheets are submitted. Unanet AE allows for 
multiple Timesheet Groups. For example, one group of employees submits weekly 
timesheets while another group submits semi-monthly timesheets. Weekly, biweekly, 
semi-monthly, and daily timesheets are supported. Any coverage period can be 
selected, regardless of the payroll cycle. The support for different cycles allows them to 
co-exist with already established procedures in the firm.  

Timesheet Groups are created via Human Resources > Employees. Timesheet Groups 
is a required field, so one must be assigned to each employee. 

 

Activity 2.2 – Create and Apply Timesheet Groups 
In this activity, you will create a Timesheet Group and assign it to an 
employee.  

 
Activity Steps 
 
Part 1: Create a Timesheet Group 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Select Timesheet Groups from the Tools menu in the header. The Timesheet 

Groups window opens.  
3. Use the information in the table to create a Timesheet Group:  

Field Information 
Name Semi-Monthly 
Next Start Date Current month/1/Current year 
Next End Date Current month/15/Current year 
Cycle Type Semi-Monthly 
Holiday Calendar Not assigned 

4. Select the Save button.  
 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_2.2/story.html
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Part 2: Apply a Timesheet Group 
1. Type CBA in the Employee Lookup field.  
2. Press Enter. The Employees applet populates with the information for cadams.  
3. Select Semi-Monthly from the Timesheet Group drop-down list.  
4. Select the Save button.  
5. Close the Employees applet.  

 

Holiday Calendars 
A Holiday Calendar allows you to create a list of holidays that can be both highlighted 
and pre-filled on a timesheet. When you use Holiday Calendars, it allows Admin staff 
the ability to manage holidays and helps eliminate employee error. This does not limit 
time entered on a particularly configured holiday, but simply indicates the holiday and 
can prefill configured project and hours.  

When setting up Holiday Calendars, they can span multiple years by leaving the year 
blank. You can have one ongoing Holiday Calendar which can be assigned to one or 
multiple Timesheet Groups. If you prefer to establish one Holiday Calendar per year, 
you can also configure the system this way. 

 

Activity 2.3 – Set Up Holiday Calendars 
In this activity, you will set up a Holiday Calendar and assign it to a 
Timesheet Group. 

 
Activity Steps 
 
Part 1: Set Up a Holiday Calendar  

1. Navigate to Human Resources > Holiday Calendars. The Holiday Calendars 
applet opens.  

2. Select the New button. The Name? window opens.  
3. Type 2022 Holiday Calendar in the Name field.  
4. Select the OK button.  
5. Select Lookup in the Holiday Project field. The Find: Projects window opens.  
6. Select Indirect from the Charge Type drop-down list.  
7. Select the Search button.  
8. Double-click 90004 Holiday.  
9. Type 8 in the Hours field.  

  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_2.3/story.html
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10. Use the information in the table to create the Holiday Dates:  
Holiday Name Month  Day Year 
New Year’s Day 1 1 2022 
Memorial Day 5 30 2022 
Independence Day 7 4 2022 
Labor Day 9 5 2022 
Thanksgiving Eve 11 24 2022 
Thanksgiving 11 25 2022 
Christmas 12 26 2022 

11. Select the Save button.  
12. Close the Holiday Calendars applet.  

 
Part 2: Apply a Timesheet Group 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Select Timesheet Groups from the Tools menu in the header. The Timesheet 

Groups window opens.  
3. Select 2022 Holiday Calendar from the Holiday Calendar drop-down list for the 

Semi-Monthly Timesheet Group.  
4. Select the Save button.  
5. Close the Employees applet.  
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Time and Expense Templates 
Time and Expense templates are used to auto fill time and/or expense sheets with 
commonly used projects, such as admin, vacation, or sick. In addition, projects can 
have default Labor/Expense Codes populate on the timesheet. If no hours are entered 
for these projects, the projects from the template are removed when submitting. Time 
and Expense Templates can be set up to allow employees to see their utilization on 
their timesheets. Unanet AE allows for multiple templates that can be personalized per 
employee, where they are then assigned. 
 

Activity 2.4 – Create and Apply Time and Expense Templates 
In this activity, you will create a Time & Expense Template and assign it to 
an employee.  

 
Activity Steps 
 
Part 1: Create a Template 

1. Navigate to Human Resources > Time & Expense Templates. The Time & 
Expense Templates applet opens.  

2. Select the New button.  
3. Type Overhead in the Name field.  
4. Select the following check boxes for Time Utilization:  

• Show Direct PCT (%) 
• Show Billable PCT (%) 
• Show Target PCT (%) 

5. Select the Sort template projects to top of sheet check box for Sort.  
6. Select Lookup in Project Path field within the grid. The Projects window opens.  
7. Select 90001 Admin in the Projects table. Note: You can use the Search field 

or scroll though the list of projects. 
8. Double-click the project path in the Available table.  
9. Select the Use In Time check box.  
10. Repeat steps 6-9 to add the following projects:  

• 90004 Holiday 
• 90002 Sick  

11. Select the Save button. A list of created templates displays under Template 
Name.  

12. Close the Time & Expense Templates applet.  
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Part 2: Apply a Template  
1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Type CBA in the Employee Lookup field.  
3. Press Enter. The Employees applet populates with the information for cadams.  
4. Select Overhead from the Time & Exp. Template drop-down list.  
5. Select the Save button.  
6. Close the Employees applet.  

 

Expense Codes 
Expense Codes allow for the categorization of project expenses which are linked 
directly to the Chart of Accounts. They can also trigger project markups and default bill 
status. Used in any expense journal, Expense Codes have a direct effect on financial 
and project reporting, along with invoicing.  

Expense Codes are then assigned to Expense Groups. Then the Expense Group is 
assigned to a project. Inside the Expense Group, the Expense Code can be further 
defined to meet the demands of each of your project expenses. 

 

Activity 2.5 – Create Expense Codes/Groups 
In this activity, you will create Expense Codes and Expense Groups.  

 
 
Activity Steps 
 
Part 1: Create an Expense Code 

1. Navigate to Project Administration > Expense Codes. The Expense Codes 
applet opens.  

2. Use the information in the table to create the Ground Transportation Expense 
Code:  
Field Information 
Show in Expense Sheet  Select 
Active Select 
Code Ground Transportation  
Name Ground Transportation 
Exp. Code Type Other Direct Charge 
Exp. Markup Type Markup 
Markup 1.0 
Unit Rate 0.00 
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Bill Status Ready to bill 
Direct Cost 5540 
Overhead 7180 
Direct Bill Revenue 4200 

3. Select the Save button.  
4. Close the Expense Codes applet.  

 
Part 2: Create Expense Groups 

1. Navigate to Project Administration > Expense Groups. The Expense Groups 
applet opens.  

2. Select the New button on the toolbar. The New Expense Group window opens.  
3. Type Architects One in the Expense Group Name field.  
4. Type 01/01/2021 in the Start Date field. 
5. Select the Check All check box.  
6. Deselect the following check boxes:  

• 007 Other Travel 
• 008 Consultant 
• 009 Consultant Non-Billable 

6. Select the Create button.  
7. Update the Markup field to 1.10 for the following Expense Codes:  

• 001 Lodging 
• 003 Meals 
• 005 Airfare 
• 010 Office Supplies 

8. Select the Save button. Expense Codes can be deleted and added as needed 
within the Expense Group. 

9. Close the Expense Codes applet.  
 
Part 3: Apply Expense Groups 

1. Navigate to Project Administration > Projects. The Projects applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Expense & G/L tab.  
5. Select Architects One from the Expense Group drop-down list.  
6. Select the Save button.  
7. Close the Projects applet.  

  



 
Lesson 2: Setting Up Time and Expense ©2022 Unanet. All rights reserved. 

 
27 

Unit Billing 
Unit Billing allows for the billing of in-house expenses across multiple projects with a 
single journal entry. This is accomplished by using Expense Codes/Groups in 
conjunction with a zero-cost Purchase or Employee Reimbursable Journal Entry.  

Expense Codes are used to define the units, which will appear on the project invoice. 
They control Unit Cost Rate and Unit Bill Rate (or markup). When using this 
functionality, the Expense Codes are checked as “Is Unit” and have a Unit Type 
associated with them.  

 

Activity 2.6 – System Configuration to Support Expense 
Units 
In this activity, you will create an Expense Code to support unit billing.  

 
 
Activity Steps 
 

1. Navigate to Project Administration > Expense Codes. The Expense Codes 
applet opens.  

2. Use the information in the table to create the Soil Sample Expense Code:  
Field Information 
Is Unit Select 
Unit Each 
Show in Expense Sheet Select 
Active Select 
Code Soil Sample 
Name Soil Sample 
Exp. Code Type Other Direct Charge 
Exp. Markup Type Flat Amount 
Markup 550.00 
Unit Rate 0.00 
Bill Status Ready to bill 
Direct Cost 5540 
Direct Bill Revenue 4200 

3. Select the Save button.  
4. Close the Expense Codes applet.  
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Activity 2.7 – Add Unit to Expense Group 
In this activity, you will add an Expense Code to an Expense Group. 

 
 
Activity Steps 
 

1. Navigate to Project Administration > Expense Groups. The Expense Groups 
applet opens.  

2. Select Architects One from the list. Architects One displays in the Expense 
Group Name field. 

3. Select Lookup in the Expense Code field in the Enter New Line row. The 
Expense Codes Lookup window open.  

4. Double-click Soil Sample. 
5. Select the Save button. 
6. Close the Expense Groups applet.  

 

Labor Codes/Groups 
Labor Codes are used on the timesheet to designate the type of work that an employee 
is performing. Labor Codes can be subtotals on Project Management Reports. They 
cannot hold billing rates, nor do they have budgets.  

Labor Codes can be used on direct and/or indirect Projects, with the ability to create 
Labor Code Groups to limit the Labor Codes available for use on a project or WBS 
level. Additionally, they support Comment Templates which can require the entry of 
specified information before a timesheet can be submitted. 

 

Activity 2.8 – Create Labor Codes/Groups 
In this activity, you will create Labor Codes and Labor Code Groups.  

 
 
Activity Steps 
 
Part 1: Create Labor Codes 

1. Navigate to Project Administration > Labor Codes. The Labor Codes applet 
opens.  

2. Use the information in the table to create the Training Labor Code:  
Field Information 
Active  Select 
Labor Code TRN 
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Labor Name Training 
Type Both 
Comment Required Not selected 

3. Select the Save button.  
4. Use the information in the table to create the Meeting Labor Code:  

Field Information 
Active  Select 
Labor Code MTG 
Labor Name Meeting 
Type Both 
Comment Required Not selected 

5. Select the Save button.  
6. Close the Labor Codes applet.  

 
Part 2: Create Labor Groups 

1. Navigate to Project Administration > Labor Code Groups. The Labor Code 
Groups applet opens.  

2. Select the New button. The New Labor Code Group window opens.  
3. Type Training Group in the Labor Code Group Name field.  
4. Select the MTG Meeting check box.  
5. Select the TRN Training check box.  
6. Select the Create button.  
7. Close the Labor Code Groups applet. 

 
Part 3: Apply Labor Groups 

1. Navigate to Project Administration > Projects. The Project applet opens.  
2. Type PRDEV in the Project Lookup field.  
3. Press Enter. The Professional Development project information displays.  
4. Select the Expense & G/L tab.  
5. Select Training Group from the Labor Code Group drop-down list.  
6. Select the Save button.  
7. Close the Projects applet.  
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Job Titles  
Job Titles describe the position held by an employee. Depending on the job, a Job Title 
can describe the job responsibilities, the level of the job, or both. Job Titles can have 
Rates associated with them and can be used in setting up Rate Schedules. Job Titles 
are displayed on Invoice Designs as billing backup. Examples of Job Titles include 
Architect, Senior Mechanical Engineer, Surveyor, and CAD Operator. 

 

Activity 2.9 – Create Job Titles 
In this activity, you will create a Job Title and assign to an employee.  

 
 
Activity Steps 
 
Part 1: Create a Job Title 

1. Navigate to Human Resources > Job Titles. The Job Titles applet opens.  
2. Select the New button.  
3. Use the information in the table to create the Designer Job Title:  

Field Information 
Code DES02 
Title Designer II 

4. Select the Save button.  
5. Close the Job Titles applet.  

 
Part 2: Assign a Job Title to an Employee 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Type CBA in the Employee Lookup field.  
3. Press Enter. The Employees applet populates with the information for cadams.  
4. Select the Job Titles tab.  
5. Select DES02 Designer II in the Available Job Titles grid.  
6. Select the right-facing arrow icon. The Job Title moves to the Current Job 

Titles grid for the employee.  
7. Repeat steps 5-6 to add PRM01 Project Manager as a Job Title for the 

employee.  
8. Type 30 in the Work % field for DES02 Designer II. 
9. Type 70 in the Work % field for PRM01 Project Manager.  
10. Select the Save button.  
11. Close the Employees applet. 
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Check Your Understanding 
 

 
Determine if each statement is true or false.  
 

 
 True or False 
Each employee must be assigned to a Timesheet Group.  

Each employee must be assigned to a Time & Expense Template.  
A Holiday Calendar can be assigned to multiple Timesheet Groups.  
Expense Codes are created via the Project Administration module.  
Expense Codes can be used for unit billing.  
Labor Codes can be utilized on Timesheets for budgeting.  
Labor Code Groups are required to use Labor Codes  
Job Titles are created via the Human Resources module.  

 
 
 

 
Refer to Appendix A for answers to the Check Your Understanding questions. 

 



 

 
 
Lesson 3: Managing Benefits ©2022 Unanet. All rights reserved. 

 
32 

LESSON 3: MANAGING BENEFITS 

Learning Objectives 
 
Recall how to manage Benefits. 

• Explain how to set up Benefits.  
• Explain how to create Accrual Schedules. 

 

Benefit Accrual Setup 
The Benefit Accrual applet is used to manage the accrual of employee benefits such as 
sick, vacation, PTO, etc. 

Accruals are based on Benefit Projects and enrolled employees. Once benefit projects 
are established, Benefit Accrual will use accrue hours based on the setup and look to 
the employee’s timesheet to track used hours against the benefit project to calculate 
each employee's balance. 

When you create a Benefit Project, you must have already created an Indirect Project 
that will be associated with the benefit.  

 

Activity 3.1 – Set Up Benefits 
In this activity, you will create a benefit and enroll employees in the benefit.  

 
 
Activity Steps 
 
Part 1: Create a Benefit 

1. Navigate to Human Resources > Benefit Accrual. The Benefit Accrual applet 
opens.  

2. Select the New button on the toolbar. The Benefit Accrual Setup window 
opens.  

3. Type Sick in the Name field.  
4. Select Lookup in the Project field. The Find: Projects window opens.  
5. Double-click the 90002 Sick Project.  
6. Select the Calendar radio button. 
7. Select Calendar from the Type drop-down list.  
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8. Use the information in the table to complete the Benefit Year section:  
Field Information 
Days in Year 365 
Periods Per Year 1 
Work Hours Per Year 2080 
Accrue Hours Per Year 40 

9. Select the Calculate link. The Accrue Hours Per Period field autopopulates.  
10. Use the information in the table to complete the Maximums section:  

Field Information 
Maximum Hours check box Select 
Maximum Hours 40 
Maximum Carry Over check box Select 
Maximum Carry Over 0 

11. Select the Save button.  
 
Part 2: Enroll Employees 

1. Select the Import Employees icon above the Members grid. The Import 
Employees? message displays.  

2. Select the Yes button. All active employees are added to the benefit. Note: To 
add a single employee to a benefit, select the Add icon.  

3. Select the check box for Casco, Lewis J.  
4. Select the Delete icon for Casco, Lewis J. The Are You Sure? window opens.  
5. Select the Yes button.  
6. Close the Benefit Accrual applet.  
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Accrual Schedules 
Accrual Schedules allow employees to accrue benefits based on length of employment, 
position, or experience. Accrual schedules can also be used for overrides for those 
employees who are granted higher accruals than the standard accrual for the company. 

Activity 3.2 – Create Accrual Schedules 
In this activity, you will create an Accrual Schedule.  

 
 
Activity Steps 
 
Part 1: Create Accrual Schedules 

1. Navigate to Human Resources > Benefit Accrual. The Benefit Accrual applet 
opens.  

2. Select the Accrual Schedules button on the toolbar. The Benefit Schedules 
window opens.  

3. Select the + icon on the bottom-left corner of the window.  
4. Type VAC-Staff in the Schedule Name field.  
5. Select the OK button.  
6. Select the + icon on the bottom-left corner of the window.  
7. Type VAC-Management in the Schedule Name field.  
8. Select the OK button.  
9. Select the VAC-Staff Benefit Schedule in the Schedules section.  
10. Use the information in the table to create the VAC-Staff Benefit Schedule for 

year one:  
Field Information 
Start Month 0 
End Month 11 
Hours Per Year 2080 
Total Accruable Hours 40 
Periods Per Year 12 
Accrue Per Period 3.3333 (system generated) 
Hours Per Period 173 (system generated) 
Max Hours  60 
Max Carryover 20 

11. Use the information in the table to create the VAC-Staff Benefit Schedule for 
years two and three:  
Field Information 
Start Month 12 
End Month 35 
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Hours Per Year 2080 
Total Accruable Hours 80 
Periods Per Year 12 
Accrue Per Period 6.6667 (system generated) 
Hours Per Period 173 (system generated) 
Max Hours  100 
Max Carryover 20 

12. Use the information in the table to create the VAC-Staff Benefit Schedule for 
over three years:  
Field Information 
Start Month 36 
End Month 99,999 
Hours Per Year 2080 
Total Accruable Hours 120 
Periods Per Year 12 
Accrue Per Period 10 (system generated) 
Hours Per Period 173 (system generated) 
Max Hours  140  
Max Carryover 20 

13. Select the Save button.  
14. Select the Accrual Schedules button. The Benefit Schedules window opens.  
15. Select the VAC-Management Benefit Schedule in the Schedules section.  
16. Use the information in the table to create the VAC-Management Benefit 

Schedule:  
Field Information 
Start Month 0 
End Month 99,999 
Hours Per Year 2080 
Total Accruable Hours 160 
Periods Per Year 12 
Accrue Per Period 13.3333 (system generated) 
Hours Per Period 173 (system generated) 
Max Hours  -1 
Max Carryover -1 

Notes: Entering a -1 for Max Hours allows the maximum to be accrued based 
on the tier. Entering a -1 for Max Carryover allows for unlimited carryover.  

17. Select the Save button.  
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Part 2: Assign an Accrual Schedule to a Benefit Accrual 
1. Select the New button on the toolbar. The Benefit Accrual Setup window 

opens.  
2. Type Vacation – Full Time in the Name field. 
3. Select Lookup in the Project field. The Find: Projects window opens.  
4. Double-click the 90003 Vacation Project.  
5. Select the Calendar radio button. 
6. Select Calendar from the Type drop-down list.  
7. Select VAC-Staff from the Accrual Schedule drop-down list.  
8. Select the Save button.  

 
Part 3: Enroll Employees 

1. Select the Import Employees icon above the Members grid. The Import 
Employees? warning message displays.  

2. Select the Yes button. All active employees are added to the benefit.  
 
Part 4: Override Employee Benefits 

1. Double-click Casco, Lewis J. The Employee Benefit Override window opens.  
2. Select the Override Project Settings check box.  
3. Select the Calendar (typical) radio button.  
4. Select Calendar from the Type drop-down list.  
5. Select VAC-Management from the Accrual Schedule (optional) drop-down list.  
6. Select the Save button. 
7. Select the Refresh icon. The employee’s name displays blue indicating the 

employee has an override schedule at the employee level.  
 
Part 5: Run Benefit Accruals 

1. Select the Run Accruals button. The Run Benefit Accrual window opens.  
2. Type 1/1/2021 in the As Of Date field.  
3. Select the Vacation – Full Time check box.  
4. Select the Sick check box.  
5. Select the Run button. The Are You Sure? message displays.  
6. Select the Yes button. The Balance column displays the vacation time that was 

accrued for each employee for that accrual period. Note: To see Sick Accruals, 
use the lookup for the Sick Benefit. 

7. Select the Run Accruals button. The Run Benefit Accrual window opens.  
8. Type 2/1/2021 in the As Of Date field.  
9. Select the Vacation – Full Time check box.  
10. Select the Run button. The Are You Sure? message displays.  
11. Select the Yes button. The Balance column displays the vacation time that was 

accrued for each employee. 
12. Close the Benefit Accrual applet. 
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Check Your Understanding 
 

 
When you create a Benefit Accrual which one of the following must be 
associated with the benefit?  
 

a) Project 
b) Accrual Date 
c) Accrual Schedule 
d) Timesheet Group 

 
 
When creating an Accrual Schedule, which one of the following allows for 
unlimited carryover over of hours? 
 

a) 1 
b) 0 
c) -1 
d) 99,999 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 4: PROJECT ADMINISTRATION 

Learning Objectives 
 
Explain how to set up various components of Project Administration. 

• List the steps to create Rate Schedules. 
• List the steps to create WBS Templates. 

 

Rate Schedules 
Rate schedules can be used to control Pay, Job Cost, and Bill Rates for Projects. Rate 
Schedules can be applied to any or all nodes of the WBS. Children nodes override 
parents’ nodes. 

Activity 4.1 – Create Rate Schedules 
In this activity, you will create Rate Schedules and assign to a Project.  

 
 
Activity Steps 
 
Part 1: Create a Bill Rate Schedule 

1. Navigate to Project Administration > Rate Schedules. The Rate Schedules 
applet opens.  

2. Select the New button on the toolbar. The New Rate Schedule window opens.  
3. Type Bill Rate by Employee in the Schedule Name field.  
4. Select the Bill Rate Schedule radio button.  
5. Type 01/01/Current year in the Start Date field.  
6. Select the Create button.  
7. Select the Add Rate button at the bottom left of the applet. The Rate Editor 

window opens.  
8. Select Lookup in the Employee field. The Employee Lookup window opens.  
9. Double-click Adams, Corey.  
10. Select the Use Flat Rates check box. 
11. Type 50.00 in the Regular field.  
12. Type 50.00 in the Premium field.  
13. Select the Save button.  
14. Select the Add Rate button. The Rate Editor window opens.  
15. Select Lookup in the Employee field. The Employee Lookup window opens.  
16. Double-click Cruz, Theresa A.  
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17. Select the Use Flat Rates check box. 
18. Type 100.00 in the Regular field.  
19. Type 100.00 in the Premium field.  
20. Select the Save button.  
21. Select the Add Rate button. The Rate Editor window opens.  
22. Leave the Employee and Job Title fields empty. Note: All employees not listed 

on Rate Schedule will use this rate. 
23. Select the Use Flat Rates check box. 
24. Type 75.00 in the Regular field.  
25. Type 75.00 in the Premium field.  
26. Select the Save button.  

 
Part 2: Create a Job Cost Schedule 

1. Select the New button. The New Rate Schedule window opens.  
2. Type Job Cost in the Schedule Name field.  
3. Select the Job Cost Schedule radio button.  
4. Type 01/01/Current year in the Start Date field.  
5. Select the Create button.  
6. Select the Add Rate button. The Rate Editor window opens.  
7. Leave the Employee and Job Title fields empty. Note: All employees not listed 

on Rate Schedule will use this multiplier against their Pay Rate. 
8. Type 2.5 in the Overhead field in the Multipliers section. 
9. Select the Save button.  

 
Part 3: Create a Pay Rate Schedule 

1. Select the New button. The New Rate Schedule window opens.  
2. Type Prevailing Wages in the Schedule Name field.  
3. Select the Pay Rate Schedule radio button.  
4. Type 01/01/Current year in the Start Date field.  
5. Select the Create button.  
6. Select the Add Rate button. The Rate Editor window opens.  
7. Select Lookup in the Employee field. The Employee Lookup window opens.  
8. Double-click Fletcher, Erwin P.  
9. Type 50.00 in the Min Pay Rate field in the Base Rates section.  
10. Select the Save button.  
Note: Any employee not found on the Rate Schedule will default to the Pay Rate 
established in their employee record. 

 
Part 4: Create Bill Rate Schedule for All  

1. Select the New button. The New Rate Schedule window opens.  
2. Type Bill Rate TEST in the Schedule Name field.  
3. Select the Bill Rate Schedule radio button.  
4. Type 01/01/Current year in the Start Date field.  
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5. Select the Create button.  
6. Select the Add Rate button. The Rate Editor window opens.  
7. Select the Use Flat Rates check box.  
8. Type 100.00 in the Regular field. 
9. Type 150.00 in the Premium field.  
10. Select the Save button. This will create a schedule with one line that will apply to 

all the employees assigned to a project.  
11. Close the Rate Schedules applet.  

 
Part 5: Assign Rate Schedules to Projects   

1. Navigate to Project Administration > Projects. The Project applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Right-click Hypoch Park Pedestrian Bridge in the Project Explorer. A menu 

displays.  
5. Select Rate Schedules. The Rate Schedules window opens.  
6. Select the Use Rate Schedule radio button in the Job Cost section.  
7. Select Lookup in the Use Rate Schedule field. The Lookup window opens. 

Note: Select the Reset Criteria link if no records display.  
8. Double-click Job Cost.  
9. Select the Use Rate Schedule radio button in the Bill Rate section.  
10. Select Lookup in the Use Rate Schedule field. The Lookup window opens.  
11. Double-click Bill Rate by Employee.  
12. Select the Use Rate Schedule radio button in the Pay Rate section.  
13. Select Lookup in the Use Rate Schedule field. The Lookup window opens.  
14. Double-click Prevailing Wages.  
15. Select the Save & Close button.  
16. Close the Projects applet.  

 

WBS Templates 
WBS Templates allow you to create Work Breakdown Structures that are used often 
and apply them to projects. WBS Templates streamline your project setup and allow for 
consistency in your WBS coding and naming. These templates can be single level or 
multi-tiered and can be applied to one node or across multiple nodes at once. 
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Activity 4.2 – Create WBS Templates 
In this activity, you will create a WBS Template and apply it to a project.  
 

 
Activity Steps 
 
Part 1: Create a WBS Template 

1. Navigate to Project Administration > WBS Templates. The WBS Templates 
applet opens.  

2. Select the New button.  
3. Type Training Template in the Template field.  
4. Use the information in the table to create the parent nodes in the template:  

Code  Name 
001 Pre-Design 
002 Schematic Design 
003 Design Development 

5. Select the + icon for the 1 Pre-Design node to add child nodes.  
6. Use the information in the table to create the Pre-Design child nodes in the 

template:  
Code  Name 
10 Civil 
20 Electrical 
30 Mechanical 

7. Repeat steps 5-6 for Schematic Design and Design Development.  
8. Select the Save button. The Save Complete message displays.  
9. Select the OK button.  
10. Close the WBS Templates applet.  

 
Part 2: Assign a WBS Template to a Project   

1. Navigate to Project Administration > Projects. The Project applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Edit Project Structure check box under the Project Explorer.  
5. Right-click Hypoch Park Pedestrian Bridge in the Project Explorer. A menu 

displays.  
6. Select Apply WBS Template. The Appy WBS Template window opens.  
7. Select Training Template from the WBS Template drop-down list.  

Note: You can only select Customize for the WBS Templates that are single 
tiered. 

8. Select the Apply button. You can edit the WBS and add project data as needed.  
9. Deselect the Edit Project Structure check box.  
10. Close the Projects applet.  
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Check Your Understanding 
 

 
How do you add or edit the Project WBS? 
 

a) Right-click the project name and select Edit.  
b) Select the Edit Project Structure check box.  
c) Select File > Edit in the toolbar.  
d) Select the Expense & G/L tab.  

 
 
Which of the following are rate schedules used to control? Select all that 
apply. 

 
a) Bill Rates 
b) Job Cost Rates 
c) Pay Rates 
d) Expense Codes 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 5: MANAGING PM PERMISSIONS AND 
ACCESS  

Learning Objectives 
 
Summarize how to assign Project Management permissions and access. 

• Summarize how to set up permissions for Project Management applets. 
• Explain how Project access is granted to PMs. 
• Summarize the purpose of Project Roles. 
• Explain how to create Resource Groups. 

 

Permissions and Special Rights for PM Applets 
It is important to ensure appropriate Permissions are setup so that when your Project 
Managers log in, they can access needed Project-related applets. This is managed via 
the Permissions applet in the Administration module. 
 

Activity 5.1 – Set Up Permissions and Special Rights for PM 
Applets 
In this activity, you will review the permissions and special rights for PM 
applets.  

 
Activity Steps 
 
Part 1: Review the Permissions for Project Managers 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Project Manager group. The Permissions for 

Project Manager window opens.  
4. Select the Members tab. Here you can see which employees are assigned to 

this permission.  
5. Select the Group Permissions tab.  
6. Select the +/- icon to collapse the tree.  
7. Select the + icon for the Project Management module. Note: Permissions in the 

demo environment have already been granted for all PM applets. 
8. Select the + icon for the PM Bill Review applet. The Special Rights section for 

PM Bill Review displays.  
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9. Review the permissions. Note: By default, the permissions are not selected. 
Admin needs to determine which permissions are allowed.  

10. Repeat steps 8-9 for the following applets: 
• PM Reports  
• Project Central  
• Project Planning  

11. Select the Save button.  
12. Close the Permissions applet.  

 
Part 2: Review Additional PM Permissions 

1. Navigate to Administration > Global Settings. The Global Settings applet 
opens.  

2. Select the Invoicing tab.  
3. Review the two settings that apply to PMs: Allow PM To Edit Invoice 

Comments and Allow PM To Apply Fixed Fee Amount.  
4. Select the Save button if changes were made. 
5. Close the Global Settings applet.  

 

PM Security and Access 
Once permissions are in place, Project Managers will be able to access their projects 
once they are assigned as a Team Leader on the job. Project cost has additional 
security that is setup in the Employee applet. 
 
Here is a description of the access each role gives you. 

Job Type Description 
Project Manager  They can view all projects where they are assigned as the 

Project Manager in any applet, report, alert, query, and widget 
assigned through project roles. 

Principal-In-Charge They can view all projects where they are assigned as the 
Project Manager or the Principal In Charge in any applet, report, 
alert, query, and widget assigned through project roles. 

Project Accountant They can view all projects in any applet, report, alert, query, and 
widget assigned through project roles. 
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Activity 5.2 – Grant Access to Projects and Cost 
In this activity, you will grant access to Projects and Cost.  

 
 
Activity Steps 
 
Part 1: Assign a Job Type 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Type EPF01 in the Employee Lookup field.  
3. Press Enter. The Employees applet populates with the information for Erwin P. 

Fletcher. 
4. Verify that the Project Manager or Principal-In-Charge is selected in the Job 

Type field.  
5. Select the Save button if changes were made. 

 
Part 2: Review Rate Options 

1. Select the Accounting / Rates tab.  
2. Ensure the following Rate Options permissions are selected:  

• Can View Pay Rate 
• Can View Pay Rate in Summary 
• Can View Job Cost Rate 
• Can View Job Cost in Summary 

3. Select the Save button if changes were made. 
4. Close the Employees applet.  

 
Part 3: Assign a Project Manager to Project 

1. Navigate to Project Administration > Projects. The Projects applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Members tab. 
5. Select Lookup in the Project Manager field. The Employee Lookup window 

opens. 
6. Double-click Erwin P. Fletcher. This gives the employee access to this Project 

when running reports, working with budgets, and performing Bill Review. 
7. Select the Save button.  
8. Close the Projects applet.  
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Part 4: Allow Special Rights 
1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Project Manager group. The Permissions for 

Project Manager window opens.  
4. Select the Group Permissions tab.  
5. Select the +/- icon to collapse the tree.  
6. Select the + icon for the Project Management module.  
7. Select the + icon for the PM Bill Review applet. The Special Rights section for 

PM Bill Review displays.  
8. Select the Allowed check box for Can Override Project Leader. Any employee 

assigned to this group can access any project, even those they are not assigned 
as a leader, within the PM Bill Review applet.  

9. Select the Save button.  
10. Close the Permissions applet.  
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Project Roles 
Project Roles give the ability to set up additional Project Leaders on a job, in addition to 
the Project Manager, Principal in Charge, and Project Accountant. For example, a 
Junior PM may need access to their Projects to perform only certain PM functions.  

Project Roles control the list of Projects returned in specified locations; it does not grant 
access to Modules/Applets within Unanet AE. Project Roles are first created under List 
Management. Once created, they are managed in the Project Roles applet. There, you 
grant "Act as PM" rights in Applets, PM Reports, Custom Reports, Alerts, Queries and 
Widgets. Once created, you assign the Project Role to a Project. 

Activity 5.3 – Create and Manage Project Roles 
In this activity, you will create a Project Role, grant permissions to the Project 
Role, and assign an employee to a Project Role on a Project.  

 
Activity Steps 
 
Part 1: Create a Project Role 

1. Navigate to Administration > List Management. The Systems List 
Management applet opens.  

2. Select User Lists from the drop-down list.  
3. Select Project Roles in the list.  
4. Type Junior PM in the Display Text field for row 1. The ID is generated by the 

system after saving.  
5. Select the Save button.  
6. Close the Systems List Management applet.  

 
Part 2: Add Permissions to a Project Role 

1. Navigate to Administration > Project Roles. The Project Roles applet opens.  
2. Double-click Junior PM.  
3. Select the Act as PM check box for the following permissions under each tab:   

Applets PM Reports Custom Reports 
A/R Collections ExpenseTransactions  Project Figures 
A/R Reports LaborTransactions Bill Review 
Project Planning ProjectHistory Contract Backlog 

4. Select the Act as PM check box for the following permissions under each tab:   
Alerts Widgets 
Overbudget Projects My Projects 
Past Due Receivables  

5. Select the Save button.  
6. Close the Project Roles applet.  
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Part 3: Assign a Project Role to Project  
1. Navigate to Project Administration > Projects. The Projects applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Members tab. 
5. Select Lookup in the Employee Code field in the Team Members section. The 

Employee Lookup window opens.  
6. Double-click Adams, Corey B. 
7. Select Junior PM from the Role drop-down list for Adams, Corey B.  
8. Select the Save button.  
9. Close the Projects applet.  

Resource Groups 
Resource Groups are defined groups of employees which can be used to limit the list of 
possible employees to schedule when planning projects. 

Project Central allows you to filter by Resource Group and Project Planning supports 
filtering with Auto Fill. 

 

Activity 5.4 – Create Resource Groups 
In this activity, you will create a Resource Group and assign to a Project.  

 
 
Activity Steps 
 
Part 1: Create a Resource Group 

1. Navigate to Project Management > Resource Groups. The Resource Groups 
applet opens.  

2. Select the New button. The Resource Group Name window opens.  
3. Type Design Team in the Resource Group Name field.  
4. Select the OK button.  
5. Select Lookup in the Employee Code field. The Employee Lookup window 

opens.  
6. Double-click Adams, Corey. 
7. Repeat steps 5-6 to add the following Employees: 

• Hernandez, George J.  
• Stanwyk, Gail W. 

8. Select the Group Leader check box for Stanwyk, Gail W. Note: Group Leader 
is informational only and does not affect scheduling and planning.  

9. Select the Save button.  
10. Close the Resource Groups applet.  
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Part 2: Assign a Resource Group to a Project 
1. Navigate to Project Management > Project Planning. The Project Planning 

applet opens.  
2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Resource Groups button on the toolbar. The Resource Group 

Assignments window opens. 
5. Select Project from the WBS Level drop-down list.  
6. Select Design Team from the Resource Groups drop-down list. 
7. Select the add button.  
8. Select the Auto Fill check box.  
9. Close the Resource Group Assignments window. 
10. Close the Project Planning applet.  
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Check Your Understanding 
 

 
Which one of the following determines whether an employee can view pay 
and/or job cost on reports? 

 
a) Special Rights 
b) Resource Groups 
c) Project Roles 
d) Rate Options 

 
 
Where are Resources Groups assigned to a specific project? 
 

a) Project Management > Resource Groups  
b) Project Management > Project Planning  
c) Project Administration > Projects  
d) Project Administration > WBS Templates 

 
 

 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 6: MANAGING REPORTS 

Learning Objectives 
 
Explain how to set up reporting. 

• Recall where reports are managed. 
• Explain how to give access to Reporting applets. 
• Explain how to manage Report Management reports.  
• Explain how to manage Project (PM) reports. 
• Explain how to manage Custom Reports. 

 

Reporting Overview 
Reports represent sets of data and support common project management and 
accounting processes. Each report category is located within an applet in the Utilities 
module. In Unanet AE, reports are organized into the following categories:  
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Reporting Permissions 
You cannot manage reports without the proper access. Once Permissions are 
established under the Administration module, you can grant access to the individual 
reports. 
 

Activity 6.1 – Manage Reporting Management Applets 
Permissions 
In this activity, you will grant permissions to the reporting management 
applets.  

 
Activity Steps 
 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Project Manager group. The Permissions for 

Project Manager window opens.  
4. Select the Group Permissions tab.  
5. Select the +/- icon to collapse the tree.  
6. Select the + icon for the Utilities module.  
7. Select the View, Edit, Add, and Delete check boxes for the following applets: 

• Custom Reports 
• PM Report Designer 
• Report Management 

8. Select the Save button.  
Notes: Access is granted in Permissions to individual reports that are housed 
on the Main Menu. Examples of these reports run under the General 
Accounting module are the Balance Sheet and Income Statement. 

9. Close the Permissions applet.  
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Managing Report Management Reports 
Report Management reports support a wide range of Unanet AE standard processes. 
Once access has been granted under Permissions, the reports can be managed under 
the Report Management applet.  
 

Demo 6.2 – Explore Report Management 
In this demo, you will learn about the features in Report Management.  

 

Demo Steps 
 

1. Navigate to Utilities > Report Management. The Report Management applet 
opens. Report Management contains reports that are sprinkled throughout 
menus and toolbars within the modules in Unanet AE.  

2. Select Accounts Payable Reports from the Report Types drop-down list. 
Three reports are listed: A/P Aged, A/P Balances, and A/P Register.  
Notes: Here you can mark a report as inactive; however, that inactivates the 
report for everyone. Use Permissions to determine individual or group access. If 
any changes are needed to the Report Management reports, it first needs to be 
downloaded, changes made offline, and then uploaded back into Unanet AE.  

3. Close the Report Management applet.  
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Managing PM Report Designer Reports 
Project Management Reports are project-based reports. PM Report Designer houses 
PM Reports which can be managed by granting permissions to Unanet AE users. 
Additionally, defaults can be setup, which help define the parameters when running a 
specific report. 
 

Activity 6.3 – Manage PM Reports Permissions and Defaults 
In this activity, you will assign PM Report permissions, copy a report, and edit 
prompt defaults for the report.  

 
Activity Steps 
 
Part 1: Assign PM Report Designer Permissions 

1. Navigate to Utilities > PM Report Designer. The PM Report Designer applet 
opens. The standard reports display in red font. Any reports that are customized 
display in black font.  

2. Select Labor Transactions from the Reports list.  
3. Select the Permissions tab in the Labor Transactions section.  
4. Select the Accounts Receivable check box in the Groups list.  
5. Select the Save button.  

 
Part 2: Edit Prompt Defaults 

1. Select the Edit Prompt Defaults button. The Print Criteria window opens.  
2. Select the Billable check box in the Charge Types section. 
3. Deselect the Charge Types check box.  
4. Select the Federal Government check box in the Sectors section.  
5. Select the State Government check box in the Sectors section.  
6. Select the Save Defaults button. A Success message displays.  
7. Select the OK button.  

 
Part 3: Copy Labor Transactions Report 

1. Select the Copy Report button on the toolbar. The Copy “LaborTransactions” 
window opens.  

2. Type LaborTransactions2 in the Name field.  
3. Select the OK button.  
4. Select Labor Transactions (black font) from the Reports list. Now you can 

make edits to the report details and columns.  
Note: To have the updated columns appear when running the report in Unanet 
AE, the display needs to be edited within Visual Studios. 

5. Close the PM Report Designer applet.  
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Managing Custom Reports/Actions 
The Custom Reports applet allows users to manage and construct Custom Reports that 
are housed in the application and appear on the Unanet AE menus. There are several 
Custom Reports available out of the box and are designated as System. You are unable 
to modify the original version of a report; however, you can copy a report and modify it, 
or create a new one using Unanet AE’s Report Builder. 

A Custom Report is categorized as a Report, Data Grid, Action, or Warning. Once 
access is granted, the icons on the Main Menu will help you determine the category 
when accessing reports. 

 

 

Activity 6.4 – Manage Custom Reports/Actions 
In this activity, you will manage custom reports and actions.  

 
 
Activity Steps 
 
Part 1: Access System Reports 

1. Navigate to Utilities > Custom Reports. The Custom Reports applet opens. 
You can filter the list of the reports that display.  

2. Select System from the System drop-down list.  
3. Select Reports from the Type drop-down list. This filter lists an assortment of 

reports that do not pertain to one particular role.  
 
Part 2: Run a System Report 

1. Double-click Opportunities in the Reports list.  
2. Select the Preview Report button on the toolbar. The Opportunities window 

opens. 
3. Select the Print button. The Opportunities report window opens.  
4. Select the Close button.  
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Part 3: Pin a System Report to a Menu   
1. Select the Modules / Applets tab.  
2. Select the Prospect Management check box in the Modules list.  
3. Select the Opportunities check box in the Applets list.  
4. Select Toolbar from the Type drop-down list.  
5. Select the Save button.  

 
Part 4: Assign Permissions 

1. Select the Permissions tab.  
2. Select the Accounts Receivable check box in the Groups list.  
3. Select the Save button.  

 
Part 5: Access Actions 

1. Select System from the System drop-down list.  
2. Select Actions from the Type drop-down list. This filter lists the Actions that are 

available.  
 

Part 6: Access Data Grids 
1. Select System from the System drop-down list.  
2. Select Data Grids from the Type drop-down list. This filter lists the Data Grids 

that are available. This option is typically used by IT.  
 
Part 7: Access Warnings 

1. Select System from the System drop-down list.  
2. Select Warnings from the Type drop-down list. This filter lists the Warnings that 

are available.  
 
Part 8: Access Custom Reports 

1. Select Custom from the System drop-down list.  
2. Select Reports from the Type drop-down list. The reports listed include reports 

downloaded from Marketplace and custom reports built with ReportBuilder.  
3. Close the Custom Reports applet.  
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Check Your Understanding 
 

 
Which module is used to manage reports and invoices? 
 

a) Utilities 
b) Administration 
c) Personal 
d) Human Resources 

 
 

Which one of the following applets is used to provide Project Managers 
access to a report that was downloaded from Marketplace?  
 

a) Permissions 
b) Report Management 
c) Custom Reports 
d) PM Report Designer 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 7: CREATING REPORTS 

Learning Objectives 
 
Recall the steps to create various reports. 

• Recall how to create and edit ReportBuilder Reports. 
• Explain how to create Queries. 
• Summarize how to use QueryBuilder. 
• List the steps to build Financial Statements. 
• Explain how to edit existing Invoice Designs. 

 

ReportBuilder  
ReportBuilder is a standalone report building application that allows a user to define 
column headers, filtering and grouping options, and customize the display. Once 
created, these reports are managed like all other Custom Report.  

ReportBuilder is easily navigated and walks the user through each element in the report 
design process. The elements of report design include the compilation of data and the 
organization of that data by means of design. No SQL knowledge is required. 

Step Details 
Dataset Select the information for the report being built.  
Fields Select the fields to be used on the report.  
Calculated Fields Name, configure, and build the supporting expressions. 
Sorts Determine the sorting rules to apply the report. 
Filters & Prompts Determine the method of filtering data: explicit filters or user prompts. 
Template Select a template for the report.  
Settings Configure and customize the selected template.  
Groups Determine the grouping rules to apply the report. 
Table Layout Define the attributes of the table displayed on the report. 
Finish Name the report and install it to Unanet AE. 
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Activity 7.1 – Create and Edit ReportBuilder Reports 
In this activity, you will create and edit a report using ReportBuilder. 

 
Activity Steps 
 
Part 1: Datasets 

1. Navigate to Utilities > Custom Reports. The Custom Report applet opens.  
2. Select the Launch ReportBuilder button on the toolbar. The ReportBuilder 

window opens. 
3. Select Time Sheets from the Datasets list.  
4. Select the Next button on the bottom right corner.  

 
Part 2: Fields 

1. Type Project path in filter fields.  
2. Select Project_path_1.  
3. Select the right-facing arrow to move the field to the Selected Fields list.  
4. Repeat steps 1-3 to add the following fields to the Selected Fields list:  

• Project_Name_1 
• Employee_is_Active 
• Employee_Code 
• Employee_Name 
• Work_Date 
• Work_Hours 
• Effort_Amount 
• Bill_Hours 
• Bill_Rate 
• Pay_Amount 

5. Use the up and down arrows to reorder the fields as necessary, so that they 
appear in the same order as the list in step 4.  

6. Select the Next button.  
 
Part 3: Calculated Fields 

1. Select the Use Calculated Fields check box.  
2. Type Profit in the Field Name field.  
3. Use the Field Expression builder to create the following expression:  

(Bill_Hours * Bill_Rate) – Pay_Amount  
4. Select the Next button.  

 
Part 4: Sorts 

1. Select Project_Path_1 from the first Field Name drop-down list.  
2. Select Employee_Code from the second Field Name drop-down list.  
3. Select the Next button.  
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Part 5: Data Filters & Report Prompts 
1. Use the information in the table to create the Data Filters & Report Prompts:  

Field Label ? Value (leave blank to prompt) 
Employee_is_Active  = 1 
Project_Path_1 Project =  

Note: A blank in the Value field creates a user prompt.  
2. Select the Next button.  

 
Part 6: Templates 

1. Select the use this template link under the Landscape: All Pages Header (No 
Logo) template.  

2. Select the Next button.  
 
Part 7: Settings 

1. Type Employee Hours and Effort by Project in the Report Text field.  
2. Deselect the Show Subtitle check box in the 2: Subtitle Settings section. 
3. Select the Next button.  

 
Part 8: Groups 

1. Use the information in the table to create the Report Groupings:  
Field Sort 

Descending 
Show Header Show Footer Show Map 

Project_Path_1  Select Select Select 
Employee_Code  Select Select  

2. Select the Next button.  
 
Part 9: Table Layout 

1. Select the PREVIEW SAMPLE REPORT button. The Report Sample window 
opens.  

2. Close the Report Sample window. 
3. Type Project Name in the second H cell.  
4. Select the Work Date/D cell.  
5. Select MM/dd/yyyy from the Format Code drop-down list in the CELL STYLING 

section.  
6. Drag the following Headers off the table to remove from the report:  

• Employee is Active  
• Bill Hours  
• Bill Rate  
• Pay Amount 

7. Select the ROW SETTINGS tab.  
8. Type 0.2500 in the Row Height field.  
9. Select the TABLE & GROUP OPTIONS tab.  
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10. Select the Auto Size check box for Column Sizing.  
11. Select the PREVIEW SAMPLE REPORT button. The Sample Report window 

opens.  
12. Close the Report Sample window. 
13. Select the Next button.  

 
Part 10: Finish the Report 

1. Type Employee Hours and Effort by Project in the Report Name field.  
2. Select the Save Report button.  
3. Close the ReportBuilder window.  
4. Select the Refresh button on the toolbar. The Employee Hours and Effort by 

Project report displays in the System: Custom Reports list.  
 
Part 11: Assign Permissions and Location 

1. Double-click Employee Hours and Effort by Project.  
2. Select the Permissions tab.  
3. Select the Administrator check box in the Groups section.  
4. Select the Modules / Applets tab.  
5. Select the Project Management check box.  
6. Select the Save button.  

 
Part 12: Preview the Report 

1. Select the Preview Report button on the toolbar. The Employee Hours and 
Effort by Project window opens.  

2. Select Million Dollar Bridge in the Project field.  
3. Select the Print button. The Employee Hours and Effort by Project report 

window opens.  
4. Select the Print Layout button.  
5. Select the Close button on the report window. 

 
Part 13: Edit the Report 

1. Double-click Employee Hours and Effort by Project.  
2. Select the Settings tab.  
3. Select the ReportBuilder button in the Settings tab. The ReportBuilder window 

opens. 
3. Make edits to the report, as necessary. 
4. Select the Finish tab to save the report. 
5. Close the ReportBuilder window.  
6. Close the Custom Reports applet. 
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Masterfile Queries 
There are seven query applets in Unanet AE:  

• Clients  
• Contacts  
• Firms 
• Opportunities 
• Vendors  
• Projects  
• Employees 

 

The concept of the query tools is to allow the user to define lists of data based on a user 
query definition without having to know how to write SQL code to get results. The list 
can then be used to navigate to the individual records within the list or can be exported 
to Excel. 

When creating a query, there are three privacy options: personal, private, and public.  

• Personal: Visible only to the user who designs them 
• Private: Available only to users who have permission to view private queries 
• Public: Viewable by everyone 

 

Activity 7.2 – Create Queries 
In this activity, you will create a Client, Vendor, Employee, and Project Query.  

 
 
Activity Steps 
 
Part 1: Create a Client Query 

1. Navigate to Accounts Receivable > Client Queries. The Client Queries applet 
opens.  

2. Select the New button on the toolbar. The Query Designer window opens.  
3. Type Active Clients by Name in the Name field.  
4. Select Personal from the Type drop-down list.  
5. Select the Input tab.  
6. Type is in the Column field.  
7. Select the Parameter check box for Clients IsActive.  
8. Select the Output tab. 
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9. Use the information in the table to create the outputs:  
Table Column Show Column Order 
Clients FirmCode Select 2 
Firms FirmName Select 3 
Clients IsActive Select 1 

10. Select the Save button.  
11. Select Active Clients by Name in the Client Queries list.  
12. Select = from the Operator drop-down list in the Parameters section.  
13. Select the Value 1 check box in the Parameters section.  
14. Select the Run button.  

 
Part 2: Create a Vendor Query 

1. Navigate to Accounts Payable > Vendor Queries. The Vendor Queries applet 
opens.  

2. Select the New button. The Query Designer window opens.  
3. Type Vendor Pay-to Address in the Name field.  
4. Select Personal in the Type field.  
5. Select the Input tab.  
6. Select the Parameter check box for Vendors Is Active.  
7. Select the Output tab.  
8. Use the information in the table to create the outputs:  

Table Column Show Column Order 
Vendors FirmCode Select 1 
Firms FirmName Select 2 
Pay-To Addresses Street1 Select 3 
Pay-To Addresses Street2 Select 4 
Pay-To Addresses City Select 5 
Pay-To Addresses State Select 6 
Pay-To Addresses Zip Select 7 

9. Select the Save button.  
10. Select Vendor Pay-to Address in the Vendor Queries list.  
11. Select = from the Operator drop-down list in the Parameters section.  
12. Select the Value 1 check box in the Parameters section.  
13. Select the Run button.  

 
Part 3: Create a Project Query 

1. Navigate to Project Management > Project Queries. The Project Queries 
applet opens.  

2. Select the New button. The Query Designer window opens.  
3. Type Active Project by Client in the Name field.  
4. Select Personal from the Type drop-down list.  
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5. Select the Input tab.  
6. Select the Parameter check box for Project Facts ChargeTypename.  
7. Select = from the Filter Operator drop-down list for Project Facts 

ChargeTypename. 
8. Type 1 in the Filter 1 field for Project Facts ChargeTypename.  
9. Select the Output tab. 
10. Use the information in the table to create the outputs:  

Table Column Show Column Order Sort Order Ascending 
Firms FirmName Select 3 1 Select 
Projects ProjectPath Select 1   
Projects ProjectName Select 2   

11. Select the Save button.  
12. Select Active Project by Client in the Project Queries list.  
13. Select = from the Operator drop-down list in the Parameters section for the 

ChargeTypename option.  
14. Type Billable in the Value 1 field. 
15. Select the Run button.  

 
Part 4: Create an Employee Query 

1. Navigate to Human Resources > Employee Queries. The Employee Queries 
applet opens.  

2. Select the New button. The Query Designer window opens.  
3. Type Employee Time and Expense Approvers in the Name field.  
4. Select Personal in the Type field.  
5. Select the Input tab.  
6. Select the Parameters check box for Employees IsActive.  
7. Select the Output tab. 
8. Use the information in the table to create the outputs:  

Table Column Show Column Order 
Employees EmpCode Select 1 
Employees Empname Select 2 
Employees TimeExpApproverEmpname Select 3 
Employees AltTimeExpApproverEmpname Select 4 

9. Select the Save button.  
10. Select Employee Time and Expense Approvers in the Employee Queries list.  
11. Select = from the Operator drop-down list in the Parameters section.  
12. Select the Value 1 check box in the Parameters section.  
13. Select the Run button.  
14. Close the Client Queries applet. 
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Query Builder 
Advanced applets in Unanet AE leverage the power and flexibility of SQL queries, 
where the user can directly query their Unanet AE data. 

Query Builder visualizes query writing and dynamically builds Unanet AE-optimized 
queries for use in applets like Dashboard Queries Manager, Custom Reports, etc. 

 

Activity 7.3 – Create SQL Queries Using Query Builder 
In this activity, you will create an SQL Query using Query Builder.  

 
 
Activity Steps 
 

1. Navigate to Utilities > Query Builder. The Query Builder applet opens. 
2. Select Accounts Receivable from the Datasets drop-down list.  
3. Select the check boxes for the following Available Fields: 

• Clients: Client Is Active 
• Clients: Client Name 
• Accounts Receivable: Balance 
• Accounts Receivable: Invoice Date 
• Accounts Receivable: Invoice No 

4. Select the Filters tab. 
5. Use the information in the table to create the Filters:  

Field ? Value (SQL Format) 
Client_Name =  
Client_Is_Active = 1 

6. Select the Build & Execute button. On the Results tab, the records display for 
the query. You can export the query or save as an analytic model.  

7. Select the Save As Model button. The Enter Name window opens. 
8. Type QBAR in the Enter an Analytic Model Name field.  
9. Select the OK button. The Save Successful window opens.  
10. Select the OK button.  
11. Close the Query Builder applet. 
12. Navigate to Utilities > Dashboard Queries Manager. The Dashboard Queries 

Manager applet opens.  
13. Double-click QBAR in the Query Name list. The QBAR query displays on the 

Query tab. 
14. Close the Dashboard Queries Manager applet.  

 

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_7.3/story.html
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Financial Statement Designer 
Financial Statement Designer provides for flexible statement generation. Balance 
Sheets, Profit & Loss (consolidated and by profit center), and other statements can be 
created here. This allows a group of G/L accounts to be combined to appear on a 
financial statement design. Any line item can contain up to fifteen columns, so 
comparatives between periods and/or budgets can be achieved. Financial statements 
can use accrual or cash figures. 

Financial Statement Designer allows you to utilize Sample Financial Statements or 
create custom statements. When creating custom statements, you will define lines and 
columns to hold the rows of G/L Accounts and G/L Periods respectively. 

 

Activity 7.4 – Create Financial Reports 
In this activity, you will create a Financial Report.  

 
 
Activity Steps 
 
Part 1: Run Query 

1. Navigate to Utilities > SQL Query. The SQL Query applet opens.  
2. Type fssample_sav for line 1. 
3. Select the Run Query button on the toolbar. The Query Execution Complete 

message displays in the upper-right corner. The templates are now available in 
the designer.  

4. Close the SQL Query applet. 
 
Part 2: Create a Financial Report 

1. Navigate to Utilities > Financial Statement Dsg. The Financial Statement 
Designer applet opens.  

2. Select Classified Income Statement from the Financial Statements drop-down 
list to use as a template or reference when creating new Financial Statements.  

3. Select the New button on the toolbar. The New Financial Statement window 
opens.  

4. Type Sample P&L in the Financial Statement Name field.  
5. Select ANSI A8.5X11 Letter – (2 Columns) from the Financial Statement 

Template drop-down list.  
6. Select the Create button.  
7. Select the Columns tab.  

  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_7.4/story.html
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8. Use the information in the table to create columns:  
Cash/Accrual Calc. Type Period Type Header 1 
Accrual Transactions Current Period Current 
Accrual Transactions Current Fiscal Year Year-to-Date 

9. Select the Lines tab.  
10. Use the information in the table to create lines: 

Line Order Line Label Command Type Indention Bold 
1 INCOME Text  Select 
2  Itemize 10  
3 TOTAL INCOME Summarize  Select 
10 DIRECT EXPENSES Text  Select 
11  Itemize 10  
12 TOTAL DIRECT EXPENSES Summarize  Select 
13 INDIRECT EXPENSES Text  Select 
14  Itemize 10  
15 TOTAL INDIRECT EXPENSES Summarize  Select 
16 TOTAL EXPENSES Summarize  Select 
20 NET INCOME Summarize  Select 

14. Select the Save button.  

Part 3: Modify Filter Ranges 
1. Select row 2. 
2. Select the Modify Filter Ranges button. The Line Filter Criteria window opens.  
3. Select the System Types tab.  
4. Select the Financial Type check box.  
5. Select the Income check box.  
6. Select the Save button.  
7. Select the Close button.  
8. Repeat steps 1-7 for the following rows:  

Line Order Line Label Financial Type Cost Types 
3  Income  
11  Expense Direct 
12 TOTAL DIRECT EXPENSES Expense Direct 
14  Expense Indirect 
15 TOTAL INDIRECT EXPENSES Expense Indirect 
16 TOTAL EXPENSES Expense  

 
Part 4: Create a Formula for Net Income 

1. Select row 20. 
2. Select the Modify Filter Ranges button. The Line Filter Criteria window opens. 
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3. Type Income in the Filter Title field.  
4. Select the Add Values radio button in the Math section.  
5. Select the System Types tab.  
6. Select the Financial Type check box.  
7. Select the Income check box.  
8. Select the Save button.  
9. Select the + icon on the bottom-left of the Line Filter Criteria window.  
10. Type Expense in the Filter Title field.  
11. Select the Subtract Values radio button in the Math section.  
12. Select the System Types tab.  
13. Select the Financial Type check box.  
14. Select the Expense check box. 
15. Select the Save button.  
16. Select the Close button.  

Part 5: Assign Permissions 
1. Select the Permissions tab.  
2. Select the cadams check box in the Users section. 
3. Select the Save button.  
4. Close the Financial Statement Designer applet.  

 
  



 
Lesson 7: Creating Reports ©2022 Unanet. All rights reserved. 

 
69 

Invoice Designs 
The Invoice Design applet is where Invoice Designs are customized in Unanet AE. 
Once invoice sections are designed, they are put together to form an invoice design. 
Invoice designs are then assigned to projects. Invoice designs can be labor only, 
expense only, or combined (both labor and expense). Designs can be created and 
edited on the Invoice Designs tab. 
 

Activity 7.5 – Edit Invoice Design 
In this activity, you will make edits to the invoice design.  

 
 
Activity Steps 
 
Part 1: Review Invoice Design 

1. Navigate to Utilities > Invoice Design. The Invoice Design applet opens.  
2. Select MixedLogo from the Invoice Designs list. Note: This invoice design was 

downloaded from Marketplace. 
3. Review the Design Sections portion. Note: Some of the posting sections are set 

to Do Not Print.  
 
Part 2: Add a Logo 

1. Select the Section Designs tab. This is where the sections are managed.  
2. Select Header from the Section Designs drop-down list.  
3. Select HeaderLogoCustomizableCVS in the list.  
4. Select Edit Section Images / Settings in the toolbar. The Report Images / 

Settings Editor window opens. Here you can insert your logo depending on the 
logo shape.  

5. Select the Cancel button.  
 
Part 3: Show Statement of Accounts 

1. Select Border from the Section Designs drop-down list.  
2. Select BorderCustomizableCVS in the list.  
3. Select Edit Section Images / Settings in the toolbar. The Report Images / 

Settings Editor window opens. 
4. Select the Report Settings tab.  
5. Type True for the Show Statement Section setting in the Miscellaneous 

section.  
6. Select the OK button.  
7. Select the Save button at the bottom of the Section Designs window.  
8. Close the Invoice Design applet.  

 

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_7.5/story.html
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Check Your Understanding 
 

 
Which one of the following privacy options would you select for a query if you 
want only some users to be able to view the query? 

 
a) Public 
b) Private 
c) Personal 
d) Custom 

 
 
Which one of the following applets would you use to pin a report to the 
navigation menu?  

 
a) Permissions 
b) Report Management 
c) PM Report Designer 
d) Custom Reports 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 8: CREATING AND MANAGING 
DASHBOARDS 

Learning Objectives 
 
Summarize how to create and manage Dashboards. 

• Explain the purpose of Dashboard Groups. 
• Summarize how to deploy Dashboards.  
• Explain how to customize Dashboard Layouts. 

 

Dashboard Groups 
Dashboard Groups are made up of Classic Widgets and Analytic Dashboards. 
Dashboards can be configured to support different layouts to organize your data. 
Employees are assigned a Dashboard Group which governs what they can view and 
customize on their personal Dashboard. 

 

Activity 8.1 – Create Dashboard Groups 
In this activity, you will create a Dashboard Group. 

 
Activity Steps 
 

1. Navigate to Utilities > Dashboard Groups. The Dashboard Groups applet 
opens.  

2. Type Finance in the Name field.  
3. Select the Widgets tab.  
4. Select the check boxes for the following Widgets:  

• Activities 
• Alerts 
• Analytics Container 
• Contacts 
• Expense Sheets 
• Gridget 
• My Projects 
• Query Chart 
• Reports 
• Tiles 
• Timesheet 

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_8.1/story.html
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5. Select the Queries tab.  
6. Select the Allowed check box for the Financial – Cost and Revenue (12 

Months) Query.  
7. Select the Alerts tab.  
8. Select the Allowed check box for the following Alerts: 

• Accounts Payable Balances 
• Accounts Receivable Balances 
• Bank Balances 
• Past Due Receivables 
• Timesheet due today 
• Your Expense Sheet has been rejected 
• Your Timesheet has been rejected 

9. Select the Tiles tab. 
10. Select the Allowed check box for the Bank Balance Tile.  
11. Select the Gridgets tab.  
12. Select the Allowed check box for the following Gridgets:  

• Expense Sheet – Approver 
• Expense Sheet – Approver Detail 

13. Select the My Project Columns tab. All Project Columns are selected by 
default.  

14. Select the Analytic Dashboards tab.  
15. Select the Allowed check box for P&L Example in the Financial grouping.  
16. Select the Save button.  
17. Close the Dashboard Groups applet. 
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Deploying Dashboard 
Assigning employees to created Dashboard Groups gives them access to all the 
allowed widgets in the group. Once deployed, the employee can create Dashboard 
layouts upon login, or Admin can configure on behalf of the group. 
 

Activity 8.2 – Apply Dashboards 
In this activity, you will apply a Dashboard Group to an employee.  

 
 
Activity Steps 
 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Type CBA in the Employee Lookup field.  
3. Press Enter. The Employees applet populates with the information for cadams.  
4. Select Finance from the Dashboard Group drop-down list.  
5. Select the Save button.  
6. Close the Employees applet.  

 

Configuring Dashboards 
The Unanet AE Dashboard gives you immediate access to the information that matters 
most to you. Dashboards can be configured by Admin, or the end users can tailor the 
Dashboard to meet their unique needs.  
 

Activity 8.3 – Manage Dashboard Layouts  
In this activity, you will customize the Dashboard layout for all employees 
assigned to the Dashboard Group.  

 
Activity Steps 
 
Part 1: Add Activities 

1. Navigate to Utilities > Dashboard Groups. The Dashboard Groups applet 
opens.  

2. Double-click Finance in the Dashboard Groups list.  
3. Select the Configure Dashboards button on the toolbar. The Group 

Dashboard Layout window opens.  
4. Select Default from the blank drop-down list.  
5. Select the + icon at the bottom of the Group Dashboard Layout window. The 

Add Dashboard Widget window opens.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_8.2/story.html
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6. Select Activities from the Add Dashboard Widget drop-down list.  
7. Select the Add Widget button. 

 
Part 2: Add Alerts 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Alerts from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button.  
4. Select Alerts in the Widgets list. 
5. Select the Use check box for the following Alerts:  

• Timesheet due today 
• Your Expense Sheet has been rejected 
• Your Timesheet has been rejected 

6. Select the Save button.  
 
Part 3: Add Contacts 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Contacts from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button.  

 
Part 4: Add Expense Sheets 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Expense Sheets from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 

 
Part 5: Add Timesheets 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Timesheet from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select the Save button.  

 
Part 6: Add New Layout  

1. Select the + icon in the Dashboard Layout Name field. The New Dashboard 
window opens.  

2. Type Financials in the Name field.  
3. Select the Classic Dashboard radio button in the Type section.  
4. Select the Create button. 

 
Part 7: Add Gridgets 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Gridget from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select Gridget in the Widgets list.  
5. Select Expense Sheet – Approver from the Grid Query drop-down list.  
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6. Select the Save button.  
7. Select the + icon at the bottom of the Group Dashboard Layout window. 
8. Select Gridget from the Add Dashboard Widget drop-down list.  
9. Select the Add Widget button. 
10. Select Gridget in the Widgets list.  
11. Select Expense Sheet – Approver Detail from the Grid Query drop-down list.  
12. Select the Save button.  

 
Part 8: Add My Projects 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select My Projects from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select My Projects in the Widgets list. 
5. Select Current Period from the Period Type drop-down list.  
6. Select the Use check box for the following Columns:  

• PTD Cost 
• PTD Billed 
• PTD Unbilled 
• PTD Profit 
• PTD Received 

7. Select the Chart check box for the Columns in step 6.  
8. Select the Save button.  

 
Part 9: Add Query Chart 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Query Chart from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select Query Chart in the Widgets list. 
5. Select Financial – Cost and Revenue from the Chart Title drop-down list.  
6. Select the Save button.  

 
Part 10: Add Reports 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Reports from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select Reports in the Widgets list. 
5. Select the Reports check box for the following Reports:  

• Accounts Payable > A/P Reports 
• Accounts Receivable > A/R Reports 
• General Accounting > Balance Sheets 
• General Accounting > General Journal Reports 
• General Accounting > General Ledger Reports  
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• General Accounting > Income Statements 
6. Select the Save button.  

Note: These reports will be visible on the Dashboard only if the employee has 
been granted Report permissions. 

 
Part 11: Add Tiles 

1. Select the + icon at the bottom of the Group Dashboard Layout window. 
2. Select Tiles from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button. 
4. Select Tiles in the Widgets list.  
5. Select Bank Balance from the Tile Query drop-down list.  
6. Select the Save button.  

 
Part 12: Add Alerts 

1 Select the + icon at the bottom of the Group Dashboard Layout window. 
2 Select Alerts from the Add Dashboard Widget drop-down list.  
3. Select the Add Widget button.  
4. Select Alerts in the Widgets list. 
5. Select the Use check box for the following Alerts:  

• Accounts Payable Balances 
• Accounts Receivable Balances 
• Bank Balances 
• Past Due Receivables 

6. Select the Save button.  
 
Part 13: Add New Layout  

1. Select the + icon in the Dashboard Layout Name field. The New Dashboard 
window opens.  

2. Type Analytics in the Name field. 
3. Select the Analytic Dashboard radio button in the Type section. 
4. Select the Create button. 

 
Part 14: Add Analytic Dashboard 

1. Select the Show check box for P&L Example. 
2. Select the Default Load check box for P&L Example. 
3. Select the Save and Close button. 
4. Close the Dashboard Groups applet.  
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Check Your Understanding 
 

 
What is the purpose of Dashboard Groups? 
 

a) Determines which employees can create Dashboards 
b) Determines what an employee can view on a Dashboard  
c) Determines what access employees have to applets 
d) All of the above 

 
 
Which one of the following modules is used to customize Dashboards? 
 

a) Personal 
b) Prospect Management 
c) Utilities 
d) Administration 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 9: CREATING AND MANAGING ANALYTIC 
DASHBOARDS 

Learning Objectives 
 
Summarize how to create and manage Analytic Dashboards. 

• Recall the moving parts associated with Analytic Dashboards.  
• List the applet permissions necessary to work with Analytic Dashboards.  
• Explain how to download an Analytic Model from Marketplace. 
• Recall how to use the Analytic Dashboard Designer tool. 
• Summarize how to grant permissions to an analytic dashboard. 

Analytic Dashboard – Moving Parts Overview 
Analytic Dashboards are built on the components of data and design. Similar to reports, 
Analytic Dashboards rely on a dataset (Analytic Model). Each model contains a query 
that draws from the data source. 

Analytic Models provide the data for designing dashboards using the built-in Analytic 
Dashboard Designer. Created dashboards are then managed in the Analytic 
Dashboards applet and distributed through Dashboard Groups. 

Component Description 
Permissions Govern user access to applets, models, and dashboards. 
Data Source The source of data used in Analytic Dashboards. Defaults to 

Unanet AE, but third-party data sources are supported. 
Analytic Models Datasets used to design dashboards. Unanet AE optimized 

models are available in Marketplace. Additionally, models can 
be built via Query Builder and managed with Dashboard 
Queries Manager. 

Analytic Dashboard 
Designer 

Design tool for creating Analytic Dashboards.  

Analytic 
Dashboards applet 

Applet used for managing Analytic Dashboards.  

Dashboard Groups Used to allow access to Analytic Dashboard views. 
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Analytic Dashboards Permissions 
Unanet AE relies on permissions to grant access to the Analytic Dashboards feature 
set. You will need permission to the following applets that are involved with Analytic 
Dashboards: 

• Analytic Dashboard Designer 
• Analytic Dashboards 
• Dashboard Groups 
• Dashboard Groups > Special Rights > Can Save Default Layout 
• Dashboard Queries Manager 
• Marketplace Purchases 

 

Activity 9.1 – Work with Analytic Dashboard Applets 
In this activity, you will grant permissions to Analytic Dashboard applets.  

 
 
Activity Steps 
 

1. Navigate to Administration > Permissions. The Permissions applet opens.  
2. Select the Groups tab.  
3. Select the lock icon for the Accounts Receivable group to add permissions. 

The Permissions for Accounts Receivable window opens.  
4. Select the Group Permissions tab.  
5. Select the +/- icon to collapse the tree. 
6. Select the + icon for the Utilities module.  
7. Select the View, Edit, Add, and Delete check boxes for the following Applets: 

• Analytic Dashboard Designer 
• Analytic Dashboards 
• Dashboard Groups 
• Dashboard Queries Manager 
• Marketplace Purchases 
• Query Builder 

8. Select the + icon for the Dashboard Groups applet. The Special Rights options 
display for Dashboard Groups.  

9. Select the Allowed check box for Can Save Default Layout. 
10. Select the Save button.  
11. Close the Permissions applet.  

 
 

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Activity_9.1/story.html
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Analytic Models 
Analytic Models (or queries) provide the data for designing Analytic Dashboards. 

While we have given you the tools to build your own, Unanet AE offers several 
optimized models available through the Marketplace. Whether downloaded or custom 
built, Analytic Models are used when designing dashboard views and can be managed 
in the Dashboard Queries Manager applet. 

 

Demo 9.2 – Download Analytic Models (Marketplace) 
In this demo, you will learn how to download an Analytic Model from 
Marketplace.  

 
 

This demo cannot be completed in the Training System.  
 

 
Demo Steps 
 

1. Navigate to Utilities > Marketplace Purchases. The Marketplace Purchases 
applet opens.  

2. Select the InFocus Marketplace link in the upper-right corner. The Unanet AE 
Support Portal opens in a new tab.  

3. Type [your email address] in the Email Address field.  
4. Type [your password] in the Password field. Note: These are different 

credentials from your Unanet AE login. 
5. Select the Sign In button. The Unanet AE Marketplace opens.  
6. Select Widgets in the Browse section.  
7. Select Analytic Model from the SUB-TYPES list.  
8. Select the Employee Stats by Month Analytic Model widget.  
9. Select the Free - Get button. The TERMS OF SERVICE AGREEMENT window 

opens. Note: This agreement will only appear for the first download. 
10. Select the Agree check box.  
11. Select the Get button.  
12. Close the Unanet AE Support Portal. 
13. Close the Marketplace Purchases applet. 

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_Admin/Demo_9.2/story.html
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Activity 9.3 – Install the Analytic Model and Assign 
Permissions 
In this activity, you will install the Analytic Model in Unanet AE and assign 
permissions.  

 
Activity Steps 
 
Part 1: Install the Analytic Model 

1. Navigate to Utilities > Marketplace Purchases. The Marketplace Purchases 
applet opens.  

2. Select Employee Stats by Month Analytic Dashboard in the list.  
3. Select the Install / Update button in the toolbar.  

 
Part 2: Assign Model Permissions 

1. Select the Gear icon in the Manage column for Employee Stats by Month 
Analytic Model. The Dashboard Queries Manager applet opens.  

2. Select Analytic Models in the list. 
3. Double-click Employee Stats by Month CVS in the list.  
4. Select the Model Permissions tab.  
5. Select the demo check box is the Users list.  
6. Select the Accounts Receivable check box in the Groups list.  
7. Select the Save button.  
8. Close the Dashboard Queries Manager applet.  
9. Close the Marketplace Purchases applet. 

 

Analytic Dashboard Designer 
Analytic Dashboard Designer applet features an intuitive, interactive design 
environment that displays your dashboards in real-time as you build them. Each design 
uses a data source and an Analytic Model. The designer supports multiple data sources 
and multiple models per design (advanced designs). 
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Activity 9.4 – Use the Analytic Dashboard Designer Tool 
In this activity, you will use the Analytic Dashboard Designer to create and 
customize an Analytic Dashboard.  

 
Activity Steps 
 
Part 1: Create an Analytic Dashboard 

1. Navigate to Utilities > Analytic Dashboard Designer. The Analytic Dashboard 
Designer applet opens. Note: Select the Auto Hide icon at the bottom of the 
Navigation pane to increase your Workspace.  

2. Select the New button on the toolbar. The Add Model? window opens.  
3. Select the Yes button. The Choose a Model window opens.  
4. Select Employee Stats by Month CVS.  
5. Select the Open button. 
6. Select the Reload Data icon below the query. 

 
Part 2: Add a Chart 

1. Select the Chart button.  
2. Drag the Hours field to the Values pane. 
3. Drag Transaction_Date (Year) to the Arguments pane.  
4. Select Month from the Transaction_Date drop-down list in the Arguments 

section.  
5. Drag Project_Charge_Type to the Series pane.  
6. Select Series (graph) icon on the Values pane next to the Hours field. The 

Series Options window opens.  
7. Select Stacked Bar.  
8. Select the OK button.  

 
Part 3: Add a Grid 

1. Select the Grid button.  
2. Drag Project_Path_Level_1 to the first Columns pane. 
3. Drag Project_Long_Name_Level_1 to the second Columns pane.  
4. Drag Hours to the third Columns pane.  
5. Select the Hours drop-down arrow.  
6. Select Format from the menu. The Numeric Format window opens.  
7. Select Number in the Format type field.  
8. Select the OK button.  
9. Drag Hours to the fourth Columns pane.  
10. Select the Hours drop-down arrow.  
11. Select Calculation > Percent of Total from the menu.  
12. Drag Project_Charge_Type to the Measures pane.  
13. Select the Project_Path_Level_1 drop-down arrow. 
14. Select Top N from the menu. The Top N Values window opens.  
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15. Select the Enabled check box.  
16. Select the Show “Others” value check box.  
17. Select the Apply button. 
18. Select the OK button.  
19. Select the Project_Long_Name_Level_1 drop-down arrow. 
20. Select Top N from the menu. The Top N Values window opens.  
21. Select the Enabled check box.  
22. Select the Show “Others” value check box.  
23. Select the Apply button.  
24. Select the OK button.  
25. Select the Project_Charge_Type drop-down arrow. 
26. Select Max from the menu.  

 
Part 4: Add a Format Rule to the Grid 

1. Select the Project_Charge_Type drop-down arrow. 
2. Select Add Format Rule > Expression from the menu. The Expression window 

opens. 
3. Select the + icon.  
4. Select the Begins with (green) link in the box.  
5. Select Equals.  
6. Type Billable in the <enter a value> area.  
7. Select the Bold icon.  
8. Select the Apply to row check box.  
9. Select the Apply button.  
10. Select the OK button.  
11. Right-click the Hours (Sum) column in Grid 1.  
12. Select Add Total > Auto from the menu.  

 
Part 5: Add a Pie Chart 

1. Select the Pies button.  
2. Drag Hours to the Values pane.  
3. Drag Project_Charge_Type to the Arguments pane. 
4. Drag the Pies 1 tile under the Grid 1 tile. Note: A blue bar displays to indicate 

where the insert item will land once dropped. 
 
Part 6: Add Cards 

1. Select the Cards button.  
2. Drag Hours to the Cards Actual pane.  
3. Drag Hours_Billable to the second Cards Actual pane.  
4. Drag Hours_Indirect to the third Cards Actual pane.  
5. Drag Hours_Opportunity to the fourth Cards Actual pane.  
6. Select the Design tab on the ribbon menu.  
7. Select the Arrange in Rows button.  
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8. Type 1 in the Count field.  
9. Drag the Cards 1 tile under the Chart 1 tile, if not already placed there. Note: A 

blue bar displays to indicate where the insert item will land once dropped. 
 
Part 7: Add a Text Box 

1. Select the Home tab on the ribbon menu.  
2. Select the Text Box button.  
3. Drag Employee_Name to the Values pane.  
4. Select the Employee_Name drop-down arrow. 
5. Select Max from the menu.  
6. Drag Employee_Code to the second Values pane.  
7. Select the Employee_Code drop-down arrow. 
8. Select Max from the menu.  
9. Select the Design tab on the ribbon menu.  
10. Select the Edit button.  
11. Select the Insert Field button.  
12. Select Employee_Name from the Select value drop-down list.  
13. Press Enter.  
14. Select the Insert Field button. 
15. Select Employee_Code from the Select value drop-down list. 
16. Select the Home tab in the Text Box Editor section.  
17. Select to highlight the Employee_Name (Max) text in Text Box 1. 
18. Select 14 from the Font Size drop-down list.  
19. Select to highlight the Employee_Code (Max) text in Text Box 1.  
20. Select the Italics icon.  
21. Select the Design tab in the Text Box Tools section.  
22. Select the Edit button.  
23. Drag the Text Box 1 tile above the Chart 1 tile. Note: A blue bar displays to 

indicate where the insert item will land once dropped. 
 
Part 8: Add a Range Filter 

1. Select the Home tab on the ribbon menu. 
2. Select the Range Filter button.  
3. Drag Hours to the Values pane.  
4. Drag Transaction_Date to the Argument pane.  
5. Select the Transaction_Date drop-down arrow. 
6. Select Month - Year from the menu.  
7. Drag the Range Filter tile above the Grid 1 tile. Note: A blue bar displays to 

indicate where the insert item will land once dropped. 
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Part 9: Create a Master Filter 
1. Select Chart 1 in the Dashboard.  
2. Select the Data tab on the ribbon menu.  
3. Select the Multiple Master Filter button. 
4. Select a bar in the Chart 1 tile to see Grid and Cards filter.  
5. Select the Clear Filter icon for Chart 1.  

 
Part 10: Finish the Dashboard 

1. Select the Home tab on the ribbon menu. 
2. Select the Title button in the Dashboard section. The Dashboard Title window 

opens.  
3. Type Employee Hours in the Text field.  
4. Select the Apply button. 
5. Select the OK button.  
6. Select Text Box 1.  
7. Select the Design tab on the ribbon menu.  
8. Deselect the Show Caption button.  
9. Select Chart 1.  
10. Select the Design tab on the ribbon menu.  
11. Select the Edit Names button. The Edit Names window opens.  
12. Type Hours by Month in the Dashboard item name field.  
13. Select the OK button.  
14. Select the Y-Axis Settings button. The Y-Axis Settings window opens.  
15. Deselect the Show title check box.  
16. Select the Apply button. 
17. Select the OK button.  
18. Select the Home tab on the ribbon menu. 
19. Select the Save button on the toolbar. The Save Dashboard window opens.  
20. Select Employee from the Grouping drop-down list.  
21. Type My Hours in the Dashboard Name field. 
22. Type My Hours in the Title field (this should auto-populate). 
23. Select the Save button.  
24. Close the Analytic Dashboard Designer applet.  
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Analytic Dashboards 
Once an Analytic Dashboard view is created, you can manage who has access to work 
with the design. Often, this may simply be you- the creator of the dashboard view. 
However, some enterprise environments may have a team of designers managing 
various dashboard views. 

In addition to designer permissions, Analytic Dashboards allow you to edit, copy, delete, 
import, and export your dashboard. Other management options include 
activate/deactivate, grouping, titles, etc. 

 

Activity 9.5 – Manage Analytic Dashboards 
In this activity, you will grant permissions to the analytic dashboard you 
created.  

 
Activity Steps 
 

1. Navigate to Utilities > Analytic Dashboards. The Analytic Dashboards applet 
opens.  

2. Double-click My Hours in the list. 
3. Select the Accounts Receivable check box in the Groups list on the Designer 

Permissions tab.  
4. Select the Save button.  
5. Close the Analytic Dashboards applet.  
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Activity 9.6 – Deploy Analytic Dashboards 
In this activity, you will grant access to the created Analytic Dashboard to 
Dashboard Groups. 

 
Activity Steps 
 

1. Navigate to Utilities > Dashboard Groups. The Dashboard Groups applet 
opens.  

2. Double-click Finance in the Dashboard Groups list.  
3. Select the Analytic Dashboards tab. 
4. Select the Allowed check box for the My Hours Analytic Dashboard.  
5. Select the Save button.  
6. Select the Configure Dashboards button on the toolbar. The Group 

Dashboard Layout window opens.  
7. Select Analytics from the blank drop-down list.  
8. Select the Show check box for the My Hours Analytic Dashboard. 
9. Select the Default Load check box for the My Hours Analytic Dashboard. 
10. Select the Save and Close button. 
11. Close the Dashboard Groups applet.  
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Check Your Understanding 
 

 
Determine if each statement is true or false.   
 

 
 True or False 
Dashboards are managed in the Analytic Dashboards applet and 
distributed through Dashboard Groups. 

 

Permissions to the various Analytic Dashboard applets are granted 
using Administration > Permissions.  

 

All Analytic Models must be downloaded from Marketplace.   
Permissions to specific Analytic Dashboards are granted using the 
Analytic Dashboard Designer applet. 

 

Permissions to Analytic Dashboards can be given to users or groups.  
 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 10: CUSTOMIZING THE USER INTERFACE 

Learning Objectives 
 
Recall methods used for customizing the user interface. 

• Explain how to add an additional column to a grid using Column Chooser. 
• Summarize how to create user defined fields.  
• Explain how to use the Layout Manager. 

Column Chooser 
The Column Chooser contains any additional columns that may not be displayed in the 
default layout of a grid. It gives you the ability to change the font size for the header 
(labels) and rows (data). You can add a standard column or a custom column.  

 

Activity 10.1 – Work with the Column Chooser 
In this activity, you will add an additional column to a grid.  

 
 
Activity Steps 
 
Part 1: Add a Standard Column 

1. Navigate to Project Management > Project Planning. The Project Planning 
applet opens.  

2. Type 20210000 in the Project Lookup field.  
3. Press Enter. The Hypoch Park Pedestrian Bridge project information displays.  
4. Select the Column Chooser (gear) icon in the Project grid. The Column 

Chooser window opens.  
5. Select the Show check box for Labor Allocated Hours. 
6. Type Alloc Hrs in the Label Override field for Labor Allocated Hours.  

 
Part 2: Review Custom Columns 

1. Select the Custom Columns tab. 
2. Review the information that is needed for creating a custom column.  
3. Hover mouse over the Formula cell in the Cus_Calc_ETC column.  
4. Select the Formula (Sigma symbol) icon in the Cus_Calc_ETC column. The 

Formula Builder window opens. Here you can build a formula for a custom 
column.  

5. Select the Cancel button.  
6. Select the OK button. The Alloc Hrs column is added.  
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Part 3: Remove Columns from the Grid 
1. Drag the EAC Amount header off the table to remove the column from the grid.  
2. Close the Project Planning applet. 

UDF Designer 
Unanet AE gives you the ability to store and utilize user-defined information in fields 
referred to as UDFs. They are created via Administration > UDF Designer or by clicking 
the UDF Designer button on the toolbar from supported applets.  

You can create UDFs for the following applets: 
• Clients  
• Vendors 
• Employees 
• Projects 
• Contacts 
• ProjectLevel2 

 
To see a list of the UDFs that have been created, go to the respective applets, and click 
the Custom Fields tab. The label of the Custom Fields tab can be changed at 
Administration > Global Settings > UDF tab. UDFs can also be used in conjunction with 
the Layout Manager to incorporate them into the main tabs of the applets. 
 

Activity 10.2 – Create a User Defined Field (UDF) 
In this activity, you will create a user defined field using the UDF Designer.  

 
 
Activity Steps 
 

1. Navigate to Administration > UDF Designer. The UDF Designer window 
opens.  

2. Select Employees from the Applet drop-down list.  
3. Use the information in the table to create a UDF:  

Field Information 
Label Eye Color 
Name Cus_EyeColor 
Data Type Character 

Note: The Name field cannot include punctuation marks or spaces.  
4. Select the Save button. 
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Activity 10.3 – Create a UDF Table 
In this activity, you will create a UDF table using the UDF Table Designer.  

 
 
Activity Steps 
 
Part 1: Create a Table 

1. Navigate to Administration > UDF Table Manager. The UDF Table Manager 
applet opens.  

2. Select the New button.  
3. Type Family in the Display Name field.  
4. Use the information in the table to create a column:  

Field Information 
Name Cus_Spouse 
Caption Spouse 
Data Type Varchar 
Size 50 

5. Use the information in the table to create a column:  
Field Information 
Name Cus_Children 
Caption Children 
Data Type Varchar 
Size 50 

6. Select the Save button.  
7. Select the Data tab.  
8. Select the Load Data button.  
9. Select the following check boxes:  

• Allow Insert 
• Allow Update 
• Allow Delete 
• Fit Columns 

10. Select the Create Gridget link.  
11. Select the Save button. 
12. Close the UDF Table Manager applet.  

 
Part 2: Create a User Defined Field for the Table 

1. Navigate to Administration > UDF Designer. The UDF Designer window 
opens.  

2. Select Employees from the Applet drop-down list.  
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3. Use the information in the table to create a UDF:  
Field Information 
Label Family 
Name Grid_Family 
Data Type Gridget 
Gridget Family - Editor 

4. Select the Save button. 
 

Layout Manager 
The Layout Manager gives you the ability to customize the layout of all master file 
applets: Clients, Contacts, Employees, Firms, Opportunities, Projects, and Vendors. 
With the Layout Manager, you have the ability to require that additional information be 
entered before you save, change the order and appearance of any tab (font color and 
size, location of sections, etc.), and incorporate UDFs into any tab. 
 

Activity 10.4 – Use the Layout Manager 
In this activity, you will use the Layout Manager to customize the Employee 
applet and add UDFs to a tab.  

 
 
Activity Steps 
 
Part 1: Copy System Form 

1. Navigate to Utilities > Layout Manager. The Layout Manager window opens.  
2. Select Employees from the Forms drop-down list.  
3. Select the Custom Mode check box.  
4. Select the Copy System Form button. The Are You Sure? window opens.  
5. Select the Yes button.  

 
Part 2: Add a Tab 

1. Select the + icon in the Tabs section. The Layout Tab window opens.  
2. Type Custom in the Name field. 
3. Select the Save button. 

 
Part 3: Add a Section 

1. Select Custom in the Tabs grid.  
2. Select the + icon in the Sections section. The Layout Section window opens.  
3. Type Custom in the Name field.  
4. Select the Save button. 
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Part 4: Add Fields 
1. Select Eye Color in the User Defined Fields section. 
2. Select the right-facing arrow icon. The Field window opens.  
3. Select the Save button.  
4. Select Family in the User Defined Fields section.  
5. Select the right-facing arrow icon. The Field window opens.  
6. Type 400 in the Width field.  
7. Type 100 in the Height field.  
8. Select the Save button.  
9. Select the Add Spacer link.  
10. Close the Layout Manager applet.  

 
Part 5: Review the Employees Form 

1. Navigate to Human Resources > Employees. The Employees applet opens.  
2. Select the Custom tab. The UDFs that you created display on the tab.  
3. Close the Employees applet.  
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Check Your Understanding 
 

 
Which one of the following options would you use to add a user defined field to 
a form? 

 
a) UDF Designer 
b) UDF Table Designer 
c) Layout Manager 
d) Column Chooser 

 
 

Which one of the following options would you use to create a user defined 
field? 

 
a) UDF Designer 
b) UDF Table Designer 
c) Layout Manager 
d) Column Chooser 

 
 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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APPENDIX A: Check Your Understanding Answer Key 
 

Lesson 1: Managing System-wide Permissions 
 

 
Where are groups created and permissions assigned to groups?  
 

a) Administration > Permissions 
b) Human Resources > Employees 
c) Utilities > Navigator Queries 
d) Accounts Receivable > Clients 

 
 
Which module is used for creating a new document type?  
 

a) Administration  
b) Human Resources  
c) Utilities  
d) Accounts Receivable  
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Lesson 2: Setting Up Time and Expense 
 

 
Determine if each statement is true or false.  
 

 
 True or False 
Each employee must be assigned to a Timesheet Group. T 

Each employee must be assigned to a Time & Expense Template. F 
A Holiday Calendar can be assigned to multiple Timesheet Groups. T 
Expense Codes are created via the Project Administration module. T 
Expense Codes can be used for unit billing. T 
Labor Codes can be utilized on Timesheets for budgeting. F 
Labor Code Groups are required to use Labor Codes F 
Job Titles are created via the Human Resources module. T 
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Lesson 3: Managing Benefits 
 

 
When you create a Benefit Accrual which one of the following must be 
associated with the benefit?  
 

a) Project 
b) Accrual Date 
c) Accrual Schedule 
d) Timesheet Group 

 
 
When creating an Accrual Schedule, which one of the following allows for 
unlimited carryover over of hours? 
 

a) 1 
b) 0 
c) -1 
d) 99,999 
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Lesson 4: Project Administration 
 

 
How do you add or edit the Project WBS? 
 

a) Right-click the project name and select Edit.  
b) Select the Edit Project Structure check box.  
c) Select File > Edit in the toolbar.  
d) Select the Expense & G/L tab.  

 
 
Which of the following are rate schedules used to control? Select all that 
apply. 

 
a) Bill Rates 
b) Job Cost Rates 
c) Pay Rates 
d) Expense Codes 
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Lesson 5: Managing PM Permissions and Access 
 

 
Which one of the following determines whether an employee can view pay 
and/or job cost on reports? 

 
a) Special Rights 
b) Resource Groups 
c) Project Roles 
d) Rate Options 

 
 
Where are Resources Groups assigned to a specific project? 
 

a) Project Management > Resource Groups  
b) Project Management > Project Planning  
c) Project Administration > Projects  
d) Project Administration > WBS Templates 

 
 
 
  



 
APPENDIX A: Check Your Understanding Answer Key ©2022 Unanet. All rights reserved. 

 
100 

Lesson 6: Managing Reports 
 

 
Which module is used to manage reports and invoices? 
 

a) Utilities 
b) Administration 
c) Personal 
d) Human Resources 

 
 
Which one of the following applets is used to provide Project Managers 
access to a report that was downloaded from Marketplace?  

 
a) Permissions 
b) Report Management 
c) Custom Reports 
d) PM Report Designer 
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Lesson 7: Creating Reports 
 

 
Which one of the following privacy options would you select for a query if you 
want only some users to be able to view the query? 

 
a) Public 
b) Private 
c) Personal 
d) Custom 

 
 
Which one of the following applets would you use to pin a report to the 
navigation menu?  

 
a) Permissions 
b) Report Management 
c) PM Report Designer 
d) Custom Reports 
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Lesson 8: Creating and Managing Dashboards 
 

 
What is the purpose of Dashboard Groups? 
 

a) Determines which employees can create Dashboards 
b) Determines what an employee can view on a Dashboard  
c) Determines what access employees have to applets 
d) All of the above 

 
 
Which one of the following modules is used to customize Dashboards? 
 

a) Personal 
b) Prospect Management 
c) Utilities 
d) Administration 
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Lesson 9: Creating and Managing Analytic Dashboards 
 

 
Determine if each statement is true or false.   
 

 
 True or False 
Dashboards are managed in the Analytic Dashboards applet and 
distributed through Dashboard Groups. 

T 

Permissions to the various Analytic Dashboard applets are granted 
using Administration > Permissions.  

T 

All Analytic Models must be downloaded from Marketplace.  F 
Permissions to specific Analytic Dashboards are granted using the 
Analytic Dashboard Designer applet. 

F 

Permissions to Analytic Dashboards can be given to users or groups. T 
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Lesson 10: Customizing the User Interface 
 

 
Which one of the following options would you use to add a user defined field to 
a form? 

 
a) UDF Designer 
b) UDF Table Designer 
c) Layout Manager 
d) Column Chooser 

 
 
Which one of the following options would you use to create a user defined 
field? 

 
a) UDF Designer 
b) UDF Table Designer 
c) Layout Manager 
d) Column Chooser 
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COMPLETION CERTIFICATE AND EVALUATION 
 
When the course has finished, Unanet University staff will mark the attendance in the 
Learning Management System (LMS.) This marking is percentage based and may be 
prorated if a participant was absent for any period of time during the course. 

The LMS will generate a completion certificate (including CPE credits, where 
applicable) which will be available to the participant under their Transcript section of the 
LMS.  

We appreciate your feedback on our courses and encourage you to complete the 
course evaluation. 
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