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ABOUT THIS PARTICIPANT GUIDE 
 
This document serves as a supplement to the training courses offered through Unanet 
University. Participants should use this workbook to complete exercises in the student 
Unanet system while attending the course. Additionally, participants should record notes 
and actions for reference when working within their own Unanet AE system.  

Symbols used in this guide 
 

   
 

   
 

 

Unanet Contact Information 
• VirtualUU@unanet.com  

 
Send questions here for information about courses, course schedule, 
unanetuniversity.com, certifications, and enrollments. This is a mailbox that is monitored 
daily. 

Support Portal  
To improve your experience in accessing our support resources, all Knowledge Center 
articles, and FAQs have been relocated to the Unanet Support Portal, located 
at support.unanet.com. You will need a Support ID to access the portal, which you can 
acquire using the steps below: 

To obtain a login to the Unanet support portal or to create a new ticket, send an 
email to support@unanet.com with "Support Portal ID request" in the Subject line. 

The following conditions must be met to be granted a support account: 
• The "from" address must match the domain of your company. 
• It must NOT be a generic email account (e.g., it cannot be from 

gmail.com, aol.com, or msn.com). 
 
The company must have an active support agreement with Unanet. 

Activity 

Demo 

Tour 

Important Note 

Question 

mailto:VirtualUU@unanet.com
https://support.unanet.com/support/home
mailto:support@unanet.com?subject=Support%20Portal%20ID%20request&body=Please%20activate%20a%20support%20ID%20for%20my%20email.
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COURSE INTRODUCTION 
 
In this course, you will gain a comprehensive understanding of Unanet AE Analytic 
Dashboards, learning to utilize their powerful features effectively. You will briefly review 
the query data process. The course focuses primarily on dashboard design concepts 
and administration.  

Learning Objectives  
 
After this session of Unanet AE: Using Analytic Dashboards, participants will be able 
to: 
 

• Characterize Unanet AE Analytic Dashboards.  
• List the concepts around quality dashboard design. 
• Review dashboard administration.  
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LESSON 1: INTRODUCTION TO ANALYTIC 
DASHBOARDS 

Learning Objectives 
 
Characterize Unanet AE Analytic Dashboards. 

• Describe how a dashboard could benefit your company. 
• List the different types of dashboards in UAE. 
• Explain the primary components necessary to create an analytic dashboard. 

Purpose 
The purpose of an analytic dashboard is to simplify complex data, provide meaningful, 
real-time insights, and enable users to monitor, analyze, and act upon key data points in 
an efficient and effective manner. 

Definition of a Dashboard 
An analytic dashboard is a tool used to visually display and analyze data in a 
comprehensive and interactive manner. It provides users with an easy-to-understand 
overview of key performance indicators (KPIs), metrics, and trends relevant to a specific 
area of interest or business operation.  

Analytic dashboards often feature customizable widgets that allow users to choose 
which data visualizations they want to see. These visualizations can include charts, 
graphs, tables, and other interactive displays that provide insights into specific areas of 
a business. 

The starting place in UAE is your dashboard. It is the first thing you see when logging in 
and can serve as a launch pad for business analytics and streamlining your work in 
UAE. 

Benefits of a Dashboard  
Benefits of a dashboard include:  

• Data Visualization: Analytic dashboards present data in a visually appealing and 
easily consumable format, such as charts, graphs, tables, or maps. Visual 
representations make it easier for users to grasp complex information quickly and 
identify patterns or outliers. 

• Dynamic Interaction: Analytic dashboards provide interactive features that allow 
users to drill down into the data, filter information based on specific criteria, and 
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explore different perspectives. Users can investigate trends, correlations, and 
underlying factors that contribute to specific outcomes. 

• Real-time insights: Dashboards provide real-time or near real-time data updates, 
allowing users to monitor key metrics and performance indicators in the moment. 
This enables timely decision-making and the ability to respond to changing 
conditions promptly. 

• Centralized data view: Dashboards consolidate data from various sources and 
systems into a single interface, offering a unified view of the organization's 
performance. This reduces the need to navigate multiple systems or reports to 
gather information, saving time and effort. 

• Customizability: Analytic dashboards are often highly customizable, allowing 
users to select and arrange widgets or visualizations according to their specific 
needs and preferences. This flexibility enables users to focus on the metrics that 
matter most to them and tailor the dashboard to their unique requirements. 

Why UAE Dashboards 
A dashboard provides a powerful and efficient way to comprehend your business's data, 
offering direct access to your UAE data without the need for third parties. Additionally, 
this service comes at no additional cost, making it a cost-effective solution for managing 
and understanding your data. 

Dashboard Types 
There are two types of dashboards available in UAE. Classic and Analytic Dashboards 
are housed and consumed through the Dashboard applet which makes accessible all 
dashboards a user has permission to consume. 
 
Permissions to each dashboard are managed using Dashboard Groups (UT > 
Dashboard Groups). 

Classic Dashboard 
Classic dashboards allow you to augment UAE and streamline common activities. For 
instance, you can receive an alert when a project goes over budget or when receivables 
go past due. Alternatively, many reports in UAE can be run directly from classic 
dashboards and gridgets, allowing you to display or update data through a dynamic 
grid. 

Analytic Dashboard 
Analytic dashboards use rich data visualizations allowing you to perform business 
analysis and gain powerful insights into your data. For instance, you can view utilization 
across departments with running trend lines. Use charts, grids, maps, etc. to 
dynamically filter and interact with your data all in real-time. 
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Overview of Analytic Dashboards 
Analytic dashboards use rich data visualizations allowing you to perform business 
analysis and gain powerful insights into your data. Analytic dashboards are built on two 
components: Data and Design. As such, we’ve built dedicated applets for working with 
each. Each applet is available from the Utilities module. 

Like any other report, analytic dashboards rely on a dataset - we call this an analytic 
model. Each model contains a query that draws from a data source. 

Analytic models provide the data for designing dashboards, which can be done with the 
Analytic Dashboard Designer. Created dashboards are then managed in the Analytic 
Dashboards applet. 

Each aspect of an analytic dashboard is governed by assigned User Permissions. 

Moving Parts 
• Permissions for working with analytic dashboards are assigned in AD > 

Permissions. Please complete the steps below to grant permissions as 
appropriate to the applets used by this tool. 

o Data Source – This is the source of data used in analytic models. 
Defaults to InFocus, but third party data sources are supported 
(Administration > Global Settings > External Data Sources). 

o Analytic Models - Analytic models are at the core of building great 
dashboards.  Model is just another term for query. These are the datasets 
used to design dashboards. InFocus-optimized models are available in AE 
Marketplace. Additionally, models can be built and managed with 
Dashboard Queries Manager (UT > Dashboard Queries Manager) and 
Query Builder (UT > Query Builder). 

o Analytic Dashboard Designer – This is the tool used to create your 
analytic dashboards (UT > Analytic Dashboard Designer). The Analytic 
Dashboard Designer applet features an intuitive, interactive design 
environment that displays your dashboards in real time as you build them. 
Each design uses a data source (defaults to InFocus) and an analytic 
model. 

o Analytic Dashboards – Once an analytic dashboard is created, you'll 
manage your new dashboard in the Analytic Dashboards applet (UT > 
Analytic Dashboards). Similar to other reporting applets, analytic 
dashboards allow you to edit, copy, delete, import, and export your 
dashboard. 

Querying Data 
Querying data in analytic dashboards involves retrieving and presenting information 
from a data source or multiple data sources in a visual and interactive format. Analytic 
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dashboards are used for data analysis, reporting, and decision-making, and they 
provide users with a way to explore data, gain insights, and make informed decisions.  
Querying data, and the Query Builder is discussed in a separate course.  

Dashboard Design 
The Analytic Dashboard Designer applet features an intuitive, interactive design 
environment that displays your dashboards in real-time as you build them. Each design 
uses a data source (defaults to Infocus) and an analytic model. 
 
When clicking New, you’ll be prompted to select an analytic model. Note that the 
designer supports multiple data sources and multiple models per design (advanced 
designs). Once selected, you’re ready to begin using the design tools. 
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Check Your Understanding 
 

 
What is the main benefit of using dashboards in UnanetAE?  
 

a) To facilitate team meetings 
b) To schedule project tasks 
c) To visualize data (Correct) 
d) To store company policies 
e) To control inventory 

 
 
What is the purpose of querying data in analytic dashboards in UnanetAE?  
 

a) To schedule tasks 
b) To manage resources 
c) To allocate budget 
d) To retrieve and present information in a visual and interactive 

format 
e) To facilitate team communication 
 

 
 

 
Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 2: DASHBOARD DESIGN 

Learning Objectives 
 
List the concepts around quality dashboard design. 

• Review the role of an analytic dashboard designer. 
• Explain how to work with data within analytic dashboards. 
• Describe how to use the components of an analytic dashboard.  
• Examine dashboard interactivity. 
• List dashboard design format rules. 
• Review dashboard layout.  

 

Overview - Dashboard designer role 
The role of a dashboard designer is to create visually appealing and user-friendly 
dashboards that effectively communicate data insights and support decision-making. 
The dashboard designer is responsible for translating data requirements and user 
needs into intuitive and informative dashboard layouts. Here are the key aspects of their 
role: 

• Data Visualization and Design: The dashboard designer creates visually 
appealing and informative data visualizations such as charts, graphs, tables, 
maps, and other graphical elements. They have a deep understanding of 
visualization best practices, color theory, typography, and layout design to 
ensure the data is presented in a visually engaging and understandable manner. 

• User Experience (UX) Design: The dashboard designer focuses on designing an 
intuitive user interface and navigation flow within the dashboard. They consider 
the user's perspective, ensuring that the dashboard is easy to navigate, 
interactive, and provides a seamless user experience. They may conduct user 
research, create user personas, and gather feedback to refine the design and 
improve usability. 

• Information Architecture: The dashboard designer structures and organizes the 
content and data within the dashboard to provide a logical and meaningful flow of 
information. They categorize and group data elements, define hierarchies, and 
determine the appropriate placement of visualizations to ensure users can easily 
find and interpret the relevant information. 

• Dashboard Layout and Composition: The dashboard designer determines the 
layout and composition of the dashboard, arranging visualizations and 
components in a way that optimizes data understanding and communication. 
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They consider the balance between aesthetics and functionality, ensuring that 
the most important insights and KPIs are prominently displayed while maintaining 
a coherent and organized overall design. 

• Collaboration with Data Analysts and Stakeholders: The dashboard designer 
collaborates closely with data analysts, business stakeholders, and end-users to 
understand their data requirements and goals. They gather feedback, iterate on 
design concepts, and incorporate user feedback to create a dashboard that 
meets the needs of the intended audience. 

 

Overall, the role of a dashboard designer is to create visually appealing, user-friendly, 
and informative dashboards that effectively communicate data insights. They combine 
data visualization expertise with design principles to create compelling and impactful 
dashboards that empower users to make data-driven decisions. 

Dashboard Designer’s Responsibilities 
An analytic dashboard designer is responsible for designing and creating interactive 
dashboards that provide real-time insights and data visualizations to support decision-
making processes. The role of an analytic dashboard designer typically includes: 

• Understanding the user's needs: A dashboard designer should have a clear 
understanding of the users' requirements, business objectives, and data sources. 
This information helps the designer to create a dashboard that aligns with the 
users' needs. 

• Data visualization: A dashboard designer should have a strong understanding of 
data visualization techniques and best practices. This skillset allows the designer 
to create visually appealing dashboards that communicate data insights 
effectively. 

• Dashboard architecture: The designer must create an intuitive and logical 
architecture for the dashboard. This architecture should allow users to access 
relevant data quickly and easily. 

• Data integration: A dashboard designer should have experience integrating data 
from various sources, including databases, spreadsheets, and cloud-based 
services. 

• Testing and maintenance: Once the dashboard is created, the designer must 
conduct thorough testing to ensure it is accurate and functional. The designer 
must also maintain the dashboard to ensure it continues to meet user needs and 
remains up-to-date with changing data sources. 

 

Overall, the role of an analytic dashboard designer is to design and develop dashboards 
that provide data insights that enable data-driven decision-making. The designer must 
have a strong understanding of the users' needs, data visualization techniques, and 
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best practices, as well as technical skills such as data integration and dashboard 
maintenance.  

Best Practices for Dashboard Designers 
Here are some best practices for an analytic dashboard designer. 
 

• Understand your audience: It's important to know who your dashboard users are, 
what their needs are, and what data they need to see to make informed 
decisions. This will help you design a dashboard that is useful and relevant to its 
intended audience. Communication between the end user and the designer is 
key.  

• Keep it simple: Avoid cluttering the dashboard with too much information or too 
many visualizations. Keep the design simple and intuitive, so users can quickly 
and easily find the data they need. Ideally keep it to a single page, and prioritize 
the “big picture” view.  

• Choose the right visualizations: Different types of data require different types of 
visualizations. Use the appropriate charts and graphs to represent the data 
effectively and avoid confusing users. 

• Highlight key information: Use colors, symbols, and other visual cues to draw 
attention to important data points or trends. Emphasize the visual aspect over 
text data. This will help users quickly identify the most relevant information. 

• Provide context: Provide context and explanations for the data on the dashboard. 
This will help users understand what they are looking at and how it relates to 
their business goals. 

• Ensure data accuracy: It's important to ensure that the data on the dashboard is 
accurate, up-to-date, and relevant. This requires regular maintenance and 
monitoring of data sources. Test your data before you start building to ensure 
user visibility, field functionality and correct totals.  

UAE Analytic Dashboard Designer 
The designer itself is organized into three sections: Toolbar, Data browser/pane, and 
the Dashboard surface. You’ll use the toolbar options in conjunction with your data to 
build your dashboard view on the surface. 

Designer Toolbar 
The Analytic Dashboard Designer toolbar offers powerful options for working with 
designs and is where primary tools are made available. The toolbar contains both 
standard options (always visible) and item-specific options, visible when working with 
the item. While item specific options will be discussed in context, here is a list of 
standard toolbar options. 
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Field Descriptions - Dashboard Designer 
 
Following is a list of standard applet fields/buttons/elements used in the Analytic 
Dashboard Designer. 

Menu Options 

• File/Help - Lists standard Unanet A/E File and Help options. 
 

Toolbar Options 

 
• Pinned Options 

o Save - Saves the loaded dashboard. 
o Undo - Reverses edits made. 
o Redo - Adds back Undone changes. 
o Update - Updates the dashboard with the latest modifications. This could 

be used if two users were working on the same dashboard design. 
Home Tab 

• New - Creates a new dashboard. 
• Open - Opens an existing dashboard. 
• Save - Saves the loaded dashboard. 
• Undo - Reverses edits made. 
• Redo - Adds back Undone changes. 
• Insert Section - Dashboard Items used in designing an Analytic Dashboard. 

Supported items are as follows: 
o Pivot 
o Grid 
o Chart 
o Scatter Chart 
o Pies 
o Gauges 
o Cards 
o Choropleth Map 
o Geo Point Maps 
o Range Filter 
o Images 
o Text Box 
o Groups 
o Treemap 
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o Tab Container 
o  Filter Elements (e.g., Combo Box, List Box, Tree View) 

 
• Item Section - Hidden until an Item (listed above) is inserted. Note that these 

options only affect the last item you selected. Available options include:  
o Duplicate - Duplicates the highlighted item on the dashboard. 
o Delete - Deletes the highlighted item. 
o Remove Data Items - Removes Data Items from the dashboard. This is a 

quick way to remove all the data items from the DATA ITEMS pane. 
o Edit Rules - Launches dialogue to work with conditional format rules 

added to the dashboard item. 
o Convert To - Used for converting one item to another (e.g., convert a Grid 

to a Chart).  
 

 
 

• Dashboard Section - Settings global to the loaded dashboard. 
o Title - Configures dashboard title options. 
o Currency - Configures currency options. 
o Edit Colors - Edits global dashboard colors. 
o Automatic Updates - Enables automatic updates for the dashboard. 
o Update - Use to manually update the dashboard. Disabled when using 

Automatic Updates. 
o Add Variable Parameters - Adds additional dashboard parameters. 
o Parameters - Used to manage dashboard parameters. 

 
Data Source Tab 

• Add Infocus Data Source - Adds an Infocus data source. 
• Add External Data Source - Adds an external data source- configured in Global 

Settings (AD > Global Settings > External Data Sources). 
• Add Custom Data Source - Adds a custom data source (Excel, CSV, etc.). 
• Rename - Renames the loaded data source. 
• Delete - Removes the loaded data source. 
• Server Mode - Enables server mode. When enabled, data related operations 

(grouping, filtering, etc.) are performed on the server. When not enabled, 
processing is done client side in-memory. Generally, Server Mode only supports 
SQL Data Sources and may or may not impact performance. 

• Add Calculated Field - Launches the Expression editor for creating calculated 
fields. 
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• Add Analytic Model - Adds Analytic Models to the Query dropdown. Multiple 
data sources are supported. 

• Add Query - Launches the Query Editor for developing queries from the 
designer. 

• Edit - Edits the currently loaded query (Analytic Model). 
• Rename - Renames the currently loaded query. 
• Filter - Edits the currently loaded query filter. 
• Delete - Deletes the currently loaded query from the data source. 
• Model Info - Displays Field/List Descriptions for the loaded Analytic Model. 

Note: Descriptions for the model are entered for each model via UT > 
Dashboard Queries Manager. 

 

 

Data Browser/Pane 
The Data Browser is where you’ll interact with your Data Source and Analytic Model. 
Once a model is loaded to the dashboard (done by clicking refresh above the model 
field list), you can bind fields to Dashboard Items by dragging and dropping fields into 
the DATA ITEMS pane as appropriate for the Dashboard Item (Grid, Chart, Pie, etc.). 

Data Source Browser 
The Data Source Browser allows you to navigate through dashboard data sources. It 
displays the data source structure and allows you to bind dashboard items to the 
required data source fields using drag-and-drop operations. The Data Source Browser 
also enables you to manage calculated fields. 
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Command buttons 
• Data Source - Lists the currently loaded data source. Supports multiple data 

sources (advanced designs). 
• Query/Model - Lists the currently loaded Analytic Models. Supports multiple 

models (advanced designs). 
• Group Fields by Type button - Groups field list by data type (datetime, 

nvarchar, int, etc.). 
• Sort Fields AZ button - Sorts field list alphabetically. 
• Sort Fields ZA button - Sorts field list alphabetically (descending order). 
• Reload Data (Refresh) - Refreshes the field list. Note: When starting a new 

design, you must first click refresh to perform an initial data load. Otherwise your 
data will not display. 

• Change Binding - Currently not in use. 

DATA ITEMS pane 
As mentioned above, Dashboard Items (Grids, Charts, etc.) are bound to data fields via 
the DATA ITEMS pane. The DATA ITEMS pane is placed side-by-side with the Data 
Source Browser, and allows you to create and modify data binding using drag-and-drop 
operations. 

 
 

• Options in the DATA ITEMS pane will vary based on the Dashboard Item. Below 
is a list of available options. 

o Command Buttons - Listed in the upper right of the DATA ITEMS pane, 
command buttons allow you to run various operations like adding a new 
pane to a chart dashboard item. 
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o Data Item Placeholders (Values, Columns, Rows, Arguments, Series, 
etc.) - Used to bind data fields to the dashboard item. Available 
placeholders are determined by the selected dashboard item. 

o Data Section - corresponds to a particular dashboard item area or 
element. 

o Data Item container - used to provide data item sets (e.g., for calculating 
the difference between two measures). Data item containers have 
Options buttons that allow you to change specific dashboard item settings 
(e.g., to switch between chart series types or grid column types). 

o Sort indicator - shows the current sort order for the data item. 
o Coloring indicator - indicates whether coloring by hue is enabled for the 

data item. 
o Hidden Data Items - Data items being used by the dashboard (filters, 

etc.) that don’t appear in any displayed dashboard item. For instance, you 
could use a Grid to display Employee Name and Hours and then use a 
hidden field to filter out time against indirect projects based on the Charge 
Type. Fields can be used as either Dimensions or Measures based on the 
intended use for the field.  

o Dimensions - Represent data items that can be added to the dashboard 
as they are with no required aggregation. Dimensions can further be 
sorted and/or grouped. (Project Code, Employee Name, etc.). 

o Measures - Represent data items that are added to the dashboard only as 
summaries (Sum of Hours, Max Work Date, etc.). 

  

Dashboard Surface 
The Dashboard surface is your primary design space and reflects added items. 
Dashboard items can be configured, resized, and reorganized as needed.  

In short, what you see on the surface (in terms of design), is what your end users will 
experience when viewing the Analytic Dashboard.  
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Field Descriptions 
• Title - Defaults to “Dashboard.” The “Dashboard” title can be renamed, removed, 

etc., by clicking Title from the Home Toolbar. 
• Export To - Exports the design to Print Preview, PDF, or Image. For example, 

this can be a great option if publishing a dashboard for one-time analysis. 
• Dashboard Parameters button - Reflects the  parameters available to the 

design and subsequently the end user. 

Tour 2.1 – Review the Analytic Dashboard Designer Applet 
    Watch this video overview of the Analytic Dashboard Designer applet. 

 

Working with the Data 
Here we will discuss some of the methods for formatting data.  As grids are a flexible 
way to view data, we will work with them in our examples. Data can be added to the grid 
in columns, configured based on column types, formatted and configured to interact with 
other Dashboard Items.  

Formatting Data 
The first way of formatting we will discuss is column types. Columns are used to label 
and provide data to the grid columns. Grids support multiple column types which can be 
edited by clicking the column type indicator (right-aligned icon in the New Column 
placeholder field in the DATA ITEMS pane). The system makes a judgement about the 
type of data and automatically assigns it a type. For example, text input is assigned as a 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Tour_2.1.mp4
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dimension, numbers are assigned as a measure. Below is a description of each column 
type: 

• Dimension – Dimension represents data items that can be added to the 
dashboard as they are with no required aggregation. Dimensions can further be 
sorted and/or grouped. (e.g. Project Code, Employee Name, etc). 

• Measure – Measure represents data items that are added to the dashboard only 
as summaries (e.g. Sum of Hours, Max Work Date, etc). Measures can be 
displayed as the value or as a bar. 

• Delta – Delta calculates the difference between the sum of two measures and 
can display a visual indicator of the difference. Actual represents the first 
measure and Target represents the second. Deltas can be displayed as a value 
or a bar. Values can be further configured to evaluate the following: 

o Value Type - How the calculated result is represented 
o Result Indication - Condition that defines the visual indicator (e.g. 

Greater is good will display a green up arrow if the Actual exceeds the 
Target)  

o Threshold Type - Further rules can be applied to when a visual indicator 
will be displayed in the result (e.g. display a green up arrow only if the 
Actual exceeds the target by 15% or $1500.00). Threshold Type defines 
the type of threshold to apply- percent or absolute value.  

o Threshold Value - Sets the value for the threshold (e.g. 15%).  
 
Data added to range filters is automatically formatted based on the data type. That said, 
formats can be edited by clicking the Options button (down arrow) seen when hovering 
over the data item. For instance, Date Values have several display options. To change 
display settings, hover over the data item and complete the following: 

• Click the Options button (down arrow). 
• Select the Date type (e.g. Year, Quarter, etc). 
• Optionally set the Format. 

o Default 
o Full (e.g. Month = October, etc.) 
o Abbreviated (e.g. Month = Oct, etc.) 
o Numeric (e.g. Month = 10, etc.) 
o Long (e.g. Date-Hour = Saturday, October 15, 2016 10:57pm (en-US) 
o Short (e.g. Date-Hour = 10/15/2016 10:57pm (en-US)) 
o Time Only (e.g. Date-Hour = 10:57pm (en-US)) 

 
To change the format for numbers or currency: 

• Hover over the field in the DATA ITEMS pane 
• Click the Options button (down arrow) 
• Select Format. 
• Configure settings as appropriate. 



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
23 

o Format Type - Defaults to Auto. Options include: General, Number, 
Currency, Scientific, Percent. 

o Unit - Defines how the currency value should be converted 
o Precision - Defines the decimals to display 
o Currency - Defaults to Dashboard global currency setting. Specific 

currency settings can be set here. 
o Culture - Defines the currency cultures for currencies with multiple 

cultures 
o Include group separator - Displays a comma between each numeric 

group (e.g. 1,000,000.00) 

Activity 2.2 – Formatting Data 
In this activity, you will work with some common data types and apply basic 
formatting to dates and numbers.  

 
Activity Steps 
 
Part 1: Work with common data types  

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Labor Resource Schedule Summary CVS model. 
5. Select the Grid button. The grid displays on the Dashboard.  
6. Select the Parameters button on the upper-right corner of the Dashboard. The 

Dashboard Parameters window opens.  
7. Type 3/31/2023 in the Value field for the Thru_Date line.  
8. Select the Submit button. 
9. Click and drag the following fields from the Data Source browser to the New 

Column field in the DATA ITEMS pane.  
Note: If you see a red exclamation point in the upper left corner of a dashboard 
item after adding fields to the DATA ITEMS pane, select the Reload Data button. 
• Employee_Name 
• Transaction_Date 
• Labor_Effort 
• Labor_Pay_Cost  
• Labor_Effort (this is a second Labor_Effort column) 

Note: You can rearrange the order by clicking and dragging the fields up and 
down the list.  

10. Select the sum button to the right of the second Labor_Effort column in the 
DATA ITEMS pane. The Column Options window opens.  

11. Select the Delta radio button.  
12. Select the OK button. A Target field displays under the Labor_Effort column.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.2/story.html
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13. Click and drag a Labor_Pay_Cost field to the Target field. The column in the 
grid now displays an updated header and the difference between Labor_Effort 
and Labor_Pay Cost.  
 

 
Part 2: Formatting dates and numbers 

1. Select the down arrow for the Transaction Date column in the DATA ITEMS 
pane. Note: Hover the cursor over the column name to activate the arrow. You 
can also right-click the name to view the same drop-down menu. 

2. Select Exact Date from the list. The Transaction_Date column updates on the 
grid. 

3. Select the down arrow for the Transaction Date column in the DATA ITEMS 
pane again. 

4. Select Format (Day: Default) > Day > Long. The date displays in long form in 
the grid.  

5. Select the down arrow for the Transaction Date column in the DATA ITEMS 
pane. 

6. Select Quarter-Year from the list.  
7. Select the down arrow for the first Labor_Effort column in the DATA ITEMS 

pane. 
8. Select Format…. The Numeric Format window opens.  
9. Select Number in the Format Type field. Note the display at the bottom of the 

window previews the format of the numbers as each option is selected. 
10. Select Ones in the Unit field.  
11. Select 0 in the Precision field.  
12. Select the Include group separator check box.  
13. Select the OK button.  
14. Select the down arrow for the first Labor_Pay_Cost column in the DATA 

ITEMS pane. 
15. Select Format…. The Numeric Format window opens.  
16. Select Currency in the Format Type field. Note the display at the bottom of the 

window previews the format of the numbers as each option is selected. 
17. Select Ones in the Unit field.  
18. Select 2 in the Precision field.  
19. Select the Include group separator check box.  
20. Select the OK button.  

Calculated Fields 
The Dashboard Designer provides the capability to create calculated fields that allow 
you to apply complex expressions to data fields that are obtained from the dashboard's 
data source. You can use these fields in data visualizations as regular data source 
fields. After you have created a data source, you can add a new calculated field based 
on the existing data source fields. 
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Keep in mind that fields are locally created and stay local. This means that another user 
that selects the same query will not have access to the calculated fields created for a 
particular dashboard. They will have to create their own calculated fields.  
 
To create a calculated field, right-click anywhere in the fields list. To modify a calculated 
field, right-click the field to display the menu. The menu contains the following items: 

• Edit Expression - Opens the Expression Editor dialog, which allows you to 
change an expression for an existing calculated field. 

• Field Type - Specifies the type of the calculated field. 
• Rename - Changes the calculated field name. 
• Delete - Removes the existing calculated field from the data source. 

 
Note: If for some reason you delete a calculated field, and the field is part of a report, 
the grid data will disappear. An error icon will display in the upper left corner of the grid 
by the grid name. Select the error icon for details. You can recreate the calculated field, 
undo the removal, or remove the field from the DATA ITEMS pane to restore the grid 
view.  
 

Expression Editor 
The Expression Editor which allows you to specify an expression that will be used to 
obtain calculated field values. Here, you can construct the required expression. It 
functions in a manner similar to Excel. 
The top pane of the Expression Editor displays the expression as it is built. The lower 
left pane displays the available elements.  These elements include:  

• Columns 
• Constants 
• Operators 
• Functions 
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As you choose the element you wish to add, the center pane automatically updates.  
For example, when you choose Columns in the left pane, the center pane displays all 
the available columns in this query available for your calculated field. If you choose 
Operators, the center pane displays all the possible operators (addition, subtraction, 
percentage, etc.). 
The pane on the lower right displays a description of the element. This is particularly 
useful when working with the functions, as the names do not fully describe the function. 
 
After the expression has been specified, select the OK button. This displays a new 
calculated field in the data source structure. 
 
Now you can specify the required calculated field type, change its default name, etc. 

Activity 2.3 – Calculated Fields 
In this activity, you will add a calculated field to the grid.  

 
Activity Steps 
 
Part 1: Create a new dashboard 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Employee Utilization Summary Month CVS model. 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.3/story.html
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5. Select the Grid button. The grid displays on the Dashboard.  
6. Click and drag the following fields from the Data Source browser to the New 

Column field in the DATA ITEMS pane. Note: If you see a red exclamation point 
in the upper left corner of a dashboard item after adding fields to the DATA 
ITEMS pane, select the Reload Data button. 
• Employee_Code 
• Employee_Name 
• Direct_Labor_Job_Cost 
• Labor_Pay_Cost  

Note: You can rearrange the order by clicking and dragging the fields up and 
down the list.  
 

Part 2: Create a calculated field to subtract data 
1. Right-click anywhere in the Data Source panel list of fields.  
2. Select Add Calculated field.  Note: you can also access calculated fields by 

selecting the Data Source tab > Calculated field. The Expression Editor 
opens.  

3. Verify Columns is selected in the lower left pane.  
4. Type direct_labor in the search field over the center pane to filter the list of fields.  
5. Double-click Direct_Labor_Job_Cost. Note that the field now displays at the top 

of the editor.   
6. Select Operators in the lower left pane.  
7. Click the X in the text field over the center pane to remove the previous filter. 
8. Double-click the – (minus) sign. 
9. Select Columns in the lower left pane.  
10. Type direct_labor in the search field over the center pane to filter the list of fields.  
11. Double-click Direct_Labor_Pay_Cost.  
12. Select the OK button. The new Calculated Field 1 displays in the field list.  
13. Click and drag the Calculated Field 1 field to the New Column field. 
14. Right-click Calculated Field 1 in the Data Source pane.  
15. Select Rename from the list.  
16. Type Overhead_Cost in the field. Note that the field name updates in the DATA 

ITEMS pane and in the column header on the grid. 
 
Part 3: Create a calculated field to concatenate data 

1. Right-click anywhere in the field list.  
2. Select Add Calculated field. The Expression Editor opens.  
3. Select Functions in the lower left pane.  
4. Type concat in the text field over the center pane to filter the list of fields.  
5. Double-click Concat. Note the updated description on the right. 
6. Select Columns in the lower left pane.  
7. Click the X in the text field over the center pane to remove the previous filter. 
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8. Type employee_code in the text field over the center pane to filter the list of 
fields.  

9. Double-click Employee_Code.  
10. Type ‘ ‘, in the formula at the top of the editor after [Employee_Code], to add a 

space. 

 
Note: You must use single quotes. The editor will not accept double quotes.  

11. Click the X in the text field over the center pane to remove the previous filter. 
12. Type employee_name in the text field over the center pane to filter the list of 

fields.  
13. Double-click Employee_Name. The final formula displays as follows: 

 
14. Select the OK button. 
15. Click and drag the new Calculated Field 1 field to the top of the Columns list in 

the DATA ITEMS pane. The new field displays the employee code and name in 
one column, saving space in the grid. 

16. Right-click Calculated Field 1 in the Data Source pane.  
17. Select Rename from the list.  
18. Type Employee in the field. Note that the field name updates in the DATA ITEMS 

pane and in the column header on the grid. 
19. Click and drag the following fields out of the DATA ITEMS pane.  

• Employee_Code 
• Employee_Name 

 
Part 4: Create a calculated field to display cost for all employees in a department 

1. Click and drag an Employee_Home_Org_Path field to the 2nd position in the 
Columns list in the DATA ITEMS pane.  

2. Right-click anywhere in the field list.  
3. Select Add Calculated field. The Expression Editor opens. 
4. Select Functions in the lower left pane.  
5. Type if in the text field over the center pane to filter the list of fields.  
6. Double-click Iif.  
7. Select Columns in the lower left pane.  
8. Click the X in the text field over the center pane to remove the previous filter. 
9. Type employee_home in the text field over the center pane to filter the list of 

fields.  
10. Double-click Employee_Home_Org_Path.  
11. Type =‘ARC ‘ in the formula at the top of the editor. 

 
12. Click the X in the text field over the center pane to remove the previous filter. 
13. Type direct_labor in the text field over the center pane to filter the list of fields.  
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14. Double-click Direct_Labor_Job_Cost.  
15. Type 0 at the end of the formula. 

 
16. Select the OK button. 
17. Right-click Calculated Field 1 in the Data Source pane.   
18. Select Rename from the list.  
19. Type DL_JC_ARC in the field.  
20. Click and drag the DL_JC_ARC field to the 3rd position in the Columns list in the 

DATA ITEMS pane. The field displays the cost for the employee with the ARC 
path. 

Dashboard Items 
To create a dashboard item in the Dashboard Designer, click the corresponding button 
in the Home ribbon tab.  
 

 
 
This creates an empty dashboard item, and displays the required data sections for 
binding this item to data. 
 

  
 
Perform the following steps to design a dashboard item. 

• Bind the dashboard item to data. 
• Perform the required data shaping operations (such as grouping, sorting and 

filtering). 
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• Use the interactivity features to enable interaction between various dashboard 
items. 

• Adjust the dashboard item's position and size and specify the dashboard item 
caption settings. 

• Specify specific dashboard item settings based on its type.  
 

After you have created and designed the dashboard item, you can create an exact 
copy. To do this, click the Duplicate button in the Home ribbon tab or use the 
dashboard item's context menu. To remove the dashboard item from the dashboard, 
use the Delete button or the corresponding item in the context menu. 
 

 

Overview 
This topic discusses how to bind items to data and hidden data items.  
 
Bind Dashboard Items to Data 
To bind dashboard items to data in the Dashboard Designer, use the DATA ITEMS 
pane. 
 

 
 
Each dashboard item type has a specific set of data sections, such as Values, 
Arguments and Series in the chart, Columns and Sparklines in the grid, and Values, 
Columns and Rows in the pivot grid. Each data section corresponds to a particular 
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dashboard item area or element, and should be mapped to data to be displayed within 
this area/element. 
 
Mapping is performed using data items - objects that are used to bind a dashboard item 
to data source fields. Data items are used to link the dashboard item to the required 
data source fields and, thus, visualize data within the dashboard item. 
 
Another key concept in data binding is the data item container, which represents a set 
of data items. It can contain either a single data item or multiple data items, and allows 
you to specify various options related to how a specific dashboard item visualizes data. 
 

 
 
The data item can process data in two ways - as dimensions or measures. This 
depends on the data section to which the data item is assigned, and the type of the data 
item container. 

• Dimension - a data item whose values are not intended to be summarized. 
These values can be of any type - string, date-time or numeric. In any case, the 
dashboard does not summarize the dimension values, but groups identical 
values. You can perform grouping, sorting, or display the top values for the 
dimension values. 
You can also customize data format settings for numeric and date-time values. 
To access the data shaping settings, use the data item's menu button.  
 

 
 
For instance, dimensions are used to provide data for the chart argument axis, 
pivot grid column and row headers. 
 

• Measure - a data item whose values are summarized before they are used in the 
dashboard. These values can be of any type - numeric, date-time or string. In 
any case, the dashboard will calculate an appropriate summary function against 
measure values. You can also customize the data format settings that affect how 
summary values are displayed. To access these settings, use the data item's 
menu button. 
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For example, measures are used to provide data for the chart's Y-axis, and to 
calculate pivot cell values. 
 

Specific data sections display Options buttons for each data item container. Use these 
buttons to open a dialog that allows you to specify the settings of this data item 
container. These settings affect how a particular dashboard item's area/element 
displays the provided data. 
 

 
 
Create Binding 
The DATA ITEMS pane displays data sections of the selected dashboard item. It can 
be used to add, rearrange or remove data items. 
To bind a dashboard item to data, select the dashboard item. Then choose the required 
data field from the Data Source Browser and drop it onto the appropriate section in the 
DATA ITEMS pane. 
 

 
You can remove the data item by dragging it outside the DATA ITEMS pane. 
To rename the data item, click its menu button and select Rename, to open the 
Rename Data Item dialog. 
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Modify Binding 
You can modify data binding by dragging data item containers within a data section. To 
do this, drag the data item container to the required position. 

 
You can also modify data binding by dragging data items within the DATA ITEMS pane. 
This action has the following specifics. 

• If you drag the data item to a new position, the settings specified for the 
corresponding data item container will be restored to the default values. 

• If you drag the data item to an existing data item placeholder, the settings of the 
corresponding data item container will be applied. 

 
Clear Binding 
To remove all data items for a selected dashboard item, use the Remove Data Items 
button in the Home ribbon tab. 
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You can also do this via the dashboard item's context menu. 
 

 
 
Hidden Data Items 
The HIDDEN DATA ITEMS area can be used to perform various data shaping and 
analysis operations by measures or dimensions that do not directly take part in the 
visual representation of data. 
 
To create hidden data items, choose the required data field from the Data Source 
Browser and drop it onto the appropriate section in the HIDDEN DATA ITEMS area. 
You can perform the following operations using hidden data items. 
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Filtering 
You can use hidden dimensions to apply filtering to the dashboard item. To do this, 
select the required hidden dimension in the Filter Editor dialog and specify the required 
condition. 
 

 
 
For instance, the Grid on the image above is filtered by the first quarter of the 
CurrentDate (Year) dimension. 
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Sorting 
You can sort values of the specified dimension by the hidden measure. To do this, 
select the required measure from the dimension's Sort By sub-menu. 
 

 
 
For instance, categories displayed in the Grid on the image above are sorted by values 
of the hidden Quantity (Sum) measure. 
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Top N 
You can use hidden measures in Top N conditions. To do this, select the required 
measure from the Measure combo box in the Top N Values dialog. 
 

 
 
For instance, the Grid on the image above displays top 5 categories for the Quantity 
(Sum) hidden measure. 
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Conditional Formatting 
You can create format rules based on hidden measures to apply conditional formatting 
to elements corresponding to visible values. To do this, use the Add Format Rule menu 
of the hidden measure. 
 

 
For the Expression format condition, you can use the required hidden measure in the 
same manner as in the Filter Editor dialog. 

Grid 
The image below shows a sample Grid dashboard item that is bound to data. 
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To bind the Grid dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. The data sections include:  

• Columns: Contains data items that provide values for grid columns. The Options 
button next to the Column data item allows you to select the column type and 
specify their options. 

• Sparkline: Contains a data item that provides arguments for sparkline columns.  
 
Column Type Overview 
The Grid dashboard item supports five types of columns. The type of the column is 
indicated within the corresponding data item container in the DATA ITEMS area.  
 
 

 
 

 
 
Column Type 
Indicator Column Type Description 

 Dimension 
The dimension column displays values from the bound 
data item "as is". If the dimension column is bound to a 
data source containing images, it can display images. 
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 Measure 

A measure column displays summaries calculated 
against data in a bound data item. Values in the 
measure column can be displayed as text or 
represented by bars.  
To select between these modes, open the Column 
Options window and select Value or Bar. If bars are 
displayed, use the Always show zero level check box 
to specify whether the bar's zero level is always visible. 

 Delta 

A delta column calculates summaries against two 
measures, and displays the difference between these 
summaries. This difference can be indicated with a 
numeric value displayed within the delta element and an 
additional delta indication. 
Delta columns are bound to two measures that provide 
two values: the Actual value and the Target value. The 
difference between these values is displayed in the 
column. 
When you switch the column type to Delta, the data item 
container is changed, to accept the Actual and Target 
measures.  
Values in the delta column can be displayed as text, or 
represented by bars. To select between these modes, 
open the Column Options window and select Value or 
Bar. If bars are displayed, use the Always show zero 
level check box to specify whether the bar's minimum 
value is zero (checked) or an automatically selected 
value that ensures that the difference between bars is 
clearly displayed (unchecked). 

 Sparkline 

A sparkline column visualizes the variation in summary 
values over time. 
The sparkline column is bound to a measure providing 
sparkline values and to a dimension providing a date-
time interval. 
You can control sparkline appearance settings using the 
Column Options dialog. To open this dialog, click the 
column type indicator. In this dialog, you can control 
various settings that affect how the sparkline is 
displayed within a grid cell. 
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 Hyperlink 

A hyperlink column allows you to display hyperlinks in 
the Grid dashboard item. You can provide hyperlinks as 
a separate data column. or they can be automatically 
created at run-time from any column using the specified 
URI pattern. 

 
When you drop a data item into the Columns section, the type for the new column is 
determined automatically, based on the data type. 
 
To change the column type, click the column type indicator. In the open Column 
Options window, select the required column type in the Column Type section. 
 
Sorting Data within the Grid 
To sort records by a column's values and replace the existing sort conditions applied to 
the current or other columns, click the target column's header until the Up or Down 
arrow icon is displayed within the header. The Up and Down arrows indicate ascending 
and descending sort orders, respectively. 
You can also apply the required sort condition by right-clicking a column header or the 
field name in the DATA ITEMS pane and selecting Sort Ascending or Sort 
Descending from the open context menu.   

 
Filtering Data within the Grid 
Filtering data is particularly useful when working with dimensions. The Dashboard 
allows you to filter apply filtering to a specific data-aware dashboard item. Basically, 
filter conditions specify what data to select from a data source and display in a data-
bound control. A typical simple filter condition consists of three parts: the column/field 
name, operator and a value(s). For instance, '[Discount] >= 0.05' is a simple 
filter condition, where '[Discount]' is a field name, '>=' is an operator and '0.05' is a 
value. This condition when applied to a data-aware control will display records that have 
values in the Discount column greater than or equal to 0.05. The general steps to create 
a filter condition are:  
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• Open the Filter Editor - To open the Filter Editor in a grid control, right-click 
anywhere in the grid and select the Edit Filter option.  
 

 
 

• Select a column - To filter against a particular column, click the column name 
field. This will display the list of available columns. For the example above, you 
would select the Discount column. 
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• Select a comparison operator - Click the operator field to choose the required 
operator. The comparison operator list displays only those operators that are 
supported by the current column's data type. 
 

 
 
• Enter a value - For the example above, you would enter 0.05. 

 

 
 
• Save changes - Click the OK or Apply buttons, to filter data using the created 

filter condition. The grid will show the filter panel displaying the current filter 
criteria. 
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Grid Tools and Design 
The Grid dashboard item allows you to customize its layout in various ways. You can 
manage the width of grid columns, specify the visibility of column headers, enable cell 
merging, etc. To access design tools for the grid, select Grid Tools > Design tab. The 
tools are grouped. 
 

 
 
Common Group 

• Show Caption: To show or hide the caption of a dashboard item, click the Show 
Caption button.  

• Edit Names: This is an alternate location for editing names of the columns and 
grid. 
 

Style Group 
The Grid dashboard item allows you to specify various style settings. 

• Grid Lines: The Horizontal Lines and Vertical Lines buttons control grid line 
visibility. 

• Banded Rows: To paint the background of odd and even rows differently, use 
the Banded Rows button. 
 

Layout Group 
• Column Headers: Use the Column Headers button to toggle column header 

visibility. 
• Merge Cells: The grid allows you to merge neighboring cells with identical 

values. To do this, use the Merge Cells button. 
• Word Wrap: The word wrapping feature enables the capability to display cell 

content on multiple lines if the size of a dashboard item is insufficient to 
completely display the cell content on a single line. 

• Font: If you want to change the font in your grid, select the Font button. You can 
select Font, Style, Size, and Effects. Note: The Undo button does not revert the 
font back to a previous style. 

• Padding: Select the Padding button to add height (visual space) to the lines in 
the grid.  

 
Column Width Mode Group 
The Grid dashboard item allows you to manage column widths using different modes. 
Use buttons in the Column Width Mode group to manage the column width modes. 
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The following modes are available. 
• AutoFit to Contents: The grid adjusts columns to the minimum width required to 

completely display their content automatically. If the entire content cannot be 
displayed within the dashboard item, horizontal scrolling is enabled. 

• AutoFit to Grid: The grid adjusts the width of all columns to fit their content in an 
optimal way. If you are changing the size of the dashboard item, the width of 
columns is changed proportionally. 

• Manual: The grid allows you to adjust column widths manually. 
 

Activity 2.4 – Grid 
In this activity, you will add and modify a grid.  

 
Activity Steps 
 
Part 1: Add a grid  

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Financial Statement CVS model. 
5. Select the Grid button. The grid displays on the Dashboard.  
6. Select the Parameters icon on the upper-right corner of the Dashboard. The 

Dashboard Parameters window opens.  
7. Type 2021-12 in the Value field for the Current_Period_Code line.  
8. Select the Submit button. 
9. Click and drag the following fields to the New Column field in the DATA ITEMS 

pane. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 
• Account_Financial_Type 
• Account_Base_Code  
• Account_Base_Name  
• YTD_Activity 

 
Part 2: Add a total  

1. Right-click the YTD_Activity column header.  
2. Select Add Total > Auto.  
3. Right-click the Account_Base_Code.column header.  
4. Select Add Total > Count. The total count displays at the bottom of the grid 

below the column.  
5. Right-click the YTD_Activity column header.  
6. Select Add Total > Count. Both totals display below the column.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.4/story.html
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7. Right-click the YTD_Activity column header.  
8. Select Clear Totals. Both totals disappear. 
9. Right-click the YTD_Activity column header.  
10. Select Add Total > Sum. 

 
Part 3: Sort data 

1. Click the Account_Base_Code header. The system automatically sorts the data 
from low value to high value in that column. This overrides the default sorting of 
left to right in the grid.  

2. Click and drag the YTD_Activity field from the DATA ITEMS pane to the 
Measures area of the HIDDEN DATA ITEMS pane. The column is no longer 
visible in the chart.  

3. Right-click the Account_Financial_Type field in the DATA ITEMS pane.  
4. Select Sort by > YTD_Activity (sum). The grid updates. 
5. Click and drag the YTD_Activity field from the HIDDEN DATA ITEMS pane back 

to the DATA ITEMS pane Column section.  
6. Right-click the Account_Financial_Type field in the DATA ITEMS pane 

Column section.  
7. Select Sort by > (Value). The grid updates. 

 
Part 4: Add and remove a filter 

1. Right-click anywhere on the grid.  
2. Select Edit Filter. The Filter Editor opens.  
3. Hover the cursor in the space next to the And icon in the upper left corner. 

Additional icons display. 
4. Select the plus icon.  
5. Select Account_Base_Code. A menu displays.  
6. Select Account_Financial_Type. 
7. Select Begins with. A menu displays.  
8. Select = Equals. 
9. Select Enter a Value. 
10. Select the drop-down arrow. The system has preselected the available choices 

for you.  
11. Select Asset.  
12. Hover the cursor in the space next to the And icon in the upper left corner. 

Additional icons display. 
13. Select the plus icon. 
14. Select Begins with. A menu displays.  
15. Select < Is less than or equal to. 
16. Select Enter a Value. 
17. Select the drop-down arrow. The system has preselected the available choices 

for you.  
18. Select 1030. 
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19. Select the Apply button. This allows you to check the filtering on the grid before 
closing the Filter Editor.  

20. Select the OK button. Note: If the dashboard does not refresh automatically, 
select the Refresh icon in the Data Source pane.  

21. Right-click anywhere on the grid.  
22. Select Clear. 

 
 
Part 5: Add and remove a filter that uses a hidden asset 

1. Click and drag the Account_Financial_Type field from the DATA ITEMS pane 
to the Dimension field in the HIDDEN DATA ITEMS pane. The column is no 
longer visible in the chart.  

2. Right-click anywhere on the grid.  
3. Select Edit Filter. The Filter Editor opens.  
4. Hover the cursor in the space next to the And icon in the upper left corner. 

Additional icons display. 
5. Select the plus icon.  
6. Select Account_Base_Code. A menu displays.  
7. Select Account_Financial_Type. Note that Account_Financial_Type is not 

visible in the grid, but is still in the list as an option. 
8. Select Begins with. A menu displays.  
9. Select = Equals. 
10. Select Enter a Value. 
11. Select the drop-down arrow. The system has preselected the available choices 

for you.  
12. Select Liability.  
13. Select the OK button. The filtered data displays.  
14. Click and drag Account_Financial_Type from the HIDDEN DATA ITEMS pane 

to the first spot in the DATA ITEMS pane. This “breaks” the filter and the grid will 
refresh. 
Note: Be careful to place it over/in front of the Account_Base_Code field, not on 
top of it which will replace it.  

 
Part 6: Rename fields 

1. Select the Options drop-down arrow for the Account_Financial_Type field.  
2. Select Rename. The Rename Data Item window opens. 
3. Type Account Financial Type in the New name field (remove the underscores).  
4. Select the OK button.  The name updates on the Dashboard. 
5. Right-click anywhere on the grid. Note: When using this method the name 

changes, and will remain changed, only on the grid. It does not change the 
names of the fields in the DATA ITEMS pane.  

6. Select Edit Names. The Edit Names window opens. Here you can edit all the 
headers and the name of the Dashboard.  
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7. Modify (remove the underscores) the following Column headers as shown.  
• Account_Base_Code to Account Base Code 
• Account_Base_Name to Account Base Name 
• YTD_Activity (Sum) to YTD Activity   

Note: When you add measures, the system will automatically add in 
parentheses the type of aggregation it is performing.  

8. Select the OK Button.  
9. Click and drag the Account_Code field to the DATA ITEMS pane in the 2nd spot, 

replacing Account_Base_Code. Note that the name does not update on the 
Dashboard.  

Pivot 
Pivots offer data visualization in a hierarchical grid. Data can be added to the pivot, 
nested into a hierarchy, formatted and configured to interact with other Dashboard 
Items. Data fields are bound to the Pivot by dragging them to the Data Items pane as a 
Value, Column or Row. Additionally, Hidden Data Items can be used for additional 
configurations, such as filtering, without displaying the field in the Pivot. 
 

 
 
Working with Pivot Data 
Each Dashboard Item has different requirements for the data you add to it. Pivots use 
Values, Columns and Rows. 

• Values - Contains data items used to calculate values displayed in the pivot 
table. (e.g. the Sum of all Hours) 

• Columns - Contains data items whose values are used to label columns. 
• Rows - Contains data items whose values are used to label rows. 
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For example, to view the total hours for each project by year, add: 
Values Columns Rows 

Hours (Sum) Work Date (Year) Project Name 

 
Columns can be further broken out by adding additional fields to Values. 
Values Columns Rows 

Hours (Sum) Work Date (Year) Project Name 

Bill_Dollars (Sum)   

 
Hierarchy can be added to the pivot by binding additional fields to Columns or Rows. 
Once hierarchy is added, the pivot will display expand/collapse icons which can be used 
to view or hide the added hierarchy. 
Values Columns Rows 

Hours (Sum) Work Date (Year) Project Name 

Bill_Dollars (Sum) Work Date (Month) Employee Name 

 
Transposing Columns and Rows 
The Pivot dashboard item provides the capability to transpose pivot columns and rows. 
In this case, data items contained in the Columns section are moved to the Rows 
section and vice versa. 
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To transpose the selected Pivot dashboard item, use the Transpose button in the 
Home ribbon tab. 
 
Conditional Formatting 
Once data is added to the pivot, it can be formatted in a variety of ways to help visualize 
otherwise static data points, highlighting cells that meet certain defined criteria. 
A Pivot dashboard item applies conditional formatting to cell values. You can calculate a 
format rule by measures placed in the Values section and dimensions placed in the 
Columns or Rows section. Note that you can use hidden measures to specify a 
condition used to apply formatting to visible values. 
 
Pivot Tools and Design 
Pivots feature a specific set of design and data tools, available from the toolbar (some 
options are also available by right-clicking the pivot). 
 

 
 
Common Group 

• Show Caption: To show or hide the caption of a dashboard item, click the Show 
Caption button.  

• Edit Names: This is an alternate location for editing names of the columns and 
grid. 
 

Initial State 
• Sets the default state of grid hierarchy (expanded or not). Expanding the columns 

may result in a much wider table.  
 

Layout Group 
• Totals: Shows/Hides row and/or column totals. 
• Grand Totals: Shows/Hides grand totals. 
• Layout: If the Pivot dashboard item contains a hierarchy of dimensions in the 

Rows section, you can specify the layout (Tabular or Compact) used to arrange 
values corresponding to individual groups. 

• Row Totals Position: If necessary, you can change the Pivot dashboard item’s 
totals/grand totals position. 
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• Column Totals Position: If necessary, you can change the Pivot dashboard 
item’s totals/grand totals position.  

• Values Position:  Allows you to control the position of headers used to arrange 
summary values corresponding to different measures. 

• Reset Layout Options: Select to reset the layout options.  
 

Activity 2.5 – Pivot Table 
In this activity, you will add and update a pivot table.  

 
Activity Steps 
 
Part 1: Add a pivot table 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Opportunity History model. 
5. Select the Pivot button. The pivot displays on the Dashboard.  
6. Click and drag the following fields to the Value field in the DATA ITEMS pane. 

Note: If you see a red exclamation point in the upper left corner of a dashboard 
item after adding fields to the DATA ITEMS pane, select the Reload Data button.  
• expectedrevenue 
• projectcode  

7. Click and drag the following fields to the Column field in the DATA ITEMS pane. 
• pmempname 
• leadstagename 

8. Click and drag the following fields to the Row field in the DATA ITEMS pane. 
• chargetypename 
• projectname 

 
Part 2: Format the table 

1. Right-click anywhere in the pivot table.  
2. Select Transpose. The table updates.  Rows and columns have changed spots.  
3. Right-click anywhere in the pivot table.  
4. Select Transpose. The table reverts to the original setup.   
5. Hover the cursor over the column line between the expectedrevenue and 

projectcode columns.   
6. Drag the line to adjust the header visibility to show the entire name. 
7. Select Pivot Tools > Design.  
8. Select Initial State > Expand Row Group.  The rows will now display in the 

expanded layout by default.  
9. Select Grand Totals.  
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10. Select to clear the check for Show Column Grand Totals. The Grand Total 
Column is removed from the table.  

11. Select Grand Totals.  
12. Select the check for Show Column Grand Totals. The Grand Total Column 

displays in the table.  
13. Select Layout > Tabular. The row headers update.  
14. Select Row Totals Position > Top. The totals for each level display at the top of 

the level.  
15. Select Column Totals Position > Near. The column totals move from the far 

right side of the table to the left side nearest the row headers.  
16. Select Values Position > Rows. The values move from column level to row level 

in the table.  
17. Select Reset Layout Options. The table reverts to its original form.  

Chart 
 

 
To bind the Chart dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. The table below lists and 
describes the Chart's data sections. 
 
Section  Description 

Values 
Contains data items against which the Y-coordinates of data points 
are calculated. The Options button next to the Value 
data item allows you to select the series type and specify different 
options. Note that some types of series accept several measures.  
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Arguments Contains data items that provide values displayed along the X-axis 
of the chart. 

Series Contains data items whose values are used to create chart series. 

 
Transposing Arguments and Series 
The Chart dashboard item provides the capability to transpose chart arguments and 
series. In this case, data items contained in the Arguments section are moved to the 
Series section, and vice versa. 
 

 
 
To transpose the selected Chart dashboard item, use the Transpose button in the 
Home ribbon tab. 
 
Series Overview 
The Chart dashboard item supports a variety of series types - from simple bar and line 
charts to complex candle stick and bubble graphs. 
 
Series Types 
To switch between series types in the Dashboard Designer, click the Options button 
next to the required data item (or placeholder) in the Values section on the Data Items 
pane.  
 

 
 
In the open  Series Options dialog, select the required series type and click OK.  
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You can also do this using the Series Type gallery in the Design Ribbon tab.  
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Series Options 
To manage common series options, use the Common Options tab of the Series 
Options dialog. 
 

 
 

• Plot on secondary axis - Specifies whether or not the secondary axis is used to 
plot the current series. 

• Ignore empty points - Specifies whether or not empty points are ignored when 
plotting the current series. 
Note that this option is in effect for the Line, Area and Range Area series. 

• Show point markers - Specifies whether or not to show point markers for the 
current series. Note: The point markers are always shown when Master Filtering 
is enabled for the Chart dashboard item. Note that this option is in effect for the 
Line and Area series. 
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Series Point Labels 
The Point Label Options tab of the Series Options dialog allows you to enable series 
point labels and manage their settings. 
 

 
• Show point labels - Specifies whether or not to show point labels for the current 

series. 
• Content - Specifies the type of content displayed within point labels. 
• Overlapping mode - Specifies the label overlap mode. Note: This option is not 

in effect when the dashboard is displayed in the Web Viewer. 
• Orientation - Specifies the orientation of point labels. 

 
Bar options 
Note: These settings are for Bar series only. 

• Show for zero values - Specifies whether or not to show labels for points with 
zero values. 

• Position - Specifies the position of point labels relative to bars. 
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Bar Series 
Bar series visualize data using rectangular bars with lengths proportional to the values 
that they represent. The following types of Bar series are available. 

Type Description 

Bar 

Bar series can be used to compare values across categories. 

Stacked Bar 

Stacked Bar series show the contribution of individual 
categories to the whole. 
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Full-Stacked Bar 

 
Full-Stacked Bar series allow you to compare the percentage 
that each value contributes to a total across categories. 
 

 
 
Point and Line Series 
Point series visualize data as a set of individual numeric data points. Line series are 
used to connect numeric data points by 
different types of line segments. The following types of Point and Line series are 
available. 
 
Type  Description 

Point 

 
Point series visualize data as a set of individual numeric data 
points. 
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Line 

 
Line series connect numeric data points by straight line 
segments. 

 

Stacked Line 

 
Stacked Line series can be used to show the trend of the 
contribution for each value. 
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Full-Stacked Line 

 
Stacked Line series are useful for showing the trend of the 
percentage for each value. 
 

 

Step Line 

 
Step Line series use vertical and horizontal lines to connect 
the numeric data points forming a step-like progression. 
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Spline 

 
Spline series plot a fitted curve through each numeric data 
point. 
 

 
 
Area Series 
Area series connect numeric data points by different types of line segments and fill the 
area between the line and X-axis/other series. The following types of Point and Line 
series are available. 
 
Type  Description 

Area 

Area series connect numeric data points by straight line 
segments and fill the area between the line and X-axis. 
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Stacked Area 

Stacked Area series can be used to show the trend of the 
contribution for each value. Stacked Area series connect 
numeric data points by straight line segments and fill the area 
between the line and previous series. 
 

 

Full-Stacked Area 

Full-Stacked Area series are useful to show the trend of the 
percentage for each value. 
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Step Area 

Step Area series use vertical and horizontal lines to connect 
the numeric data points forming a step-like progression and fill 
the area between the line and X-axis. 
 

 

Spline Area 

Spline Area series plot a fitted curve through each numeric 
data point and fill the area between the line and X-axis. 
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Stacked Spline 
Area 

Stacked Area series can be used to show the trend of the 
contribution for each value. Stacked Area series plot a fitted 
curve through each numeric data point, and fill the area 
between the line and previous series. 
 

 

Full-Stacked 
Spline Area 

Full-Stacked Spline Area series are useful to show the trend of 
the percentage for each value. 
 

 
 
Range Series 
Range series are generally used to show variations in a specified time range like 
temperature, price, etc. The following types of Range series are available. 
 
Data Binding Specifics 
A range series is a space between two simple series displayed as a filled area (Range 
Area) or bars that stretch from a point in one series to the corresponding point in the 
other (Range Bar). Thus, you need to provide two measures instead of one to display 
a range series. 
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• Value 1 - a measure against which the first set of values is calculated. 
• Value 2 - a measure against which the second set of values is calculated. 

 
When you select the Range Bar or Range Area series type in the Designer, the DATA 
ITEMS area displays two data item placeholders. Drag and drop the required measures 
to corresponding placeholders. 
 

Type  Description 

Range Bar 

Range Bar series are similar to Bar series except that they are 
drawn between a range of values. 
 

 

Range Area 

 
Range Area series are similar to Area series except that their 
areas are filled between a range of values. 
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Weighted Series 
Weighted series allow you to visualize data in three dimensions. 
 
Data Binding Specifics 
Data points in a weighted series present the following two measures. 

• Value - the Y-coordinate of series points. 
• Weight - the size of series points. 

When you select the Bubble series type in the Designer, the DATA ITEMS area 
displays two data item placeholders. Drag and drop the required measures to 
corresponding placeholders. 
 

Type  Description 

Bubble 

Bubble series are similar to Point series except that they allow 
you to provide an additional measure whose values are 
expressed in a bubble size. 
 

 
 
Financial Series 
Financial series are used to illustrate stock prices. The following types of Financial 
series are available. 
 
Coloring Specifics 
 
Note that financial series do not support a standard coloring mechanism used to color 
chart series points. The Chart dashboard item colors series points of financial series in 
the following way. 

• Black if the price at the end of the previous period is lower than the price at the 
end of the current period. 
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• Red if the price at the end of the previous period is larger than the price at the 
end of the current period. 

 
 

Type  Description 

High-Low-Close 

When you select the High-Low-Close series type in the 
Designer, the DATA ITEMS area displays three data item 
placeholders. High-Low-Close series require three measures to 
be provided. 

• High - the maximum price within the specified period (the 
top of the series point). 

• Low - the minimum price within the specified period (the 
bottom of the series point). 

• Close - the price at the end of the specified period (the 
tick mark). 
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Stock 

When you select the Stock series type in the Designer, the 
DATA ITEMS area displays four data item placeholders. Stock 
series require four measures to be provided. 

• Open - the price at the beginning of the specified period 
(the left tick mark). 

• High - the maximum price within the specified period (the 
top of the series point). 

• Low - the minimum price within the specified period (the 
bottom of the series point). 

• Close - the price at the end of the specified period (the 
right tick mark). 
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Candle Stick 

When you select the Candle Stick series type in the Designer, 
the DATA ITEMS area displays four data item placeholders. 
Candle Stick series require four measures to be provided. 

• Open - the price at the beginning of the specified period. 
• High - the maximum price within the specified period (the 

upper shadow top). 
• Low - the minimum price within the specified period (the 

lower shadow bottom). 
• Close - the price at the end of the specified period. 
 

 
 

 
Panes 
The Chart dashboard item can contain any number of panes. Panes are visual areas 
within a diagram that display chart series. Each pane has its own Y-axis and displays a 
specific set of series. All panes in a chart share the same X-axis. 
 

 



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
70 

 
 
To add a pane, click the Add Pane button at the top right of the DATA ITEMS pane. 
Once a new pane is added, the Dashboard Designer creates another Values section in 
the DATA ITEMS pane.  
 

 
 
Use this section to provide data items that supply values to be displayed in the new 
pane. 
To remove a pane, click the Remove Pane button displayed in the corresponding 
Values section. 
 
Coloring 
The Chart dashboard item paints different measures and series dimensions by hue in 
Default color mode. The image below shows the chart item whose State series 
dimension values are painted in different colors. A special icon on the data item 
shows that color variation is enabled. 
Note: The Chart dashboard item does not support coloring for the financial series. 
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Legend 
A legend is an element of a chart that identifies chart series and series points (for 
instance, colored points corresponding to argument values). 
 

 
 
Visibility 
You can specify whether or not a chart should display a legend. 
In the Designer, use the Show Legend button in the Legend section of the Design 
Ribbon tab. 
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Position and Orientation 
To specify the legend's position and orientation, select one of the predefined options 
from the gallery in the Design Ribbon tab. 
 

 
 
Axis 
The Chart dashboard item displays two axis by default: the X-axis and the Y-axis. The 
topics in this section describe how to customize axis settings. 
 
X-Axis 
The X-axis is the axis of arguments. 
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Common X-Axis Settings 
To access X-axis settings, use the X-Axis Settings button in the Diagram section of 
the Design Ribbon tab. This will open the X-Axis Settings dialog. This dialog contains 
the following settings. 
 

 
 
 

Setting  Description 

Reverse Allows you to reverse the X-axis. If the X-axis is reversed, its 
values are ordered from right to left. 

Show X-axis Allows you to hide and show the X-axis. 

Show title Allows you to hide and show the X-axis title. You can choose 
whether to use the default text or specify a custom string. 

Enable zooming 
Allows you to enable zooming for the X-axis. The X-axis' scroll 
bar provides the capability to perform navigation in the zoomed 
diagram. 
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Limit visible points 
Allows you to limit the number of points displayed on the chart's 
diagram along the X-axis. The X-axis' scroll bar provides the 
capability to perform navigation if the number of all points 
exceeds the number of visible points. 

 
Numeric Format X-Axis Settings 
If arguments are numeric, the X-Axis Settings dialog contains a Numeric Format tab. It 
allows you to specify the numeric display formats for X-Axis data. 
 

 
 
 

Setting  Description 

Format type Specifies format types for numeric values. 

Unit Specifies the unit to convert the numeric values. 

Precision Specifies the number of fractional digits to display. 
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Currency Specifies the currency symbol and format provided by the 
current culture settings. 

Culture Specifies the name of a culture that defines the currency 
symbol and format. 

Include group 
separator 

Specifies whether separators should be inserted between digit 
groups. 

 
DateTime Format X-Axis Settings 
For date and time arguments, the X-Axis Settings dialog displays a Numeric Format tab. 
It allows you to specify the date and time display formats for X-Axis data. 
Using the dialog, you can override default formats applied according to the data 
grouping type. The following image shows the Date Time Format tab in the dialog 
when the grouping type is set to Exact Date. Click the Reset to Default button to return 
all format settings back to their default values. 
 

 
 
 
Continuous and Discrete X-Axis 
If the dimension in the Arguments section contains numeric data, the Chart can create 
either a continuous X-axis or a discrete X-axis.  
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Continuous X-Axis Discrete X-Axis 

If a continuous axis is used, the 
distance between argument values is 
proportional to their values. 

On a discrete axis, all argument values 
are an equal distance from each other. 

 
 

 
To specify the X-axis type in the Designer, open the data item menu for the argument 
dimension and select the axis type. 
 
Y-Axis 
The Y-axis is the numerical axis of values.  

 
 
To access the Y-axis settings, use the Y-Axis Settings button in the Diagram section 
of the Design Ribbon tab. This will open the Y-Axis Settings dialog. 
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Use the combo box at the top to select the pane for the Y-axis settings you need to edit. 
 
Common Settings 
The dialog contains the following settings. 
 

Setting  Description 

Always show 
zero level  

 
Specifies whether or not the axis' zero level is visible. If this option 
is unchecked, the visible axis 
range is defined based on the values plotted in the chart. 
 

 

Reverse Allows you to reverse the Y-axis. If theY-axis is reversed, its 
values are ordered from top to down. 
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Show grid lines Allows you to hide and show grid lines for the Y-axis. 

Show axis  Allows you to hide and show the Y-axis. 

Show title Allows you to hide and show the Y-axis title. You can choose 
whether to use the default text or specify a custom string. 

Logarithmic 
scale 

Specifies whether the axis should display its numerical values 
using a logarithmic scale. The combo box next to this option 
allows you to select the logarithmic base from one of the 
predefined values. 

 
Numeric Format  
The Numeric Format tab allows you to specify the numeric display formats for Y-Axis 
data.  
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The tab contains the following settings. 
 

Setting  Description 

Format type Specifies format types for numeric values. 

Unit Specifies the unit to convert the numeric values. 

Precision Specifies the number of fractional digits to display. 

Currency Specifies the currency symbol and format provided by the 
current culture settings. 

Culture Specifies the name of a culture that defines the currency 
symbol and format. 

Include group 
separator 

Specifies whether separators should be inserted between digit 
groups. 
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Orientation 
You can rotate the Chart so that the X-axis becomes vertical, and the Y-axis becomes 
horizontal.  

 

 
 
To rotate a Chart in the Designer, use the Rotate button in the Diagram group of the 
Design Ribbon tab. 
 



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
81 

Conditional Formatting 
Use conditional formatting to highlight chart elements such as bars, lines, areas, and 
data points. The following series types support conditional formatting: 

• Bar 
• Point/Line 
• Area 
• Bubble 
• Range Bar 
 

 
 

Supported Format Rules 
You can use the following data in rule calculations: 

• Measures from the Values section 
• Dimensions from the Arguments/Series section 
• Hidden measures 

 
The following list contains available format rules and corresponding data types: 

• Numeric 
o Value 
o Top-Bottom 
o Average 
o Expression 
o Color Ranges 
o Gradient Ranges 

• String 
o Value (with a condition type set to Equal To, Not Equal To or Text that 

Contains) 
o Expression 

• Date-Time 
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o Value 
o A Date Occurring (for dimensions with a continuous date-time group 

interval) 
o Expression 
o Color Ranges 
o Gradient Ranges 

 
Create and Edit a Format Rule 
You can create and edit format rules in the following ways: 

• Click the Edit Rules button on the Home ribbon tab. 
• Click the measure/dimension menu button in the Data Item's pane and select 

Add Format Rule/Edit Rules. 
 
Chart-Specific Format Condition Settings 
Specify appearance settings and set the condition's value to create a format rule. 
Available settings depend on the selected format condition type. The image below 
displays the Greater Than dialog (a Value format condition applied to a chart). The 
condition colors points/bars if their values exceed 3000. 
 

 
Enable Display in Legend to add information about the applied rule to the chart. Set 
the Caption field to specify the legend's text. For Range format rules, the legend's text is 
generated automatically and depends on the range intervals. 
 
Use the Apply to chart elements drop-down list to apply a rule to points or lines. 

• Point: A rule applies to the data points such as bars, points and bubbles. 
• Line/Area: A rule applies to lines and areas. 
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The image below displays the Chart item with the applied Greater Than format rule. The 
Apply to chart elements option is set to Point and the rule is applied to points of the line 
series.  
 

 
 
If you select Line/Area, the format rule applies to the line when at least one line point 
meets the rule's condition 
 

 
 
Coloring 
A Chart item paints elements in pale gray if they do not meet the applied format 
condition. Note that this does not apply to elements that use the Hue color mode.  
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Select the Color by Hue option in a Data item's pane to restore the color scheme. 

 

Activity 2.6 – Chart 
In this activity, you will create a chart.  

 
Activity Steps 
 
Part 1: Add a chart 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Opportunity History model. 
5. Select the Chart button. The chart displays on the Dashboard.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.6/story.html
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6. Click and drag the expectedrevenue field to the Value field in the DATA ITEMS 
pane. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 

7. Click and drag the leadstagename field to the Argument field in the DATA 
ITEMS pane. 

8. Click and drag the createdate field to the Series field in the DATA ITEMS pane. 
 

 
Part 2: Add a second value to the chart 

1. Select Chart Tools > Design.  
2. Select the Stacked Bar series type. Note: Hover your cursor over each icon to 

view the name.  
3. Click and drag the winprobability field to the Value field in the DATA ITEMS 

pane. 
4. Select the Series icon next to the winprobability field. The Series Options 

window opens.  
5. Select the Common Options tab.  
6. Select the Plot on secondary axis check box.  
7. Select the OK button.  
8. Select the down arrow for the winprobability field. Note: Hover the cursor over 

the field to view the arrow.  
9. Select Average.   
10. Select the Series icon next to the winprobability field. The Series Options 

window opens.  
11. Select the Point series type (first icon in the second row).  
12. Select the OK button.  
13. Select the Series icon next to the winprobability field. The Series Options 

window opens.  
14. Select the Common Options tab.  
15. Clear the Plot on secondary axis check box.  
16. Select the OK button.  

 
Part 3: Add a pane 

1. Select the Add Pane icon in the upper right corner of the DATA ITEMS pane. A 
new section and field display.  

2. Click and drag the winprobability field from Values (Pane 1) section to the 
Value field in the Values (Pane 2) section. A second chart displays in the same 
chart item on the dashboard.  

3. Select the down arrow for the winprobability field.  
4. Select Sum.   
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Scatter Chart 
 

 
 
The Scatter Chart dashboard item  visualizes summaries using three dimensions: the X-
axis, the Y-axis and the size of data points. The Scatter Chart can display point labels 
and tooltips that show information on data points. To see a tooltip, hover over the 
required point. 
To bind the Scatter Chart dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. A table below lists and 
describes Scatter Chart data sections. 
 
Section  Description 

X-Axis Contains the data item against which the X-coordinates of data 
points are calculated. 

Y-Axis Contains the data item against which the Y-coordinates of data 
points are calculated. 

Weight Contains the data item whose values are used to calculate the 
weight of data points. 

Arguments Contains data items providing scatter chart arguments that are used 
to create data points. 
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Transposing X- and Y-axis 
The Scatter Chart dashboard item provides the capability to transpose its axes. In this 
case, the data item contained in the X-Axis section is moved to the Y-Axis section, and 
vice versa. 
 

 
 
To transpose the selected Scatter Chart dashboard item, use the Transpose button in 
the Home ribbon tab. 
 
Renaming Items 
To rename the Data Items, select the Edit Names button in the Design ribbon tab. 
 
Coloring 
The Scatter Chart dashboard item does not paint its arguments in Default mode. 
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Legend 
A legend is an element of a scatter chart that identifies chart points (for instance, 
colored points corresponding to argument values). 
 

 
 
Visibility 
You can specify whether or not a chart should display a legend. In the Designer, use the 
Show Legend button in the Legend section of the Design Ribbon tab. 
 
Position and Orientation 
To specify the legend's position and orientation, select one of the predefined options 
from the gallery in the Design Ribbon tab. 
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Axes 
Scatter Chart X and Y-axes are numerical axis of values. You can specify various axes 
settings to change visual data presentation.  
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To access X and Y-axis settings, use the X-Axis Settings/Y-Axis Settings buttons in 
the Diagram section of the Design Ribbon tab.  This will open the X-Axis Settings/Y-
Axis Settings dialog.  
 

 
 
In this dialog, you can specify the following settings. 

• Always show zero level - Specifies whether or not the axis' zero level is visible. 
If this option is unchecked, the visible axis range is defined based on the values 
plotted in the chart. Note that the X-Axis Settings dialog does not contain this 
option.  

• Reverse - Allows you to reverse the axis. If the axis is reversed, its values are 
ordered from top to down. 

• Show grid lines - Allows you to hide and show grid lines for the axis. 
• Show axis - Allows you to hide and show the axis. 
• Show title - Allows you to hide and show the axis title. You can choose whether 

to use the default text or specify a custom string. 
• Logarithmic scale - Specifies whether or not the axis should display its 

numerical values using a logarithmic scale. The combo box next to this option 
allows you to select the logarithmic base from one of the predefined values. 
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The Numeric Format tab allows you to specify the numeric display formats for axis 
data. 
 

 
The tab contains the following settings. 

• Format type - Specifies format types for numeric values. 
• Unit - Specifies the unit to convert the numeric values. 
• Precision - Specifies the number of fractional digits to display. 
• Currency - Specifies the currency symbol and format provided by the current 

culture settings. 
• Culture - Specifies the name of a culture that defines the currency symbol and 

format. 
• Include group separator - Specifies whether separators should be inserted 

between digit groups. 
 
Orientation 
You can rotate the Scatter Chart so that the X-axis becomes vertical, and the Y-axis 
becomes horizontal. To rotate a Chart in the Designer, use the Rotate button in the 
Diagram section of the Design Ribbon tab. 
 
Labels 
The Scatter Chart display can display point labels that contain descriptions for data 
points, and provide tooltips with additional information. 
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Point Labels 
To manage the visibility of point labels, click the Point Labels button in the Design 
ribbon tab. In the open Point Label Settings dialog, enable the Show point labels 
check box to show point labels. 
 

 
 
You can specify the following settings for point labels: 

• Content - Specifies the type of content displayed within point labels. You can 
select one of the following options. 

o Values - Point labels show summary values from X and Y-axes. 
o Argument - Point labels show argument values. 
o Argument and values - Point labels show argument values and 

corresponding summary values. 
o Weight - Point labels show the weight summary value. 
o Argument and weight - Point labels show the argument value and the 

corresponding weight summary value. 
• Overlapping mode - Specifies the label overlap mode. The following options are 

available. 
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o Hide overlapping labels - If two or more labels overlap, some of them 
are automatically hidden to avoid overlapping. 

o None - The overlapping resolving algorithm is disabled. 
o Reposition overlapping labels - The default algorithm to re-position 

point labels in a random way, and avoid overlapping labels. 
• Orientation - Specifies the orientation of point labels. The following options are 

available. 
o Default - A point label is displayed in its default orientation. 
o Rotate to the Right - A point label is rotated 90 degrees clockwise. 
o Rotate to the Left - A point label is rotated 90 degrees counter clockwise. 

Activity 2.7 – Scatter Chart 
In this activity, you will work with a scatter chart.  

 
Activity Steps 
 
Part 1: Create a scatter chart 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Opportunity Forecast model. 
5. Select the Scatter Chart button. The chart displays on the Dashboard.  
6. Click and drag the expectedrevenue field to the X-axis field in the DATA ITEMS 

pane. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 

7. Click and drag the probability field to the Y-axis field in the DATA ITEMS pane. 
8. Click and drag the weightedRevenue field to the Weight field in the DATA 

ITEMS pane. 
9. Click and drag the projectname field to the Arguments field in the DATA ITEMS 

pane. 
 
Part 2: Rename the data items 

1. Select Scatter Chart Tools > Design.  
2. Select the Edit Names button. The Edit Names window opens.  
3. Type Target Projects in the Dashboard item name field.  
4. Type Expected Revenue in the X-axis field.  
5. Type Probability in the Y-axis field.  
6. Type Weighted Revenue in the Weight field.  
7. Select the OK button.  

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.7/story.html
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Part 3: Update the axis numeric formats 
1. Select the X-Axis Settings button on the Design tab. The X-axis Settings 

window opens.  
2. Select the Numeric Format tab.  
3. Select Number in the Format type field.  
4. Select Ones in the Unit field.  
5. Select 0 in the Precision field.  
6. Select the Apply button. The x-axis numbers update. 
7. Select the OK button.  
8. Select the Y-Axis Settings button. The Y-axis Settings window opens.  
9. Select the Numeric Format tab.  
10. Select Number in the Format type field.  
11. Select Ones in the Unit field.  
12. Select the Include group separator check box.  
13. Select the Apply button. The y-axis numbers update. 
14. Select the OK button. 

 
Part 4: Update the data items numeric formats 

1. Select the down arrow for the Expected Revenue field in the DATA ITEMS 
pane. 

2. Select Format. The Numeric Format window opens. 
3. Select Number in the Format type field.  
4. Select Ones in the Unit field.  
5. Select 2 in the Precision field.  
6. Select the Include group separator check box.  
7. Select the OK button. 
8. Hover over a data point to review the updated format in the pop-up information.  
10. Select the down arrow next to the Probability field in the DATA ITEMS pane. 
9. Select Format. The Numeric Format window opens. 
10. Select Number in the Format type field.  
11. Select Ones in the Unit field.  
12. Select 2 in the Precision field.  
13. Select the Include group separator check box.  
14. Select the OK button. 
11. Hover over a data point to review the updated format in the pop-up information. 
12. Select the down arrow for the Weighted Revenue field in the DATA ITEMS 

pane. 
15. Select Format. The Numeric Format window opens. 
16. Select Number in the Format type field.  
17. Select Ones in the Unit field.  
18. Select 0 in the Precision field.  
19. Select the OK button. 
13. Hover over a data point to review the updated format in the pop-up information. 
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Part 5: Adjust color 
1. Select the down arrow for to the projectname field in the DATA ITEMS pane. 
2. Select Color by > Hue.  

Note: To edit the assigned colors, select the Edit Colors button on the Design 
tab.  
 

Part 6: Add point labels 
1. Select the Point Labels button on the Design tab. The Point Labels Settings 

window opens.  
2. Select the Show point labels check box.  
3. Select Weight in the Content field.  
4. Select Reposition overlapping labels in the Overlapping Mode field. 
5. Select the OK button. 

 
Part 7: Adjust the legend 

1. Select the down arrow in the Legend section of the Design tab.  
2. Select the second Outside Vertical legend option.  

Pies 
The Pie dashboard item displays a series of pies or donuts that represent the 
contribution of each value to a total. 
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To bind the Pie dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. A table below lists and 
describes Pie's data sections. 
 
Section  Description 

Values Contains data items that define the share of pie segments. In case 
of negative measure values, Pie uses their absolute values. 

Arguments Contains data items that provide values used to label pie segments. 

Series Contains data items whose values are used to label pie charts. 

 
The Pie dashboard item provides the capability to transpose pie arguments and series. 
You can also perform more complicated calculations around the displayed values using 
the drop-down menu available on the Value fields. The sort preferences for Arguments 
and Series are available using the drop-down menus for each field.  
 

 
 
To transpose the selected Pie dashboard item, use the Transpose button in the Home 
ribbon tab. In this case, data items contained in the Arguments section are moved to the 
Series section, and vice versa.  
 
  



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
97 

Coloring 
In Default color mode, the Pie dashboard item colors its segments in the following way: 

• If the Pie dashboard item contains measures (the Values section) and series 
dimensions (the Series section), only values corresponding to different measures 
are colored by hue. 

 
 
 
• If the Pie dashboard item contains arguments (the Arguments section), different 

argument values are colored by hue. 
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Layout 
The Pie dashboard item allows you to specify the number of columns or rows in which 
individual diagrams are arranged. 
To control how pies are arranged, use the buttons in the Content Arrangement group 
of the Design Ribbon tab. By default, the Auto Arrange option is enabled, which 
automatically resizes pies to fit within the dashboard item. 
 

 
You can also specify the number of columns in which pies are arranged. Click the 
Arrange in Columns button and specify the appropriate number in the Count field. 
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Similarly, you can arrange pies in a specific number of rows. 
 

 
 
Labels 

 
 
You can specify which information should be displayed within data labels and tooltips. 
To do this, use the Data Labels and Tooltips buttons in the Labels group of the 
Design Ribbon tab. 
 
These buttons open a drop-down menu that is similar for both buttons. This menu 
allows you to specify which values are displayed within data labels or tooltips. 
 
The Data Labels Position button allows you to decide if you prefer the labels around 
the perimeter of the graph, or on the graph directly.  
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Style 
The Pie dashboard item allows you to select whether diagrams should be painted as 
pies or donuts. 
 

  

Activity 2.8 – Pies 
In this activity, you will work with pie charts.  

 
Activity Steps 
 
Part 1: Add a pie chart 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Employee Utilization Summary Month model. 
5. Select the Pies button. The pie chart displays on the Dashboard.  
6. Click and drag the Work_Hours field to the Values field in the DATA ITEMS 

pane. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 

7. Click and drag the Project_Charge_Type field to the Arguments field in the 
DATA ITEMS pane. 

8. Click and drag the Employee_Name field to the Series field in the DATA ITEMS 
pane. 

 
Part 2: Rename the data items 

1. Select Pie Tools > Design.  
2. Select the Edit Names button. The Edit Names window opens.  
3. Type Hours Worked By Employees in the Dashboard item name field.  
4. Type Work_Hours in the Values field.  
5. Select the OK button.  

 
Part 3: Update the labels 

1. Select the Data Labels button.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.8/story.html
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2. Select Value.  
3. Select the down arrow for the Work _Hours in the DATA ITEMS pane. 
4. Select Format. The Numeric Format window opens. 
5. Select Number in the Format type field.  
6. Select Auto in the Unit field.  
7. Select the OK button. 
8. Select the Tooltips button.  
9. Select Argument.  
10. Select the Data Position Labels button.  
11. Select Inside. 
 

Part 4: Change style and coloring 
1. Select the Donut button. 
2. Select the Edit Colors button on the Design tab. The Global Color Scheme 

window opens.  
3. Select the Color cell for the Indirect line.  
4. Select the second color on the second row. 
5. Select the Apply button.  
6. Select the OK button.  

 
Part 5: Change the series sort order 

1. Select the down arrow for the Employee_Name field in the DATA ITEMS pane. 
2. Select Sort By > Work_Hours. The charts now display in order of highest work 

hours to lowest.  

Gauges 
The Gauge dashboard item displays a series of gauges. Each gauge can communicate 
two values - one with a needle and the other with a marker on the scale. 
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To bind the Gauge dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. A table below lists and 
describes Gauge's data sections. 
 
Section  Description 

Gauges 

Contains data items used to calculate values displayed by gauges. 
Data items are arranged in containers.  
Each data item container can hold two data items. The first item 
contains actual data and the second item (optional) contains target 
data. If both items are provided, gauges show the difference 
between actual and target values.  
You can fill several data item containers in the Gauges section and 
use the Values drop-down menu to switch between the provided 
values. To open the Values menu, click the icon in the dashboard 
item caption. This drop-down menu is available if the Series section 
is not empty. Otherwise, a separate gauge is created for each data 
item container, and all gauges are displayed simultaneously. 

Series Contains data items whose values are used to label gauges. 

 
Delta 
Gauges allow you to display the difference between the actual and target values of a 
particular parameter. This difference is called delta. 
Delta is shown with a delta indicator (indicating whether the actual value is less than or 
greater than the target value) and delta values (representing this difference as an 
absolute value or a variation). 

 
 
To customize settings that relate to the calculation and display of deltas, use the 
options buttons (icon) displayed next to the data item container in the Gauges section 
of the DATA ITEMS pane. 
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These buttons open the Gauge Options dialog.  
 

 
 
Use it to define the condition for displaying delta indication, specify which delta values 
should be displayed, and introduce the comparison tolerance. 
 
Delta Values 
You can specify which values should be displayed within gauges. Use the Value type 
combo box in the Gauge Options window to select the value that will be displayed as 
the delta value. 
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Value Type  Result 

Actual Value 

 

Absolute Variation 

 

Percentage Variation 

 

Percentage of Target 

 
 
Delta Indication 
You can specify the condition for displaying delta indication. To do this, use the Result 
indication combo box in the Gauge Options window. 

• Greater is Good - The 'good' indication is displayed if the actual value exceeds 
the target value; if the target value exceeds the actual value, the 'bad' indication 
is displayed. 

 
 

• Less is Good - The 'bad' indication is displayed if the actual value exceeds the 
target value; if the target value exceeds the actual value, the 'good' indication is 
displayed. 
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• No Indication - Indication is not displayed. 

 
• Warning if Greater - A warning is displayed if the actual value exceeds the target 

value; otherwise, no indication is displayed. 

 
• Warning if Less - A warning is displayed if the target value exceeds the actual 

value; otherwise, no indication is displayed. 

 
 

Comparison Tolerance 
The comparison tolerance allows you to create more advanced conditions for displaying 
delta indication. For instance, you can specify that a specific indication should be 
displayed when the actual value exceeds the target value by 10% or by $2K. 
Use the Threshold type combo box to select whether you wish to specify the 
comparison tolerance in percentage values or in absolute values. Then use the 
Threshold value box to specify the comparison tolerance. 
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Gauge Scale 
By default, the Gauge dashboard item automatically determines the range of the gauge 
scales based on the values they display. 
 

 
 
You can override this behavior and specify the maximum and minimum values on the 
scale. To do this, open the Gauge Options window using the Options button displayed 
in the data item container in the Gauges section of the DATA ITEMS pane. 
 

 
 
In the Gauge Options window, uncheck the Auto check box for the maximum or 
minimum value, and specify this value in the corresponding field. 
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The Format tab allows you to specify the numeric display formats for different value 
types, as described in the Formatting Data document. 
 

 
The tab contains the following settings. 

• Format type - Specifies format types for numeric values. 
• Unit - Specifies the unit to convert the numeric values. 
• Precision - Specifies the number of fractional digits to display. 
• Currency - Specifies the currency symbol and format provided by the current 

culture settings. 
• Culture - Specifies the name of a culture that defines the currency symbol and 

format. 
• Include group separator - Specifies whether separators should be inserted 

between digit groups. 
 
Layout 
The Gauge dashboard item allows you to specify the number of columns or rows in 
which individual gauges are arranged. To control how gauges are arranged, use the 
buttons in the Content Arrangement group of the Design Ribbon tab. 
By default, the Auto Arrange option is enabled, which automatically resizes gauges to 
fit within the dashboard item. 
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You can also specify the number of columns in which gauges are arranged. Click the 
Arrange in Columns button and specify the appropriate number in the Count field. 
 

 
 
 
 



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
109 

Similarly, you can arrange pies in a specific number of rows by clicking the Arrange in 
Rows button. 
 

 
 
 
Style 
The Gauge dashboard item allows you to select the gauge type. 
The following types are supported. 
 
Full Circular: 
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Half Circular: 
 

 
 
Left-Quarter Circular: 
 

 
Right-Quarter Circular: 
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Three-Fourths Circular: 
 

 
 
Linear Horizontal: 

 
 
Linear Vertical: 

 
 
To select the gauge type, use the buttons in the Style group of the Design Ribbon tab. 
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Activity 2.9 – Gauges 
In this activity, you will work with gauges.  

 
Activity Steps 
 
Part 1: Add a gauge 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Project Figures CVS model. 
5. Select the Gauges button. The Gauges chart displays on the Dashboard.  
6. Select the Parameters icon on the upper-right corner of the Dashboard. The 

Dashboard Parameters window opens.  
7. Type 2023-12 in the Value field for the Current_Period_Code line.  
8. Select the Submit button. 
9. Click and drag the PTD_Billed field to the Actual field in the DATA ITEMS pane. 

Note: If you see a red exclamation point in the upper left corner of a dashboard 
item after adding fields to the DATA ITEMS pane, select the Reload Data button. 

10. Click and drag the Budget_Amount field to the first Target field in the DATA 
ITEMS pane. The gauge shows a backlog of Budget_Amount minus the 
PTD_Billed. 

11. Click and drag the PTD_Work_Hours field to the next available Actual field in 
the DATA ITEMS pane. 

12. Click and drag the Budget_Hours field to the next available Target field in the 
DATA ITEMS pane.  
 

Part 2: Filter data with a hidden dimension  
1. Click and drag the Project_Charge_Type field to the Dimension field in the 

HIDDEN DATA ITEMS pane.  
2. Right-click on the Gauge item on the Dashboard.  
3. Select Edit Filter. The Filter Editor for Gauges 1 window opens.  
4. Hover the cursor in the space next to the And icon in the upper left corner. 

Additional icons display. 
5. Select the plus icon.  
6. Select Begins with. A menu displays.  
7. Select = Equals. 
8. Select Enter a Value. 
9. Select the drop-down arrow. The system has preselected the available choices 

for you.  
10. Select Billable.  
11. Select the OK button. Note: If the dashboard does not refresh automatically, 

select the Refresh icon in the Data Source pane.  
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Part 3: Rename the fields 
1. Select the down arrow for the PTD_Billed field.  
2. Select Rename. The Rename Data Item window opens.  
3. Type PTD Billed in the New Name field.  
4. Select the OK button. 
5. Select the down arrow for the Budget_Amount field.  
6. Select Rename. The Rename Data Item window opens.  
7. Type Budget Amount in the New Name field. 
8. Select the OK button. 
9. Select the down arrow for the PTD_Work_Hours field.  
10. Select Rename. The Rename Data Item window opens.  
11. Type PTD Work Hours in the New Name field. 
12. Select the OK button. 
13. Select the down arrow for the Budget_Hours field.  
14. Select Rename. The Rename Data Item window opens.  
15. Type Budget Hours in the New Name field. 
16. Select the OK button. 

 
Part 4: Edit format 

1. Select the options icon (gear symbol) for the PTD Billed/Budget Amount 
gauge. The Gauge Options window opens.   

2. Select the Format tab.  
3. Verify that Scale Label is selected in the Select value type field.  
4. Select Number in the Format type field. 
5. Select Thousands in the Unit field. 
6. Select 0 in the Precision field.  
7. Select the Include group separator check box.  
8. Select Absolute variation in the Select Value Type field. 
9. Select Thousands in the Unit field. 
10. Select the Include group separator check box.  
11. Select the OK button. 
12. Select the options icon for the PTD Work Hours/Budget Hours gauge. The 

Gauge Options window opens.   
13. Select Percent of target in the Value Type field.  
14. Select No indication in the Result Indication field.  
15. Select the Format tab.  
16. Select Percent of target in the Select value type field.  
17. Select 1 in the Precision field.  
18. Select the Include group separator check box.  
19. Select the OK button. 

 
Part 5: Update style 

1. Select Gauges Tools > Design in the toolbar.  
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2. Select Three-Quarter Circular.  
 
Part 6: Add Series 

1. Click and drag the Project_Long_Name field to the Series field in the DATA 
ITEMS pane. The Dashboard now displays all the project gauges for the first set 
of data items (PTD Billed vs Budget Amount).  

2. Select the Values icon in the upper right corner of the Dashboard. 
3. Select PTD Work Hours vs Budget Hours. The Dashboard now displays all the 

project gauges for the second set of data items. 
4. Select Arrange in Columns on the Design tab. 

Cards 
The Card dashboard item displays a series of cards. Each card illustrates the difference 
between two values. This difference can be expressed as an absolute value, an 
absolute variation or a percentage variation. 
 

 
 
To bind the Card dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. A table below lists and 
describes Card data sections. 
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Section  Description 

Cards 

Contains data items used to calculate values displayed within cards. 
Data items are arranged in containers.  
Each data item container can hold two data items. The first item 
contains actual data and the second item (optional) contains target 
data. If both items are provided, cards show the difference between 
actual and target values. You can fill several data item containers 
in the Cards section and use the Values drop-down menu to switch 
between the provided values. To open the Values menu, click the 
icon in the dashboard item caption or use its context menu. This 
drop-down menu is available if the Series section is not empty. 
Otherwise, a separate card is created for each data item container, 
and all cards are displayed simultaneously. 

Series Contains data items whose values are used to label cards. 

Sparkline Provide a dimension whose data will be used to visualize values 
using sparklines. 

Layout 
The Card dashboard item allows you to manage the position and visibility of elements 
displayed on cards. These elements include actual and target values, a delta indicator 
and corresponding delta values, a sparkline, etc. 
To manage the position and visibility of card elements, choose a predefined layout 
template and customize its settings. 
 
Available Layout Templates 
The table below contains information about the available layout templates: 
 

Layout 
Type  Example Description 

Stretched 

 

The Stretched layout template 
arranges card elements so 
that they occupy an entire 
card area. 
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Centered 

 

The Centered layout template 
is used to center card 
elements so that they occupy 
a specified width/height. 

Compact 

 

The Compact layout template 
is used to arrange card 
elements so that they 
occupy the minimum area. 

Lightweight 

 

The Lightweight layout 
template displays the 
minimum set of elements 
within a card. 

 
For all layout types, you can change the visibility of its elements, or you can specify the 
display value type for data-bound elements. To learn more, see the Change Layout 
paragraph below. 
Default Layout 
The Card dashboard item uses the Stretched layout template that arranges card visual 
elements in the following way by default: 
 

 
 
 
Note: Delta Indicator and delta values (such as Percent Variation or Absolute Variation) 
are colored depending on delta settings.  
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Change Layout 
To change a card's layout in the Dashboard Designer, click the Options button (the 
icon) displayed next to the data item container in the Cards section. This opens the 
Card Settings dialog. 
 

 
On the Layout Options tab, select the required layout type in the Select template list 
and specify its settings: 
 

• Min width - Specifies the minimum width of the card content. 
• Max width - Specifies the maximum width of the card content. Use the Auto 

option to determine the maximum width automatically. 
 
You can show/hide values and visual elements within the card. Use the Apply to All 
Cards button to propagate the specified layout settings to all cards corresponding to 
Actual-Target pairs. The Reset button resets all setting to their default values. 
 
Delta 
Cards allow you to visualize the difference between the actual and target values using 
special delta values and a delta indicator. If the default layout is used (Stretched layout 
type), the card displays the following delta values/elements: 
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• Delta Indicator - Indicates whether the actual value is less or greater than the 
target value. 

• Percent Variation and Absolute Variation - delta values that show a difference 
between the actual and target value. You can also display the Percent of Target 
value. To do this, customize the card's layout. 

To customize settings that relate to the calculation and display of delta values/elements, 
use the Options button (the icon) displayed next to the data item container in the Cards 
section. 
In the open Card Settings dialog, go to the Delta Options tab: 
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Then, specify the following settings: 
• Result Indication - You can specify the condition for displaying delta indication. 

o Greater is Good - The 'good' indication is displayed if the actual value 
exceeds the target value; if the target value exceeds the actual value, the 
'bad' indication displays. 
 

 
 

o Less is Good - The 'bad' indication displays if the actual value exceeds 
the target value; if the target value exceeds the actual value, the 'good' 
indication displays. 
 

 
 

o Warning if Greater - A warning  displays only if the actual value exceeds 
the target value. 
 

 
 

 
o Warning if Less - A warning  displays only if the target value exceeds the 

actual value. 
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o No Indication - Indication does not display. 

 

 
 
 
• Threshold type / Threshold value - For instance, you can specify that a specific 

indication should display when the actual value exceeds the target value by 10% 
or by $2K. Use the Threshold type combo box to select whether you wish to 
specify the comparison tolerance in percentage values or absolute values. Then 
use the Threshold value box to specify the comparison tolerance. 

 
Cards Arrangement 
The Card dashboard item allows you to specify the number of columns or rows in which 
individual cards are arranged. Use the buttons in the Content Arrangement group of 
the Design Ribbon tab to control how cards are arranged. The Auto Arrange option is 
enabled by default, which automatically resizes cards to fit within the dashboard item. 
 

 

 
 
You can also specify the number of columns in which cards are arranged. Click the 
Arrange in Columns button and specify the appropriate number in the Count field. 
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Similarly, you can arrange cards in a specific number of rows. 
 

 

 

Activity 2.10 – Cards 
In this activity, you will work with cards.  

 
Activity Steps 
 
Part 1: Add a card 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.10/story.html
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4. Double-click the Employee Utilization Summary Month model. 
5. Select the Cards button. The Cards item displays on the Dashboard.  
6. Click and drag the Direct_Work_Hours field to the Actual field in the DATA 

ITEMS pane. Note: If you see a red exclamation point in the upper left corner of 
a dashboard item after adding fields to the DATA ITEMS pane, select the 
Reload Data button. 

7. Click and drag the Indirect_Work_Hours field to the first Target field in the 
DATA ITEMS pane.  

8. Click and drag the Employee_Name field to the Series field in the DATA ITEMS 
pane. 

9. Click and drag the Month_End_Date field to the Argument field in the DATA 
ITEMS pane.  

10. Select the down arrow for the Month_End_Date field. 
11. Select Month-Year. 

 
Part 2: Edit format 

1. Select the options icon for the Direct_Work_Hours/Indirect Work Hours card.  
The Card Options window opens. 

2. Select the Format Options tab.  
3. Select Number in the Format type field. 
4. Select Ones in the Unit field. 
5. Select 0 in the Precision field.   
6. Select the Include group separator check box.  
7. Select the Apply button. 
8. Select Absolute Variation in the Select value type field. 
9. Verify that Number is selected in the Format type field. 
10. Select Ones in the Unit field. 
11. Verify that 0 is selected in the Precision field.  
12. Select the Include group separator check box. 
13. Select the Apply button.  
14. Select the Sparkline Options tab.  
15. Select Area in the Sparkline view type field.  
16. Select the Apply button. 
17. Select the OK button.  

 
Part 3: Edit arrangement 

1. Select Cards Tools > Design in the toolbar.  
2. Select Arrange in Columns.  
3. Select 2 in the Count field. 

 
Part 4: Edit layout 

1. Select the options icon for the Direct_Work_Hours/Indirect Work Hours card.  
The Card Options window opens. 
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2. Select the Layout Options tab, if necessary.  
3. Select Lightweight in the Select template field.  
4. Select the OK button.  

 

Choropleth Maps 
The Choropleth Map dashboard item allows you to colorize the required areas in 
proportion to the provided values. 
 

 
 
Providing Maps 
This document explains how to use the default ReportsNow Dashboard maps, or 
provide custom maps. 
 
Default Maps 
ReportsNow Dashboard ships with a set of default maps showing various parts of the 
world. The following maps are included. 

• World Countries - a world map. 
• Europe - a map of Europe. 
• Asia - a map of Asia. 
• North America - a map of North America. 
• South America - a map of South America. 
• Africa - a map of Africa. 
• USA - a map of the USA. 
• Canada - a map of Canada. 
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Note: The World Countries map has a lower level of detail than maps of specific regions 
and may not contain some countries. As an alternative, you can load a custom map with 
the required granularity. 
 
To select the required default map, use the Default Map button in the Open group of 
the Design ribbon tab. As an alternative, use the corresponding command in the map 
context menu. 
 
Custom Maps 
ReportsNow Dashboard uses a Shapefile vector format to provide custom maps. 
Commonly, this format includes two file types. 

• .shp file - holds map shapes (points/lines/polygons). 
• .dbf file - contains attributes for each shape. 

To open an existing shapefile, use the Load Map or Import Map button in the Ribbon, 
or the command in the context menu. 
In the open dialog, locate the required .shp file. Note that custom maps created in the 
Cartesian coordinate system are not supported. 
 
Note:  If the map is opened using the Load Map button, the dashboard definition will 
contain the path to a map shapefile. If the map is opened using the Import Map button, 
the dashboard definition will contain the map itself. 
 
Note:  Attributes from the corresponding .dbf file located in the same directory will be 
included in the map automatically. 
 
Map Attributes 
After you select the default map or a custom map, you can view supplemental 
information (such as the name of the country, state, etc.). To do this, click the Options 
button next to the Attribute placeholder. 
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In the open Map Attribute Binding dialog, click Preview. 
 

 
 
This table displays the available attributes for the current map. Each set of attribute 
values is related to a specific map shape. 
 
Providing Data 
The only difference is in the data sections that the required dashboard item has. This 
topic describes how to bind a Choropleth Map dashboard item to data in the Designer. 
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To bind the Choropleth Map dashboard item to data, drag and drop a data source field 
to a placeholder contained in one of the available data sections. The Choropleth Map 
provides two data item groups for data binding: DATA ITEMS and TOOLTIP DATA 
ITEMS. Tables below list the available data sections.  
DATA ITEMS 

• Attribute - Allows you to associate map shapes with data source field values.  
 
To associate map shapes with data source field values, drag-and-drop the 
required dimension to the data item's placeholder and select the required 
attribute in the Map Attribute Binding dialog. To open this dialog, click the 
Options button (the icon) next to the Attribute placeholder. 
 

 
Select the required attribute and click OK. 

 
• Maps - Contains data items whose values are used to color map shapes. Map 

shape colors vary based on the map type. 
Click the Options button (or the icon depending on the map type) next to the 
Value placeholder and select the required map type in the open Choropleth 
Map Options dialog. 
 

 
 

• If you select Value, the Choropleth map colors map shapes depending on the 
values provided.  

• If you select Delta, the Choropleth map colors map shapes depending on the 
difference between two values.  
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Note: You can fill several data item containers in the Maps section and use the 
Values drop-down menu to switch between the provided values. To open the 
Values menu, click the icon in the dashboard item caption. 

 
TOOLTIP DATA ITEMS 

• Measures - Allows you to add supplementary content to the tooltips. Drag and 
drop the required measures to provide additional data. 

 
Map Coloring 
The Choropleth Map dashboard item colors map shapes depending on the data 
provided. For instance, you can visualize a sales amount or population density. 
 

 
 

Palette and Scale Settings 
The Choropleth Map automatically selects palette and scale settings to color map 
shapes. If you need to customize these settings, click the Options button next to the 
data item that contains these values. 
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This opens the Choropleth Map Options dialog. 

 
You can specify the following settings in this window. 

• Color palette - allows you to specify the start and end color of the palette. 
• Scale settings - specifies whether a percent scale or an absolute scale is used 

to define a set of colors. You can specify the number of levels that represent the 
number of colors used to color the map. 

• Preview is used to display a full set of palette colors generated based on the 
start/end colors and the number of levels. Use the Allow Edit check box to 
automatically change the generated colors or specify value ranges for each color. 
 

Delta 
The Choropleth Map allows you to indicate the difference between the actual and target 
values of a particular parameter. This difference is called delta. 

 
  



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
129 

Delta Options 
To specify delta indication settings, click the Options button next to the data item 
container. 
 

 
This opens the Choropleth Map Options dialog. When the map type is set to Delta, 
this dialog contains the following settings. 
 

 
 

• Value Type 
You can specify which values to display within map tooltips. Use the Value type 
combo box to select the value that will be displayed as the delta value. 

 

Value Type  Tooltip 
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Actual value 

 

Absolute variation 

 

Percent variation 

 

Percent of target 

 

 
• Result Indication 

You can specify the condition that will be used to select the indicator color. To do 
this, use the Result indication combo box. 

 

Value Type  Tooltip 

Greater is good 

 

Less is good 
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Warning if greater 

 

Warning if less 

 

No indication 

 

 
 

• Threshold type and Threshold value 
 
You can specify that a required indicator should only be displayed when the 
difference between the actual and target values exceeds a specified value. For 
instance, the actual value exceeds the target value by 10%, or by $2K. 
 
Use the Threshold type combo box to select whether you wish to specify the 
threshold in percentage values or in absolute values. Then use the Threshold 
value box to specify the threshold value. 
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The Format tab allows you to specify the numeric display formats for different value 
types, as described in the Formatting Data document. 
 

 
 
The tab contains the following settings. 

• Format type - Specifies format types for numeric values. 
• Unit - Specifies the unit to convert the numeric values. 
• Precision - Specifies the number of fractional digits to display. 
• Currency - Specifies the currency symbol and format provided by the current 

culture settings. 
• Culture - Specifies the name of a culture that defines the currency symbol and 

format. 
• Include group separator - Specifies whether separators should be inserted 

between digit groups. 
 
Map Navigation 
The Choropleth Map dashboard item allows you to perform navigation actions such as 
zooming and scrolling. 
The Dashboard Designer allows you to specify the initial zooming/scrolling state for the 
Choropleth map using the mouse. 
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You can disable the capability to scroll/zoom the map using the Lock Navigation button 
in the Design ribbon tab. 
 

 
Use the Full Extent button to display the entire map within the dashboard item. 
 
Labels 
A Choropleth map provides the capability to display titles within map shapes and allows 
you to manage what data to show in the shape tooltips. 
To manage map titles and tooltips, click the Shape Labels button in the Design ribbon 
tab. This opens the Shape Label Settings dialog. 
 

 
 
In this dialog, you can specify attributes whose values will be displayed within shapes 
and tooltips. Use the button to preview the available attributes and their values for the 
current map. 
 
Shape Titles 
The Title attribute option allows you to select the attribute whose values are displayed 
within corresponding map shapes. 
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You can also use the Include summary value option to add summary values to shape 
titles. 
 
Tooltips 
The Choropleth Map dashboard item displays a tooltip that shows information related to 
a hovered shape. 
 

 
You can choose whether to use a binding attribute to display as the title of shape 
tooltips (the Use binding attribute option) or specify a custom attribute using the 
Tooltip attribute option. 
 

 
The Choropleth Map also allows you to add supplementary content to the tooltips using 
the TOOLTIP DATA ITEMS area.  
 
Legend 
A legend is an element of a map that shows values corresponding to each color. 
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Visibility 
To display a legend within a map, use the Show Legend button in the Legend group of 
the Design Ribbon tab. 
 
Position and Orientation 
To specify the legend's position and orientation, select one of the predefined options 
from the gallery in the Design Ribbon tab. 

 
 
 

Tour 2.11 – Choropleth Maps 
In this tour, you will review choropleth maps.  

 

Geo Point Maps 
The Dashboard Designer allows you to create three types of Geo Point maps. 

•   The Geo Point Map dashboard item allows you to place callouts on the map 
using geographical coordinates. 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Tour_2.11.mp4
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• The Bubble Map dashboard item allows you to place bubbles on the map. Each 

bubble can represent data using its weight and color. 

 
• The Pie Map dashboard item allows you to display pies on the map. Each pie 

visualizes the contribution of each value to the total. 

 
To create the required Geo Point Map dashboard item, use the Geo Point Maps 
button in the Home ribbon tab. 
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Providing Maps 
This section explains how to use the default ReportsNow Dashboard maps, or provide 
custom maps. 
 
Default Maps 
ReportsNow Dashboard ships with a set of default maps showing various parts of the 
world. The following maps are included. 

• World Countries - a world map. 
• Europe - a map of Europe. 
• Asia - a map of Asia. 
• North America - a map of North America. 
• South America - a map of South America. 
• Africa - a map of Africa. 
• USA - a map of the USA. 
• Canada - a map of Canada. 

 
Note that the World Countries map has a lower level of detail than maps of specific 
regions and may not contain some countries. As an alternative, you can load a custom 
map with the required granularity. 
 
To select the default map, use the Default Map button in the Design ribbon tab. As an 
alternative, use the corresponding command in the map's context menu. 
 
Custom Maps 
ReportsNow Dashboard uses a Shapefile vector format to provide custom maps. 
Commonly, this format includes two file types. 

• .shp file - holds map shapes (points/lines/polygons). 
• .dbf file - contains attributes for each shape. 

To open an existing shapefile, use the Load Map or Import Map button in the Ribbon, 
or the command in the context menu (Load Map... or Import Map...). 
In the open dialog, locate the required .shp file. Note that custom maps created in the 
Cartesian coordinate system are not supported. 
 
Note: If the map is opened using the Load Map button, the dashboard definition will 
contain the path to a map shapefile. If the map is opened using the Import Map button, 
the dashboard definition will contain the map itself. 
 
Note: Attributes from the corresponding .dbf file located in the same directory will 
automatically be included in the map. 
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Geo Point Map 
The Geo Point Map dashboard item allows you to place callouts on the map using 
geographical coordinates. 
 

 
 
Note that the Geo Point Map provides two data item groups for data binding: DATA 
ITEMS and TOOLTIP DATA ITEMS. Tables below list the available data sections. 
 
Data Items 
Section  Description 

Latitude Accepts a dimension used to provide geographic latitude. 

Longitude Accepts a dimension used to provide geographic longitude. 

Value Accepts values related to geographic points. These values are 
displayed within map callouts. 

 
Tooltip Data Items 
Section  Description 

Dimensions Accepts dimensions allowing you to add supplementary content to 
the tooltips. 

Measures Accepts measures allowing you to add summaries to the tooltips. 
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Bubble Map 
The Bubble Map dashboard item allows you to place bubbles on the map. Each bubble 
can represent data using its weight and color. 
 

 
 
Note that the Bubble Map provides two data item groups for data binding: DATA ITEMS 
and TOOLTIP DATA ITEMS. Tables below list the available data sections. 
 
Data Items 
Section  Description 

Latitude Accepts a dimension used to provide geographic latitude. 

Longitude Accepts a dimension used to provide geographic longitude. 

Weight Accepts values related to geographic points. These values are 
displayed within map callouts. 

Color 

Accepts a measure used to evaluate the bubble's color. 
The Bubble Map dashboard item automatically selects palette and 
scale settings used to color bubbles. To customize these settings, 
click the Options button next to the Color placeholder. This opens 
the Color Scale Options dialog, which allows you to specify the 
palette and scale options. 
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Tooltip Data Items 
Section  Description 

Dimensions Accepts dimensions allowing you to add supplementary content to 
the tooltips. 

Measures Accepts measures allowing you to add summaries to the tooltips. 

 
Coloring 
The Bubble Map dashboard item automatically selects palette and scale settings used 
to color bubbles depending on the provided values. To customize these settings, click 
the Options button next to the Color placeholder. This opens the Color Scale Options 
dialog, which allows you to specify the palette and scale options. 
 

 
 
You can specify the following settings in this window. 

• Color palette - allows you to specify the start and end color of the palette. 
• Scale settings - specifies whether a percent scale or an absolute scale is used 

to define a set of colors. You can specify the number of levels that represent the 
number of colors used to color the map. 

• Preview is used to display a full set of palette colors generated based on the 
start/end colors and the number of levels. Use the Allow Edit check box to 
automatically change the generated colors or specify value ranges for each color. 
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Legends 
Bubble Map provides two types of legends used to identify map objects - color and 
weighted legends. 
 
 
Color Legend 
The color legend helps you to identify which colors correspond to specific values. 
 

 
 
To display a color legend within a map, use the Show Color Legend button in the 
Color Legend section of the Design Ribbon tab. 
 

 
To specify the legend's position and orientation, select one of the predefined options 
from the gallery in the Design Ribbon tab. 

 
 
Weighted Legend 
The weighted legend allows you to identify values corresponding to specific bubble 
sizes. 
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To select the required weighted legend type, use the Show Weighted Legend button in 
the Weighted Legend section of the Design Ribbon tab. To specify the legend's 
position, select one of the predefined options from the gallery in the Design Ribbon tab. 
 

 
 
Pie Map 
The Pie Map dashboard item allows you to display pies on the map. Each pie visualizes 
the contribution of each value to the total. 
 

 
 
Note that the Pie Map provides two data item groups for data binding: DATA ITEMS and 
TOOLTIP DATA ITEMS. Tables below list the available data sections. 
 
Data Items 
Section  Description 

Latitude Accepts a dimension used to provide geographic latitude. 

Longitude Accepts a dimension used to provide geographic longitude. 
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Values 

Accepts measures used to calculate pie values. In case of negative 
measure values, Pie Map uses their absolute values. If you 
added a data item to the Argument section and several data items 
to the Values section, you can use the Values drop-down 
menu to switch between the provided values. To open the Values 
menu, click the icon in the map's caption or use the map's context 
menu. 

Argument Allows you to provide data for pie arguments. 

 
Tooltip Data Items 
Section  Description 

Dimensions Accepts dimensions allowing you to add supplementary content to 
the tooltips. 

Measures Accepts measures allowing you to add summaries to the tooltips. 

 
 
Pie Options 
The Pie Map dashboard item allows you to take into account the weight of pies. In this 
case, the relative sizes of the pies depend on the corresponding summary values. 
 

 
 
Coloring 
In Default color mode, the Pie Map dashboard item colors its segments in the following 
way: 

• If the Pie Map dashboard item contains arguments (the Arguments section), 
different argument values are colored by hue. 

• If the Pie Map dashboard item contains only measures (the Values section), 
values corresponding to different measures are colored by hue. 
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The image below illustrates the Pie Map dashboard item whose argument values are 
painted in different colors. A special icon (nine dot grid) on the data item shows that 
color variation is enabled. 
 

 
 
Legends 
The Pie Map provides two types of legends used to identify map objects - color and 
weighted legends. 
 
Color Legend 
The color legend helps you to identify which colors correspond to specific argument 
values. 
 

 
 
To display a color legend within a map, use the Show Color Legend button in the 
Color Legend section of the Design Ribbon tab. 
 
To specify the legend's position and orientation, select one of the predefined options 
from the gallery in the Design Ribbon tab. 
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Weighted Legend 
The weighted legend allows you to identify values corresponding to specific pie sizes. 
 

 
 
Note that the Pie Map dashboard item does not display the weighted legend if weighed 
pies are disabled. 
 
To select the required weighted legend type, use the Show Weighted Legend button in 
the Weighted Legend section of the Design Ribbon tab. 
 
To specify the legend's position, select one of the predefined options from the gallery in 
the Design Ribbon tab. 
 

 
 
Clustering 
When a Geo Point map contains a large number of objects (callouts, bubbles or pies), 
showing each object individually on the map is not useful. The Dashboard Designer 
provides the capability to group neighboring map objects. This feature is called 
Clustering. 
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For instance, the Geo Point Map dashboard item combines callouts to bubbles. 

 
 
The Bubble Map and Pie Map dashboard items cluster bubbles/pies with other 
bubbles/pies. 
 

 
 
To enable clustering in the Designer, use the Enable Clustering button in the Data 
ribbon tab. 
 
Labels 
Geo Point maps provide the capability to display titles within map shapes and allows 
you to add supplementary content to the callout/bubble/pie tooltips. 
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Shape Titles 
To manage map titles, click the Shape Title button in the Design ribbon tab. This opens 
the Shape Title Settings dialog. 

 
 
In this dialog, you can specify attributes whose values will be displayed within shapes. 
Use the button to preview the available attributes and their values for the current map. 
 
The Title attribute option allows you to select the attribute whose values are displayed 
within corresponding map shapes. 
 

 
 
Tooltips 
Geo Point maps also allow you to add supplementary content to the callout/bubble/pie 
tooltips using the TOOLTIP DATA ITEMS area.  
 
Map Navigation 
Geo Point maps allow you to perform navigation actions such as zooming and scrolling. 
The Dashboard Designer allows you to specify the initial zooming/scrolling state for the 
Geo Point map using the mouse. 
You can disable the capability to scroll/zoom the map using the Lock Navigation button 
in the Design ribbon tab. Use the Full Extent button to display the entire map within the 
dashboard item. 
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Tour 2.12 – Geo Point Maps 
In this tour, you will review the three types of Geo Point Maps.  

 

Range Filter 
The Range Filter dashboard item allows you to apply filtering to other dashboard items. 
This item displays a chart with selection thumbs that allow you to filter out values 
displayed along the argument axis. 
 

 
 
To bind the Range Filter dashboard item to data, drag and drop a data source field to a 
placeholder contained in one of the available data sections. A table below lists and 
describes Range Filter data sections. 
 
Section  Description 

Values Contains data items against which the Y-coordinates of data points 
are calculated. 

Argument 

Contains a data item that provides values displayed along the 
horizontal axis of the Range Filter. Filtering is performed based 
on these values. Note that the Options button (the icon) allows you 
to create predefined ranges used to select the required date-time 
interval. 

Series Contains data items whose values are used to create chart series. 

 
 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/ Tour_2.12.mp4
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Series 
The Range Filter dashboard item supports various Line and Area series types. 
To switch between series types in the Designer, click the options button next to the 
required data item in the Values section. In the open Series Type dialog, select the 
required series type and click OK. 
 

 
 
You can also do this using the buttons in the Series Type group of the Design ribbon 
tab. 

 
 
The Range Filter supports the following series types. 
 
Line: 

 
 
Stacked Line: 
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Full-Stacked Line: 

 
 
Area: 

 
 
Stacked Area: 

 
 
Full-Stacked Area: 

  
 
Coloring 
The Range Filter dashboard item paints different measures and series dimensions by 
hue in Default color mode. The image below shows the Range Filter item whose State 
series dimension values are painted in different colors. A special icon on the data item 
shows that color variation is enabled. 
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Activity 2.13 – Range Filter 
In this activity, you will use the Range Filter to apply filtering to other 
dashboard items.  

 
Activity Steps 
 
Part 1: Add a grid item 

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Sales Journal Detail CVS model. 
5. Select the Grid button. The Grid item displays on the Dashboard.  
6. Select the Parameters icon on the upper-right corner of the Dashboard. The 

Dashboard Parameters window opens.  
7. Type 1/1/2020 in the Value field for the From_Date line.  
8. Select the Submit button. 
9. Click and drag the following fields to the New Column field in the DATA ITEMS 

pane. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 
• Transaction_Date 
• Billed 

11. Select the down arrow for the Transaction_Date field in the DATA ITEMS 
pane. 

12. Select Exact Date. 
 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.13/story.html
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Part 2: Copy grid item 
1. Right-click anywhere on the grid.  
2. Select Duplicate. 
3. Right-click anywhere on the second grid. 
4. Select Convert To > Pies. 
5. Select the down arrow for the Transaction_Date field in the DATA ITEMS 

pane. 
6. Select Year. 

 
Part 3: Add range filter 

1. Select the Range Filter button.  
2. Click and drag the Billed field to the Value field in the DATA ITEMS pane.  
3. Click and drag the Transaction_Date field to the Argument field in the DATA 

ITEMS pane.  
4. Click and drag the Client_Name field to the Series field in the DATA ITEMS 

pane. 
5. Select the down arrow for the Transaction_Date field. 
6. Select Month-Year. 
7. Select the Series Type icon for the Billed field. The Series Type window opens.  
8. Select the Stacked Bar icon (second icon in the third row). 
9. Select the OK button.  
10. Select the Design tab.  
11. Select the Show Caption button. The Range Filter caption displays.  
12. Click the Range Filter caption and drag the entire range filter to the top of the 

dashboard.  
13. Select the September 2020 bar in the Range Filter. The Grid and Pie dashboard 

items update to display data from September 2020.  
14. Click and drag the handle on the right side of the selection window to include 

November 2020.  The Grid and Pie dashboard items update to display data from 
September 2020 through November 2020.  

15. Click and drag the entire selection window to the right to display the data from 
December 2020 to February 2021.  

16. Right-click anywhere on the ranger filter.  
17. Select Remove Caption.  
 

Part 4: Set a default date range 
1. Verify the Design tab is still selected.  
2. Select the Edit Periods button. The Edit Periods window opens.  
3. Select Last 2 Years.  
4. Select the arrow. 
5. Select the Default check box.  
6. Select the Close button.  
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Filter Elements 
The Dashboard Designer allows you to create filter elements which are used to filter 
other dashboard items. 

• Combo Box 
• List Box 
• Tree View 
• Date Filter 

To add the required filter element to the dashboard, use the Filter Elements button in 
the Home ribbon tab. 
 
Combo Box 
The Combo Box dashboard item allows you to select a value(s) from a drop-down list. 
You can switch the combo box type in the ribbon Design tab. 
 
Combo Box Type  Example Description 

Standard 

 

Allows you to select only a single 
value. 

Checked 

 

Allows you to select multiple 
values in the open drop-down 
list. 
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List Box 
The List Box dashboard item allows you to select a value(s) from the list view. 
You can switch the list box type in the ribbon Design tab. 
 
List Box Type  Example Description 

Checked 

 

Allows you to select multiple 
values in the list box. 

Radio 

 

Allows you to select only a single 
value in the radio group. 

 
 
Tree View 
The Tree View dashboard item displays values in a hierarchical way and allows you to 
expand/collapse nodes. 
 

 
 
You can manage the initial expanded state of filter values using the Auto Expand 
button in the Design ribbon tab. 
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Date Filter 
The Date Filter dashboard item allows you to filter dashboard data based on the 
selected data range. The range can be relative (Last 3 Months),  fixed dates (01-01-
2018), or presets (Month-to-date). You can also filter dates before or after a specified 
date. 
The DateFilter item displays a set of intervals that can be used as quick filters. 
 

 
 
Providing Data 
This topic describes how to bind filter elements to data using the Dashboard Designer. 
 
Binding Overview 
All filter elements provide the Dimensions data section, which accepts dimensions used 
to provide filter values. 
To learn about the specifics of binding various filter elements to data, see the table 
below. 
 
Dashboard 
Item  Data Sections Description 

Combo 
Box 

 

The Combo Box filter element can 
contain several dimensions at the 
Dimensions data section. 
In this case, the drop-down list will 
contain combinations of dimension 
values. 

List Box 

 

The List Box filter element can 
contain several dimensions at the 
Dimensions data section. In 
this case, the list will contain 
combinations of dimension values. 
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Tree View 

 

The Tree View filter element allows 
you to display dimension values in 
a hierarchical way. This can be the 
set of dimensions with different 
group intervals (for instance, 
Year/Quarter/Month) or the set of 
related dimensions (for instance, 
geographical data such as 
continents/countries/cities). 

 

Activity 2.14 – Filter Elements 
In this activity, you will create filter elements used to filter other dashboard 
items.  

 
Activity Steps 
 
Part 1: Add a grid  

1. Select Utilities > Analytic Dashboard Designer. 
2. Select the New button. An Add Model? message displays.  
3. Select the Yes button. The Analytic Models window opens.  
4. Double-click the Sales Journal Detail CVS model. 
5. Select the Grid button. The Grid item displays on the Dashboard.  
6. Select the Parameters icon on the upper-right corner of the Dashboard. The 

Dashboard Parameters window opens.  
7. Type 1/1/2020 in the Value field for the From_Date line.  
8. Type 2020-01 in the Value field for the From_Period_Code. 
9. Type 2023-01 in the Value field for the Thru_Period_Code. 
10. Select the Submit button. 
11. Click and drag the following fields to the New Column field in the DATA ITEMS 

panel. Note: If you see a red exclamation point in the upper left corner of a 
dashboard item after adding fields to the DATA ITEMS pane, select the Reload 
Data button. 
• Transaction_Date 
• Amount_Normalized 

13. Select the down arrow for the Transaction_Date field in the DATA ITEMS 
pane. 

14. Select Exact Date. 
15. Right-click the Amount_Normalized column header.  
16. Select Add Total > Auto. 

 
  

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.14/story.html
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Part 2: Add a combo box filter 
1. Select Filter Elements > Combo Box.  
2. Click and drag the Firm_Name field to the Dimension field in the DATA ITEMS 

pane.  
3. Select the drop-down arrow on the search field in the Combo Box filter. The list 

of firm names display. 
4. Select Nautical Supply, Inc. The grid displays a filtered list. 
5. Select the Clear Master Filter (Funnel with red x) icon. 
6. Click and drag the Firm_Code field to the Dimension field in the DATA ITEMS 

pane.  
7. Select the drop-down arrow on the search field in the Combo Box filter. The list 

of firm names and codes display. 
8. Select Filter Element Tools > Design.  
9. Select the Edit Names button. The Edit Names window opens. 
10. Type Combo Box – Firm Name and Code in the Dashboard item name field.  
11. Select the OK button.  
12. Select the Design tab > Checked button.  
13. Select the drop-down arrow on the search field in the Combo Box filter. The list 

of firm names and codes display with check boxes. 
14. Select the check boxes for the following firms: 

• Back Cove Trail Systems 
• Casco Bay Sailing Company 
• Nautical Supply, Inc 

12. Select the OK button. The grid list displays only projects for those three firms. 
13. Select the Clear Master Filter (Funnel with red x) icon. 
14. Select the Design tab > Enable Search button. A second text search field 

displays when the primary field is selected. 
15. Type Nautical in the text search field. The drop-down list filters for that firm. 
16. Select the Nautical Supply, Inc check box. The grid displays only projects for 

that firm. 
17. Select the OK button.  
18. Select the Clear Master Filter icon. 
19. Select the Standard button.  
20. Select to deactivate the Allow Empty Filter button. The grid updates to display 

the first filter on the list. 
21. Select the Allow Empty Filter button. 

 
Part 3: Add a list box filter 

1. Select the Home tab.  
2. Select Filter Elements > List Box.  
3. Click and drag the list box under the combo box. 
4. Click and drag the Project_PM_Name field to the Dimension field in the DATA 

ITEMS pane. 



 
Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 

 
158 

5. Click and drag the Project_PM_Code field to the Dimension field in the DATA 
ITEMS pane. 

6. Select Filter Element Tools > Design.  
7. Select the Edit Names button. The Edit Names window opens. 
8. Type List Box – PM Name and Code in the Dashboard item name field.  
9. Select the OK button.  
10. Select the Radio button. This allows you select one item at a time on the list.  
11. Select the Fletcher, Erwin P. radio button. The grid updates. 
12. Select Hernandez, George J. radio button. The grid updates. 
13. Select the Clear Master Filter icon. 
14. Select the Enable Search button. A second text search field displays.  
15. Type erwin in the text search field. The drop-down list is filtered for that PM. 
16. Select the Fletcher, Erwin radio button.  
17. Select the X to clear the text search field.  
18. Select the Clear Master Filter icon. 

 
Part 4: Add a tree view filter 

1. Select the Home button.  
2. Select Filter Elements > Tree View. 
3. Click and drag the tree view under the list box. 
4. Click and drag the Project_Charge_Type field to the Dimension field in the 

DATA ITEMS pane. 
5. Click and drag the Project_Path field to the Dimension field in the DATA ITEMS 

pane. 
6. Select Filter Element Tools > Design.  
7. Select the Edit Names button. The Edit Names window opens. 
8. Type Tree View – Project Charge Type and Path in the Dashboard item name 

field.  
9. Select the OK button.  
10. Select the arrow to expand the Billable list.  
11. Select the Billable check box. The grid updates. 
12. Select to clear the Billable check box.  
13. Select the Enable Search button. A text search field displays. 
14. Type 2013 in the text search field. The drop-down list is filtered for that firm. 
15. Select the 20130000-001 check box.  
16. Select the 20130000-004 check box. 
17. Select the Clear Master Filter icon. 
18. Select the X to clear the text search field.  

 
Note: If you prefer that the Tree View filter open with the tree fully expanded, select the 
Auto Expand button, then save and close the dashboard. The next time you open the 
dashboard, the Tree View will default to an expanded view. 
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Part 5: Add a date filter 
1. Select the Home button.  
2. Select Filter Elements > Date Filter.  
3. Click and drag the date filter under the Tree View box. 
4. Click and drag the Transaction_Date field to the Dimension field in the DATA 

ITEMS pane. 
5. Select the down arrow for the Transaction_Date field in the DATA ITEMS 

pane. 
6. Select Exact Date. 
7. Right-click the Date Filter.  
8. Select Edit Names.The Edit Names window opens. 
9. Type Date Filter – Transaction Date in the Dashboard item name field.  
10. Select the OK button.  
11. Select the Gear icon next to the Transaction_Date field in the DATA ITEMS 

pane. The Edit Periods window opens.  
12. Select Last Year.  
13. Select the arrow. The Date Filter updates with another button. 
14. Select Last 2 Years.  
15. Select the arrow. The Date Filter updates with another button. 
16. Select Last 5 Years.  
17. Select the arrow. The Date Filter updates with another button. 
18. Select the Close button.  
19. Select the Last Year button. The grid shows no date because there is none for 

the last year.  
20. Select the Last 2 Years button. The grid updates. 
21. Select the Last 5 Years button. The grid updates. 
22. Select the Set Filter button.  
23. Type 1/1/2021 in the first text field. 
24. Type 12/31/2021 in the second text field.  
25. Select the Apply button. The grid updates with data from 2021. 
26. Select Data Filter Tools > Design.  
27. Select Arrangement Mode > Vertical. The buttons are now stacked.  
28. Select the Clear Master Filter icon. 
29. Select Date Picker Location > Near. The date picker button is first in the list.  
30. Select Date Picker Location > Far. The date picker button is last in the list. 
31. Select Date Picker Location > Hidden. The date picker button is hidden. 
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Images 
The Dashboard Designer allows you to create two types of Image dashboard items. 

• The Image dashboard item allows you to add static images to a dashboard. 
 

 
 

• The Bound Image dashboard item can be bound to a set of images (for instance, 
stored in the database). You can use the Bound Image as a detail item along 
with the Master Filtering feature. 

 

 
 
To create the required Image dashboard item, use the Images button in the Home 
ribbon tab. 
 
Providing Images 
Providing Static Images 
To load an image to a dashboard item, use the Load Image and Import Image buttons 
in the ribbon, or commands in the context menu (Load Image... and Import Image..., 
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respectively). These commands open the Open dialog, which allows you to locate the 
desired image. 
The Load Image command saves the path to the image in the dashboard definition, 
while the Import Image command saves the image itself. 
 
Binding the Bound Image to Data 
The Bound Image dashboard item provides the Attribute data section containing the 
corresponding placeholder. 

 
 
Specify the binding mode for the Bound Image by clicking the Options button (the icon) 
next to the Attribute placeholder. This opens the following dialog. 
 

 
This dialog provides two options. 

• Binary Array - Use this mode if images are stored in the data source as byte 
arrays. 

• URI - Use this mode to locate images accessible by a predefined URI. In this 
case, the data source field should return strings that are parts of URIs to these 
images. 
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For instance, the URI pattern in the form below specifies the path to the folder 
containing the required images. 
 

 
Data source field values will be inserted to the position of the {0} placeholder. Thus, the 
Bound Image maps the current dimension value with the image placed at the specified 
URI. 
 
Note that the Bound Image can display only a single image simultaneously. If Master 
Filtering is not applied to the Bound Image, it selects the displayed image in the 
following ways. 

• In the Binary Array mode, the displayed image cannot be predicted precisely as a 
result of sorting limitations for the image/binary data types. Use the Master 
Filtering feature to display the specified image. 

• In the URI mode, the Bound Image displays an image corresponding a first 
attribute value taking into account the attribute's sort order. 

 
Image Settings 
You can customize the representation of Image and Bound Image dashboard items in 
different ways. 
 
Image Alignment 
To specify how the image is aligned within the dashboard item, use the Alignment 
group in the Design ribbon tab. 
 
Image Size Mode 
You can specify the image size mode that defines how the image fits within the 
dashboard item. 
To do this, use the Size Mode group in the ribbon's Design tab. 
The following table illustrates each size mode in two cases: when the image is smaller 
than the dashboard item, and vice versa. 
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Size 
Mode  

Images Smaller 
than 
Dashboard Item 

Images Larger 
than Dashboard 
Item 

Description 

Clip 
  

The image is clipped if it is larger 
than the Image dashboard item. 

Stretch 
  

The image is stretched or shrunk 
to fit the size of the Image 
dashboard item. 

Squeeze 
  

If the dimensions of the Image 
dashboard item exceed those of 
the image it contains, the 
image is shown in full-size. 
Otherwise, the image is resized to 
fit the dimensions of the 
Image dashboard item. 
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Zoom 

The image is sized proportionally 
(without clipping), so that it best fits 
the Image dashboard item. If the 
aspect ratio of the Image 
dashboard item is the same as the 
aspect ratio of the image, it will be 
resized to fit into the Image 
dashboard item while maintaining 
its aspect ratio. Otherwise, the 
image will be resized in the closest 
fitting dimension (either the height 
or the width), and the remaining 
dimension will be resized while 
maintaining the image's aspect 
ratio. 

Activity 2.15 – Images 
In this activity, you will add images to AE. 

Note: For this activity, you will need an image available to upload. You may 
download one here. 

Activity Steps 

Part 1: Upload an image 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Images button.
6. Select Image. The Image item displays on the Dashboard.
7. Select the Design tab.
8. Select Load Image.
9. Double-click Unanet Logo.
10. Select the Stretch button.
11. Select the Squeeze button.
12. Select the Align Top Left icon in the Alignment section.

Part 2: Import an image 
1. Select the Home tab.
2. Select the Images button. The Image item displays on the Dashboard.
3. Select Image.
4. Right-click anywhere in the Image 2 item.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.15/story.html
https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Unanet Logo.png
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5. Select Import Image.
6. Double-click Unanet Logo.
7. Select the Design tab.
8. Select the Zoom button.
9. Select the Align Bottom Left icon in the Alignment section.

Text Box 
Use the Text Box dashboard item to display rich text within a dashboard. 

You can either add a static text or you can use the Text Box as a detail item along with 
the Master Filtering or Filtering features. 

Activity 2.16 – Text Box 
In this activity, you will use a text box to display static and dynamic text. 

Activity Steps 

Part 1: Add a text box and static text 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Text Box button.
6. Right-click the text box.
7. Select Show Caption to clear the caption.
8. Right-click the text box.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.16/story.html
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9. Select Edit. The Text Box is now editable.
10. Type PROJECT FACTS: in the text box.
11. Select the Home tab in the Text Box Editor.
12. Highlight PROJECT FACTS: in the text box.
13. Select the following to modify the style:

• Bold
• Underline
• Font size 12

14. Select Page Layout > Page Color.
15. Select light blue (second row, fourth color block).

Part 2: Add additional text for filtering 
1. Type the following text in the text box under the Project Facts (first line).

• Project Name
• Project Code
• Project Org:
• Charge Type:

• PM:

• PTD Effort:
• PTD Cost:
• PTD Billed:

2. Highlight all the text added in step 1.
3. Select the Home tab in the Text Box Editor.
4. Select font size 10.
5. Place the cursor after the Project Name text.
6. Select Text Box Tools > Design.
7. Select the Insert Field button.
8. Repeat steps 5 and 7 for the remaining lines.

• Project Code:
• Project Org:
• Charge Type:

• PM:

• PTD Effort:
• PTD Cost:
• PTD Billed:

Part 3: Add a list box 
1. Select the Home tab.
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2. Select Filter Elements > List Box.
3. Click and drag the list box item to the left side of the dashboard.
4. Select Filter Element Tools > Design.
5. Select the Radio button.
6. Click and drag the Project_Long_Name field to the Dimension field in the

DATA ITEMS pane. Note: If you see a red exclamation point in the upper left
corner of a dashboard item after adding fields to the DATA ITEMS pane, select
the Reload Data button.

Part 4: Add values to the text box 
1. Right-click the text box.
2. Select Edit. The text box is now editable..
3. Click and drag the following fields to the Value field in the DATA ITEMS pane.

• Project_Long_Name
• Project_Path
• Project_Org_Name
• Project_Charge_Type
• Project_PM_Name
• PTD_Effort
• PTD_Cost
• PTD_Billed

4. Select Select Value in the Text Box for the Project Name line. A list of available
fields display.

5. Select Project_Long_Name.
6. Use the table below to add additional values to the text box.

Line Value 

Project Code Project_Path 

Project Org Project_Org_Name 

Charge Type Project_Charge_Type 

PM Project_PM_Name 

PTD Effort PTD_Effort 

PTD Cost PTD_Cost 

PTD Billed PTD_Billed 

7. Select the down arrow for the Project_Long_Name field in the DATA ITEMS
pane.

8. Select Max.
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9. Repeat steps 7-8 for the following values in the DATA ITEMS pane.
• Project_Long_Name
• Project_Path
• Project_Org_Name
• Project_Charge_Type
• Project_PM_Name

10. Select the Edit button.
11. Select the Baseball Stadium radio button. The data in the text box updates.
12. Select the Business Development radio button. The data in the text box

updates.

Group 
Dashboard Designer provides the capability to combine dashboard items into a group. 
The dashboard item group serves two main purposes: 

• Combine dashboard items within the dashboard into a separate layout group.
• Manage interaction between dashboard items within and outside the group

(For instance, you can combine related filter elements and data visualization
dashboard items into a group.)

Create a Group 
To create a new group, use the Group button in the Home ribbon tab. You can add 
dashboard items to a group and manage item layout using drag-and-drop.  

Note that a dashboard item group cannot be added inside of another group. 

Activity 2.17 – Group 
In this activity, you will group dashboard items. 

Activity Steps 

Part 1: Add a grid  
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Parameters icon on the upper-right corner of the Dashboard. The

Dashboard Parameters window opens.
6. Type 2020-01 in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Grid button. The Grid item displays on the Dashboard.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.17/story.html
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9. Click and drag the Project_Path_Long_Name field to the New Column field in
the DATA ITEMS panel. Note: If you see a red exclamation point in the upper
left corner of a dashboard item after adding fields to the DATA ITEMS pane,
select the Reload Data button.

Part 2: Create a second grid and add filters 
1. Right-click the grid.
2. Select Duplicate.
3. Right-click the second grid.
4. Select Edit Names. The Edit Names window opens.
5. Type Grid 2 in the Dashboard item name field.
6. Select the OK button.
7. Select Filter Elements > Tree View.
8. Click and drag the Project_Charge_Type field to the Dimension field in the

DATA ITEMS panel. Note: If you see a red exclamation point in the upper left
corner of a dashboard item after adding fields to the DATA ITEMS pane, select
the Reload Data button.

9. Select Filter Elements > Tree View.
10. Click and drag the Firm_Name field to the Dimension field in the DATA ITEMS

panel.
11. Select the Billable check box in Tree View 1. Both grids display filtered data.
12. Clear the Billable check box in Tree View 1.
13. Select the City of Portland check box in Tree View 2. Both grids display filtered

data.
14. Clear the City of Portland check box in Tree View 2.

Part 3: Create two groups 
1. Select the Group button.
2. Click and drag the Tree View 1 filter into Group 1.
3. Click and drag the Grid 1 into Group 1 below Tree View 1.
4. Select the Billable check box in Tree View 1. Only Grid 1 displays filtered data.
5. Clear the Billable check box in Tree View 1.
6. Select the Group button.
7. Click and drag the Tree View 2 filter into Group 2.
8. Click and drag the Grid 2 into Group 2 below Tree View 2.
9. Click and drag Group 2 to the right side of the dashboard.
10. Select the Dominion Power check box in Tree View 2. Only Grid 2 displays

filtered data.
11. Clear the Dominion Power check box in Tree View 2.
12. Select Group 1.
13. Select Group Tools > Design.
15. Select the Edit Names button. The Edit Names window opens.
16. Type Group A in the Dashboard item name field.
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14. Select the OK button.
15. Select Group 2.
16. Select Group Tools > Design.
17. Select the Edit Names button. The Edit Names window opens.
18. Type Group B in the Dashboard item name field.
17. Select the OK button.

Treemap 
Use the Treemap dashboard item to visualize data in nested rectangles that are called 
tiles. 

The Dashboard Designer allows you to bind various dashboard items to data in a 
virtually uniform manner. The only difference is in the data sections that the required 
dashboard item has. 
The Treemap dashboard item has the Values and Arguments data sections that 
provide numeric and discrete categorical data, respectively. The steps below provide 
the most common scenarios of binding a Treemap to data. 
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1. Drop the Sales and Profit fields to the Values section.

The Treemap will draw two tiles whose sizes correspond to the Sales and Profit 
summary values. 

2. Drop the Product Category field to Arguments.

Treemap will create individual tiles for all categories. You can switch between 
Sales and Profit values by clicking the icon in the item's caption or you can use 
its context menu. 
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3. Drop the child Product Sub-Category field into Arguments.

The Treemap will visualize all combinations of categories and corresponding 
sub-categories using individual tiles. 

4. If the Arguments section contains several dimensions, you can group child tiles
by values of the parent dimension. To group sub-categories inside corresponding
categories, click the CategoryName menu button and select Group Tiles.

Sub-category tiles will be grouped into category groups. 
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Layout 
This topic describes how to change a layout algorithm used to arrange Treemap tiles. 
To do this in the Designer, use buttons from the Layout group placed in the Design 
ribbon tab.  
The following algorithms are available. 

Algorithm Example Description 

Slice and 
Dice 

This layout algorithm divides the 
space between items, slicing it in 
the specified direction depending 
on item value. 

Squarified 
The Squarified algorithm arranges 
tiles so that their width/height ratio 
will be closer to 1. 
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Striped 

This algorithm is a modified version 
of the Squarified algorithm. The 
difference here is that tiles are 
drawn side by side as columns or 
rows. 

You can also set a layout direction to specify an arrangement of tiles depending on their 
sizes. To do this, click the Layout Direction button and select the required direction. 

• Bottom Left - Top Right - Arrange tiles from the bottom-left to the top-right
corner.

• Bottom Right - Top Left - Arrange tiles from the bottom-right to the top-left
corner.

• Top Left - Bottom Right - Arrange tiles from the top-left to the bottom-right
corner.

• Top Right - Bottom Left - Arrange tiles from the top-right to the bottom-left
corner.

Grouping 
If you use several arguments in the Treemap, you can group tiles corresponding to child 
values by parent values. For instance, the following Treemap dashboard item displays 
combinations of categories and sub-categories. 

To group sub-categories inside corresponding categories, click the Product Category 
menu button and select Group Tiles. 
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Product tiles will be grouped into category groups. 

Note that the icon will be displayed within the Product Category dimension. 

Coloring 
In Default color mode, the Treemap dashboard item colors its tiles in the following ways: 

• If the Treemap dashboard item contains only measures (the Values section),
values corresponding to different measures are colored by hue.

• If the Treemap dashboard item contains arguments (the Arguments section),
values corresponding to the first argument are colored by hue.
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Labels 
The Treemap displays labels that contain descriptions for tiles and groups and provide 
tooltips with additional information. 

You can specify which information should be displayed within tile and group labels 
separately. To do this, use the Labels and Tooltips buttons in the Design ribbon tab. 

Use buttons within the Tile Labels/Group Labels ribbon groups to manage tile and 
group labels, respectively. These buttons open the drop-down menu, which is similar for 
all buttons. 

Activity 2.18 – Treemap 
In this activity, you will use the Treemap dashboard item to visualize data in 
nested rectangles called tiles.  

Activity Steps 

Part 1: Add a treemap item 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.18/story.html
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5. Select the Parameters icon on the upper-right corner of the Dashboard. The
Dashboard Parameters window opens.

6. Type 2021-01 in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Treemap button. The Treemap item displays on the Dashboard.
9. Click and drag the Expected_Revenue field to the Value field in the DATA

ITEMS pane. Note: If you see a red exclamation point in the upper left corner of
a dashboard item after adding fields to the DATA ITEMS pane, select the
Reload Data button.

10. Click and drag the Project_Charge_Type field to the Argument field in the
DATA ITEMS pane.

Part 2: Modify the treemap 
1. Select Treemap Tools > Design.
2. Select the Edit Names button. The Edit Names window opens.
3. Type Treemap Expected Revenue in the Dashboard item name field.
4. Select the OK button.
5. Select Design > Labels > Argument and Value.
6. Click and drag the Project_Long_Name field to the Argument field in the DATA

ITEMS pane.
7. Select the down arrow for the Project_Charge_Type field.
8. Select Group Tiles.
9. Click and drag the PTD_Effort field to the Value field in the DATA ITEMS pane.
10. Select the Values icon in the upper right corner of the Dashboard.
11. Select PTD_Effort. The Dashboard now displays the data for PTD_Effort instead

of Expected_Revenue.
12. Select the Values icon in the upper right corner of the Dashboard.
13. Select Expected_Revenue.
14. Select the Striped button.

Tab Container 
The Tab container dashboard item allows you to split the dashboard layout into several 
pages. Common filter controls for large elements in a dashboard can be located on a 
separate tab page. 
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To create a tab container, use the Tab Container button in the Home ribbon tab. 
A newly created tab container contains an empty tab page (Page 1). 

Click the + (plus) icon to add an empty page to the tab container. You can use drag-
and-drop to add dashboard items to a tab page and manage the layout. Tab containers 
cannot be nested, so you cannot add a tab container to another tab container. 
However, a tab container can contain item groups. 
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Tab Order 
To change the tab page order, click the Reorder Tabs button on the Tab settings 
group. The Tabs Order dialog opens. 

Click up and down arrows to change the order of the tab pages in the tab container. 

Defer Web Tab Load 
Defers loading each tab until accessed, when possible, on the published Web 
Dashboard. 
In order for tabs to actually perform deferred loading, the pages cannot be master filters, 
the pages cannot contain widgets that act as master filters, and you cannot use the 
Display Item as Page option. 

Display Item as Page 
The tab caption is above the caption of the content element on the page. If a tab page 
contains a single element, the Display Item as Page feature is activated. It merges the 
dashboard item with a tab page and displays a single caption, as illustrated below. 
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To disable the Display Item as Page feature, use one of the following methods: 
• Select the tab page and click the Display Item as Page button in the Layout

group on the Design ribbon tab of the Page Tools contextual tab set.
• Select the Display Item as Page command in the tab page context menu.

Selection 
Click the element's border or use the item's context menu to select a page or a tab 
container. 

Activity 2.19 – Tab Container 
In this activity, you will work with a tab container. 

Activity Steps 

Part 1: Set up a dashboard  
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Parameters icon on the upper-right corner of the Dashboard. The

Dashboard Parameters window opens.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.19/story.html


Lesson 2: Dashboard Design ©2024 Unanet. All rights reserved. 181 

6. Type 2021-01 in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Grid button three times to add three grids to the dashboard.
9. Select Grid 1.
10. Click and drag the Project_Charge_Type field to the New Column field in the

DATA ITEMS pane. Note: If you see a red exclamation point in the upper left
corner of a dashboard item after adding fields to the DATA ITEMS pane, select
the Reload Data button.

11. Click and drag the PTD_Billed field to the New Column field in the DATA
ITEMS pane.

12. Select Grid 2.
13. Click and drag the Project_Charge_Type field to the New Column field in the

DATA ITEMS pane.
14. Click and drag the PTD_Profit field to the New Column field in the DATA ITEMS

pane.
15. Select Grid 3.
16. Click and drag the Project_Charge_Type field to the New Column field in the

DATA ITEMS pane.
17. Click and drag the Budget_Amount field to the New Column field in the DATA

ITEMS pane.

Part 2: Add and edit a tab container item 
1. Select the Tab Container button.
2. Click the drag Grid 1 on top of Page 1.
3. Click the drag Grid 2 on top of Page 1, below Grid 1.
4. Select the plus icon for Page 1 (upper right corner of the title bar). Page 2

displays.
5. Click the drag Grid 3 on top of Page 2. Note: By default, if there is only one item

on a page, the page name will default to the item name.
6. Select Page Tools > Design.
7. Click to clear the Display Item as Page button.
8. Select Page 1.
9. Select the Edit Names button. The Edit Names window opens.
10. Type Page #1 in the Dashboard Name field.
11. Select the OK button.
12. Select Page 2.
13. Select the Edit Names button. The Edit Names window opens.
14. Type Page #2 in the Dashboard Name field.
15. Select Tab Container Tools > Design.
16. Select the Reorder Tabs button. The Tabs Order window opens.
17. Select Page 2 from the list.
18. Select the up arrow.
19. Select the OK button. Page 2 is now in front of page 1.
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Interactivity 

This section describes features that enable interaction between various dashboard 
items. These features include Master Filtering and Drill-Down. 

Master Filtering 
The Dashboard allows you to use any data aware dashboard item as a filter for other 
dashboard items (Master Filter). You can select elements in a Master Filter item (grid 
records, chart bars, pie segments, etc.) to filter data in other dashboard items by the 
selected values. 

Master Filtering Overview 
Dashboard items can be divided into four groups by their master filtering capabilities. 

1. Data visualization dashboard items allow you to enable master filtering by
specifying the selection mode. The following dashboard items allow you to
manage their master filtering mode.
• Chart
• Scatter Chart
• Grid
• Pies
• Cards
• Gauges
• Choropleth Map
• Geo Point Maps
• Treemap
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2. Filter elements represent a special type of dashboard item whose main purpose
is to apply filtering to other dashboard items. This capability is always enabled for
these dashboard items.
The following filter elements are available.
• Combo Box
• List Box
• Tree View

Instead of switching between standard master filtering modes, some filter
elements allow you to switch their type. This allows you to select a single
value or multiple values.

3. Range Filter is a special type of dashboard item that displays a chart with
selection thumbs and allows you to filter out values displayed along the argument
axis.

4. Dashboard item group allows you to manage interaction between dashboard
items in and out of the group.

Master Filter Settings 

Master Filtering Modes 
The Master Filter item supports two selection modes. 

• Multiple - Allows you to select multiple elements in the Master Filter item.
• Single - Allows you to select only one element in the Master Filter item. When

this mode is enabled, the default selection will be set to a Master Filter element.
You can change this selection, but cannot clear it.

To enable/disable master filtering, use the Multiple Master Filter or Single Master 
Filter buttons in the Data ribbon tab. 

Note: If the selected dashboard item contains several types of elements that can be 
used for filtering, the Ribbon or Toolbar will provide the appropriate buttons to switch 
between these types (e.g., the Arguments and Series buttons in the Chart). 

Filtering Across Data Sources 
When different items in a dashboard are bound to different data sources, you can 
specify that a particular Master Filter should be applied across data sources. This 
means that it will apply filtering to fields with matching names in all data sources. 

Fields are matched by their full names. For fields in other data sources to be affected by 
Master Filtering, their names must match the name of the field in the current data 
source, and they must belong to the same hierarchy level so that their full names also 
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match. For instance, Customer.City and Customer.Address.City will not be treated as 
matching fields. 

To enable filtering across data sources, use the Cross-Data-Source Filtering button in 
the Data ribbon tab. 

Preventing Items from Being Filtered 
You can prevent specific dashboard items from being affected by Master Filters. To do 
this, use the Ignore Master Filters button in the Data ribbon tab. 

Drill-Down 
Dashboard provides the Drill-Down feature, which allows you to change the detail level 
of data displayed in a dashboard item. 
The Drill-Down feature enables users to drill down to display detail data, or drill up to 
view more general information. 

Enable Drill-Down 
Drill-down requires that the data section contains several dimensions... 

To enable drill-down, click the Drill-Down button in the Data ribbon tab (or the button if 
you are using the toolbar menu). 
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Note: If the selected dashboard item contains several types of elements that can be 
used for filtering, the Ribbon or Toolbar will provide the appropriate buttons to switch 
between these types (e.g., the Arguments and Series buttons in the Chart). 

The following dashboard items support the Drill-Down feature. 
• Chart
• Scatter Chart
• Grid
• Pies
• Cards
• Gauges
• Treemap
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Activity 2.20 – Interactivity 
In this activity, you will work with dashboard interactivity. 

Activity Steps 

Part 1: Set up a dashboard 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Parameters icon on the upper-right corner of the Dashboard. The

Dashboard Parameters window opens.
6. Type 2021-01 in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Grid button.
9. Click and drag the Firm_Name field to the New Column field in the DATA

ITEMS pane. Note: If you see a red exclamation point in the upper left corner of
a dashboard item after adding fields to the DATA ITEMS pane, select the
Reload Data button.

10. Click and drag the Expected_Revenue field to the New Column field in the
DATA ITEMS pane.

11. Right-click the Expected_Revenue header.
12. Select Add Total > Auto.
13. Right-click the grid.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.20/story.html
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14. Select Duplicate.
15. Repeat steps 13-14 to add two more grids, for a total of four grids.
16. Right-click the grid in the upper right corner.
17. Select Edit Names. The Edit Names window opens.
18. Type Grid 2 in the Dashboard item name field.
19. Select the OK button.
20. Repeat steps16-19 to rename the remaining grids:

• Lower left corner: Grid 3
• Lower right corner: Grid 4

21. Select Grid 2.
22. Click and drag the Project_Charge_Type field to the Firm_Name field in the

DATA ITEMS pane (replacing Firm_Name).
23. Select Grid 3.
24. Click and drag the Project_Org_Name field to the Firm_Name field in the DATA

ITEMS pane (replacing Firm_Name).
25. Select Grid 4.
26. Click and drag the Project_Long_Name field to the Firm_Name field in the

DATA ITEMS pane (replacing Firm_Name).

Part 2: Set master filters 
1. Select Grid 1.
2. Select Grid Tools > Data.
3. Select the Single Master Filter button. Grids 2-4 update to reflect the line

selected Grid 1.
4. Select ABC Realtors. Grids 2-4 update. Note: This feature does not allow for a

null value. One item is always selected.
5. Select the Multiple Master Filter button.  Grids 2-4 do not automatically update

to reflect the first firm in grid 1.
6. Select City of Portland. Grids 2-4 update.
7. Press and hold the ctrl key.
8. Select Anderson Survey. Grids 2-4 update with data from both firms.
9. Select the Clear Master Filter (Funnel with red x) icon in Grid 1.
10. Select Grid 2.
11. Select the Multiple Master Filter button.
12. Select Billable.
13. Press and hold the ctrl key.
14. Select Back Cove Trail Systems in Grid 1. Grids 3-4 update with billable data

from that firm.
15. Select the Clear Master Filter (Funnel with red x) icon in Grid 1.
16. Select the Clear Master Filter (Funnel with red x) icon in Grid 2.
17. Select to clear the Multiple Master Filter button for Grid 2.
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Part 3: Ignore master filters 
1. Verify that Grid 2 is still selected. 
2. Select the Ignore Master Filters button.   
3. Select Back Cove Trail Systems in Grid 1. Grids 3-4 update. Grid 2 does not 

change based on the selections made in Grid 1. 
4. Select Grid 2.  
5. Select to clear the Ignore Master Filters button.   
6. Select Grid 1. 
7. Select the Clear Master Filter (Funnel with red x) icon. 
8. Select to clear the Multiple Master Filter button. 
  

Part 4: Drill down in data items 
1. Select Grid 4.  
2. Press Delete.  
3. Select Grid 1.  
4. Click and drag the Project_Long_Name field between the existing Firm_Name 

and Expected_Revenue columns in the DATA ITEMS pane. 
Project_Long_Name displays in Grid 1.  

5. Select the Drill Down button. Project_Long_Name is no longer visible. 
6. Select Back Cove Trail Systems. Now Project_Long_Name displays in the 

grid. 
7. Select the Drill up icon (curved arrow). 
8. Select Grid 2.  
9. Click and drag the Project_Long_Name field between the existing 

Project_Charge_Type and Expected_Revenue columns in the DATA ITEMS 
pane. 

10. Select Grid 3.  
11. Click and drag the Project_Long_Name field between the existing 

Project_Org_Name and Expected_Revenue columns in the DATA ITEMS 
pane. 

12. Right-click Grid 2.  
13. Select Convert to > Cards. 
14. Select the Drill Down button. The cards are grouped by the first level, which is 

Project_Charge_Type for this example. 
15. Select Billable. The projects list displays.  
16. Select the Drill up icon (curved arrow). 
17. Right-click Grid 3.  
18. Select Convert to > Chart. 
19. Select the Drill Down button. 
20. Select the Engineering column. The projects display. 
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Format Rules 
Once data is added to an item on the dashboard, it can be formatted in a variety of 
ways to help visualize otherwise static data points. For instance, you can highlight cells 
that meet certain defined criteria. 
Formatting can be added, edited and cleared/deleted by clicking Edit Rules from the 
toolbar or by hovering over the data item and clicking the data item menu dropdown. 

Format Rules include: 
• Value - Add a formatting rule based on an evaluation of static value (>, <, <=, >=,

etc.).
• Top/Bottom - Add formatting based on the evaluation of the topmost or

bottommost value.
• Average - Add formatting rule based on an evaluation of average (>, <, <=, >=,

etc.).
• Expression - Build an expression to apply formatting (advanced).
• Icon Ranges - Apply icons to items based on an evaluation of a range.
• Color Ranges - Apply colors to items based on an evaluation of a range.
• Gradient - Apply a color gradient to items based on an evaluation of a range.
• Bar - Displays a visual representation of a value using a bar. Bars can be colored

based on positive or negative values.
• Bar Color Ranges - Displays a visual representation of a value using a bar. Bars

are colored with the color set based on an evaluation of range.
• Bar Gradient Ranges - Displays a visual representation of a value using a bar.

Bars are colored with the gradient color set based on an evaluation of range.

Activity 2.21 – Format Rules 
In this activity, you will apply conditional formatting. 

Activity Steps 

Part 1: Set up a dashboard 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Parameters icon on the upper-right corner of the Dashboard. The

Dashboard Parameters window opens.
6. Type 2023-12 in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Grid button.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.21/story.html
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9. Click and drag the following fields to the New Column field in the DATA ITEMS
pane. Note: If you see a red exclamation point in the upper left corner of a
dashboard item after adding fields to the DATA ITEMS pane, select the Reload
Data button.
• Firm_Name
• PTD_Billed
• PTD_Cost
• PTD_Overhead_Cost
• PTD_Profit

Part 2: Create and apply formatting rules 
1. Select Grid 1.
2. Select the Edit Rules button. The Edit Rules window opens.
3. Select PTD_Profit in the calculated by field.
4. Select Add > Value > Less Than. The Less Than window opens.
5. Type 0 in the Format PTD_Profit values that are less than field.
6. Select the Red with white text color block.
7. Select the Apply button. The highlights display in the PTD_Profit column.
8. Select the Apply to row check box.
9. Select the Apply button. The highlights display for the entire row across the

columns.
10. Select to clear the Apply to row check box.
11. Select the Apply button.
12. Select the OK button.
13.
14. Select PTD_Overhead_Cost in the calculated by field.
15. Select Add > Top/Bottom > Top N. The Top N window opens.
16. Select 1 in the N = field.
17. Select the light blue color block.
18. Select the Apply button. The highest value is highlighted in blue.
19. Select 2 in the N = field.
20. Select the Apply button. The top two highest values are highlighted in blue.
21. Select the OK button.
22. Select PTD_Cost in the calculated by field.
23. Select Add > Bar. The Bar window opens.
24. Select the Apply button. Bars display in the PTD_Cost column.
25. Select the OK button.
26. Select PTD_Billed in the calculated by field.
27. Select Add > Gradient Ranges > 2 Color Gradient Range > Blue - Red (third

block, third row). The Gradient Ranges window opens.
28. Select the Apply button. Gradient colors display in the PTD_Billed column.
29. Select the OK button.
30. Select Firm_Name in the calculated by field.
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31. Select Add > Expression. The Expression window opens.
32. Hover the cursor in the space next to the And icon in the upper left corner.

Additional icons display.
33. Select the plus icon. Note: Leave the defaults Firm Name and Begins with.
34. Select Enter a Value.
35. Type C in the text field. Note: The autofill feature may override your input and fill

in a complete name. Delete the additional characters if necessary before
pressing Enter.

36. Select the Green with white text color block.
37. Select the Apply button. The firm names are highlighted.
38. Select the OK button.
39. Select the Close button.

Dashboard layout 

Dashboard Title 
The Dashboard Title is located at the top of the dashboard surface. It can contain text or 
image content. 

If you are using the Ribbon menu in the Dashboard Designer, you can change title 
settings by clicking the Title button. 
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This opens the Dashboard Title dialog, which allows you to change the text within the 
dashboard title, add an image, etc. 

This dialog allows you to specify the following options. 
• Visible - Specifies whether or not the dashboard title is visible.
• Show Master Filter state - Specifies whether or not to show the state of master

filter items in the dashboard title.
When you hover over the filter icon ( ), all master filters applied to the dashboard
are displayed in the open popup.

• Alignment - Specifies the alignment of the dashboard title.
• Load button - Allows you to specify the image displayed within the dashboard

title. In this case, the dashboard definition will contain the URL to access the
image.

• Import button - Allows you to specify the image displayed within the dashboard
title. In this case, the dashboard definition will contain an image as a byte array.

The dashboard title can contain command buttons. 
Export To button - allows you to print/export the dashboard.  
Parameters button - allows you to modify dashboard parameter values. 
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Dashboard Item Caption 
Each dashboard item has a caption that is displayed at the top of the item. The caption 
contains static text along with other information, as well as command buttons. 

To show or hide the caption of a dashboard item, click the Show Caption button in the 
Design Ribbon tab or right-click the item when designing the dashboard, and click the 
Show Caption menu item. 

Note: The caption of the Range Filter dashboard item is not visible by default. 

The caption of the Dashboard item contains the following information and buttons, 
depending on the dashboard item type: 

• Dashboard Item Name - represents the static text within a dashboard item's
caption.

• Data Item Container Name - represents the name of the data item container.

You can change the default name of the dashboard item or data item container
using the Edit Names dialog. To open this dialog, right-click the item when
designing the dashboard, and click the Edit Names... menu item. Alternatively,
you can use the Edit Names button in the Design Ribbon tab.
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• Drill-Down value - shows the value or values from the current drill-down
hierarchy.

• Export to button - allows you to print or export a dashboard item.
• Values button - opens a drop-down menu that allows you to switch between the

provided values (in the pie, card, gauge and map dashboard items).
• Clear Master Filter button - allows you to reset filtering when a dashboard item

acts as the Master Filter.
• Drill Up button - allows you to return to the previous detail level when the drill-

down capability is enabled for this item.
• Clear Selection button - allows you to clear the selection inside an item.
• Initial Extent button - restores the Map dashboard items' default size and

position.
• Select Date Time Periods button / menu - allows you to select date-time

periods for the Range Filter.
• Multiselection button (Web only)- allows you to filter data by selecting multiple

elements in dashboard items.
• Maximize button - expands any dashboard item into the whole dashboard size

to examine data in greater detail.
• Restore button - restores the expanded item to its initial state.
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Dashboard Items Layout 
The Dashboard Designer provides the capability to arrange and resize dashboard items 
and groups in various ways, using simple drag-and-drop operations. 

Layout Concepts 
The dashboard arranges dashboard items and groups using layout items and layout 
groups. They are special containers that are used to present a dashboard layout as a 
hierarchical structure. 

• A layout item is used as a container that displays an individual dashboard item.
• A layout group is used as a container that is used to arrange layout items (or

other layout groups) either horizontally or vertically. At the same time, layout
groups are used as containers that display dashboard item groups.

Thus, a dashboard layout is hierarchically arranged from the root layout group to 
bottommost layout items, which display individual dashboard items. 
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Item Resizing 
You can resize individual items/groups of items by dragging their edges. 

By default, a 2x2 layout group of dashboard items is horizontally oriented and contains 
two child layout groups. This arranges dashboard items in two columns  and allows you 
to set a different height for items in different columns. You can switch the orientation of 
the 2x2 group to Vertical using the indicator at the group intersection. 

This allows you to specify different widths for dashboard items in different rows. The 
table below lists and describes different modes. 

Indicator Result Description 

Orients the layout group 
horizontally and allows you to 
change the height of individual 
items and the width of columns. 

Orients the layout group vertically 
and allows you to change the width 
of individual items and the height of 
rows. 
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Maximize and Restore Item 
You can expand any dashboard item into the whole dashboard size to examine data in 
greater detail. The expanded dashboard item size in this case is the same as the root 
layout group. 

• To maximize a dashboard item, click the Maximize button in the dashboard item
caption.

• To restore the item size, click Restore.
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Item Positioning 
You can change the position of a dashboard item by using drag-and-drop and one of 
the following approaches. 

• If the caption of the dashboard item is visible, click it and hold down the left
mouse button while dragging the item.

• If the caption of the dashboard item is not visible, click the icon in the top left
corner, and hold down the left mouse button while dragging the item.

Depending on the required dashboard item position, a new layout group is created (if 
required) to maintain the arrangement of items. Thus, the dashboard item can be 
inserted to the desired area of a new or existing dashboard layout group. 
The following table illustrates how a dashboard item is dragged. 

Result Description 

Select the required dashboard item. 

Drag the dashboard item to the 
expected area. The drag indicator will 
show possible positions for the 
dashboard item. 

Move the mouse cursor to the required 
position. The drop indicator highlights 
the hovered position. 
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Then, the drop indicator sequentially 
displays areas that can be occupied by 
the dashboard item. Release the left 
mouse button when the drop indicator 
displays the required area. 

The dashboard item is moved to a new 
position. 

Activity 2.22 – Design a Dashboard 
In this activity, you will build a simple dashboard with multiple items. 

Activity Steps 

Part 1: Add a grid 
1. Select Utilities > Analytic Dashboard Designer.
2. Select the New button. An Add Model? message displays.
3. Select the Yes button. The Analytic Models window opens.
4. Double-click the Project Figures CVS model.
5. Select the Parameters icon on the upper-right corner of the Dashboard. The

Dashboard Parameters window opens.
6. Verify that 2021-11 displays in the Value field for the Current_Period_Code line.
7. Select the Submit button.
8. Select the Grid button. The grid displays on the Dashboard.
9. Click and drag the following fields to the New Column field in the DATA ITEMS

pane. Note: If you see a red exclamation point in the upper left corner of a
dashboard item after adding fields to the DATA ITEMS pane, select the Reload
Data button.
• Firm_Name
• PTD_Earned
• PTD_Profit

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_2.22/story.html
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Part 2: Add a calculated field 
1. Right-click anywhere in the field list.
2. Select Add Calculated field. The Expression Editor opens.
3. Type the following in the editor text field.

Sum([Contract])-sum([PTD_Earned]) 

4. Select the OK button.
5. Expand Calculated Fields in the Data Source pane.
6. Right-click Calculated Field 1.
7. Select Rename from the list.
8. Type Backlog in the field.
10. Click and drag the Backlog field to the 2nd position in the Columns list between

Firm_Name and PTD_Earned.

Part 3: Format the Grid 
1. Right-click anywhere on the Grid.
2. Select Edit Names. The Edit Names window opens.
3. Type Key Financial Metrics in the Dashboard item name field.
4. Edit the Column Names:

• Firm_Name - Client
• Backlog (do not change)
• PTD_Earned – PTD Revenue
• PTD_Profit – PTD Profit

5. Select the OK button.
6. Select the Backlog down-arrow.
7. Select Format.
8. Select Number in the Format Type field.
9. Select Ones in the Unit field.
10. Select 0 in the Precision field.
11. Select the Include group separator check box.
12. Select the OK button.
13. Repeat steps 6-12 for the PTD_Earned and the PTD_Profit columns.
14. Right-click the Backlog column header.
15. Select Add Total > Auto.
16. Repeat steps 14-15 for the PTD Revenue and the PTD Profit columns.
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Part 4: Add a chart 
1. Select the Chart button. The chart displays on the Dashboard.
2. Click and drag the following fields to the Value field in the DATA ITEMS pane.

Note: If you see a red exclamation point in the upper left corner of a dashboard
item after adding fields to the DATA ITEMS pane, select the Reload Data button.
• PTD_Billed
• PTD_Unbilled_Revenue

3. Click and drag the following fields to the Argument field in the DATA ITEMS
pane.
• Firm_Name
• Project_Long_Name

4. Select Chart Tools > Data.
5. Select the Drill Down button.
6. Select Design > Y-Axis Settings. The Y-Axis Settings window opens.
7. Select to clear the Show Title check box.
8. Select the OK button.
9. Select the Series icon next to the PTD_Billed field. The Series Options window

opens.
10. Select the middle bar icon.
11. Select the OK button.
12. Right-click anywhere on the Chart.
13. Select Edit Names. The Edit Names window opens.
14. Type Billed vs Unbilled Revenues in the Dashboard item name field.
15. Edit the Column Names:

• PTD_Billed – PTD Billed
• PTD_Unbilled_Revenue - PTD Unbilled

16. Select the OK button.

Part 5: Add a pie chart 
1. Select the Home tab.
2. Select the Pies button. The pie chart displays on the Dashboard.
3. Click and drag the PTD_Work_Hours field to the Values field in the DATA

ITEMS pane.
4. Click and drag the Project_Long_Name field to the Arguments field in the

DATA ITEMS pane.
5. Select Pie Tools > Design.
6. Select the Data_Labels button.
7. Select None.
8. Select to deactivate the Show Pie Captions button.
9. Right-click anywhere on the Pies item.
10. Select Edit Names. The Edit Names window opens.
11. Type PTD Hours Worked By Project in the Dashboard item name field.
12. Type PTD Work Hours in the Values field.
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13. Select the OK button.
14. Select the Donut button.

Part 6: Add a treemap item 
1. Select the Home tab.
2. Select the Treemap button. The Treemap item displays on the Dashboard.
3. Click and drag the Expected_Revenue field to the Value field in the DATA

ITEMS pane.
4. Click and drag the Project_Location_City field to the Argument field in the

DATA ITEMS pane.
5. Right-click anywhere on the Treemap item.
6. Select Edit Names. The Edit Names window opens.
7. Type Expected Revenue by Project City in the Dashboard item name field.
8. Type Expected Revenue in the Values field.
9. Select the OK button.

Part 7: Set master filters 
1. Select the Grid item.
2. Select Grid Tools > Data.
3. Select the Multiple Master Filter button.
4. Select City of Portland. The other items update.
5. Select the Clear Master Filter (Funnel with red x) icon.

Part 8: Add Filter Elements 
1. Select the Home tab.
2. Select Filter Elements > List Box.
3. Click and drag the List Box to the left of the dashboard.
4. Click and drag the Project_Charge_Type field to the Dimension field in the

DATA ITEMS pane.
5. Right-click the List Box 1 item.
6. Select Edit Names. The Edit Names window opens.
7. Type Charge Type in the Dashboard item name field.
8. Select the OK button.
9. Select the Design tab.
10. Select the Radio button.
11. Click to deactivate the Allow Empty Filter button.
12. Select the Home tab.
13. Select Filter Elements > Tree View.
14. Click and drag the Tree view to the bottom left of the dashboard, under the List

View.
6. Click and drag the following fields to the Dimension field in the DATA ITEMS

pane.
• Project_PM_Proper_Name
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• Project_Long_Name
15. Select the arrow to expand Erwin P Fletcher.
16. Select the arrow to collapse Erwin P Fletcher.
17. Right-click the Tree View 1 item.
18. Select Edit Names. The Edit Names window opens.
19. Type PM Name & Projects in the Dashboard item name field.
20. Select the OK button.

Part 9: Save the dashboard 
1. Select the Save button. The Save Dashboard window opens.
2. Type Sample in the Grouping field.
3. Type Key Project Data in the Dashboard Name field.
4. Select the Save button.

Note: To open a saved dashboard, select the Open button, and select the file. 
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Check Your Understanding 

What are the key aspects of a dashboard designer's role? 

a) To create visually appealing and informative data visualizations.
b) To design an intuitive user interface and navigation flow.
c) To structure and organize the content and data within the

dashboard.
d) To determine the layout and composition of the dashboard.
e) All of the above.

Which of these is not a best practice for dashboard designers? 

a) Understanding the audience and their data needs.
b) Keeping the design simple and intuitive.
c) Highlighting key information using colors and visual cues.
d) Choosing complicated visualizations to impress the audience.

How do you add totals to a column on a grid?  

a) Right-click the column header and select Add Total.
b) Select the down arrow next to the field name in the Data Items

column.
c) Select the Add Total button on the Grid Tools Data ribbon.
d) Select the Add Total button on the Grid Tools Design ribbon.

What is the purpose of the Ignore Master Filters button?  

a) It disables all master filters in a dashboard
b) It enables all master filters in a dashboard
c) It allows you to selectively ignore master filters for specific items
d) It allows you to apply master filters to specific items only
e) It allows you to clear all master filters in a dashboard.

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 3: DASHBOARD ADMINISTRATION 

Learning Objectives 

Review dashboard administration. 
• Describe Dashboard Administrator responsibilities.
• List the applets necessary to work with Analytic Dashboards
• Summarize how to grant permissions to Analytic Dashboards
• Explore employee-related dashboard permissions.

Overview 
The role of an analytic dashboard administrator is to oversee the management, 
configuration, and maintenance of the analytic dashboard system within an 
organization. 

Dashboard Administrator’s Responsibilities 
Dashboard administrators are responsible for ensuring the smooth operation and 
optimal performance of the dashboard, as well as handling administrative tasks related 
to user access, security, and data integrity. Here are the key aspects of their role: 

• System Configuration and Setup: The dashboard administrator is responsible for
the initial configuration and setup of the analytic dashboard system. This includes
connecting to data sources and defining access permissions.

• User Access and Security Management: The dashboard administrator manages
user access to the analytic dashboard system. They assign permissions and
ensure that appropriate security measures are in place to protect sensitive data.

• Performance Optimization: The dashboard administrator monitors and optimizes
the performance of the dashboard, ensuring that it can handle the volume of data
and users accessing it. They may analyze performance metrics, identify
bottlenecks, and implement optimization strategies to improve speed, reliability,
and scalability.

• Backup and Recovery: The dashboard administrator ensures that data is backed
up regularly and can be recovered in the event of a system failure or disaster.
They may implement data backup and recovery processes, conduct disaster
recovery testing, and develop contingency plans to minimize downtime and data
loss.

• Governance and Data Management: The dashboard administrator is responsible
for ensuring the accuracy and integrity of the data within the dashboard. They
may work with data analysts and other stakeholders to establish data
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governance policies, data quality standards, and data management practices that 
ensure the data is reliable and up-to-date. 

• User Support and Training: The dashboard administrator provides user support
and training to ensure that users can effectively use the dashboard and access
the data they need. They may provide technical support, troubleshoot issues,
and respond to user feedback and inquiries. They may also develop training
materials, conduct training sessions, and provide ongoing support to ensure that
users are confident and proficient in using the dashboard.

In summary, the role of an analytic dashboard administrator involves overseeing the 
management, configuration, and maintenance of the analytic dashboard system. They 
handle user access, security, data integration, performance monitoring, troubleshooting, 
and support to ensure the effective and secure operation of the dashboard system. 

Dashboard Designer & Administrator Permissions 
Unanet AE relies on permissions to grant access to the Analytic Dashboards feature 
set. You will need permission to the following applets that are involved with Analytic 
Dashboards: 

• Analytic Dashboard Designer
• Analytic Dashboards
• Dashboard Groups
• Dashboard Groups > Special Rights > Can Save Default Layout
• Dashboard Queries Manager
• Marketplace Purchases

Activity 3.1 – Grant Permissions 
In this activity, you will grant permissions to Analytic Dashboard applets. 

Activity Steps 

1. Navigate to Administration > Permissions. The Permissions applet opens.
2. Select the Groups tab.
3. Type Dashboard Administrator in the Enter New Line field.
4. Select the Save button.
5. Select the lock icon for the Dashboard Administrator group. The Permissions

for Dashboard Administrator window opens.
6. Select the Group Permissions tab.
7. Select the +/- icon to collapse the tree.
8. Select the + icon for the Utilities module.
9. Select the View, Edit, Add, and Delete check boxes for the following Applets:

• Analytic Dashboard Designer
• Analytic Dashboards

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_3.1/story.html
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• Dashboard Groups
• Dashboard Queries Manager
• Marketplace Purchases
• Query Builder

Note: Selecting the Add checkbox automatically selects the View and Edit 
checkboxes. 

10. Select the + icon for the Dashboard Groups applet. The Special Rights options
display for Dashboard Groups.

11. Select the Allowed check box for Can Save Default Layout.
12. Select the Save button.

Analytic Models
Analytic Models (or queries) provide the data for designing Analytic Dashboards. 
While we have given you the tools to build your own, Unanet AE offers several 
optimized models available through the Marketplace. Whether downloaded or custom 
built, Analytic Models are used when designing dashboard views and can be managed 
in the Dashboard Queries Manager applet. 

Activity 3.2 – Assign Analytic Model Permissions 
In this activity, you will assign analytic model permissions. 

Activity Steps 

1. Navigate to Utilities > Dashboard Queries Manager.
2. Select Analytic Models in the dropdown list.
3. Double-click Project Figures CVS in the list.
4. Select the Model Permissions tab.
5. Select the demo check box in the Users list.
6. Select the Dashboard Administrator check box in the Groups list.
7. Select the Save button.

Analytic Dashboards 
Once an Analytic Dashboard view is created, you can manage who has access to work 
with the design. Often, this may simply be you - the creator of the dashboard view. 
However, some enterprise environments may have a team of designers managing 
various dashboard views. 

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_3.2/story.html
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In addition to designer permissions, Analytic Dashboards allow you to edit, copy, delete, 
import, and export your dashboard. Other management options include 
activate/deactivate, grouping, titles, etc.  

Activity 3.3 – Grant Designer Permissions 
In this activity, you will grant designer permissions to the analytic dashboard 
you created in Activity 2.22.  

Activity Steps 

1. Navigate to Utilities > Analytic Dashboards. The Analytic Dashboards applet
opens.

2. Double-click Key Project Data in the list.
3. Select the Dashboard Administrator check box in the Groups list on the

Designer Permissions tab.
4. Select the Save button.

Dashboard Permissions (Dashboard Groups applet) 
Dashboards are distributed to Employees using Dashboard Groups. 

Configured in Utilities > Dashboard Groups, each group defines the Widgets and 
Dashboards (Classic and Analytic) available to the employees assigned to the group. 
Dashboards created here are available to each employee assigned to the Dashboard 
Group via the Dashboards menu option within the Dashboard applet. 

Key Concepts 

• Employees are assigned to a Dashboard Group within their Employee Record,
which thereby governs what they can view and customize on their personal
Dashboards.

• Once the Dashboard Group has been given access to a specific set of Widgets,
the group can be configured with predefined Dashboards (Classic and Analytic).
These Dashboards are made available to users who are a part of the group.
When such a user logs in they will see the default Dashboard defined by the
Dashboard Group.

• When a user is viewing Widgets that are part of the default Dashboard for a
group, they cannot alter the specific settings of the Widget; they can only
organize them on the Dashboard and choose whether or not to show them upon
login. Alternatively, a user can customize/create other Dashboards by clicking
Configure > Dashboards from the toolbar on the Dashboard applet. This will
allow them to configure and personalize their own Dashboards - using only the
Widgets that are allowed to them by their respective Dashboard Group.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_3.3/story.html
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Note:  If there are queries or alerts that reveal sensitive information, make sure they are 
not allowed, except to specific Dashboard Groups. 

Activity 3.4 – Deploy Analytic Dashboards 
In this activity, you will deploy the analytic dashboard you created in Activity 
2.22 to Dashboard Groups.  

Activity Steps 

1. Navigate to Utilities > Dashboard Groups. The Dashboard Groups applet
opens.

2. Double-click Accounting in the Dashboard Groups list.
3. Select the Analytic Dashboards tab.
4. Select the Allowed check box for the Key Project Data Analytic Dashboard.
5. Select the Save button.
6. Select the Configure Dashboards button on the toolbar. The Group

Dashboard Layout window opens.
7. Select Analytics from the blank drop-down list.
8. Select the Show check box for the Key Project Data Analytic Dashboard.
9. Select the Default Load check box for the Key Project Data Analytic

Dashboard.
10. Select the Save and Close button.

https://unanetuniversitycontent.unanet.com/uu_content/AE_UsingAnalyticDashboardDesigner/Activity_3.4/story.html
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Check Your Understanding 

How can employees be assigned to Dashboard Groups? 

a) Granting permissions to applets
b) Navigating to Utilities > Dashboard Groups
c) Configuring the Group Dashboard Layout
d) Selecting a Dashboard Group in the Employee applet
e) Defining access permissions

What can employees do with Widgets on their personal Dashboard? Select all 
that apply.  

a) Alter specific settings of the Widget
b) Organize the widgets on the Dashboard
c) Grant access to Dashboard Groups
d) Define access permissions
e) Choose whether or not to show the widgets upon login

Refer to Appendix A for answers to the Check Your Understanding questions. 
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APPENDIX A: Check Your Understanding Answer Key 

Lesson 1: Introduction to Analytic Dashboards 

What is the main benefit of using dashboards in UnanetAE? 

a) To facilitate team meetings
b) To schedule project tasks
c) To visualize data (Correct)
d) To store company policies
e) To control inventory

What is the purpose of querying data in analytic dashboards in UnanetAE? 

a) To schedule tasks
b) To manage resources
c) To allocate budget
d) To retrieve and present information in a visual and interactive

format
e) To facilitate team communication



APPENDIX A: Check Your Understanding Answer Key ©2024 Unanet. All rights reserved. 212 

Lesson 2: Dashboard Design 

What are the key aspects of a dashboard designer's role? 

a) To create visually appealing and informative data visualizations.
b) To design an intuitive user interface and navigation flow.
c) To structure and organize the content and data within the

dashboard.
d) To determine the layout and composition of the dashboard.
e) All of the above.

Which of these is not a best practice for dashboard designers? 

a) Understanding the audience and their data needs.
b) Keeping the design simple and intuitive.
c) Highlighting key information using colors and visual cues.
d) Choosing complicated visualizations to impress the audience.

How do you add totals to a column on a grid? 

a) Right-click the column header and select Add Total.
b) Select the down arrow next to the field name in the Data Items

column.
c) Select the Add Total button on the Grid Tools Data ribbon.
d) Select the Add Total button on the Grid Tools Design ribbon.

What is the purpose of the Ignore Master Filters button? 

a) It disables all master filters in a dashboard
b) It enables all master filters in a dashboard
c) It allows you to selectively ignore master filters for specific items
d) It allows you to apply master filters to specific items only
e) It allows you to clear all master filters in a dashboard.
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Lesson 3: Dashboard Administration 

How can employees be assigned to Dashboard Groups? 

a) Granting permissions to applets
b) Navigating to Utilities > Dashboard Groups
c) Configuring the Group Dashboard Layout
d) Selecting a Dashboard Group in the Employee applet
e) Defining access permissions

What can employees do with Widgets on their personal Dashboard? Select all 
that apply.  

a) Alter specific settings of the Widget
b) Organize the widgets on the Dashboard
c) Grant access to Dashboard Groups
d) Define access permissions
e) Choose whether or not to show the widgets upon login
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COMPLETION CERTIFICATE AND EVALUATION 
When the course has finished, Unanet University staff will mark the attendance in the 
Learning Management System (LMS.) This marking is percentage based and may be 
prorated if a participant was absent for any period of time during the course. 

The LMS will generate a completion certificate (including CPE credits, where 
applicable) which will be available to the participant under their Transcript section of the 
LMS.  

We appreciate your feedback on our courses and encourage you to complete the 
course evaluation. 


	Table of Contents
	ABOUT THIS PARTICIPANT GUIDE
	Symbols used in this guide
	Unanet Contact Information
	Support Portal

	COURSE INTRODUCTION
	Learning Objectives

	Lesson 1: Introduction to Analytic Dashboards
	Learning Objectives
	Purpose
	Definition of a Dashboard
	Benefits of a Dashboard

	Why UAE Dashboards
	Dashboard Types
	Classic Dashboard
	Analytic Dashboard

	Overview of Analytic Dashboards
	Moving Parts
	Querying Data
	Dashboard Design

	Check Your Understanding

	Lesson 2: Dashboard Design
	Learning Objectives
	Overview - Dashboard designer role
	Dashboard Designer’s Responsibilities
	Best Practices for Dashboard Designers

	UAE Analytic Dashboard Designer
	Designer Toolbar
	Field Descriptions - Dashboard Designer
	Data Browser/Pane
	Data Source Browser
	Dashboard Surface
	Field Descriptions

	Tour 2.1 – Review the Analytic Dashboard Designer Applet

	Working with the Data
	Formatting Data
	Activity 2.2 – Formatting Data
	Activity Steps

	Calculated Fields
	Expression Editor
	Activity 2.3 – Calculated Fields
	Activity Steps


	Dashboard Items
	Overview
	Bind Dashboard Items to Data
	Hidden Data Items

	Grid
	Column Type Overview
	Sorting Data within the Grid
	Filtering Data within the Grid
	Grid Tools and Design

	Activity 2.4 – Grid
	Activity Steps

	Pivot
	Working with Pivot Data
	Transposing Columns and Rows
	Conditional Formatting
	Pivot Tools and Design
	Common Group
	Initial State
	Layout Group


	Activity 2.5 – Pivot Table
	Activity Steps

	Chart
	Transposing Arguments and Series
	Series Overview
	Bar Series
	Point and Line Series
	Area Series
	Range Series
	Weighted Series
	Financial Series

	Panes
	Coloring
	Legend
	Axis
	X-Axis
	Y-Axis

	Orientation
	Conditional Formatting

	Activity 2.6 – Chart
	Activity Steps

	Scatter Chart
	Transposing X- and Y-axis
	Renaming Items
	Coloring
	Legend
	Axes
	Orientation
	Labels

	Activity 2.7 – Scatter Chart
	Activity Steps

	Pies
	Coloring
	Layout
	Labels
	Style

	Activity 2.8 – Pies
	Activity Steps

	Gauges
	Delta
	Delta Values
	Delta Indication

	Gauge Scale
	Layout
	Style

	Activity 2.9 – Gauges
	Activity Steps

	Cards
	Layout
	Delta
	Cards Arrangement

	Activity 2.10 – Cards
	Activity Steps

	Choropleth Maps
	Providing Maps
	Providing Data
	Map Coloring
	Delta
	Map Navigation
	Labels
	Legend

	Tour 2.11 – Choropleth Maps
	Geo Point Maps
	Providing Maps
	Default Maps
	Custom Maps

	Geo Point Map
	Bubble Map
	Coloring
	Legends

	Pie Map
	Pie Options
	Coloring
	Legends

	Clustering
	Labels
	Shape Titles
	Tooltips

	Map Navigation

	Tour 2.12 – Geo Point Maps
	Range Filter
	Series
	Coloring

	Activity 2.13 – Range Filter
	Activity Steps

	Filter Elements
	Combo Box
	List Box
	Tree View
	Date Filter
	Providing Data
	Binding Overview


	Activity 2.14 – Filter Elements
	Activity Steps

	Images
	Providing Images
	Providing Static Images
	Binding the Bound Image to Data

	Image Settings
	Image Alignment
	Image Size Mode


	Activity 2.15 – Images
	Activity Steps

	Text Box
	Activity 2.16 – Text Box
	Activity Steps

	Group
	Create a Group

	Activity 2.17 – Group
	Activity Steps

	Treemap
	Layout
	Grouping
	Coloring
	Labels

	Activity 2.18 – Treemap
	Activity Steps

	Tab Container
	Tab Order
	Defer Web Tab Load
	Display Item as Page
	Selection

	Activity 2.19 – Tab Container
	Activity Steps


	Interactivity
	Master Filtering
	Master Filtering Overview
	Master Filter Settings

	Drill-Down
	Enable Drill-Down

	Activity 2.20 – Interactivity
	Activity Steps


	Format Rules
	Activity 2.21 – Format Rules
	Activity Steps


	Dashboard layout
	Dashboard Title
	Dashboard Item Caption
	Dashboard Items Layout
	Activity 2.22 – Design a Dashboard
	Activity Steps


	Check Your Understanding

	Lesson 3: Dashboard Administration
	Learning Objectives
	Overview
	Dashboard Administrator’s Responsibilities

	Dashboard Designer & Administrator Permissions
	Activity 3.1 – Grant Permissions
	Activity Steps

	Activity 3.2 – Assign Analytic Model Permissions
	Activity Steps


	Analytic Dashboards
	Activity 3.3 – Grant Designer Permissions
	Activity Steps


	Dashboard Permissions (Dashboard Groups applet)
	Key Concepts
	Activity 3.4 – Deploy Analytic Dashboards
	Activity Steps


	Check Your Understanding

	APPENDIX A: Check Your Understanding Answer Key
	Lesson 1: Introduction to Analytic Dashboards
	Lesson 2: Dashboard Design
	Lesson 3: Dashboard Administration

	COMPLETION CERTIFICATE AND EVALUATION



