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ABOUT THIS PARTICIPANT GUIDE 
 

This document serves as a supplement to the training courses offered through Unanet 

University. Participants should use this workbook to complete exercises in the student 

Unanet system while attending the course. Additionally, participants should record notes 

and actions for reference when working within their own Unanet system.  

Symbols used in this guide 
 

   
 

   
 

 

Unanet Contact Information 
• VirtualUU@unanet.com  

 
Send questions here for information about courses, course schedule, enrollments, 

certifications, and unanetuniversity.com. This mailbox is monitored daily. 

Support Portal  
To improve your experience in accessing our support resources, all Knowledge Center 

articles, and FAQs have been relocated to the Unanet Support Portal, located 

at support.unanet.com. You will need a Support ID to access the portal, which you can 

acquire using the steps below: 

To obtain a login to the Unanet support portal or to create a new ticket, send an 
email to support@unanet.com with "Support Portal ID request" in the Subject line. 

The following conditions must be met to be granted a support account: 
• The "from" address must match the domain of your company. 
• It must NOT be a generic email account (e.g., it cannot be from 

gmail.com, aol.com, or msn.com). 
 
The company must have an active support agreement with Unanet. 

Activity 

Demo 

Tour 

Important Note 

Question 

mailto:VirtualUU@unanet.com
https://support.unanet.com/support/home
mailto:support@unanet.com?subject=Support%20Portal%20ID%20request&body=Please%20activate%20a%20support%20ID%20for%20my%20email.
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COURSE INTRODUCTION 
 

In this course, you will review options for developing project management reports using 

Analytics. You will use the periodic JSR data object to create tabular, graphical, and 

pivoted data outputs, use conditional formatting and basic functions in Analytics Studio, 

and review the parameters involved. Upon completion of this course, you will have 

created an Analytics version of the periodic line and bar chart that can be exported and 

uploaded into your own Unanet instance. 

Learning Objectives  
 

After this session of Unanet GovCon: Using Analytics Studio for Project 

Management Reporting, participants will be able to: 

 

• Provide an overview of the report types available via Analytics Studio.  

• Explain how to create a CrossTab Report. 

• Explain how to create an Advanced Report. 
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Student Training Site  
 

A Unanet training system has been specifically created to support this course. The 

system is configured around a fictional GovCon company named MyCo. The activities, 

and accompanying simulations, reference MyCo, its related internal and external 

organizations, and business processes. 

 

Roles & Access 
 

Unanet is a role-based system which provides security and access based on the roles 

assigned to the user by the System Administrator. It is helpful to be familiar with 

Unanet’s roles and the access that comes with each unique role. Users may find the 

need to be assigned a combination of roles in order to perform various job functions. 

 

During this course, students will be instructed to log-in to Unanet utilizing specific user 

personas which contain the appropriate roles in order to access and complete the 

required activities. 

 

Please note, the password is case sensitive; username is not. 

 Unanet Role Name Username Password 

x x x admin welcome 
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LESSON 1: INTRODUCTION TO ANALYTICS 

Learning Objectives 
 

Provide an overview of the report types available via Analytics Studio. 

• Summarize the different report types available via Analytics Studio.  

• Explain how to create an ExpressView Report.  

• Explain how to create a Chained Report. 

Overview 
Analytics is a custom reporting capability that is embedded in the Unanet software. It is 

accessible by selecting the Analytics option on the Reports Dashboard. Analytics 

provides its users with an additional, embedded option for developing and viewing 

custom reports. All Unanet Cloud customers are provided with our Analytics Plus 

offering as part of regular license fees.  

Analytics Studio is an add-on capability, allowing those that require advanced analytics 

and custom reporting to further mine their data for real-time insight. Analytics Studio 

offers you a deeper level of analysis and drill-down capabilities so you can interact 

dynamically with your data. Feature-rich, expert-level dashboards, including C-Suite 

dashboards, are embedded in Analytics Studio, and you can further customize them for 

your unique business needs.  
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Report Types 
Analytics Studio allows you to build all available report types. The following table 

provides an overview of the reporting options.  

 

ExpressView 
ExpressView is a tool to quickly get insight into vertically expanding data records and 

groups. An ExpressView report can optionally include a visualization. 

Built with an intuitive drag-and-drop interface, ExpressView is intended to be a way to 

get started quickly viewing data. ExpressView reports can be converted to Advanced 

Reports to gain the additional capabilities of that format. 

ExpressView reports can be scheduled, added to Chained Reports and Dashboards, 

and exported to multiple formats. 
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Data Object Design 
ExpressView reports can be developed utilizing any of the data objects available in 

Analytics, with the exception of the Project Periodic JSR and Project Periodic 

Performance data sets. These objects require the use of Parameters, a feature specific 

to Analytics Studio reporting. 

 

Activity 1.1 – Create an ExpressView Report 
In this activity, you will create an ExpressView Report to show time entered by 

fiscal period.  

Note: To avoid errors with formulas, be sure to type the formulas rather than 

using copy and paste.  

 

Activity Steps 

 

Part 1: Create a New ExpressView  

1. Navigate to Reports > Analytics.  

2. Select the Create New Report + button.  

3. Select ExpressView. The welcome to the ExpressView Designer window 

opens.  

4. Select skip tutorial to go straight to the designer.  

5. Select the Disable Tutorial check box.  

6. Select the Skip Tutorial button. 

7. Select the Dismiss button.  

8. Select the right-facing arrow for People Labor and Expense to expand.  

9. Select the right-facing arrow for PPL: Labor and Expense Details.  

10. Drag the following fields to the Design pane:  

• Person First Name 

• Person Last Name 

• Fiscal Period 

• Quantity 

• Project Code  

11. Select the down-facing arrow for PPL: Label and Expense Details to collapse.  

12. Select the right-facing arrow for PRJ: Project List to view joint objects.  

13. Type payment terms in the Search field.  

14. Press Enter. All the objects that have payment terms display.  

15. Select the X button to clear the search.  

 

Part 2: Create a Formula Field 

1. Select the + Add Formula link.  

2. Type last in the Formula field.  
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3. Select PPL: Labor and Expense Details.Person Last Name.  

4. Type &”, “&First in the Formula field.  

5. Select PPL: Labor and Expense Details.Person First Name.  

6. Press Enter.  

7. Select the Apply changes checkmark button.  

8. Select the header for the last column.  

9. Select the pencil button in the header.  

10. Type Person Name in the header.  

11. Press Enter.  

 

Part 3: Apply a Filter 

1. Select the Radial circle for Fiscal Period. The Radial Menu opens. You can 

Group, Delete, Sort, or Filter the column.  

2. Select the Filter button.  

3. Select Equal To in the first dropdown menu in the Filters section. 

4. Select FY19-11 in the second dropdown menu.  

5. Select the Run button to view the data. 

6. Select the Stop button to return to Design view.  

7. Select the Filter button.  

8. Select Is Between in the first dropdown menu in the Filters section. 

9. Select FY19-01 in the second dropdown menu.  

10. Select FY19-07 in the third dropdown menu.  

11. Select the Run button to view the data. 

12. Select the Stop button to return to Design view.  

 

Part 4: Group by Fiscal Period 

1. Select the Radical circle for Fiscal Period. 

2. Select the Group button. The data is grouped by fiscal period.  

3. Select the Run button to view the data. 

4. Select the Stop button to return to Design view.  

5. Close the New ExpressView tab.  

6. Select the Don’t Save button.  

 

Chained Report 

Chained Reports combine multiple reports into a single, multi-page document. This can 

simplify running and distributing a group of related reports at once. They also support 

collating reports along a common sort field, to create a super-grouping of common 

report data. In addition, you can chain entirely disparate reports together without an 

issue. 

Chained Reports can be scheduled and exported to multiple formats.  
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Activity 1.2 – Create a Chained Report 
In this activity, you will create a Chained Report using existing reports.  

 

 

Activity Steps 

 

Part 1: Create a Chained Report 

1. Select the Create New Report + button.  

2. Select Chained Report. 

3. Type Sample Chained Report in the Enter the report name field.  

4. Select the My Reports folder. 

5. Select the Next button.  

6. Select the right-facing arrow for the Analytics Studio Reports folder. 

7. Select the right-facing arrow for the CXO Tiles folder.  

8. Drag the following reports to the Report Name pane: 

• CXO-Cash 

• CXO-Rev 

• CXO-NI 

9. Select the Next button.  

10. Select PDF from the Default Export Type dropdown list. 

11. Select the Save and Close button.  

 

Part 2: View the Chained Report 

1. Select the right-facing arrow for My Reports.  

2. Select the PDF button for Sample Chained Reports. The Parameters window 

opens. 

3. Use the information in the table to update the following parameters:  

Parameter Name Value 

Legal Entity MYCO 

Fiscal Year FY22 

Fiscal Month End Date 1/31/2022 

Budget Name Baseline 

4. Select the Okay button.  

5. Close the Sample Chained Report tab.  
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Check Your Understanding 
 

 

Which one of the following report options can you convert to an Advanced 

Report ?  

 

a) ExpressView Report 

b) CrossTab Report 

c) Chained Report 

 

 

Which one of the following report options would you use for combining 

multiple reports into a single document? 

 

a) ExpressView Report 

b) CrossTab Report 

c) Chained Report 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 2: CROSSTAB REPORTING 

Learning Objectives 
 

Explain how to create a CrossTab Report.  

• Recall how to create a CrossTab Report.  

 

Introduction 
A CrossTab, or cross tabulation, is a widget for grouping and summarizing data fields 

that automatically expands vertically and horizontally depending on the number of data 

groupings. CrossTabs are also known as two-way tables, contingency tables, and pivot 

tables.  

Periodic JSR CrossTab Report 

The following exercise will walk you through the process of creating a CrossTab report 

based on the Periodic JSR data object. This report is designed to display project metrics 

across a user-defined period-of-time. 
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Parameters 
The Periodic JSR data object requires the use of parameters. These parameters are 

similar to filters and allow the user to specify key criteria for a report. The parameters 

that can be utilized in in the Periodic JSR data object very closely match the filter 

options in Unanet’s standard Project Periodic Cost Summary & Status Report. They 

include the following options: 

• @JSRactualsThroughDate@ 

• @JSRadjustments@ 

• @JSRcostReport@ 

• @JSRincludeExpenseReports@ 

• @JSRincludeNonCompExpRpts@ 

• @JSRincludePendingAdjustments@ 

• @JSRindirectCostRate@ 

• @JSRnumPeriods@ 

• @JSRpostedDateOnly@ 

• @JSRreportingPeriod@ 

• @JSRreportingPeriodStartDate@ 

• @JSRrowOptionShowPlans@ 

• @JSRrowOptionShowBudgets@ 

• @JSRrowOptionShowActuals@ 

• @JSRrowOptionShowActualsBudgets@ 

• @JSRrowOptionShowActualsPlan@ 

• @JSRshowTasks@ 
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 An example of the Project Periodic Cost Summary & Status Criteria is shown below. 

 

 

After adding a parameter to a report, the user will be prompted to select a parameter 

option during the report’s execution. 
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Activity 2.1 – Create a JSR CrossTab Report 
In this activity, you will create a JSR CrossTab Report.  

 

 

Activity Steps 

 

Part 1: Name the Report 

1. Select the Create New Report + button.  

2. Select CrossTab Report. 

3. Type Crosstab – JSR in the Enter the report name field.  

4. Select the My Reports folder. 

5. Select the Next button.  

 

Part 2: Select Categories 

1. Select the right-facing arrow for Project Periodic JSR (Studio Report Only).  

2. Drag the following categories to the Category Name pane:   

• PRJ: Periodic JSR  

• PRJ: Project List 

3. Select the Next button.  

 

Part 3: Select Layout  

1. Select the Layout tab.  

2. Drag Period Begin Date to the Column Header Source pane.  

3. Drag the following sources to the Row Header Source pane:  

• Project Code 

• Cost Report Item Label 

• Row Metrics 

4. Drag the following sources to the Tabulation Data Source pane:   

• Current Period Hours or Amount 

• ITD Amount 

5. Select the Finish button.  

 

Part 4: Format the Report 

1. Select Report Options gear button > Options > Report Viewer. The Report 

View Options window opens.  

2. Deselect the Simulate PDF check box.  

3. Select the Okay button. 

4. Select the following cells:  

• PRJ: Periodic JSR.Current Period Hours or Amount 

• PRJ: Periodic JSR.ITD Amount 

5. Select the Format Cells button. The Format Cells window opens.  

6. Select Number from the Category list.  
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7. Select the Okay button.  

8. Select the following cells:  

• PRJ: Periodic JSR.Project Code 

• PRJ: Periodic JSR.Cost Report Item Label 

• PRJ: Periodic JSR.Row Metrics 

9. Select the Format Cells button. The Format Cells window opens. 

10. Select the Border tab.  

11. Select the Make Borders Uniform check box. 

12. Select the color picker box.  

13. Select the black option.  

14. Select the Okay button.  

 

Part 5: Add Parameters 

1. Select cell A2.  

2. Type @JSR in the fx field.  

3. Select the @JSRcostReport@ parameter from the list. 

4. Type & in the fx field after the @JSRcostReport@ parameter.  

5. Repeat steps 2-4 to add the following parameters:  

• @JSRnumPeriods@ 

• @JSRrowOptionsShowActuals@ 

• @JSRreportingPeriodStartDate@ 

• @JSRshowTasks@ 

• @JSRindirectCostRate@ 

6. Press Enter.  

7. Select cell B2.  

8. Type @project in the fx field.  

9. Select the @projectCode@ parameter from the list.  

10. Press Enter. 

 

Part 6: Run the Report 

1. Select the Run button. The Parameters window opens.  

2. Use the information in the table to update the following parameters:  

Parameter Name Value 

Reporting Period Start Date 01/01/2021 

Project Code 20.CONTENT-PRODUCTION 

3. Select the Okay button.  

4. Review the information in the report.  

5. Close the Crosstab – JSR report tab.  
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Part 7: Add a Column 

1. Select cell A6.  

2. Select the Menu button > Modify. The CrossTab Data Designer window opens.  

3. Select the Options button. The Options window opens.  

4. Select Right from the Placement dropdown list in the GRAND TOTAL COLUMN 

section.  

5. Select the Okay button.  

 

Part 8: Add Labels 

1. Select the Edit Tabulation pencil button for PRJ: Periodic JSR.Current Period 

Hours or Amount in the Tabulation Data Source pane. The Tabulation 

Options window opens.  

2. Type Current Period in the Label field. 

3. Select the Okay button.  

4. Select the Edit Tabulation pencil button for PRJ: Periodic JSR.ITD Amount in 

the Tabulation Data Source pane. The Tabulation Options window opens.  

5. Type ITD Amount in the Label field. 

6. Select the Okay button.  

7. Select the Okay button on the CrossTab Data Designer window.  

 

Part 9: Review Parameters  

1. Select Report Options gear button > Advanced > Parameters. The 

Parameters window opens.  

2. Review the Parameters information.  

3. Select the Cancel button.  

 

Part 10: Format the Report 

1. Select the following cells in column F:  

• PRJ: Periodic JSR.Current Period Hours or Amount 

• PRJ: Periodic JSR.ITD Amount 

1. Select the Bold button.  

2. Select Align Right from the Alignment dropdown list.  

3. Select the Format Cells button. The Format Cells window opens.  

4. Select the Border tab.  

5. Select the Make Borders Uniform check box. 

6. Select the color picker box.  

7. Select the black option.  

8. Select the Okay button.  

9. Select the following cells in columns D and E:  

• Current Period 

• ITD Amount 

• PRJ: Periodic JSR.Current Period Hours or Amount 

• PRJ: Periodic JSR.ITD Amount 
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10. Select the Format Cells button. The Format Cells window opens. 

11. Select the Border tab.  

12. Select the Make Borders Uniform check box. 

13. Select the color picker box.  

14. Select the black option.  

15. Select the Okay button.  

 

Part 11: Run the Report 

1. Select the Run button. The Parameters window opens.  

2. Use the information in the table to update the following parameters:  

Parameter Name Value 

Reporting Period Start Date 01/01/2021 

Project Code 20.CONTENT-PRODUCTION 

3. Select the Okay button.  

4. Review the information in the report.  

5. Close the Crosstab – JSR report tab.  

 

Part 12: Add Additional Column 

1. Select cell A6.  

2. Select the Menu button > Modify. The CrossTab Data Designer window opens.  

3. Select PRJ: Project List from the dropdown list.  

4. Drag Funded Value – Original to the Row Header Source pane.  

5. Select the up-facing arrow for the PRJ: Project List.Funded Value – Original 

to move it up under PRJ: Periodic JSR.Project Code.  

6. Select the Okay button.  

 

Part 13: Update Formatting 

1. Select cell C4. 

2. Select the Format Paintbrush button. 

3. Select cell D4.  

4. Select cell C5.  

5. Select the Format Paintbrush button.  

6. Select cell D5.  

7. Select cell F4.  

8. Select the Format Paintbrush button. 

9. Select cell G4. 

 

Part 14: Add Conditional Formatting 

1. Select cells F6 and G6. 

2. Select the Format Cells button. The Format Cells window opens.  

3. Select the Conditional tab.  

4. Select the + Add button.  
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5. Select Red for the Attribute.  

6. Select the fx button. The Formula Editor window opens.  

7. Select the + Cell Value button.  

8. Type >= in the Formula field after CellValue ( ). 

9. Select PRJ: Project List from the dropdown list.  

10. Drag Funded Value – Original to the Formula field.  

11. Select the Okay button.  

12. Select the Okay button on the Format Cells window.  

 

Part 15: Run the Report 

1. Select the Run button. The Parameters window opens.  

2. Use the information in the table to update the following parameters:  

Parameter Name Value 

Reporting Period Start Date 01/01/2021 

Project Code 20.CONTENT-PRODUCTION 

3. Select the Okay button.  

4. Review the information in the report.  

5. Close the Crosstab – JSR report tab.  

 

Part 16: Add a Parameter 

1. Select cell C2.  

2. Type @JSR in the Formula field.  

3. Select the @JSRrowOptionShowActualsBudgets@ parameter from the list. 

4. Type & in the Formula field after the @JSRrowOptionShowActualsBudgets@ 

parameter.  

5. Type @JSR in the Formula field.  

6. Select the @JSRactualsThroughDate@ parameter from the list.  

7. Press Enter. 

 

Part 17: Run the Report 

1. Select the Run button. The Parameters window opens.  

2. Use the information in the table to update the following parameters:  

Parameter Name Value 

Reporting Period Start Date 01/01/2021 

Project Code 20.CONTENT-PRODUCTION 

Actuals Through Date 10/31/2021 

3. Select the Okay button.  

4. Review the information in the report.  

5. Close the Crosstab – JSR report tab.  
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Part 18: Add Dynamic Filters 

1. Select Report Options gear button > Options > Report Viewer. The Report 

Viewer window opens.  

2. Select the Filters tab.  

3. Drag Period Begin Date to the Filter pane.  

4. Type Period Begin Date in the Title field.  

5. Select Range Slider from the Type dropdown list.  

6. Select the Initially Display Filter on Panel check box.  

7. Repeat steps 3-6 to add the Primary Project Lead – Username filter: 

Field Value 

Filter Primary Project Lead – Username 

Title Project Lead 

Type Multiple Choice 

Initially Display Filter on Panel Select 

8. Select PRJ: Project List from the dropdown list.  

9. Repeat steps 3-6 to add the Ultimate Customer/Agency filter: 

Field Value 

Filter Ultimate Customer/Agency 

Title Ultimate Customer/Agency 

Type Multiple Choice 

Initially Display Filter on Panel Select 

10. Select the General tab.  

11. Select Show from the Show Toolbar in Report Viewer dropdown list.  

12. Select the Okay button.  

 

Part 19: Run the Report 

1. Select the Run button. The Parameters window opens.  

2. Use the information in the table to update the following parameters:  

Parameter Name Value 

Reporting Period Start Date 01/01/2021 

Row Option – Show Actuals Combined with Budgets N 

Actuals Through Date 07/01/2021 

3. Select the Okay button.  

4. Select the HHS check box in the Ultimate Customer/Agency section to filter.  

5. Slide the Period End Date to 07/01/2021.  

6. Review the information in the report.  

7. Close the Crosstab – JSR report tab.  

8. Select the Save Report button. 

9. Close the Crosstab – JSR tab.  
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Check Your Understanding 
 

 

Determine if each statement is true or false.  

 

 

 True or False 

CrossTabs are also known as pivot tables.  

CrossTabs automatically expand vertically and horizontally 
depending on the number of data groupings. 

 

Parameters are only used when designing a report.   

The Periodic JSR data object does not require the use of 
parameters. 

 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 

 



©2022 Unanet. All rights reserved. 

 

 
LESSON 3: ADVANCED REPORTING 

23 

LESSON 3: ADVANCED REPORTING 

Learning Objectives 
 

Explain how to create an Advanced Report. 

• Explain how to create a tabular report using Advanced Reports.  

• Explain how to create a bar and line chart using Advanced Reports.  

• Summarize how to use the Dashboard to format Advanced Reports.  

 

Introduction 
The most powerful reporting tools are available with Advanced Reports, including 

geographic maps; CrossTabs; repeating groups; complex join, filter, and sort logic; 

drilldowns to linked child reports, and more. Advanced Reports are made using a 

spreadsheet-like cell-grid interface. The Advanced Report Designer allows users to 

build reports without requiring knowledge of SQL or the underlying data model. 

Advanced Reports can be executed to a browser-based Report Viewer interface, which 

allows for interactivity, additional changes to be made without re-running the report, and 

for saving user-specific customization. 

Advanced Reports can be scheduled, added to Chained Reports and Dashboards, 

embedded into web pages, used to populate document templates, and exported to 

multiple formats. 
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Tabular Reports 

ExpressView reports are the simplest option for creating tabular reporting solutions in 

Analytics. However, ExpressView reports cannot leverage the use of Parameters, a 

requirement for reports developed using the Periodic JSR data object, so Advanced 

Reports can be utilized to look at Periodic JSR data in a tabular view.  
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Sections 
An Advanced Report's sections define the appearance and pattern of the report. 

Specifically, sections determine how frequently their cell contents are repeated. 

The appearance of a report is based on data that is not necessarily known at the time it 

is made. The data, and the relationships it describes, are dynamic and mutable. So 

tabular reports are usually not fixed designs. Instead, you are describing how the report 

structures itself around a set of unpredictable data. Knowing which sections are suitable 

for different types of content is crucial for designing the best possible report. 

Section Description 

Page Header The rows in this section appear at the top of each page.  

Report Header The rows in this section appear at the beginning of the report.  

Detail The rows in this section appear once for each row of data 

returned during execution.  

Report Footer The rows in this section appear at the end of the report.  

Page Footer The rows in this section appear at the bottom of each page.  

Group Header The rows in this section appear at the start of each new value of 

a sorted data field.  

Note: Group header sections require that a sort exists.  

Group Footer The rows in this section appear at the end of each value of a 

sorted data field.  

Note: Group footer sections require that a sort exists.  

Repeating Group Use when you have multiple one-to-many relationships from one 

data category to other categories and you want each category’s 

data to appear separately.  
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Activity 3.1 – Create a Periodic JSR Data Report 
In this activity, you will create an Advanced Report for Periodic JSR Data. 

You will get hands-on experience using Advanced Report Sections to create 

custom report formats.  

 Note: To avoid errors with formulas, be sure to type the formulas rather than  

using copy and paste.  

 

Activity Steps 

 

Part 1: Name the Report 

1. Select the Create New Report + button.  

2. Select Advanced Report. 

3. Type Periodic JSR Data in the Enter the report name field. 

4. Select the My Reports folder. 

5. Select the Next button.  

 

Part 2: Select Categories 

1. Select the right-facing arrow for Project Periodic JSR (Studio Report Only).  

2. Drag PRJ: Periodic JSR to the Category Name pane.  

3. Select the Next button.  

4. Select the Finish button.  

 

Part 3: Add Parameters 

1. Select row 3.  

2. Select Insert Rows After from the dropdown list.  

3. Select cells A3, B3, C3, D3, and E3.  

4. Select the Merge Cells button.  

5. Select cell A3.  

6. Type =Concatenate(Bold(“Project Code: “),@projectCode@) in the fx field.  

7. Repeat steps 1-6 to add the formulas to the following cells: 

Cell Formula 

A4 =Concatenate(Bold(“Project Status: “),@projectStatus@) 

A5 =Concatenate(Bold(“Cost Report: “),@JSRcostReport@) 

A6 =Concatenate(Bold(“Indirect Cost Rate: “),@JSRindirectCostRate@) 

A7 =Concatenate(Bold(“Reporting Period: “),@JSRreportingPeriod@,”,”,Bold(“Starting Period: “), 
@JSRreportingPeriodStartDate@,”,”,Bold(“# of Periods: “),@JSRnumPeriods@) 

A8 =Concatenate(Bold(“Show Plans: “),@JSRrowOptionShowPlans@) 

A9 =Concatenate(Bold(“Show Budgets: “),@JSRrowOptionShowBudgets@) 

A10 =Concatenate(Bold(“Show Actuals: “),@JSRrowOptionShowActuals@) 

A11 =Concatenate(Bold(“Show Actuals & Plans: “),@JSRrowOptionShowActualsPlans@) 
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A12 =Concatenate(Bold(“Show Actuals &  Budgets: “),@JSRrowOptionShowActualsBudget@) 

A13 =Concatenate(Bold(“Actuals Through Date: “),@JSRactualsThroughDate@) 

A14 =Concatenate(Bold(“Posted Date Only: “),@JSRpostedDataOnly@) 

A15 =Concatenate(Bold(“Show Tasks: “),@JSRshowTasks@) 

A16 =Concatenate(Bold(“Adjustments: “),@JSRadjustments@,”,”,Bold(“Include Pending Adjustments: 
“),@JSRincludePendingAdjustments@) 

A17 =Concatenate(Bold(“Include Expense Reports: “),@JSRincludeExpenseReports@,”,”, 
Bold(“Include Non-Completed Expense Reports: “),@JSRincludeNonCompExpRpts@) 

  

Your report should look like this: 

 

Part 4: Basic Report Formatting 

1. Select column A.  

2. Select Insert Columns Before from the dropdown list.  

3. Repeat steps 1 and 2 to insert another column.  

4. Select column A. 

5. Select Set Column Width from the dropdown list. 

6. Type 10 in the Column Width (px) field. 

7. Select the Okay button.  

8. Repeat steps 4-7 to set the column with for column B. 

9. Select the Detail Section. 

10. Select Delete Section from the dropdown list. 

11. Select the Save Report button.  

 

Part 5: Create a Dashboard 

1. Select the Create New Report + button.  

2. Select Dashboard. 

3. Select New Tile on the Toolbar and drag to the Canvas.  

4. Use the handles to resize the tile to the size of the Canvas.  
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5. Select the Existing Report button.  

6. Drag Period JSR Data to the tile. 

7. Select Parameters on the Toolbar. 

8. Select the dropdown button for projectCode.  

9. Select *All from the Value dropdown list.  

10. Verify the Prompt for value check box is selected.  

11. Repeat steps 9-11 to add the values for the parameters: 

Parameter Value Prompt for value 

ProjectStatus 2-Open Select 

JSRcostReport PCD Deselect 

JSRindirectCostRate *Provisional Select 

JSRreportingPeriod Calendar Month Select 

JSRreportingPeriodStartDate 2021-10-01 Select 

JSRnumPeriods 12 Select 

JSRrowOptionShowPlans *Active Plan Sets Select 

JSRrowOptionShowBudgets N Deselect 

JSRrowOptionShowActuals *Y Select 

JSRrowOptionShowActualsPlans *No Plans Select 

JSRrowOptionShowActualBudgets N Select 

JSRactualsThroughDate 2022-01-15 Select 

JSRpostedDataOnly N Select 

JSRshowTasks Y Select 

JSRadjustments *Adjustments using Worked 
Date within range 

Select 

JSRincludePendingAdjustments *Y Select 

JSRincludeExpenseReports Using Line Item Data within 
range 

Select 

JSRincludeNonCompExpRpts *Y Select 

12. Select the Save and Close button.  

13. Select Save on the Toolbar. The Save Dashboard window opens.  

14. Type Periodic JSR Dashboard in the Name field.  

15. Select the My Reports folder.  

16. Select the Save button.  

17. Close the Periodic JSR Dashboard tab.  

 

Part 6: Add a Sort 

1. Select Report Options gear button > Sorts. The Report Sorts window opens.  

2. Drag Project Code to the Sort By pane.  

3. Select the Okay button. 
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Part 7: Add a Group Header 

1. Select Section > Add Section > Group Header. The Group Header window 

opens.  

2. Select PRJ:Periodic JSR.Project Code from the Show this group for each 

change of the following dropdown list.  

3. Select the Okay button.  

4. Right-click cell C19. Note: This cell is in the Header: PRJ: Periodic JSR.Project 

Code row.  

5. Select Insert > Formula from the list. The Formula Editor window opens.  

6. Drag Project Code to the Formula box.  

7. Select the Okay button.  

8. Select the Save Report button.  

 

Part 8: Run the Dashboard 

1. Select the Run Report button for the Periodic JSR Dashboard in the My 

Reports section. The Parameters window opens.  

2. Select the Okay button.  

3. Select the Parameters button on the left side of the Dashboard. The 

Parameters pane opens. You can change any of the parameters on the report.  

4. Type 1 in the JSRnumPeriods field.  

5. Press Enter. The Dashboard refreshes based on the updated parameters.  

 

Part 9: Add Formulas 

1. Select the Periodic JSR Data tab.  

2. Right-click cell D19. 

3. Select Insert > Formula from the list. The Formula Editor window opens. 

4. Drag Project Revised Begin Date to the Formula field.  

5. Select the Okay button.  

6. Right-click cell E19. 

7. Select Insert > Formula from the list. The Formula Editor window opens. 

8. Drag Project Revised End Date to the Formula field.  

9. Select the Okay button.  

10. Select the Save Report button.  

 

Part 10: Refresh the Dashboard 

1. Select the Periodic JSR Dashboard tab. 

2. Select the Refresh button on the left side of the Dashboard.  

 

Part 11: Add a Sort 

1. Select the Periodic JSR Data tab.  

2. Select Report Options gear button > Sorts. The Report Sorts window opens.  

3. Drag Task Number to the Sort By pane.  

4. Select the Okay button. 
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Part 12: Add a Group Header 

1. Select Header: PRJ:Periodic JSR.Project Code > Add Section > Group 

Header. The Group Header window opens.  

2. Select PRJ:Periodic JSR.Task Number from the dropdown list.  

3. Select the Okay button.  

4. Select cell C20.  

5. Select the Align button > Right Align.  

6. Right-click cell C20. 

7. Select Insert > Formula from the list. The Formula Editor window opens. 

8. Type {PRJ: Periodic JSR.Task Number}&” – “&{PRJ: Periodic JSR.Task Name} 

the Formula field.  

9. Select the Okay button.  

10. Select the Save Report button.  

11. Select cells C20 and D20.  

12. Select the Merge Cells button.  

 

Part 13: Add a Category 

1. Select Report Options gear button > Categories. The Report Categories 

window opens.  

2. Select the right-facing arrow for Project Periodic JSR (Studio Report Only). 

3. Drag PRJ: JSR Task List to the Category Name pane. 

4. Select the Okay button. 

5. Right-click cell F20. 

6. Select Insert > Formula from the list. The Formula Editor window opens. 

7. Type AggSum(If({PRJ: Periodic JSR.Cost Report Item Label}="Revenue", {PRJ: 

Periodic JSR.Current Period Hours or Amount}, 0)) in the Formula field. 

8. Select the Okay button.  

9. Select the Save Report button. 

 

Part 14: Add a Section 

1. Select Header PRJ:Periodic JSR.Task Number > Add Section > Group 

Footer. The Group Footers window opens.  

2. Select PRJ:Periodic JSR.Project Code from the dropdown list.  

3. Select the Okay button.  

4. Select cells C21, D21, and E21. 

5. Select the Merge Cells button. 

6. Right-click cell C21. 

7. Select Insert > Formula from the list. The Formula Editor window opens. 

8. Type “Totals for project: “&{PRJ: Periodic JSR.Project Code} in the Formula 

field.  

9. Select the Okay button.  

10. Select the Bold button.  

11. Select the Save Report button.  
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Part 15: Refresh the Dashboard 

1. Select the Periodic JSR Dashboard tab.  

2. Select the Refresh button.  

 

Part 16: Add a Row 

1. Select the Periodic JSR Data tab.  

2. Select row 21 > Insert Rows After.  

3. Select the Save Report button. 

 

Part 17: Refresh the Dashboard 

1. Select the Periodic JSR Dashboard tab.  

2. Select the Refresh button.  

 

Part 18: Add a Row 

1. Select the Periodic JSR Data tab.  

2. Right-click cell F21. 

3. Select Insert > Formula from the list. The Formula Editor window opens. 

4. Type AggSum(If({PRJ: Periodic JSR.Cost Report Item Label}="Revenue", {PRJ: 

Periodic JSR.Current Period Hours or Amount}, 0))in the Formula field.  

5. Select the Okay button.  

6. Select the Save Report button. 

 

Part 19: Refresh the Dashboard 

1. Select the Periodic JSR Dashboard tab.  

2. Select the Refresh button.  

3. Close the Periodic JSR Dashboard tab.  

4. Close the Periodic JSR Data tab.  
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Charting 

Charts allow you to showcase your data in a visual format. They allow you to quickly 

scan your data for patterns and trends. Charts are easily made and customized. 
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Activity 3.2 – Create a Periodic JSR Bar and Line Chart 
In this activity, you will use the report you created in Activity 3.1 and add a bar 

and line chart.  

Note: To avoid errors with formulas, be sure to type the formulas rather than 

using copy and paste.  

 

Activity Steps 

 

Part 1: Duplicate a Report 

1. Select the right-facing arrow for My Reports.  

2. Select Periodic JSR Data.  

3. Select the Menu button > Duplicate. The Duplicate Report window opens.  

4. Type Periodic Bar & Line Chart in the Enter the report name field.  

5. Select My Reports.  

6. Select the Okay button.  

7. Select Periodic Bar & Line Chart.  

8. Select the Menu button > Edit.  

9. Select Header: PRJ: Periodic JSR.Project Code > Delete Section.  

10. Select Header: PRJ: Periodic JSR.Task Number > Delete Section.  

11. Select Footer: PRJ: Periodic JSR.Product Code > Delete Section.  

 

Part 2: Update Report Sorts 

1. Select Report Options > Sorts. The Report Sorts window opens.  

2. Select the Delete button for the PRJ:Periodic JSR.Project Code sort.  

3. Select the Delete button for the PRJ:Periodic JSR.Task Number sort.  

4. Select PRJ: Periodic JSR in the dropdown list.  

5. Drag Period End Date to the Sort By pane.  

6. Select the Okay button.  

 

Part 2: Add a Report Header Section 

1. Select Page Header > Add Section > Report Header.  

2. Select column G > Insert Columns After.  

3. Select column G > Insert Columns After. 

4. Use the information in the table to add labels to the report:  

Cell Value 

C19 Period End Date 

D19 Periodic Revenue 

E19 Periodic Raw Cost 

F19 Periodic Total Cost 

G19 Cumulative Revenue 

H19 Cumulative Raw Cost 
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I19 Cumulative Total Cost 

5. Select the Save Report button.  

 

Part 3: Add a Header Section 

1. Select Page Header > Add Section > Group Header. The Group Header 

window opens.  

2. Select PRJ:Periodic JSR.Period End Date from the dropdown list.  

3. Select the Okay button.  

4. Select cell C20.  

5. Type =DateCustomFormat({PRJ: Periodic JSR.Period End Date},”MM yy”) in the 

fx field.  

6. Press Enter.  

7. Select cell D20. 

8. Type =AggSum(If({PRJ: Periodic JSR.Cost Report Item Label}=”Revenue”,{PRJ: 

Periodic JSR.Current Period Hours or Amount},0)) in the fx field.  

9. Copy the formula in cell D20. 

10. Paste the formula in cell E20. 

11. Replace Revenue with Raw Cost in the pasted formula in cell E20.  

12. Paste the formula in cell F20.  

13. Replace Revenue with Total Cost in the pasted formula in cell F20. 

14. Select the Save Report button.  

15. Close the Periodic Bar & Line Chart tab.  

 

Part 4: Create a Dashboard 

1. Select the Create New Report + button.  

2. Select Dashboard. 

3. Select New Tile and drag to the Canvas.  

4. Use the handles to resize the tile to the size of the Canvas.  

5. Select the Existing Report button.  

6. Drag Period Bar & Line Chart to the tile. 

7. Select Parameters on the Toolbar. 

8. Use the information in the table to add the values for the parameters:  

Parameter Value 

projectCode 20.CONTENT-PRODUCTION 

projectStatus *All 

JSRcostReport PCD 

JSRindirectCostRate *Provisional 

JSRreportingPeriod Calendar Month 

JSRreportingPeriodStartDate 2020-09-30 

JSRnumPeriods 12 

JSRrowOptionShowPlans *No Plans 
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JSRrowOptionShowBudgets N 

JSRrowOptionShowActuals N 

JSRrowOptionShowActualsPlans *No Plans 

JSRrowOptionShowActualBudgets *Y 

JSRactualsThroughDate 2021-08-31 

JSRpostedDataOnly N 

JSRshowTasks N 

JSRadjustments *Adjustments using Worked Date within range 

JSRincludePendingAdjustments *Y 

JSRincludeExpenseReports Using Line Item Data within range 

JSRincludeNonCompExpRpts N 

9. Select the Save and Close button.  

10. Select the Style tab.  

11. Select the Keep Original Report Cell Heights radio button.  

12. Select the Save button. The Save Dashboard window opens.  

13. Type Periodic Bar & Line Chart Dashboard in the Name field.  

14. Select the My Reports folder.  

15. Select the Save button.  

 

Part 5: Edit the Report 

1. Select the right-facing arrow for My Reports.  

2. Select Period Bar & Line Chart.  

3. Select the Menu button > Edit.  

4. Type =AggSum(If({PRJ: Periodic JSR.Cost Report Item Label}=”Revenue”,{PRJ: 

Periodic JSR.ITD Amount}, 0)) in the fx field for cell G20. 

5. Copy the formula in cell G20. 

6. Paste the formula in cell H20. 

7. Replace Revenue with Raw Cost in the pasted formula in cell H20.  

8. Paste the formula in cell I20. 

9. Replace Revenue with Total Cost in the pasted formula in cell I20.  

10. Select the Save Report button.  

 

Part 5: Run the Report 

1. Select the Periodic Bar & Line Chart Dashboard tab.  

2. Select Refresh on the Toolbar.  

 

Part 6: Create a Chart 

1. Select the Period Bar & Line Chart tab.  

2. Select cell 19 > Insert Row Before.  

3. Select cell 19 > Row Height. The Row Height window opens.  

4. Deselect the Auto Height check box.  
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5. Type 400 in the Row Height (px) field. 

6. Select the Okay button.  

7. Select cells C19, D19, E19, F19, G19, H19, and I19.  

8. Select the Merge Cells button.  

9. Select cell C19. 

10. Select the Chart Wizard button. The Chart Wizard window opens.  

11. Select the Combination Chart button.  

12. Select the Next button.  

 

Part 7: Add Data to the Chart 

1. Select =DateCustomFormat({PRJ: Periodic JSR.Period End Date},”MM yy”) 

from the X-Axis Labels dropdown list.  

2. Use the information in the table to add series to the chart:  

Series Value Render Type Series Name 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Revenue”, {PRJ: Periodic JSR.Current 
Period Hours or Amount},0)) 

Column Periodic Revenue 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Raw Cost”, {PRJ: Periodic JSR.Current 
Period Hours or Amount},0)) 

Column  Periodic Raw Cost 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Total Cost”, {PRJ: Periodic JSR.Current 
Period Hours or Amount},0)) 

Column Periodic Total Cost 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Revenue”, {PRJ: Periodic JSR.ITD 
Amount},0)) 

Line ITD Revenue 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Raw Cost”, {PRJ: Periodic JSR.ITD 
Amount},0)) 

Line ITD Raw Cost 

=AggSum(If({PRJ: Periodic JSR.Cost Report Item 
Label}=”Total Cost”, {PRJ: Periodic JSR.ITD 
Amount},0)) 

Line ITD Total Cost 

3. Select the Next button.  

 

Part 8: Format the Appearance of the Chart 

1. Select the Chart Axes button. The Chart Axes window opens.  

2. Type Month Ending in the Title field for X-AXIS.  

3. Type Periodic Amount in the Axis Title field for Y-Axis 1. 

4. Select the + Add Y Axis button. 

5. Type ITD Amount in the Axis Title field for Y-Axis 2.  
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6. Use the information in the table to associate the Series Name with the Y-Axis. 

Series Name Y-Axis 

Periodic Revenue Y-Axis 1 

Periodic Raw Cost Y-Axis 1  

Periodic Total Cost Y-Axis 1 

ITD Revenue Y-Axis 2 

ITD Raw Cost Y-Axis 2 

ITD Total Cost Y-Axis 2 

7. Select the Okay button. 

8. Select the Finish button.  

9. Select the Save Report button. 

10. Select section 20 > Suppress Rows check box.  

11. Select section 21 > Suppress Rows check box.  

12. Select the Save Report button.  

Part 9: Review the Dashboard 

1. Select the Periodic Bar & Line Chart Dashboard tab.  

2. Select Refresh on the Toolbar.  

 

Part 10: Update the Appearance of the Chart 

1. Select the Periodic Bar & Line Chart tab. 

2. Right-click the Bar & Line Chart.  

3. Select Edit > Legend Location > Bottom check box. 

4. Right-click the Bar & Line Chart.  

5. Select Edit > Theme > Unanet Medium. 

 

Part 11: Add Advanced Features  

Note: See Appendix B for links to resources for available advanced attributes. 

1. Select the Chart Wizard button. The Chart Wizard window opens.  

2. Select the Appearance tab.  

3. Type labelStep in the ADVANCED FEATURES field.  

4. Select the +Add Attribute button.  

5. Type 3 in the labelStep field.  

6. Select the Finish button.  

7. Select the Save Report button.  

 

Part 12: Review the Dashboard 

1. Select the Periodic Bar & Line Chart Dashboard tab.  

2. Select Refresh on the Toolbar.  

3. Close the Periodic Bar & Line Chart Dashboard tab.  

4. Close the Periodic Bar & Line Chart tab.  
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Check Your Understanding 
 

 

Which one of the following sections would you use if you had information that 

you wanted to repeat on the bottom of each page of a report?  

 

a) Report Footer 

b) Page Footer 

c) Group Footer 

 

 

Which of the following is NOT a capability of Advanced Reporting? 

 

a) Conditional formatting 

b) Advanced charts and graphs 

c) Expanding horizontal sections 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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APPENDIX A: CHECK YOUR UNDERSTANDING 

ANSWER KEY 
 

Lesson 1: Introduction to Analytics 
 

 

Which one of the following report options can you convert to an Advanced 

Report ?  

 

a) ExpressView Report 

b) CrossTab Report 

c) Chained Report 

 

 

 

Which one of the following report options would you use for combining 

multiple reports into a single document? 

 

a) ExpressView Report 

b) CrossTab Report 

c) Chained Report 
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Lesson 2: CrossTab Reporting 
 

 

Determine if each statement is true or false.  

 

 

 True or False 

CrossTabs are also known as pivot tables. T 

CrossTabs automatically expand vertically and horizontally 
depending on the number of data groupings. 

T 

Parameters are only used when designing a report.  F 

The Periodic JSR data object does not require the use of 
parameters. 

F 

 

 

  



©2022 Unanet. All rights reserved. 

 

 
APPENDIX A: CHECK YOUR UNDERSTANDING ANSWER KEY 

41 

Lesson 3: Advanced Reporting 
 

 

Which one of the following sections would you use if you had information that 

you wanted to repeat on the bottom of each page of a report?  

 

a) Report Footer 

b) Page Footer 

c) Group Footer 

 

 

 

 

Which of the following is NOT a capability of Advanced Reporting? 

 

a) Conditional formatting 

b) Advanced charts and graphs 

c) Expanding horizontal sections 
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APPENDIX B: SUPPLEMENTAL INFORMATION  
 

Appearance: Advanced Features 
Use chart attributes to customize the look and feel of a chart.  

 

Chart Advanced Features: Column 2D:  

https://exagobi.com/support/reporting/charts-and-visualizations/advanced-

features/column-2d/ 

 

Chart Advanced Features: Line:  

https://exagobi.com/support/reporting/charts-and-visualizations/advanced-features/line/ 

 

  

https://exagobi.com/support/reporting/charts-and-visualizations/advanced-features/column-2d/
https://exagobi.com/support/reporting/charts-and-visualizations/advanced-features/column-2d/
https://exagobi.com/support/reporting/charts-and-visualizations/advanced-features/line/
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COMPLETION CERTIFICATE AND EVALUATION 
 

When the course has finished, Unanet University staff will mark the attendance in the 

Learning Management System (LMS.) This marking is percentage based and may be 

prorated if a participant was absent for any period of time during the course. 

The LMS will generate a completion certificate (including CPE credits, where 

applicable) which will be available to the participant under their Transcript section of the 

LMS.  

We appreciate your feedback on our courses and encourage you to complete the 

course evaluation. 
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