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ABOUT THIS PARTICIPANT GUIDE 
 

This document serves as a supplement to the training courses offered through Unanet 

University. Participants should use this workbook to complete exercises in the student 

Unanet system while attending the course. Additionally, participants should record notes 

and actions for reference when working within their own Unanet CRM system.  

Symbols used in this guide 
 

   
 

   
 

 

Unanet Contact Information 
• VirtualUU@unanet.com  

 
Send questions here for information about courses, course schedules, enrollments, 

certifications, and unanetuniversity.com. This mailbox is monitored daily. 

Support Portal  
To improve your experience accessing our support resources, all Knowledge Center 

articles and FAQs have been relocated to the Unanet Support Portal 

at support.unanet.com. You need a Support ID to access the portal, which you can 

acquire using the steps below: 

To obtain a login to the Unanet support portal or to create a new ticket, send an 
email to support@unanet.com with "Support Portal ID request" in the Subject line. 

The following conditions must be met to be granted a support account: 
• The "from" address must match the domain of your company. 
• It must NOT be a generic email account (e.g., it cannot be from 

gmail.com, aol.com, or msn.com). 
 
The company must have an active support agreement with Unanet. 

Activity 

Demo 

Tour 

Important Note 

Question 

mailto:VirtualUU@unanet.com
https://support.unanet.com/support/home
mailto:support@unanet.com?subject=Support%20Portal%20ID%20request&body=Please%20activate%20a%20support%20ID%20for%20my%20email.
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COURSE INTRODUCTION 
 

In this course, you review tasks specific to the Publisher 4.0 module and Microsoft 

Word, such as creating and uploading templates and generating Microsoft Word 

documents with your Unanet CRM data. 

Learning Objectives  
After this session of Unanet CRM: Using Publisher with Microsoft Word, participants 

will be able to: 

 

• Recall how to navigate Publisher 4.0 in Unanet CRM.  

• Explain how to create a Word Resume with Unanet CRM data. 

• Explain how to create a Word Project Profile with Unanet CRM data. 

• Explain how to create a Word Project List with Unanet CRM data.  

• Explain how to create a Word Knowledge Document with Unanet CRM data. 

• Explain how to create a Word Opportunity Document with Unanet CRM data. 

• Explain how to create a Word Batch Job. 

 

 

 

Publisher 4.0 is neither associated nor integrated with Microsoft Publisher.  

  



©2023 Unanet. All rights reserved. 

 

 
COURSE INTRODUCTION 8 

Student Training Site  
A Unanet CRM training system has been specifically created to support this course. The 

system is configured around a fictional CRM company named Publisher Course Demo 

Firm. The activities, and accompanying simulations, reference the Demo Firm, its 

related internal and external organizations, and business processes. 

 

Roles & Access 
Unanet is a role-based system that provides security and access based on the roles 

assigned to the user by the System Administrator. It is helpful to be familiar with 

Unanet’s roles and the access that comes with each unique role. Users may need to be 

assigned various roles to perform various job functions. 

 

During this course, we instruct students to log in to Unanet utilizing specific user 

personas containing the appropriate roles to access and complete the required 

activities. 

 

Please note that the password is case-sensitive; the username is not. 

User ID Password Firm ID Firm Name 

admin Cosential! 2321 
Publisher Course 
Demo Firm 

 

 

You can easily adapt the activities in this course for use in your Unanet CRM 

system. When necessary, substitute your information/selections for the 

information provided in the activities.  

 

Course Assets 
Use this link to access the course assets needed to complete the course activities. 

Note: You cannot complete the activities as written without these assets.  

 

https://unanetuniversitycontent.unanet.com/uu_content/UnanetCRM_Word/CRM_PublisherWord_Assets.zip
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LESSON 1: INTRODUCTION TO PUBLISHER 4.0 

Learning Objectives 
Recall how to navigate Publisher 4.0 in Unanet CRM. 

• Summarize the features and functions of the Publisher 4.0 tool. 

• Recall how to search and filter the grid. 

• Explain how to configure the WYSIWYG settings for Publisher 4.0.  

 

Introduction to Publisher 4.0 
Use the Publisher 4.0 module to generate custom Resumes, Project Profiles, Project 

Lists, Opportunity Profiles, and Knowledge Profiles as Microsoft Word or Adobe 

InDesign documents. Publisher 4.0 populates your documents with data from Unanet 

CRM. You create your template, familiarize yourself with where your data lives in the 

system, insert merge variables, and merge the data with your template.  

 

 

 

Tour 1.1 – Example Documents 
In this tour, you will view examples of documents created using Publisher 4.0.
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Overview of the Publisher 4.0 Interface 
Use Publisher Manager to create and search documents, access template 

administration screens, search and filter your document grid, and build batch jobs. 

Create Documents  
You can create the following types of documents:  

 

Template Administration  
You can access the following administration screens: 

Template 
Administration 

Available Admin Features and Functionality 

Upload  

Template 

List Data 

 Formatting 

Document Data  

Dictionary 

Project Profile    

Knowledge Profile    

Resume    

Project List    

Opportunity Profile    
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Demo 1.2 – Exploring the Publisher 4.0 Interface 
In this demo, you will learn about the Publisher 4.0 interface.  

 

 

Activity Steps 

 

1. Select the Publisher 4.0 module. 

2. Select the Enable Publisher 4.0 for InDesign link, if necessary. 

3. Select the Create Document dropdown to view the different document types 

available. 

4. Select the Template Administration dropdown to view the template admin 

pages where you build List Data Formatting, access Document Data Dictionaries, 

and upload templates.  

5. Select the Filters icon. The filtering options display. You can Apply, Cancel, 

Save As, and Reset filters. 

6. Review the Search options. You can search by name, data source, project 

number, opportunity number, and client/owner. 

7. Review the Export Grid button. 

8. Select the Refresh button to view any changes.  

9. Select Doc Created Date > Sort Ascending.  

10. Select Doc Created Date > Columns. 

11. Verify that the following check boxes are selected:  

• Offices 

• Opportunity Number 

• Territories 

12. Select Doc Created Date > Group by this Field to group grid by Doc Created 

Date. 

13. Select Doc Created By > Show in Groups to ungroup documents by Doc 

Created Date. 

14. Select the Doc Created By Header and drag it before the Doc Created Date 

header to reposition columns in the grid. 
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Filtering 
You can filter your Publisher Manager document grid by several data types to display 

specific documents and save filters for future use. 

• All Documents 

• All Project Profiles 

• All Knowledge Profiles 

• All Resumes 

• All Project Lists 

• All Opportunity Profiles 

 

 

Activity 1.3 – Filtering 
In this activity, you will create a custom filter.  

 

Activity Steps 

 

1. Select the Publisher 4.0 module. 

2. Select the Filter icon. 

3. Select filter by Offices > Austin.  

4. Select filter by Template Type > Word.  

5. Select filter by Practice Areas > Education.  

6. Select the Apply button.  

7. Select the Filter icon.  

8. Select the Save As button. The Name popup opens.  

9. Type Austin Education-Word in the Please enter a name for this filter set field.  

10. Select the OK button.  
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Configure WYSIWYG Settings for Publisher 4.0 
You can define the desired functionality of your HTML editor and how it handles when a 

user presses the Enter key in various fields affecting Microsoft Word formatting. 

 

Mode Code Description 

Paragraph Mode <p> </p> 
Defines a paragraph – automatically adds a single 
blank line before and after each <p> element. 

Break Mode <br/> 
Inserts a single line break in the text (forced-line 
break, soft-return, carriage-return). 

Div Mode <div> </div> 
A generic container for a block of content. No effect 
on the content or layout until styled in some way 
using CSS. 

 

Demo 1.4 – Configuring WYSIWYG Editor Settings  
In this activity, you will configure the WYSIWYG Editor Settings for Publisher 

4.0.  

 

Activity Steps 

 

1. Select the Administration icon on the Unanet CRM header. The 

Administration menu opens.  

2. Select General Administration. The Administration page opens. 

3. Select the Firm Setup tab.  

4. Scroll down to the WYSIWYG Editor Settings section.  

5. Use the information in the table below to update the WYSIWYG Editor Settings.  

Setting Mode 

Personnel Previous Project Experience Div Mode 

Personnel Project Experience Div Mode 

Project Description Div Mode 

Project Description for Publisher Resumes Div Mode 

Publisher Format HTML Div Mode 

6. Select the Save button.  
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Check Your Understanding 
 

 

Determine if each statement is true or false.  

 

 

 True or False 

You can change the position of the columns in the document grid.   

You are unable to save searches in Publisher 4.0.  

You build your template using Publisher 4.0.  

You can add and remove columns from the document grid.   

You update WYSIWYG settings using Publisher 4.0.   

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 2: RESUMES 

Learning Objectives 
Explain how to create a Microsoft Word Resume with Unanet CRM data. 

• Explain how to create a Microsoft Word Resume Template. 

• Explain how to create List Data Formatting.  

• Recall how to upload a Resume Template to Unanet CRM. 

• Explain how to create and generate a Resume Record for Personnel. 

 

Introduction  
Use Unanet CRM’s Publisher 4.0 to create Resumes for Personnel in the Unanet CRM 

account using designed templates and CRM data. Once created, you can access the 

Resume from the Publisher Manager documentation grid or the Personnel record under 

the Documents tab.  

 

 
 

We recommend marking up a hard copy of your existing Resume with the Unanet CRM 

field names for each piece of data. This is a helpful reference document when you build 

your Resume template. 

Note: Set up and apply all styles and formatting to the Word document before adding 

placeholder images and variables.  
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Prepare to Create a Resume Template 
Any data you determine is essential to your Resume design must be part of the 

Personnel records in Unanet CRM. It may be necessary to update these records before 

you generate a Resume.  

 

Tour 2.1 – Preparing to Create a Resume Template 
In this tour, you will learn about preparing to create a Resume template by 

reviewing corresponding fields in a Personnel record. Note: Publisher will use 

the image marked as Primary Portrait in the Personnel record for the Resume.  

 

Build a Resume Template 
Once you have identified which data fields to include in the Resume, use the Document 

Data Dictionary to find the corresponding variables. Then, copy the variables from the 

Document Data Dictionary and paste them into the Word Resume template. You Must 

save the Resume template with a file extension of .docx to upload the file to Unanet 

CRM. 

Document Data Dictionary 
The Document Data Dictionary contains all the data fields you can use in your 

Document templates. You can copy and paste the Field Names from the Document 

Data Dictionary into the Format Definition field. Each template type has its own 

corresponding Document Data Dictionary. Using the variables from the right Document 

Data Dictionary for that template type is essential.  

 

Activity 2.2 – Building a Resume Template 
In this activity, you will build a Resume template.  

Note: The paragraph styles used in the templates are already created and 

applied to the text.  

 

Activity Steps 

 

Part 1: Save the Resume Template 

1. Open the Standard_Resume.docx file.  

2. Select the Show/Hide icon on the Home tab.  

3. Select File > Save a Copy. The Save a Copy window opens.  

4. Type Standard_Headshot_XX in the File name field. Note: Replace XX with your 

initials. 
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5. Select Word Document (*.docx) from the Save as type dropdown.  

6. Select the Save button. 

 

Part 2: Put Placeholder Image in the Template 

1. Right-click the headshot image. 

2. Select Change Picture > This Device. The Insert Picture window opens.  

3. Select the Headshot_placeholder.png image. 

4. Select the Insert button.  

5. Select the placeholder.png image.  

6. Select the Picture Format tab > Crop > Fill.  

 

Part 3: Replace Field Names 

1. Select the Publisher 4.0 module.  

2. Select Template Administration > Resume. The Resume Administration 

page opens.  

3. Select the Document Data Dictionary link. The Resume Data Dictionary 

window opens.  

4. Press Ctrl+F. 

5. Type formal in the Search field.  

6. Select %ResumeFormalName% for Personnel Formal Name.  

7. Press Ctrl+C. 

8. Return to Word.  

9. Select the Alex Hoffman, LEED AP, NCARB text to the paragraph marker.  

10. Press Ctrl+V.  

11. Repeat steps 1-8 to replace data with Field Name variables. 

Search Field Name Template 

Title %ResumeTitle% Project Manager  

Intro %ResumeIntro% Introduction Text 

Experience %ResumeListProjectExperience% Project Experience 

Years %ResumeYearsInIndustry% 20 years 

Years %ResumeYearsWithFirm% 18 years 

Education %ResumeListEducation% Education 

Registration %ResumeListRegistrations% Architect, No. C2100, CA 

Registration %ResumeListOtherRegistrations% LEED AP NCARB 

12. Delete remaining listings for Relevant Experience. 

13. Close the Resume Data Dictionary window.  

 

Part 4: Include a Section Break and Unlink Header and Footer from Previous 

These steps are necessary to batch documents together using the Publisher tool 

allowing each template's header and footer to be applied. 

1. Place the cursor after the %ResumeListProjectExperience% variable.  
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2. Press Return. 

3. Press Return again. 

4. Place the cursor at the last paragraph mark.  

5. Select the Layout tab. 

6. Select Breaks > Section Breaks > Next Page. 

7. Select Section Break (Next Page).  

8. Select the Normal tile in the Styles section.  

9. Double-click the next section’s header. 

10. Select the Link to Previous button to unlink the header from the previous 

header. 

11. Select the Go to Footer button.  

12. Select the Link to Previous button to unlink the footer from the previous footer. 

13. Select the Save button. 

14. Close the Resume template. Note: You must close your Word template before 

uploading it to Publisher 4.0.  
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List Data Formatting 
List Data Formatting allows you to format and arrange variables included in a list of 

information, such as project experience, on a Resume. Use Lists for all groups of data 

to include in the template. The following groups of data within Unanet CRM require a 

List Data Format for a Resume:  

• Project Experience 

• Awards 

• Education 

• Registrations 

• Previous Project Experience 

• Other Registrations 

• Training 

• Skills 

• Memberships 

• Presentations 

• Publications 

• Project Publications 

• Personnel Awards 

• References 

Activity 2.3 – Creating List Data Formatting 
In this activity, you will create list data formatting for your Resume.  

 

Activity Steps 

 

Part 1: Create a List Data Format for Project Experience 

1. Select the Publisher 4.0 module. 

2. Select Template Administration > Resume. The Resume Administration 

page opens.  

3. Select the List Data Formatting link.  

4. Select the Create Format link in the List Data Formatting – Project 

Experience section. The Project Experience List Format window opens. The 

Format Definition field is prepopulated with common variables. 

5. Type Standard_Word_XX in the Format Name field. 

6. Replace the comma + space between %ProjectName%, %ProjectClient% with 

space | space. 

7. Remove the – after %ProjectClient%. 

8. Place your cursor after %ProjectClient%. 

9. Press Return. 

10. Select %ProjectName% | %ProjectClient%. 
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11. Select the Normal button. 

12. Select Heading 5 to apply the style to %ProjectName% | %ProjectClient%.  

13. Select the Document Data Dictionary link. The Resume Data Dictionary 

window opens. These are the available merge field names. 

14. Press Ctrl+F. 

15. Type role in the Search field.  

16. Select %ResumeProjectStaffTeamRole% for Project Personnel Staff Team 

Role.  

17. Press Ctrl+C. 

18. Return to the Project Experience List Format window.  

19. Place your cursor at the beginning of 

%ResumePersonnelProjectDescription%.  

20. Press Ctrl+V.  

21. Type . at the end of the pasted variable. 

22. Select %ResumeProjectStaffTeamRole%.  

23. Select the B icon.  

24. Select Personnel in %ResumePersonnelProjectDescription%. 

25. Press Delete.  

Your definition should look like this:  

 
26. Select the Source button. 

Your definition should look like this: 

 
27. Select the Save button.  

28. Close the Resume Data Dictionary window.  
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Part 2: Create a List Data Format for Education 

1. Select the Create Format link in the List Data Formatting – Education section. 

The Education List Format window opens. 

2. Type Standard_WordWYear_XX in the Format Name field.  

3. Select the Document Data Dictionary link. The Resume Data Dictionary 

window opens. 

4. Select %ResumeEducationMajor% for Education Major.  

5. Press Ctrl+C. 

6. Return to the Education List Format window. 

7. Place your cursor at the end of the first variable in the Format Definition field.  

8. Press Ctrl+V.  

9. Type a , (comma) at the end of the pasted variable.  

10. Select the Source button to view the definition in the source code view.  

11. Select the Source button to return to the default view.  

12. Type Degree Major School Year in the Description field. 

13. Select Format > Heading 4 to apply to the entire Format Definition. 

Your definition should look like this:  

 
14. Select the Save button.  

15. Close the Resume Data Dictionary window.  

 

Part 3: Create a List Data Format for Registration 

1. Select the Create Format link in the List Data Formatting – Registrations 

section. The Registrations List Format window opens.  

2. Type Standard_Word_XX in the Format Name field.  

3. Select %ResumeRegistrationDescription% in the Format Definition field. 

4. Press Delete.  

5. Select the Document Data Dictionary link. The Resume Data Dictionary 

window opens. 

6. Press Ctrl+F.  

7. Type discipline in the Search field.  

8. Select %ResumeRegistrationsDiscipline% for RegistrationDiscipline.  

9. Press Ctrl+C.  

10. Return to the Registrations List Format window.  

11. Place your cursor at the beginning of the definition.  

12. Press Ctrl+V.  

13. Type , No. after %ResumeRegistrationsDiscipline%.  
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14. Return to the Resume Data Dictionary window.  

15. Select %ResumeRegistrationsLicence% for Registration License Number. 

Note: The word License is misspelled in the system. You need to have the 

misspelled variable included in your template. 

16. Press Ctrl+C.  

17. Return to the Registrations List Format window.  

18. Select %ResumeRegistrationLicense%. 

19. Press Ctrl+V.  

20. Type , after %ResumeRegistrationsLicence%. 

21. Return to the Resume Data Dictionary window.  

22. Select %ResumeRegistrationsState% for Registration State.  

23. Press Ctrl+C. 

24. Return to the Registrations List Format window. 

25. Place your cursor in the Format Definition field at the end of 

%ResumeRegistrationsLicence%,.  

26. Press Ctrl+V.  

27. Select %ResumeListYearFirstReg% -. 

28. Press Delete.  

29. Select Format > Heading 4 to apply to the entire Format Definition. 

Your definition should look like this: 

 
30. Select the Save button.  

31. Close the Resume Data Dictionary window.  

 

Part 4: Create a List Data Format for Other Registrations 

1. Select the Create Format link in the List Data Formatting – Other 

Registrations section. The Other Registrations List Format window opens.  

2. Type Standard_Word_XX in the Format Name field.  

3. Select - %ResumeListOtherDiscipline% 

(%ResumeListOtherRegistrationsOrganizations%) 

%ResumeListOtherYearFirstReg% in the Format Definition field.  

4. Press Delete. 

5. Select Format > Heading 4 to apply to the entire Format Definition. 

6. Select the Save button.  
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Upload a Resume Template 
Now that you have created your Resume template included a placeholder image, 

placed variables, formatted lists, saved it as a .docx, and closed the file, you can upload 

your template to Publisher 4.0.  

You can upload and store unlimited Resume templates on the Template Administration 

> Resume page.  

Note: If you need to update an existing template, download it, adjust it, then save it over 

the existing system template. Saving over the existing template automatically updates 

any Resume using that template.  

 

Activity 2.4 – Uploading a Resume Template 
In this activity, you will upload a Resume template to Publisher 4.0.  

 

Activity Steps 

 

1. Select the Publisher Manager link.  

2. Select Template Administration > Resume. The Resume Administration 

page opens.  

3. Select the +Upload Template link. The Upload Resume Layout Template 

window opens.  

4. Type StandardWImage_XX in the Template Name field.  

5. Select the Choose File button. The Open window opens.  

6. Select the Standard_Headshot_XX.docx file. 

7. Select the Open button. Note: You can also associate the Resume template with 

a particular office, practice area, or territory. This allows users to filter the choices 

when selecting a template.  

8. Select the Save button. The Template is added to Publisher 4.0.  

9. Select the Select link for List - Education. The Select a Format for Education 

window opens.  

10. Select the Standard_WordWYear_XX radio button.  

11. Select the Save button. 

12. Repeat steps 11-13 to select a format for the remaining list variables. 

List Variable Format 

List - Other Registrations Standard_Word_XX 

List - Project Experience Standard_Word_XX 

List - Registrations Standard_Word_XX 

 Users can now use this template to create a Resume.  
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Create a Resume Record for Personnel 
Use Publisher 4.0 to generate and store Resumes populated with your Project and 

Personnel data.  

Project List or Project Report 
You can choose which projects to add to a Resume with the Project List or Project 

Report options.  

 

 

Activity 2.5 – Creating a Resume  
In this activity, you will create and generate a Resume using the Resume 

template you created.  

 

Activity Steps 

 

Part 1: Create a New Resume 

1. Select the Publisher Manager link. 

2. Select Create Document > Resume.  

3. Type AlexHoffman_OfficeDataCenter_Headshot_XX in the Resume Name field.  

4. Type Alex in the Personnel field.  

5. Select Alex Hoffman from the list of returned results for Personnel.  

6. Select the Save button.  

 

Part 2: Select the Layout 

1. Select the Select link in the Selected Layout (Body of your Document) 

section. The Select a Layout window opens.  

2. Select the StandardWImage_XX radio button.  

3. Select the Save button. A warning message displays.  

4. Select the OK button.  
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Part 3: Add Projects to the Resume Using Project Reports 

1. Select the Project Reports radio button in the Project Experience Generation 

section.  

2. Select the Save button. 

3. Select Commercial - Office/Data last 5 years-Design-Build from the Select 

Project Report dropdown.  

4. Select the Save button. 

5. Select the Dynamic radio button for Generate Project List. 

6. Select the Save button. Note: The report sort order determines project order. 

You can remove the records from the list.  

 

Part 4: Add Projects to the Resume Using Project List Criteria 

1. Select the Project List Criteria radio button in the Project Experience 

Generation section.  

2. Select the Save button.  

3. Select the +Project Experience link. The Project Advanced Search window 

opens.  

4. Select the All Projects check box. 

5. Select Data Center for Primary Categories. 

6. Press Ctrl. 

7. Select Office for Primary Categories.  

8. Select Design-Build for Delivery Method.  

9. Select the Search button. The Project records found window opens.  

10. Select the All check box.  

11. Select the Save button.  

12. Select Parramatta Park Office Building and drag to the first line in the 

Selected Experience table. Note: You can delete and reorder the records. 

 

Part 5: Add Education 

1. Select the +Education link. The Select your Education items to display 

window opens. 

2. Select the Texas A&M University 2002 BS Construction Science check box. 

3. Select the Texas A&M University 2004 MS Civil Engineering check box. 

4. Select the Save button.  

 

Part 6: Add Registration 

1. Select the +State Registration link. The Select your Registration items to 

display window opens.  

2. Select the C20100 License Number check box. 

3. Select the Save button. 
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Part 7: Add Other Registrations 

1. Select the +Other Registrations link. The Select your Other Registration 

items to display window opens.  

2. Select the LEED AP check box.  

3. Select the Save button.  

 

Part 8: Select Introduction, if necessary 

1. Select the Select link for the Introduction. The Select a Resume Introduction 

window opens.  

2. Select the Select link for the Standard Resume.  

 

Part 9: Generate a Resume 

1. Select the Generate Document button. 

2. Select the .docx link to download the Resume.  

3. Select Open on the Download bar. The Resume opens in Word.  
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Best Practices for Resumes 
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Check Your Understanding 
 

 

Which one of the following options do you use for viewing the available 

variables?  

 

a) Document Data Dictionary 

b) Template Administration 

c) List Data Formatting 

 

 

Which one of the following options allows you to format and arrange variables 

included in a list of information? 

 

a) Document Data Dictionary 

b) Template Administration 

c) List Data Formatting 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 3: PROJECT PROFILES 

Learning Objectives 
Explain how to create a Word Project Profile with Unanet CRM data. 

• Explain how to create a Project Profile Template.  

• Recall how to upload a Project Profile Template to Unanet CRM. 

• Explain how to create and generate a Project Profile Record in Publisher 4.0. 

 

Introduction  
Use Unanet CRM’s Publisher 4.0 to create Project Profiles for Projects in the Unanet 

CRM account using designed templates and CRM data. Once created, you can access 

the Project Profile from the Publisher Manager documentation grid or the Project record 

under the Documents tab.  

 

 
 

We recommend marking up a hard copy of your existing document with the Unanet 

CRM field names for each piece of data. This is a helpful reference document when you 

build your Project Profile template. 

Note: Set up and apply all styles and formatting to the Word document before adding 

placeholder images and variables.  
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Prepare to Create a Project Profile Template 
Identify the fields of data that you want to display in your document. Any data you 

determine is essential to your design must be part of the Project records in Unanet 

CRM. You may need to update these records before generating a Project Profile.  

 

Tour 3.1 – Preparing to Create a Project Profile Template 
In this tour, you will learn about preparing to create a Project Profile template 

by reviewing corresponding fields in a Personnel record.  

 

Build a Project Profile Template 
Once you have identified which data fields to include in the Project Profile, use the 

Document Data Dictionary to find the corresponding variables. Then, copy the variables 

from the Document Data Dictionary and paste them into your Word Project Profile 

template. You also format any list data you have included in your template. You must 

save the Project Profile template with a file extension of .docx to upload the file to 

Unanet CRM. 

Activity 3.2 – Building a Project Profile Template 
In this activity, you will build a Project Profile template.  

 

 

Activity Steps 

 

Part 1: Save the Project Profile Template 

1. Open the Standard_ProjectProfile.docx file. Note: If necessary, select the 

Show/Hide icon on the Home tab to show the paragraph marks.  

2. Select File > Save a Copy. The Save a Copy window opens.  

3. Type PP_3ImagesClientQuote_XX in the File name field. Note: Replace XX with 

your initials. 

4. Select Word Document (*.docx) from the Save as type dropdown.  

5. Select the Save button. 

 

Part 2: Put Placeholder Images in the Template  

1. Right-click the top image. 

2. Select Change Picture > This Device. The Insert Picture window opens.  

3. Select the Placeholder_Image_3.jpg image. 

4. Select the Insert button. 

5. Repeat steps 6-9 for the other two images. Note: You must select a different 

placeholder image for each image. 
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Note: Place logos or images you do not want replaced by Publisher in the header or 

footer.  

 

Part 3: Replace Field Names 

1. Select the Publisher 4.0 module.  

2. Select Template Administration > Project Profile. The Project Profile 

Administration page opens.  

3. Select the Document Data Dictionary link. The Project Profile Data Dictionary 

window opens.  

4. Press Ctrl+F. 

5. Type projectdisplay in the Search field.  

6. Select %ProjectDisplayName% for Published Project Name.  

7. Press Ctrl+C. 

8. Return to Word.  

9. Select the Stadium Office/Data Center Complex text to the paragraph mark.  

10. Press Ctrl+V. 

11. Repeat steps 1-8 to replace data with Field Name variables. 

Search Field Name Template 

Location %ProjectLocationFullStateName% Seattle, Washington  

Description %ProjectDescription% Description 

Certification %ProjectListCertifications% LEED Platinum 

Listref %ProjectListReferences% Quotation 

Client %ProjectClient% Green Mountain, Inc. 

Client %ProjectClientContactName% Alexander Hamilton 

Client %ProjectClientContactPhone% (410) 555-1212 

Client %ProjectClientContactEmail% alex@greenmountain.com 

Architect %ProjectConsultantArchitect% Architecture Advantage 

Architect %ProjectConsultantArchitectContact% Raymond Blesener 

Architect %ProjectConsultantArchitectContactPhone% (218) 724-5568 

Architect %ProjectConsultantArchitectContactEmail% raymond@architectureadv.com 

Final %FinalContractPublishedCost% Confidential 

Start %CalculatedStartMY% August 2020 

Completion %CalculatedCompletionMY% August 2022 

Size %ProjectSize% 100,000  

Size %ProjectSizeUnits% SF 

Delivery %ProjectDeliveryMethod% Design-Build 

12. Close the Project Profile Data Dictionary window.  
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Part 4: Include a Section Break and Unlink Header and Footer from the Previous 

These steps are necessary to batch documents together using the Publisher tool 

allowing each template's header and footer to be applied. 

1. Place the cursor after the table.  

2. Select the Layout tab. 

3. Select Breaks > Section Breaks > Next Page. 

4. Double-click Header – Section 2. 

5. Select the Link to Previous button to unlink the header from the previous 

header. 

6. Select the Go to Footer button. 

7. Select the Link to Previous button to unlink the footer from the previous footer. 

8. Select the Save button. 

9. Close the Project Profile template. Note: You must close your Word template 

before uploading it to Publisher 4.0.  

Upload a Project Profile Template 
Now that you have created your Project Profile template, included placeholder images 

and placed variables, and saved it as a .docx, you can upload your template to 

Publisher 4.0. Note: You must close the template before uploading it to Publisher 4.0.  

You can upload and store unlimited Project Profile templates on the Template 

Administration > Project Profile page.  

Note: If you need to update an existing template, download it, adjust it, then save over 

the existing template. When you save over the existing template, Unanet CRM updates 

any document using this template automatically.  

List Data Formatting 
List Data Formatting allows you to format and arrange variables in a list of information 

on a Project Profile, such as project awards. Use Lists for all groups of data to include in 

the template. The following groups of data within Unanet CRM require a List Data 

Format for a Project Profile:  

• Project Awards 

• Project References 

• Project Certifications 
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Activity 3.3 – Uploading a Project Profile Template 
In this activity, you will create list data formatting and upload a Project Profile 

template to Publisher 4.0. 

 

Activity Steps 

 

Part 1: Create List Data Formatting for Project References 

1. Select the Publisher Manager link. 

2. Select Template Administration > Project Profile. The Project Profile 

Administration page opens. 

3. Select the List Data Formatting link.  

4. Select the Create Format link in the List Data Formatting – Project 

References section. The Project References List Format window opens. The 

Format Definition field is prepopulated with common variables. 

5. Type Standard_Word_XX in the Format Name field.  

6. Select the Document Data Dictionary link. The Project References Data 

Dictionary window opens. These are the available merge field names. 

7. Press Ctrl+F. 

8. Type test in the Search field.  

9. Select %ProjectRefGeneralTestimonialText% for General.  

10. Press Ctrl+C. 

11. Return to the Project References List Format window.  

12. Place your cursor at the beginning of the Format Definition field.  

13. Press Ctrl+V. 

14. Select %ProjectRefGeneralTestimonialText%. 

15. Select the I icon. 

16. Place your cursor at the beginning of %ProjectRefFirstName%. 

17. Press Enter.  

18. Select the Source button. 

Your source code view of your definition should look like this:  
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19. Select the Source button. 

Your definition should look like this: 

 
20. Select the Save button.  

21. Close the Project Profile Data Dictionary window.  

 

Part 2: Create List Data Formatting for Project Certifications 

1. Select the Create Format link in the List Data Formatting – List Project 

Certifications section. The Project Certifications List Format window opens. 

The Format Definition field is prepopulated with common variables. 

2. Type Standard_Word_XX in the Format Name field.  

3. Select the Document Data Dictionary link. The Project Profile Data Dictionary 

window opens. These are the available merge field names. 

4. Press Ctrl+F. 

5. Type level in the Search field.  

6. Select %ProjectCertLevelAwarded% for Level Awarded.  

7. Press Ctrl+C. 

8. Return to the Project Certifications List Format window.  

9. Select %ProjectCertDateCertifiedMY%. 

10. Press Ctrl+V to paste %ProjectCertLevelAwarded% in place of 

%ProjectCertDateCertifiedMY%, 

11. Delete the , after %ProjectCertName%. Note: Be sure to include a space 

between the two variables. 

12. Select the Source button.  

Your definition should look like this:  

 
13. Select the Save button.  

14. Close the Project Profile Data Dictionary window.  
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Part 3: Upload the Project Profile Template 

1. Select the Document Templates link.  

2. Select the +Upload Template link. The Upload Project Profile Layout 

Template window opens.  

3. Type Standard_W3Images_XX in the Template Name field.  

4. Select the Choose File button. The Open window opens.  

5. Select the PP_3ImagesClientQuote_XX.docx file. 

6. Select the Open button. Note: You can also associate the Project Profile 

template with a particular office, practice area, or territory. This allows users to 

filter the choices when selecting a template. 

7. Type This template features 3 images and a client quote. in the Instructions 

field.  

8. Select the Save button. The Template is added to Publisher 4.0.  

9. Select the Select link for List – Project Certifications. The Select a Format for 

List – Project Certifications window opens.  

10. Select the Standard_Word_XX radio button.  

11. Select the Save button.  

12. Select the Select link for List – Project References. The Select a Format for 

List – Project References window opens.  

13. Select the Standard_Word_XX radio button.  

14. Select the Save button.  

Users can now use the template to create a Project Profile. 
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Create a Project Profile Record in Publisher 4.0 
Use Publisher 4.0 to generate and store Project Profiles populated with your Project 

data.  

Once you create the record, users access the record from the Publisher 4.0 

documentation grid or the Project record under the Documents tab. 

 

Activity 3.4 – Creating a Project Profile 
In this activity, you will create and generate a Project Profile using your 

created Project Profile template.  

 

Activity Steps 

 

Part 1: Create a New Project Profile 

1. Select the Publisher Manager link. 

2. Select Create Document > Project Profile.  

3. Type StadiumOfficeComplex_3Images1Quote_XX in the Project Profile Name 

field.  

4. Type (2022-0818) Stadium in the Project field.  

5. Select 2022-0818 from the list of returned results for the Project. 

6. Select the Save button.  

 

Part 2: Select the Layout 

1. Select the Select link in the Selected Layout (Body of your Document) 

section. The Select a Layout window opens.  

2. Select the Standard_W3Images_XX radio button.  

3. Select the Save button. A warning message displays.  

4. Select the OK button.  

 

Part 3: Select Images  

1. Select the Select link for image 1.  

2. Select the glass-architecture-wallpaper.jpg radio button.  

3. Select the Save button.  

4. Repeat steps 1-3 to select images for the Project Profile.  

Image Number Image Name 

2 Site.jpg 

3 officespace.jpg 
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Part 4: Add Project References 

1. Select the Select Project References link in the Selected Project References 

section. The Select your Project Reference items to display window opens.  

2. Select the Alexander Hamilton check box.  

3. Select the Save button.  

 

Part 5: Add Project Certifications 

1. Select the Select Project Certifications link in the Selected Project 

Certifications section. The Select your Project Certification items to display 

window opens.  

2. Select the USGBC check box.  

3. Select the Save button.  

 

Part 6: Add Project Description 

1. Select the Select link in the Selected Description section. The Select a 

Description window opens.  

2. Select the Select link for Description Type: Proposal - Standard.  

 

Part 7: Generate the Project Profile 

1. Select the Generate Document button. 

2. Select the .docx link to download the Project Profile.  

3. Select Open on the Download bar. The Project Profile opens in Word. 
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Best Practices for Project Profiles 
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Check Your Understanding 
 

 

Where do you insert your firm logo so that Publisher 4.0 does not replace it 

with a record image?  

 

a) Project record in Publisher 4.0 

b) Header or footer 

c) Publisher 4.0 replaces all images 

 

 

Which one of the following options is necessary if you have more than one 

image in a template? 

 

a) Use a different placeholder image for each image 

b) Use a different image variable for each image 

c) Each template can only have one image 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 4: PROJECT LISTS 

Learning Objectives 
 

Explain how to create a Microsoft Word Project List with Unanet CRM data. 

• Explain how to create a Microsoft Word Project List template. 

• Recall how to upload a Project List template to Unanet CRM. 

• Explain how to create and generate a Project List from Publisher 4.0 populated 

with CRM data. 

 

Introduction  
Use Unanet CRM’s Publisher 4.0 to create Project Lists for Projects in the Unanet CRM 

account using designed templates and CRM data. 

  

 

 

We recommend marking up a hard copy of your existing document with the Unanet 

CRM field names for each piece of data. This is a helpful reference document when you 

build your Project List template. 

Note: You must know how to build a table in Word to create a Project List template. 

There are many helpful tutorials online. You should also know how to style your table 

and set row heights. 
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Prepare to Create a Project List Template 
Any data you determine is essential to your design must be part of the Project records 

in Unanet CRM. You may need to update these records before generating a project list.  

 

Tour 4.1 – Preparing to Create a Project List Template 
In this tour, you will learn about preparing to create a Project List template by 

reviewing corresponding fields in a Project record. Note: Verify that Publisher 

is entered in the Keywords field in the Image Information for the image that will 

be used in the Project List.  

 

Build a Project List Template 
Once you have identified which data fields to include in the Project List, use the 

Document Data Dictionary to find the corresponding variables. Then, copy the variables 

from the Document Data Dictionary and paste them into your Word Project List 

template. You must save the Project List template with a file extension of .docx to 

upload the file to Unanet CRM. 

Activity 4.2 – Building a Project List Template 
In this activity, you will convert an existing project list into a Project List 

template.  

Note: We built the Normal and Heading styles before placing the variable. 

You must apply a table style to your table and set border and row heights. 

 

Activity Steps 

 

Part 1: Save the Project List Template 

1. Open the Standard_ProjectList.docx file. Note: If necessary, select the 

Show/Hide icon on the Home tab to show the paragraph marks. 

2. Select File > Save A Copy. The Save A Copy window opens.  

3. Type Standard_ProjectList_XX in the File name field. Note: Replace XX with 

your initials. 

4. Select Word Document (*.docx) from the Save as type dropdown.  

5. Select the Save button.  

 

Part 2: Insert a Placeholder Image in the Template 

1. Right-click the first thumbnail image. 

2. Select Change Picture > This Device. The Insert Picture window opens.  

3. Select an image. 

4. Select the Insert button.  
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Note: Place logos or images you do not want replaced by Publisher in the header or 

footer.  

 

Part 3: Replace Field Names 

1. Select the Publisher 4.0 module. 

2. Select Template Administration > Project List. The Project List 

Administration page opens.  

3. Select the Document Data Dictionary link. The Project List Data Dictionary 

window opens.  

4. Press Ctrl+F. 

5. Type published in the Search field.  

6. Select %CalculatedProjectNamePublished% for Project Name Calc. 

Published.  

7. Press Ctrl+C. 

8. Return to Word.  

9. Select the Hubbard Broadcasting – Commercial Complex text to the 

paragraph mark.  

10. Press Ctrl+V.  

11. Repeat steps 5-10 to replace data with Field Name variables. 

Search Field Name Template 

Location %ProjectLocationAbbrStateName% Phoenix, AZ  

Final %FinalContractPublishedCost% $50,000,000 

Calculated %CalculatedCompletionMY% August 2022 

Certification %ProjectListCertifications% LEED Silver 

Project Client %ProjectClient% Hubbard Broadcasting 

Client %ProjectClientContactName% Bruce Hagerty 

Phone %ProjectClientContactPhone% (651) 642-4400 

Email %ProjectClientContactEmail% bhagerty@hbi.com 

Architect %ProjectConsultantArchitect% Abcam Architects  

Architect %ProjectConsultantArchitectContact% Frank Sarno 

Architect %ProjectConsultantArchitectContactPhone% (952) 500-7921 

Architect %ProjectConsultantArchitectContactEmail% Frank.sarno.ap@gmail.com 

Note: You may need to widen the column to allow overflow text.  

12. Select the remaining lines in the template.  

13. Right-click the selected lines.  

14. Select Delete > Delete Rows.  

15. Close the Project List Data Dictionary window. 
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Part 4: Adjust Row Height on Table 

1. Select the table.  

2. Select the Layout tab. 

3. Select Properties in the Table section. The Table Properties window opens.  

4. Select the Row tab. 

5. Select the Next Row button.  

6. Type 0.4 in the Specify height field.  

7. Verify Exactly is selected for Row height is.  

8. Select the OK button.  

9. Select the Save button. 

 

Part 5: Include a Section Break and Unlink Header and Footer From the Previous 

These steps are necessary to batch documents together using the Publisher tool 

allowing each template's header and footer to be applied. 

1. Place the cursor after the table.  

2. Select the Layout tab. 

3. Select Breaks > Section Breaks > Next Page. 

4. Double-click the next section’s header.  

5. Select the Link to Previous button to unlink the header from the previous 

header. 

6. Select the Go to Footer button. 

7. Select the Link to Previous button to unlink the footer from the previous footer. 

8. Select the Save button.  

10. Close the Project List template. Note: You must close your Word template 

before uploading it to Publisher 4.0.  

Upload a Project List Template 
Now that you have created your Project List template with a table, placeholder image, 

and variables, then saved it as a .docx; you can upload your template to Publisher.  

You can upload and store unlimited Project List templates on the Template 

Administration > Project List page.  

Note: If you need to update an existing template, download it, adjust it, then save it over 

the existing system template. Saving over the existing template automatically updates 

any Project Lists using this template.  

  



©2023 Unanet. All rights reserved. 

 

 
LESSON 4: PROJECT LISTS 44 

List Data Formatting 
List Data Formatting allows you to format and arrange variables included in a list of 

information on a Project List, such as Certifications. Use Lists for all groups of data to 

include in the template. The following groups of data within Unanet CRM require a List 

Data Format for a Project Lists:  

• Project Awards 

• Project References 

• Project Certifications 

 

Activity 4.3 – Uploading a Project List Template 
In this activity, you will create list data formatting and upload a Project List 

template to Publisher 4.0.  

 

Activity Steps 

 

Part 1: Create List Data Formatting for Project Certifications  

1. Select the Publisher Manager link. 

2. Select Template Administration > Project List. The Project List 

Administration page opens. 

3. Select the List Data Formatting link.  

4. Select the Create Format link in the List Data Formatting – List – Project 

Certifications section. The List - Project Certifications List Format window 

opens.  

5. Type Standard_Cert_XX in the Format Name field. 

6. Select the Document Data Dictionary link. The List - Project Certifications 

List Format window opens. These are the available merge field names. 

7. Press Ctrl+F. 

8. Type award in the Search field.  

9. Select %ProjectCertLevelAwarded% for Level Awarded.  

10. Press Ctrl+C. 

11. Return to the List – Project Certifications List Format window.  

12. Select ,  %ProjectCertDateCertifiedMY%.  

13. Press Ctrl+V. 

Your definition should look like this:  
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14. Select the Save button.  

15. Close the Project List Data Dictionary window.  

 

Part 2: Upload the Project List Template 

1. Select the Document Templates link.  

2. Select the +Upload Template link. The Upload Project List Layout Template 

window opens.  

3. Type Thumbnail_Cert_XX in the Template Name field.  

4. Type Include project thumbnail – keyword publisher in the Instructions field.  

5. Select the Choose File button. The Open window opens.  

6. Select the Standard_ProjectList_XX.docx file. 

7. Select the Open button. Note: You can also associate the project list template 

with a particular office, practice area, or territory. This allows users to filter the 

choices when selecting a template. 

8. Select the Save button. The Template is added to Publisher 4.0.  

9. Select the Select link for List – Project Certifications. The Select a Format for 

Project Certifications window opens.  

10. Select the Standard_Cert_XX radio button.  

11. Select the Save button. 

12. Select the Variables dropdown arrow. Here you can view all the variables 

included in the template.  

 

Create a Project List in Publisher 4.0 
Use Publisher 4.0 to generate and store Project Lists populated with your CRM Project 

data.  

Once you create a Project List record, users with Publisher 4.0 permissions can access 

the record from the Publisher documentation grid. 

 

Activity 4.4 – Creating a Project List Record 
In this activity, you will create and generate a Project List record.  

 

Activity Steps 

 

Part 1: Create a New Project List 

1. Select the Publisher Manager link. 

2. Select Create Document > Project List.  

3. Type Office/DataCenter_5YearsCommercial_XX in the Project List Name field.  

4. Select the Save button.  
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Part 2: Select the Layout 

1. Select the Select link in the Selected Layout (Body of your Document) 

section. The Select a Layout window opens.  

2. Select the Thumbnail_Cert_XX radio button.  

3. Select the Save button. A warning message displays.  

4. Select the OK button.  

 

Part 3: Select the Project Image Settings 

1. Select the On radio button for Project Images.  

2. Select By Keyword for the Image select method.  

3. Type Publisher in the Image Keyword field.  

4. Select the Save button. Note: Select the Save button in the Project Image 

Settings section.  

 

Part 4: Add Projects to the Project List Using Project List Criteria 

1. Verify that the Project List Criteria radio button is selected in the Project List 

Generation section.  

2. Select the Save button.  

3. Select the Search button in the Dynamically Generated Project List section. 

The Search window opens.  

4. Select Data Center for Primary Categories in the Project Category/Types 

section. 

5. Select Design-Build for Delivery Method in the Project Category/Types 

section.  

6. Select LEED for Certification Name in the Project Certifications section. 

7. Select the Search button.  

8. Select the All check box.  

9. Select the Save button.  

 

Part 5: Add Projects to the Project List Using Project Reports 

1. Select the Project Reports radio button in the Project List Generation section.  

2. Select the Save button.  

3. Select Commercial-Office/Data_Center last 5 years – Design Build from the 

Select Project Report dropdown. Note: The report sort order determines the 

project order. 

4. Select the Save button. 

 

Part 6: Generate a Project List 

1. Select the Generate Document button. 

2. Select the docx link to download the Project List.  

3. Select Open on the Download bar. The Project List opens in Word.  
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Best Practices for Project Lists 
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Check Your Understanding 
 

 

Which of the following variables is correctly written for replacing the client’s 

phone number? 

 

a) ProjectClientContactPhone 

b) (ProjectClientContactPhone) 

c) %ProjectClientContactPhone% 

 

 

Which one of the following options do you use if you want Unanet CRM to 

replace an image in a template? 

 

a) Select the Auto-fit check box 

b) Include a placeholder image  

c) Use a variable for the image 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 5: KNOWLEDGE PROFILES 

Learning Objectives 
Explain how to create a Microsoft Word Knowledge Document with Unanet CRM data. 

• Explain how to create a Microsoft Word Knowledge template. 

• Recall how to upload a Microsoft Word Knowledge template to Unanet CRM. 

• Explain how to create and generate a Microsoft Word Knowledge Profile 

document with CRM data. 

Introduction  
Use Unanet CRM’s Publisher 4.0 to create Knowledge documents in the Unanet CRM 

account using designed templates and CRM data. Once created, you can access the 

Knowledge documents from the Publisher Manager documentation grid. 

 

 

 

We recommend marking up a hard copy of your existing document with the Unanet 

CRM field names for each piece of data. This is a helpful reference document when you 

build your template. 

Note: Set up and apply all styles and formatting to the Word document before adding 

placeholder images and variables.  
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Prepare to Create a Knowledge Template 
Any data you determine is essential to your design must be part of the Knowledge 

module in Unanet CRM. You may need to update these records before generating a 

Knowledge Profile.  

Tour 5.1 – Preparing to Create a Knowledge Template 
In this tour, you will learn about preparing to create a Knowledge template by 

reviewing corresponding information in the Knowledge module. Note: You can 

place the formatted text in the Knowledge Bit – Description, and Word honors 

the formatting.  

 

Build a Knowledge Template 
Once you have identified which data fields to include in the Knowledge document, use 

the Document Data Dictionary to find the corresponding variables. Then, copy the 

Document Data Dictionary variables and paste them into your Word Knowledge 

template. You must save the Knowledge template with a file extension of .docx and 

close the document to upload the file to Unanet CRM. 

Activity 5.2 – Building a Knowledge Template 
In this activity, you will create a Knowledge template.  

 

Activity Steps 

 

Part 1: Save the Knowledge Template 

1. Open the Standard_KnowledgeTemplate.docx file. Note: If necessary, select 

the Show/Hide icon on the Home tab to show the paragraph marks. 

2. Select File > Save a Copy. The Save a Copy window opens.  

3. Type Standard_KP_WImage_XX in the File name field. Note: Replace XX with 

your initials. 

4. Select Word Document (*.docx) from the Save as type dropdown.  

5. Select the Save button.  

 

Part 2: Replace Field Names 

1. Select the Publisher 4.0 module. 

2. Select Template Administration > Knowledge Profile. The Knowledge Profile 

Administration page opens.  

3. Select the Document Data Dictionary link. The Knowledge Profile Data 

Dictionary window opens.  

4. Select %kpTitle% for the Knowledge Bit - Title.  

5. Press Ctrl+C. 
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6. Return to Word.  

7. Select Knowledge Profile in the header on the first page.  

8. Press Ctrl+V.  

9. Return to the Knowledge Profile Data Dictionary window.  

10. Select %kpDescription% for the Knowledge Bit – Description.  

11. Press Ctrl+C.  

12. Return to Word.  

13. Select the text in the body of the document.  

14. Press Ctrl+V.  

15. Select %kpDescription% in the Word document.  

16. Select the Normal tile in the Styles section.  

17. Close the Knowledge Profile Data Dictionary window.  

 

Part 3: Insert a Placeholder Image 

1. Right-click the placeholder image.  

2. Select Change Picture > This Device. The Insert Image window opens.  

3. Select an image. 

4. Select the Insert button.  

Note: Do not anchor an image on the same line as a variable—anchor images in a 

position where populated data cannot replace it. 

 

Part 4: Include a Section Break and Unlink Header and Footer From the Previous 

These steps are necessary to batch documents together using the Publisher tool 

allowing each template's header and footer to be applied. 

1. Place the cursor after the table.  

2. Press Enter. 

3. Press Enter again.  

4. Select the Layout tab. 

5. Select Breaks > Section Breaks > Next Page. 

6. Select Section Break (Next Page). 

7. Select the Home tab. 

8. Select the Normal tile in the Styles section.  

9. Double-click the next section’s header.  

10. Select the Link to Previous button to unlink the header from the previous 

header. 

11. Select the Go to Footer button.  

12. Select the Link to Previous button to unlink the footer from the previous footer. 

13. Select the Save button.  

14. Close the Knowledge template. Note: You must close your Word template 

before uploading it to Publisher 4.0. 
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Upload a Knowledge Template 
Now that you have created your Knowledge template with placeholder images and 

variables and saved it as a .docx, you can upload your template to Publisher 4.0.  

You can upload and store multiple Knowledge templates on the Template 

Administration > Knowledge Profile Administration page.  

Note: If you need to update an existing template, download it, adjust it, then save it over 

the existing system template. When you save over an existing template, CRM  updates 

any Knowledge document using that template.  

 

Activity 5.3 – Uploading a Knowledge Template 
In this activity, you will upload a Knowledge template from Word to Publisher 

4.0.  

 

Activity Steps 

 

1. Select the Publisher Manager link. 

2. Select Template Administration > Knowledge Profile. The Knowledge Profile 

Administration page opens.  

3. Select the +Upload Template link. The Upload Knowledge Profile Layout 

Template window opens.  

4. Type Standard_WImage_XX in the Template Name field.  

5. Type Auto-add pages in the Instructions field.  

6. Select the Choose File button. The Open window opens.  

7. Select the Standard_KP_WImage_XX.docx file. 

8. Select the Open button. Note: You can also associate the Knowledge template 

with a particular office, practice area, or territory. This allows users to filter the 

choices when selecting a template. 

9. Select the Save button. The Template is added to Publisher 4.0.  

Create a Knowledge Document  
Use Publisher 4.0 to generate and store Knowledge records such as boilerplate policy 

or procedure narratives, project approaches, and roles and responsibilities populated 

with your Knowledge data.  

Once you create a Knowledge Profile record, users can access the record from the 

Publisher 4.0 documentation grid. 
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Activity 5.4 – Creating a Knowledge Record 
In this activity, you will create and generate a Knowledge record.  

 

Activity Steps 

 

Part 1: Create a New Knowledge Record 

1. Select the Publisher Manager link. 

2. Select Create Document > Knowledge Profile.  

3. Type GuaranteedMaximumPriceWImage_XX in the Knowledge Profile Name 

field. 

4. Type Guaranteed in the Knowledge field.  

5. Select Guaranteed Maximum Price (GMP) from the list of returned results.  

6. Select the Save button.  

 

Part 2: Select the Layout 

1. Select the Select link in the Selected Layout (Body of your Document) 

section. The Select a Layout window opens.  

2. Select the Standard_WImage_XX radio button.  

3. Select the Save button. A warning message displays.  

4. Select the OK button.  

 

Part 3: Select the Image 

1. Select the Select link in the Selected Images section for the first image.  

2. Select the Construction-Site-1080x675.jpg radio button.  

3. Select the Save and Crop button.  

Note: The Selected Document functionality is for future development. Currently, 

attaching a document to a Word Knowledge Profile results in an error. 

 

Part 4: Generate a Knowledge Document 

1. Select the Generate Document button. 

2. Select the docx link to download the Knowledge document.  

3. Select Open on the Download bar. The Knowledge document opens in Word.  
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Check Your Understanding 
 

 

Which one of the following options best explains why you would associate a 

template with a specific office when uploading it to Publisher 4.0?  

 

a) Limit which offices can use the template 

b) Filter templates by office location 

c) It is a required field on the form 

 

 

Which one of the following is an example of a Knowledge bit available to use 

in a Knowledge Document?  

 

a) Client 

b) Phone Number 

c) Title 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 6: OPPORTUNITY PROFILES 

Learning Objectives 
Explain how to create a Word Opportunity Document with Unanet CRM data. 

• Explain how to create an Opportunity Profile template. 

• Recall how to upload an Opportunity Profile template to Unanet CRM. 

• Explain how to create and generate an Opportunity Profile Document with CRM 

data. 

 

Introduction  
Unanet CRM’s Publisher 4.0 module generates Opportunity records, such as letter 

proposals, cover letters, and proposal covers as Word files.  

 

 
 

We recommend marking up a hard copy of your existing document with the Unanet 

CRM field names for each piece of data. This is a helpful reference document when you 

build your template. 
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Prepare to Create an Opportunity Profile Template 
Any data you determine is essential to your design must be part of the Opportunities 

module in Unanet CRM. You may need to update these records before generating an 

Opportunity Profile.  

Note: Set up and apply all styles and formatting to the Word document before adding 

placeholder images and variables.  

 

Tour 6.1 – Preparing to Create an Opportunity Template 
In this tour, you will learn about preparing to create an Opportunity template by 

reviewing corresponding fields in an Opportunity record. Note: You can place 

the formatted text in the Description field, and Word honors the formatting. 

 

Build an Opportunity Profile Template 
Once you have identified which data fields to include in the Opportunity document, use 

the Document Data Dictionary to find the corresponding variables. Then, copy the 

Document Data Dictionary variables and paste them into your Word Opportunity Profile 

template. You must save the Opportunity Profile template with a file extension of .docx 

to upload the file to Unanet CRM. 

 

Activity 6.2 – Building an Opportunity Template 
In this activity, you will create an Opportunity template.  

 

Activity Steps 

 

Part 1: Save the Opportunity Template 

1. Open the Standard_LetterProposal.docx file. Note: If necessary, select the 

Show/Hide icon on the Home tab to show the paragraph marks. 

2. Select File > Save a Copy. The Save As window opens.  

3. Type PlanReviewSvcs_Proposal_XX in the File name field. Note: Replace XX 

with your initials. 

4. Select Word Document (*docx) from the Save as type dropdown.  

5. Select the Save button.  

 

Part 2: Replace Field Names 

1. Select the Publisher 4.0 module. 
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2. Select Template Administration > Opportunity Profile. The Opportunity 

Profile Administration page opens.  

3. Select the Document Data Dictionary link. The Opportunity Profile Data 

Dictionary window opens.  

4. Press Ctrl+F.  

5. Type due in the Search field.  

6. Select %OppProposalDueDate% for the Proposal Due Date.  

7. Press Ctrl+C. 

8. Return to Word.  

9. Select the 11/30/2023 text up to the hidden character.  

10. Press Ctrl+V.  

11. Repeat steps 5-10 to replace data with Field Name variables. 

Search Field Name Template 

Contactrole %OppContactRoleClientContact% Donald Doorman 

Contactrole %OppContactRoleClientContactTitle% Purchasing Director 

Clientname %OppClientName% Blue Lake Facility 

Address %OppClientAddress1% 6957 County Road 101 E 

Address %OppClientAddress2% Suite 100 

City %OppClientCity% Austin 

State %OppClientStateAbbrev% TX 

Zipcode %OppClientZipcode% 78741 

Name %OppName% Blue Lake Office/Data Center 
Plan Review Services 

Oppcontact %OppContactRoleClientContactFirstName% Donald 

Description %OppDescription% Background and Scope of 
Services text 

Fee %OppFirmEstimatedFee% 85,000 

Staff Team %OppStaffTeamProjectEngineer% Joseph Engineer  

Staff Team %OppStaffTeamProjectEngineerTitle% Engineer II 

StartDate   %OppEstimatedStartDateMY% 12/13/2023 

Leadbus %OppStaffTeamLeadBusinessDeveloperOffice
Phone% 

(800) 505-7489 

Leadbus %OppStaffTeamLeadBusinessDeveloperOffice
Email% 

NKegger@UnanetAEC.com 

Leadbus %OppStaffTeamLeadBusinessDeveloper% Nolan Kegger 

Leadbus %OppStaffTeamLeadBusinessDeveloperTitle% Principal in Charge 

12. Press Ctrl+F. The Navigation panel opens.  

13. Select the dropdown arrow > Advanced Find. The Find and Replace window 

opens.  

14. Select the Replace tab.  

15. Type Blue Lake Facility in the Find what field.  
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16. Type %OppClientName% in the Replace with field.  

17. Select the Replace All button. A message displays.  

18. Select the OK button. 

19. Select the Close button. 

 

Part 3: Include a Section Break and Unlink Header and Footer From the Previous 

These steps are necessary to batch documents together using the Publisher tool 

allowing each template's header and footer to be applied. 

1. Place the cursor after the table.  

2. Select the Layout tab. 

3. Select Breaks > Section Breaks > Next Page. 

4. Double-click the next section’s header.  

5. Select the Link to Previous button to unlink the header from the previous 

header. 

6. Select the Go to Footer button.  

7. Select the Link to Previous button to unlink the footer from the previous footer. 

8. Select the Save button.  

9. Close the Opportunity Profile template. Note: You must close your Word 

template before uploading it to Publisher 4.0. 

10. Close the Opportunity Profile Data Dictionary window. 

 

Upload an Opportunity Profile Template 
Now that you have created your Opportunity Profile template, including placed 

variables, and saved it as an .docx, you can upload your template to Publisher 4.0.  

You can upload and store multiple Opportunity Profile templates on the Template 

Administration > Opportunity Profile Administration page.  

Note: If you need to update an existing template, download it, adjust it, then save it over 

the existing system template. You are saving over the existing template, and this action 

updates the Opportunity Profile records using that template.  

List Data Formatting 
List Data Formatting allows you to format and arrange variables included in a list of 

information on an Opportunity Profile. Use Lists for all groups of data to include in the 

template. The data group, Quotes, requires a List Data Format for an Opportunity 

Profile. Note: This requires you to have Products & Quotes enabled for your firm. This 

course does not cover Projects & Quotes.  
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Activity 6.3 – Uploading an Opportunity Template 
In this activity, you will upload an Opportunity template to Publisher 4.0.  

 

Activity Steps 

 

1. Select the Publisher Manager link. 

2. Select Template Administration > Opportunity Profile. The Opportunity 

Profile Administration page opens. 

3. Select the +Upload Template link. The Upload Opportunity Profile Layout 

Template window opens.  

4. Type Standard_Plan_Review_Proposal_XX in the Template Name field.  

5. Select the Choose File button. The Open window opens.  

6. Select the PlanReviewSvcs_Proposal_XX.docx file. 

7. Select the Open button.  

8. Type Standard plan review services letter proposal with subtasks in the 

Instructions field. Note: You can also associate the Opportunity template with a 

particular office, practice area, or territory. This allows users to filter the choices 

when selecting a template. 

9. Select the Save button. The Template is added to Publisher 4.0.  

 

Create an Opportunity Profile Record  
Use Publisher 4.0 to generate and store Opportunity Profile records such as letter 

proposals, cover letters, and proposal covers populated with your Opportunity data.  

Once you create an Opportunity Profile record, users can access the record from the 

Publisher documentation grid. 

Note: If you generate an Opportunity document, such as a letter proposal, and later 

make edits, we recommend you upload a pdf of your final Opportunity documents to the 

Opportunity record for future reference. 

 

Activity 6.4 – Creating a Letter Proposal 
In this activity, you will create and generate a letter proposal.  

 

Activity Steps 

 

Part 1: Create a New Letter Proposal 

1. Select the Publisher Manager link. 

2. Select Create Document > Opportunity Profile.  
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3. Type Blue Lake Office/Data Center Plan Review Services_XX in the 

Opportunity Profile Name field. 

4. Type Blue Lake in the Opportunity Search field.  

5. Select Blue Lake Office/Data Center Plan Review Services from the list of 

returned results.  

6. Select the Save button.  

 

Part 2: Select the Layout 

1. Select the Select link in the Selected Layout (Body of your Document) 

section. The Select a Layout window opens.  

2. Select the Standard_Plan_Review_Proposal_XX radio button.  

3. Select the Save button. A warning message displays.  

4. Select the OK button.  

 

Part 3: Generate the Document 

1. Select the Generate Document button. 

2. Select the docx link to download the Opportunity document.  

3. Select Open on the Download bar. The Opportunity document opens in Word.  

4. Press Ctrl+F. The Navigation pane opens.  

5. Type % in the Search field. There are no results. This indicates that Publisher 

populated all the variables with data. 

 

Part 4: Review the Opportunity Record 

1. Return to Publisher 4.0. 

2. Right-click the Blue Lake Office/Data Center Plan Review Services (18-2801) 

link.  

3. Select Open link in a new tab.  

4. Select the new Unanet CRM tab. 

5. Select More > Documents. 

6. Select the Associated Opportunity Profiles tab. Here you can view associated 

Opportunity Profile templates and generate documents. 
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Check Your Understanding 
 

 

Which one of the following file extensions must you use when saving to 

upload a Word template to Publisher 4.0?  

 

a) .dot 

b) .docx 

c) .docm 

 

 

What type of document can you create from an Opportunity record? 

 

a) Project List 

b) Letter Proposal 

c) Resume 

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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LESSON 7: BATCHING DOCUMENTS 

Learning Objectives 
Explain how to create a Microsoft Word Batch Job. 

• Explain how to create and edit a batch job. 

Introduction  
Publisher 4.0 can batch-generate several different documents and document types into 

one .docx file.  

 

Note: The templates built during this course are already batch-ready because you 

included the Section Break > Next Page at the end of each. In the future, if your 

templates do not have the next-page section breaks, you must add one at the end of 

each template. Please refer to the steps found on page 60. 

Batch Jobs Tab 
The Batch Jobs tab includes the Batch Job grid.  

 

Batch Job Grid 

The Batch Job grid has the following functionality: 

• New Batch Job: Select to open the New Job window. 

• Filter by Project: Future development. 

• Filter by Opportunity: Future development. 

Columns 

The Batch Job grid includes the following columns that you can sort by, group by, 

rearrange, remove, or add: 

• Run/Edit Job: Select the dropdown arrow to Run Job, Cancel Job, Edit Job, or 

Delete Job. 

• Job Name: Displays the name of the batch job. 

• Template Type: Displays the template type; Word or InDesign. 

• Created By: Displays the user who created the batch job. 

• Contents: Displays which documents the batch job includes.  

• Opportunities: Future development. 

• Status: Displays the status of the batch job; Not Started, Pending, or Complete. 

Progress Section 

The Progress Section panel includes the following information: 

• Progress bar: Displays the progress of the selected batch job.  

• Job build time: Displays how long it takes to complete the batch job. 
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• Download Merged Documents: Appears after the Publisher completes the 

batch job.  

• Columns 

o Document order: Displays the order Publisher generates documents. 

o Document Name: Click the link to the individual document build page. 

o Data Source: Displays Personnel or Projects. 

o Status: Includes clickable links to download individual documents. 

 

Demo 7.1 – Exploring Batch Jobs Tab, Filters, and Columns 
In this demo, you will explore the Batch Jobs tab, its filters, and columns.  

 

Demo Steps 

 

1. Select the Publisher 4.0 module. 

2. Select the Batch Jobs tab.  

3. Select the Job Name dropdown arrow. A menu displays. You can sort ascending 

or descending and select which columns to display. 

4. Select the Template Type header and drag after the Created By Header to 

reposition columns in the grid. 

5. Select Template Type > Group By This Field. The grid groups templates by 

template type.  

6. Review the Filters. You can Filter by Project or Filter by Opportunity.  
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Create a Batch Job 
You can create a batch by selecting documents of the same type in the document grid 

or from the Batch Jobs tab. 

Activity 7.2 – Creating a Batch Job 
In this activity, you will create a Batch Job.  

 

Activity Steps 

 

Part 1: Create a Batch Job from the Documentation Grid 

1. Select the Publisher 4.0 module. 

2. Select the check boxes for the following documents:  

• Blue Lake Office/Data Plan Review Servicess_XX 

• GuaranteedMaximumPriceWImage_XX 

• Office/DataCenter_5yearsCommercial_XX 

• StadiumOfficeComplex_3Images1Quote_XX 

• AlexHoffman_OfficeDataCenter_Headshot_XX 

3. Select the New Batch Job button. The New Job window opens.  

4. Type Blue Lake_Plan_Review_XX in the Job Name field.  

5. Select Word for the Template Type. 

6. Select docx for the Output Format. 

7. Select the Merge check box. Note: If you select the Zip check box, Unanet CRM 

generates your batch job and exports them as individual documents in a zipped 

folder.  

8. Select the Knowledge Template in the Job Documents list and drag it to the 

position below the Opportunity Profile.  

 

Part 2: Run and Download the Batch Job 

1. Select the Save & Run button. The Success dialogue box opens.  

2. Select the OK button.  

3. Select the Batch Job tab to watch the progress of the job. Note: If you do not 

see your batch job in the list, select the Refresh button.  

4. Select Blue Lake_Plan_Review_XX in the list. The document publishing details 

are displayed at the bottom of the screen. 

5. Select the Download Merged Documents button when the Job is 100% 

complete.  

6. Select Open on the Download bar. The document opens in Word.  

7. Scroll through the pages of the document. 

8. Delete the hard return at the top of the Project List.  

9. If necessary, delete any blank pages or extra paragraph marks. 
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Activity 7.3 – Editing a Batch Job 
In this activity, you will edit a Batch Job.  

 

Activity Steps 

 

1. Return to Publisher 4.0.  

2. Select the Blue Lake Plan Review_XX dropdown arrow.  

3. Select Edit Job. The Edit Job window opens.  

4. Select the Opportunity Profile in the Job Documents list. 

5. Select the Down button to move the Opportunity Profile to the end of the list.  

6. Select the Save & Run button. A success message displays.  

7. Select the OK button.  

8. Select the Download Merged Documents button when the Job is 100% 

complete.  

9. Select Open on the Download bar. The document opens in Word.  
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Best Practices for Batch Jobs 
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Check Your Understanding 
 

 

Arrange the batching steps in the correct order when starting on the 

Document Grid.  

 

 

 

Steps Order 

Select new batch job.  

Download and open the documents.   

Select the documents to include in the batch job.   

Select the Batch Job tab to view the progress.   

Save and run the batch job.   

 

 

 

 

Refer to Appendix A for answers to the Check Your Understanding questions. 
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APPENDIX: CHECK YOUR UNDERSTANDING 

ANSWER KEY 
 

Lesson 1: Introduction to Publisher 4.0 
 

 

 

Determine if each statement is true or false.  

 

 

 True or False 

You can change the position of the columns in the document grid.  T 

You are unable to save searches in Publisher 4.0. F 

You build your template using Publisher 4.0. F 

You can add and remove columns from the document grid.  T 

You update WYSIWYG settings using Publisher 4.0. F 
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Lesson 2: Resumes 
 

 

Which one of the following options do you use for viewing the available 

variables?  

 

a) Document Data Dictionary 

b) Template Administration 

c) List Data Formatting 

 

 

Which one of the following options allows you to format and arrange variables 

included in a list of information? 

 

a) Document Data Dictionary 

b) Template Administration 

c) List Data Formatting 
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Lesson 3: Project Profiles 
 

 

Where do you insert your firm logo so that Publisher 4.0 does not replace it 

with a record image?  

 

a) Project record in Publisher 4.0 

b) Header or footer 

c) Publisher 4.0 replaces all images 

 

 

Which one of the following options is necessary if you have more than one 

image in a template? 

 

a) Use a different placeholder image for each image 

b) Use a different image variable for each image 

c) Each template can only have one image 
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Lesson 4: Project Lists 
 

 

Which of the following variables is correctly written for replacing the client’s 

phone number? 

 

a) ProjectClientContactPhone 

b) (ProjectClientContactPhone) 

c) %ProjectClientContactPhone% 

 

 

Which one of the following options do you use if you want Unanet CRM to 

replace an image in a template? 

 

a) Select the Auto-fit check box 

b) Include a placeholder image 

c) Use a variable for the image 
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Lesson 5: Knowledge Profiles 
 

 

Which one of the following options best explains why you would associate a 

template with a specific office when uploading it to Publisher 4.0?  

 

a) Limit which offices can use the template 

b) Filter templates by office location 

c) It is a required field on the form 

 

 

Which one of the following is an example of a Knowledge bit available to use 

in a Knowledge Document?  

 

a) Client 

b) Phone Number 

c) Title 

 

  



©2023 Unanet. All rights reserved. 

 

 
APPENDIX: CHECK YOUR UNDERSTANDING ANSWER KEY 73 

Lesson 6: Opportunity Profiles 
 

 

Which one of the following file extensions must you use when saving to 

upload a Word template to Publisher 4.0?  

 

a) .dot 

b) .docx 

c) .docm 

 

 

What type of document can you create from an Opportunity record? 

 

a) Project List 

b) Letter Proposal 

c) Resume 
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Lesson 7: Batching Document 
 

 

Arrange the batching steps in the correct order when starting on the 

Document Grid.  

 

 

Steps Order 

Select new batch job. 2 

Download and open the documents.  5 

Select the documents to include in the batch job.  1 

Select the Batch Job tab to view the progress.  4 

Save and run the batch job.  3 
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COMPLETION CERTIFICATE AND EVALUATION 
 

When the course has finished, Unanet University staff marks attendance in the Learning 

Management System (LMS.) This marking is percentage-based and may be prorated if 

a participant was absent for any period of time during the course. 

The LMS generates a completion certificate (including CPE credits, where applicable) 

available to the participant under their Transcript section of the LMS.  

We appreciate your feedback on our courses and encourage you to complete the 

course evaluation. 
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